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FAST TRACK INTRODUCTION

This is the abbreviated introduction. It is intended for those too impatient to read the official introduction (scroll to the first section past the Table of Contents), who want to “get on with it.”

Welcome to PHOTOSHOP ACTIONS – THE MOTHER OF ALL TUTORIALS. This version, 1.1Btoc, supercedes version 1.0B, published March 2004. If you downloaded that version, you may delete it.

A SPECIAL THANKS TO…

· Cameron Nicoll, who single handedly reformatted the entire document in order to create an easier-to-use Table of Contents.

· Pierre-Etienne Courtejoie who offered over 200 suggestions for this edition as well as advice on writing actions for non-English language versions of Photoshop. Pierre, who lives in Belgium, is a moderator at http://photoshoptechniques.com, a well organized and information-rich site if you’ve not had the pleasure of visiting.

· Ron Hirsh, many of whose ideas will be incorporated into ver 2.0.

WHAT’S NEW

· A considerable amount information has been added, especially in the areas of batch automation and How To topics. Within the document new content can be recognized by bold green type. In the Table of Contents new topics are identified by bold black type.

· Some sections were rewritten or fine tuned for the sake of clarity and/or improved technical accuracy.

· Numerous format, spelling and grammar errors were corrected.

· Some topics were reorganized for a more logical flow and to simplify lookup.

TOPIC LOOKUP

Check the newly formatted table of contents on page 2. For other ideas, see page 13.

WHEN YOU SEE Search on XXX (where XXX = a topic ID)
These are not hot (jump) links. If you click on the XXX, nothing will happen. 

You will need to copy the XXX into your word processor’s Find function and use this mechanism to ‘jump’ to the applicable section in the document. 

TO BE KEPT UP TO DATE, JUST ASK

Send e-mail request PhotoshopActions@yahoo.com if you want to be notified of updates or future versions. I positively promise you will not get any junk e-mail as a result. 

As an alternative periodically check www.AtnCentral.com for updates. 

QUESTIONS, COMMENTS, CORRECTIONS, ADDITIONS

I would appreciate hearing from you. Send e-mail to PhotoshopActions@yahoo.com. If applicable please include the document version number (1.1Btoc) and topic reference numbers, e.g., 25.2, 132.7, etc. 

ARE YOU NEW (OR FAIRLY NEW) TO PHOTOSHOP ACTIONS?

While a great deal of the content in this tutorial was written specifically for those with little to no action experience, a document this size WILL look intimidating and overwhelming.

Take heart. There is hope.

Scroll forward to section 1.2 on page 31. There you will find links to numerous well written tutorials that are not nearly as comprehensive as this one, but may better serve your immediate needs.

You can come back to this one anytime to fill in the gaps or take you further.

WHO NEEDS THIS?

Anyone, regardless of experience, with an interest in knowing more about actions, batch processing, droplets and where scripting fits in.

There’s something for everyone.

Keep having fun.

     ~Danny~

Hot off the press. The first book dedicated to Photoshop actions:

Al Ward's Photoshop Productivity Toolkit: Over 500 Time-Saving Actions.

See http://tinyurl.com/25hpy
Due late Summer 2004. I’ve preordered my copy.
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I. INTRODUCTION

B. INTRODUCTION

UP
To paraphrase Tim Plumer’s introduction in his article “Take Advantage of Photoshop Actions,” have you ever had a task in Photoshop where you apply the same steps in the same order over and over? After many repetitions of these mindless and time consuming tasks, they become boring and error prone because they don’t engage our imaginations nor require creativity. Practice doesn’t make perfect. It results in wasted time. 

If this sounds familiar you have probably wondered, “Instead of having to enter these steps manually each time, isn’t there a way they could be recorded and played back automatically with the touch of a button?” 

The good news: “Yes, there is.” All it takes is utilizing functionality built into Photoshop called Actions, the subject of this tutorial.

SINCE THERE ARE DOZENS AND DOZENS OF ACTION TUTORIALS ON THE NET, WHY ANOTHER ONE?

I discovered Photoshop actions in 2001 and was quickly hooked. After plowing through Photoshop’s related help topics I sought additional knowledge through books and Internet tutorials. Although I found numerous tidbits and golden nuggets in a number of places, I was surprised by the absence of a comprehensive information resource on the subject. 

One day in early 2003 a close friend, Harry Ellerton (whom I was helping with an action problem) suggested I write a tutorial on actions, so I did and here it is. 

WHAT MAKES THIS ONE DIFFERENT?

· Two words: Breadth and depth. Most Internet tutorials are relatively brief and coverage in books is limited, whereas this tutorial attempts to be comprehensive, almost to a fault.

· There was a conscious effort to include reasons Why — practical information, if you will — along with the What and How details.

WHAT DID YOU HOPE TO ACCOMPLISH BY WRITING IT?

· As one who was (and sometimes still is) technology challenged, one goal was to provide a resource that would enable action rookies to gain confidence through knowledge (“If I can do it, you can do it”) as well as help them avoid and/or deal with situations that frequently stymie new users. 

· To provide renewed hope for those who have tried playing actions or engaged the File > Automate > Batch or Create Droplet dialogs, but hit a wall and gave up.

· To inspire those who have considered writing actions to take the leap, despite natural feelings of anxiety. Again, “If I can do it, you can do it.”

· To help those with action experience become more effective Photoshop users by sharing less well known capabilities and techniques. 

· To be able to more quickly reply to commonly posted action-related questions on various forums by cutting and pasting prewritten answers.  

· To inspire those with action writing skills and expertise to come forward and share their best practices and pearls of wisdom. While this tutorial is comprehensive, I can assure you there many methods and skills yet to be documented.  

CAUTION (AND ENCOURAGEMENT) TO ROOKIES

Although I made a conscious effort to make this as rookie friendly as possible, regardless of your Photoshop or action experience level there will surely be times when you get overwhelmed by the technical minutia, techno-babble or shear volume of information. That’s to be expected and if it happens, say to yourself, “This is normal. No big deal.” 

Don’t give up. It’s a signal to give your brain a rest. After a few hours or days of mental vacation, give it another read and if the light bulb still doesn’t come on, engage http://www.google.com/ and initiate a search using applicable keywords. My bet is if you read descriptions and examples on a subject written from different perspectives than mine, you will eventually get it and soon be on your way again. If that doesn’t work, send me an e-mail (see below) and I’ll be glad to help.
WITH ALL DUE RESPECT TO MAC USERS

Although I used a Mac from 1990 until it died in 2002 (a Mac II-ci running System 7) and liked it a lot, you’ll quickly discover this is written primarily from a Windows perspective. Why? Because Windows has been my main platform for several years. 

Not to worry, however. From an actions perspective there’s almost no difference between the Windows and Macintosh implementations and Mac-specific tidbits I discovered along the way are included.

With regard to shortcut references, here’s the standard translation:

Windows 

Mac
Ctrl


Cmd (“Apple” key)

Alt


Option

Right-click

Control

Important: You will need to be able to decipher Windows path notation like this: 

C:\Program Files\Adobe\Photoshop 7.0\Required\Default Actions.atn
Translation: Use the Macintosh Sherlock search function to locate file Default Actions.atn.  
Assumptions

· Your action experience ranges from none to a lot and you want to learn more about actions.

· You will read this document on your monitor (it’s WAY too long to print), enabling you to switch back and forth with Photoshop.  

· Although this has been distributed in .htm format, you will open it at some point with a word processing program such as Microsoft Word and leverage features such as Split-screen and Find.

· You have an Internet connection which will enable you to reference the numerous Web resources cited. 

· While the items in the following list should not be construed as requirements, having these skills and knowledge in these areas will be beneficial regardless of the program you’re trying to learn: 

· The ability to use the mouse to choose commands from menus

· An understanding of what Drag and Drop is and how to do it

· How to size, move, hide and show windows (under Windows or Mac OS)

· What function keys (also known as F keys, PF keys or program function keys) are and where they are located on the keyboard

· The ability to use the search (find) function in a word processing program or a browser

· How to locate files on your computer using Windows’ or the Mac OS find file function

· What a file name extension is, e.g., .jpg, .psd, .atn, etc.

· Understanding what it means when you read something like 
C:\Program Files\Adobe\Photoshop 7.0\Required 

· Folder (also called a directory) basics: what they are, how to create them and how to move files into, out of and between them 

· How to download files from the Internet

· How to attach a file to an e-mail message and how to save a file attached to an e-mail message

WHAT’S THE FOCUS OF THE SUBJECT MATTER?

Photoshop actions. 

There is some discussion of writing and playing actions under Photoshop Elements and links are provided to sites where additional information can be found on this subject. 

There is no content addressing ImageReady actions. They are incompatible with their Photoshop cousins.

There is detailed coverage of compatibility (and incompatibility) with other versions of Photoshop and non-Photoshop programs.

HOW IS THE CONTENT ORGANIZED?

· Terminology: Understand these terms and the race will be 35% won.

· Frequently Asked Questions (FAQ)- For Newbies: Questions asked and problems encountered by most rookies are addressed or references are provided to detailed answers elsewhere in the document. 

· Tidbits for Action Heads: Did You Know? Another FAQ-like section that should be of interest to more experienced action users.

· Basic Concepts: Foundational questions like “What are actions?”, “Why write them?”, “Who writes them?”, “What can they do (and not do)?” are addressed.

· Compatibility: Questions are answered regarding compatibility of actions across Photoshop versions, between academic and standard versions, between Mac and Windows versions, with Photoshop Elements, Photoshop LE and non-Photoshop programs.

· Actions for the Casual User: Actions from soup-to-nuts for those who consider their skills to be somewhere between none and intermediate.

· Beyond Basics: While these topics aren’t necessarily more difficult to comprehend than those in Actions for the Casual User, they may be of less interest to those just getting started with actions. In addition to new topics, some topics introduced previously receive additional coverage. Caution: In this section many methods are presented in general terms rather than step-by-step format used in the previous section. Don’t miss finding out how to load multiple .atn files at one time, recovering deleted actions when you don’t have backup files or how to easily transport your entire action collection from one version of Photoshop to another. 

· Help - Actions: Topics related to action-specific errors or problems.

· Help - Batch Processing and Droplets: Topics addressing problems frequently encountered by batch and droplet users.

· How To: Basic instructions for constructing actions to complete common tasks.

· Exercises: Step-by-step instructions on how to create a few simple actions.

· Appendices: If you write actions take note of the comprehensive tables summarizing keyboard shortcuts and Actions Palette operations.

Content COMMENTS

· Photoshop CS considerations and differences: Although this document is primarily based on Photoshop 7, Photoshop CS related topics and tidbits are being added with each revision. It will be interesting to see how clever action authors fold new CS capabilities like layer comps and layer subsets into future actions.

· Some content was purposely duplicated. This was done in instances where it seemed appropriate to reinforce previously mentioned warnings or to avoid having to scroll back 100 pages for a two-line description.

· Where’s the Actions Palette diagram — or any diagrams and screenshots for that matter? Despite urgings from someone whose opinions I greatly respect, Michael Herbert, I chose not to include a graphic of the Actions Palette. As noted previously the assumption is you are reading this on your monitor and have easy access to a Photoshop session and/or the Internet, where numerous Actions Palette diagrams are available. 

· Embedded links: Shortly before this document was posted for download, embedded Internet links were validated. Over time some will go stale. Don’t shoot me, okay?

· Accuracy: While considerable effort was made to ensure the content of this document is correct and up to date, there are no doubt errors, critical omissions and inaccuracies that slipped through the cracks. If you find any, I’d would appreciate you not only pointing them out, but offering corrections if possible. Search on SUGGESTIONSCOMMENTS
SOURCES OF INFORMATION

· Photoshop Help, books and Internet tutorials. To get an idea of how fragmented information sources are, check the bibliography and section listing links to action tutorials. 

· Forums at sites such as http://www.dpreview.com/, http://www.retouchpro.com/ and http://www.adobeforums.com/.

· Personal observation and experiences, courtesy of The School of Hard Knocks, where I’ll always be in the third grade. 

Conventions

· Question/Answer format: Okay. I’ll admit it up front. Not all the questions came from forums I’ve perused. Many were inspired by personal experiences of which many were painful, some were joyful and all were memorable. 

· The font used for this document (Courier New): Sorry if it stirs memories of an IBM Selectric typewriter, but using it made it easier to compare and verify subtle differences in links and file paths.

· Section and question numbering: This was my first swing at organizing and writing something this voluminous. Hopefully the combination of content index and numbering scheme will make finding information fairly easy. 

· Search on KEYWORDTAGS: These are ALL CAPS special keywords that refer to other sections in the document. The original intent was to embed links in the text to enable click-on-link/jump-to-a-related-topic functionality. It didn’t work out, so I implemented the blue KEYWORDTAGS as a not-so-high-tech substitute. They are meant to be copied/pasted into a Find dialog box. While not elegant, they will work.

· Important: The bold, red type is meant to get your attention. I didn’t overuse it.

· Action Set Names, File names and C:\paths\folders: Colored and italicized for easy visual distinction.

· File path names are based the default Windows Photoshop installation here: C:\Program Files\Adobe
· Keyboard shortcuts: Alt + Ctrl + Shift + E means “While simultaneously holding down the Alt, Ctrl and Shift keys, hit the E key.”

· Commands (italicized): Desaturate, Save Actions…
· Commands selected from menus: Menu > submenu > command
· Photoshop 5.x = 5.0 or 5.5

· Photoshop 7 = 7.0 or 7.01

FINDING WHAT YOU’RE LOOKING FOR

· If you’re using Microsoft Word to view this document, click on any line item in the Table of Contents to jump to that particular page. In topic headings, click on the UP link to return to the Table of Contents.

· If you’re using a word processing program which supports split screen viewing, try displaying the table of contents in the top window and content detail in the bottom window. 

· If you’re using a browser, open one instance of the document for the index and another for the content, a two window equivalent of split screen.

· Regardless of what program type used to open the document, use its Find function to search on KEYWORDTAGS or other keywords.

TESTING ENVIRONMENT

· Windows 2000, SP3

· Photoshop 7.01

Some testing was done by friends running other versions of Photoshop under Mac OS or other versions of Windows.

Acknowledgements & CREDITS
They are numerous and well deserved. Check them out in the appendix.

THE NEXT EDITION

At the moment I plan on compiling a version 2.0 which will be in PDF format with working jump links, but doing so will depend to some degree on the feedback received on this interim document. If there is to be a second version, I will be looking for others who are interested in submitting content for it, especially in the areas of batch processing, droplets, action development tips, techniques and testing. Example actions illustrating your expertise or written contributions would be most welcome, too. 

No writing experience required. (Does it look like I have writing experience?)

Have no fear. I gladly share credit.

==================================

FEEDBACK IS WELCOME AND ENCOURAGED

==================================

SUGGESTIONSCOMMENTS

If you have suggestions, corrections, opinions, questions, comments, or version 2.0 content ideas you’d like to submit for consideration, I’d like to hear from you. 

Send e-mail to:

PhotoshopActions@Yahoo.com 

· In the e-mail text please specify The version number of this document (1.1Btoc)

· For each correction, suggestion, comment, etc. specify the section reference number from the document to which you are referring, e.g., 

24.6 – This is incorrect. You CAN teach an old dog new tricks. 
37.3 – There’s another way to do that, and here it is…
77.5 – This isn’t clear to me: What do you mean by “xxx…” 
125 – Photshop is misspelled.


=============================

HOW YOU CAN MAKE A DIFFERENCE

=============================

After you’ve read through this tutorial, please check out the last page.

OKAY, CAN WE GET ON IT?

Yeah, I guess it’s about time to do that.

C. TERMINOLOGY

UP

Learning just about anything in Photoshop (or any other subject) is less difficult if you have a firm grasp on the jargon. Actions are no different. Rather than burying a glossary at the end of this document, I thought it prudent to tackle terminology at the outset. 


If you’ve spent any time working with computers, by now you know making the slightest error when carrying out a procedure will yield somewhere between zero and incorrect results. The purpose of this section, then, is to define and distinguish among these terms that are often misused and easily confused because they look a lot alike. Mastering these distinctions will lead to a better understanding of action concepts and techniques as well as avoid terminology related errors.


If you feel a little intimidated after the first read this section, relax. That’s to be expected. Find comfort knowing that this is just the beginning. As you gain experience with actions and progress through this tutorial where terminology used correctly and consistently, the meanings and distinctions among terms will become clear. By all means refer to this section anytime you feel the need.


Before getting into the terms themselves it will be helpful to mentally divide where action-related object can reside. Some terms refer to objects that reside inside Photoshop’s Actions Palette. The reset refer to objects that reside outside Photoshop, which can be the Desktop, anywhere on a hard disk, a CD, floppy disk, as a file attachment to an e-mail message or an Internet site. Understanding where an object resides will be helpful in grasping concepts such as these that will be addressed later:

· How to get actions into Photoshop whose sources are outside Photoshop, e.g., Internet download, file attached to an e-mail message, a CD that accompanies a book, etc.

· How to get actions out of Photoshop for purposes such as printing action or sharing them with others by e-mail or upload to an Internet 


Terms related to objects within (I) the Photoshop window:

· Actions Palette 

· Actions Palette Menu 

· Action Set 

· Action Set Name 

· action 

· Action Name 

· action step 


Terms related to objects outside (O) Photoshop:

· .atn

· .atn file

· Action Set File

· Action Set File Name

To aid in visual distinction all of the above (except .atn, .atn file, action and action step) are capitalized throughout this document.

The following definitions are not intended to be in alphabetical order nor match the order of the list above. Most are further explained in subsequent sections.

· Actions Palette: Photoshop has many palettes, for example, Tools, Layers, Brushes, etc. The Actions Palette is one of them. In this palette you will find Action Sets, the actions they contain and all action-related commands and controls, represented by icons at the bottom of the palette or choices in a popup menu.

· Actions Palette Menu: This popup menu lists all action related commands. To display this menu click the black triangle (►) at the top-right of the palette.

· Action Set: Action Sets reside in the Actions Palette and their purpose is to provide a means of organizing actions just like folders are used to organize files under Windows or Mac OS. Action Sets can be created, deleted, copied and renamed at any time, and can contain zero, one or more actions. For organizational purposes Action Sets can be moved (repositioned) within the Actions Palette. Actions can be added to or deleted from Action Sets as well as moved from one Action Set to another.

Unlike Windows or Mac OS where you can have folders inside of folders, Photoshop only supports one level of Action Set, that is, you cannot have an Action Set inside of another Action Set.

Important: Action Sets, which again can only reside in the Actions Palette, are frequently confused with Action Set Files (.atn files), which reside outside of the Actions Palette, typically on your hard disk. Search on WHATSTHEDIF

Important: Photoshop can only play actions that reside in Action Sets.

· Action Set Name: A name assigned to an Action Set when it is created. Similar in concept to folder names, Action Set Names are used to visually distinguish one Action Set from another. Action Set Names can be changed at any time, but be careful if you do this (Stephen Marsh). Search on RENAMEPROBLEMS.

· Action: An action is the result of recording one or more Photoshop operations or commands and their respective settings or options. While technically an action can consist of zero steps (this is a Null Action), that is the exception. Actions range from simple (from one to just a few steps) to the very complex (literally hundreds of steps).

An action is created in a way similar to recording an audio or video tape. When Record Mode (as it’s called) is initiated, Photoshop captures nearly everything you do in what is called steps or action steps), including such things as choosing commands from menus, typing characters into text boxes, choosing among options or dragging sliders in dialog boxes, picking foreground and background colors, making selections with selection tools, etc. Record Mode is terminated by clicking Stop (■) at the bottom of the Actions Palette. 

When one plays an action (playback is initiated by clicking Play (►), also located at the bottom of the Actions Palette) Photoshop automatically executes the steps with the same settings and in the same sequence as they were recorded. 

Commands and operations applied with an action are not subject to sequence errors or setting changes that could occur if one attempted to manually apply them with mouse clicks and/or typing on a keyboard. Think of an action as “a step-by-step recipe that Photoshop plays automatically without variation.”

While actions are very powerful, unfortunately they can’t do everything. Search on CANTDOEVERYTHING
· Action Name: A name assigned to an action when it is created. Similar in concept to individual file names, Action Names are used to visually distinguish one action from another. Action Names can be changed at any time, but be careful if you do this (Stephen Marsh). Search on RENAMEPROBLEMS
· Action Step (often abbreviated step): The recorded details of Photoshop operations or commands such as:

· Applying a filter, e.g., Unsharp Mask or Gaussian Blur, and their associated settings such as Radius, Amount, Levels, etc. 

· Levels, Curves, Threshold, Invert, Desaturate, Hue/Saturation, etc. 

· Changing layer characteristics such as opacity, blend mode or layer name.

· Adding, duplicating, moving, merging or deleting layers. 

· Adding, deleting or applying layer masks.

· Opening, closing, saving or printing files.

An action step can also be (what’s known as) a Stop Command, which displays an on-screen message.

· Action Set File: A file that resides outside of the Actions Palette (on a hard disk, a floppy disk or a CD). An Action Set File is created when a Save Actions… command is applied to an Action Set, effectively copying the contents of the Action Set into the Action Set File. 

Action Set Files can be transported by e-mail (as attachments), CD or floppy disk, or uploaded to or downloaded from Internet sites. When an Action Set File is loaded into the Actions Palette, it is converted to an Action Set at which time the actions inside it are available to be played. Actions cannot be added to or deleted from an Action Set File, nor can actions inside an Action Set File be played. Actions can only be played when they reside inside Action Sets in the Actions Palette. 

· Action Set File Name: The name assigned to an Action Set File. On Macs and Windows-based computers .atn must be the last four characters of the file name. On most Mac/Photoshop combinations an Action Set File Name (including the .atn suffix) can be no longer than 31 characters.

· .atn file: See Action Set File. 

· .atn, .ATN: (1) The file name extension assigned to Action Set Files that distinguishes them from other file types. Although file name extensions are not usually required for files in the Macintosh environment, .atn is required for Action Set File Names. 

(2) It is not uncommon to see atn and ATN (with or without the leading period) used in written communication to represent action, Action Set, and/or Action Set File. In these cases one must evaluate context to discern the intended meaning. To avoid potential problems of this nature the generic application of atn and ATN will not be used in this document.


So, why so much confusion about terminology? Some of it is probably the result of two frequently used commands from the Actions Palette Menu that in my view are mislabeled: Save Actions… and Load Actions…, both of which will be addressed in much more detail later. 

When Save Actions… is selected, Photoshop actually saves an Action Set. In this case a more appropriate menu choice would be Save Action Set… A Load Actions… command actually loads an Action Set File, hence Load Action Set File… would be a more intuitive menu choice. Alas, the menu choices are what they are. Knowing how they should have been labeled will perhaps make things a little less confusing.

Finally, I invented two terms above: Action Set File (.atn), Action Set File Name. Why? To have a means to reference these distinct entities and distinguish them from other action-related objects.  

D. Frequently Asked Questions (FAQ) - for newbies
UP
1. Q: Can Photoshop actions run under Photoshop Elements? 

A: Yes, with a little help. Search on ELEMENTSCOMPAT
- - - - -

2. Q: I’m trying to write a simple action to automatically convert all files in a folder from .psd format to .jpg format using File > Automate > Batch, but with each image a dialog box is displayed requesting .jpg options. What am I doing wrong?

A: Once you know the trick, it’s a pretty easy fix. Search on OVERRIDESAVEAS 

- - - - -

3. Q: How do I transfer actions from my old version of Photoshop, say Photoshop 6, to a new version, say Photoshop CS?  

A: Easy stuff. Search on NEWPSVERSION
- - - - -

4. Q: How do I transfer actions from my old computer to my new computer?  

A: Again, a fairly simple process. Search on NEWMACHINE
- - - - -

5. Q: Where’s a good place to learn about actions? 

A: Photoshop’s built-in help topics on actions are very informative. In Photoshop press F1 and search on Automation Tasks or Actions.

If I may be so humble this tutorial is pretty good, too. (
- - - - -

6. Q: Besides this tutorial are you aware of other action tutorials on the Internet? 

A: Yes, indeed. There are many. Search on ACTIONTUTS
- - - - -

7. Q: Where does Photoshop save the actions I write? Are they in an .atn file like the ones I download from the Internet? 

A: Actions you write are NOT save in an .atn file unless you specifically engage the Save Actions… command to do that. Each time you shutdown Photoshop the contents of the Actions Palette, which includes all the actions you write, are save in a preferences file named Actions Palette.psp. Search on FINDINGPSP
- - - - -

8. Q: I’ve got a folder full of images (some portrait, some landscape). Can an action be used to automatically apply a copyright and/or signature to all of them?

A: Yes. The action is invoked through a process called batch processing, which enables it to apply the apply a copyright and/or signature to all images in a designated folder. If the action is written using the correct method, image orientation is irrelevant. Search on BATCHPROCESSING, INSERTCOPYRIGHT 

- - - - -

9. Q: I’ve seen atn, .atn, .ATN and ATN used in reference to actions, such as, “Hey, how about sending me that cool sharpening ATN.” What’s all this .atn business mean?

A: See section III. TERMINOLOGY above. 

- - - - -

10. Q: What’s the difference between an action and a filter and a plug-in?

A: On the surface this may appear to be an easy question to answer, but it isn’t. For a comprehensive side-by-side comparison search on ACTIONFILTERPLUGIN 

Here’s the abbreviated version…

While filters and plug-ins are similar in many ways, actions are in a league of their own. 

Generally speaking filters and plug-ins are invoked through menus (usually, but not always, the Filter or File menus and sometimes custom menus) and perform specific functions which cannot be modified by users beyond dialog box settings. You need to have programming skills to create a plug-in. 

Actions:

· Are invoked through the Actions Palette, the Automate > Batch dialog, by keyboard shortcuts or indirectly through droplets.

· Can be written by those without background in computer programming.

· Have no limit to their degree of modification.

· Can be shared with others as long as they were not purchased or there are no restrictions on distribution specified by the author. 

- - - - -

11. Q: Can Photoshop actions run under Photoshop LE, Corel PhotoPaint, Metacreations Photo-Brush, Micrografx Picture Publisher, Ulead Photo Impact, Jasc Paint Shop Pro, Gimp, etc? 

A: No. Non-Photoshop applications cannot play Photoshop actions and Photoshop cannot play action-like Productivity Scripts and Corel Script Files written using programs such as Jasc Paint Shop Pro 8 and Corel PhotoPaint, respectively. 

The LE in Photoshop LE stands for Limited Edition, which among other things translates to, “Does not support actions.”

- - - - -

12. Q: Where is the Actions Palette? 

A: Press F9 or choose Actions from the Window menu.

- - - - -

13. Q: How do I display the Actions Palette Menu? 

A: Click the black triangle (►) located at the top-right of the Actions Palette.

- - - - -

14. Q: I click and hold on the black triangle (►) located at the top-right of the Actions Palette to display this menu, but it doesn’t open. What am I doing wrong? 

A: You have probably exceeded a menu threshold. Search on NOACTIONS
- - - - -

15. Q: How do I save (backup) my actions?

A: Click on (highlight) the Action Set Name of the set whose actions you want to save and choose Save Actions… from the Actions Palette Menu. Search on SAVEACTIONS
- - - - -

WHATSTHEDIF 

16. Q: What’s the difference between an Action Set and an Action Set File (.atn)? 

A: The biggest distinction is where each resides (see “Location” in the table below. 

	Characteristic
	Action Set
	Action Set File (.atn)

	Location
	Resides in the  Actions Palette
	Resides outside of Photoshop, e.g., hard disk, CD or floppy disk or Internet

	Contains
	One or more actions 
	One or more actions, but they are in a different format than actions inside Action Sets

	Restrictions what characters can be included in the name
	None
	The last four characters must be “.atn”

	Actions can be added, deleted, modified or renamed
	Yes
	No

	Actions can be moved for organizational purposes
	Yes. Actions can be moved within an action set or between different action sets
	No

	Can be moved within the Actions Palette for organizational purpose
	Yes
	Not applicable since an .atn does not reside in the Actions Palette

	Photoshop can play actions from
	Yes
	No

	Photoshop will open if double-clicked
	No. This will open the Action Set Option dialog
	Yes, as long as Photoshop is not already open

	Can be transported via e-mail, CD, floppy disk or Internet upload or download process?
	No. An Action Set must be converted to as an .atn first using the Save Actions command.
	Yes


- - - - -

17. Q: Can you recommend sites where I can download actions? 

A: Yes and there are many. Search on ACTIONSITES
- - - - -

18. Q: What do I do after I download an Action Set File from the Internet or get one attached to an e-mail message? 

A: Load it into the Actions Palette. Search on LOADACTIONS
- - - - -

19. Q: What do I do with a .zip file? 

A: First you must “unzip” it. Search on UNZIPFILE
- - - - -

20. Q: When the .zip file is unzipped, what do I do then? 

A: Load the .atn file(s) it contains into the Actions Palette. Search on LOADACTIONS
- - - - -

21. Q: How do I play an action? 

A: Like many functions in Photoshop, there are a couple ways to play an action. The most common is: Select (highlight) the Action Name and click Play (►). Search on PLAYACTION 

- - - - -

22. Q: Why does nothing happen when I highlight an Action Set Name and click Play (►)? (DaveC)

A: Because you cannot play Action Sets. You can only play actions. Click on the Action Name, then click Play (►) and you’re in business.

It is possible to play all actions in an Action Set if that’s what is desired. Search on NESTEDACTIONS
- - - - -

23. Q: Play (►) is grayed out. Why? 

A: You have selected (highlighted) an Action Set Name, not an Action Name. When an Action Name is selected, Play (►) will be available.

- - - - -

24. Q: Can I suppress some or all of those annoying messages or dialog boxes that display every time I run an action? 

A: Yes, and it’s pretty easy to do. Search on MSGSUPPRESS
- - - - -

25. Q: How can I share actions from my action collection with others? 

A: Search on SHARINGACTIONS 
- - - - -

26. Q: What’s the best way to organize my actions? 

A: The best way is the way that works best for you. The options are practically unlimited. Search on ACTIONORG
- - - - -

27. Q: What’s the best way to learn how to write actions? 

A: Study actions written by others and start writing actions yourself. Search on ACTIONTUTS and ACTIONWRITE
- - - - -

28. Q: How do I move an action from one Action Set to another Action Set? 

A: Click on the Action Name (NOT the Action Set Name) and Drag and Drop the action into the destination Action Set.

- - - - -

29. Q: How do I copy an action from one Action Set to another Action Set? 

A: While holding down the Alt key, click on the Action Name (NOT the Action Set Name) and Drag and Drop the action into the destination Action Set.

- - - - -

30. Q: How do I print the steps in an action? 

A: Search on PRINTSTEPS
- - - - -

31. Q: My friend has a Mac. I’ve got Windows. If Photoshop is open and she double-clicks an .atn, the Action Set File gets loaded into the Actions Palette. When I double-click an .atn file, Photoshop opens, but no new actions. Why? 

A: This is one of those rare Mac/Windows differences. Some Windows users can get similar results using an obscure method. Search on OPENWITH

- - - - -

32. Q: If I want an Action Set File to be listed on the Actions Palette Menu, where does it need to be saved? 

A: C:\Program Files\Adobe\Photoshop 7.0\Presets\Photoshop Actions
- - - - -

33. Q: What’s the benefit of .atn files being in 
C:\Program Files\Adobe\Photoshop 7.0\Presets\Photoshop Actions? 

A: It simplifies the Load Actions process. Clicking the Action Set File Name on the Actions Palette Menu initiates the process of copying it into the Actions Palette and saving it as an Action Set, bypassing the Load Actions… process. 

- - - - -

34. Q: Do .atn files I download from the Internet or get via e-mail have to reside in 
C:\Program Files\Adobe\Photoshop 7.0\Presets\Photoshop Actions? 

A: No. Technically it does not matter where an Action Set File resides on your hard disk. Search on WHERETOPUTACTIONS
Remember, an .atn file is useless to Photoshop. It must be converted to an Action Set before actions in it can be played. Search on LOADACTIONS
- - - - -

35. Q: When I opened Photoshop for the first time, there’s an action set named Default in the Actions Palette. Where did it come from? 

A: When Photoshop is installed on your computer, the installer puts this action set into the Actions Palette. 

If you ever have to reload this action set, here’s where Default Actions.atn resides on your hard disk: 

C:\Program Files\Adobe\Photoshop 7.0\Required\
- - - - -

36. Q: Besides Default Actions.atn, where are the other Adobe provided action sets located on my hard disk? 

A: C:\Program Files\Adobe\Photoshop 7.0\Presets\Photoshop Actions
- - - - -

37. Q: How do I create a new Action Set of my own? 

A: Click NEW SET (() at the bottom of the Actions Palette.

- - - - -

38. Q: Can I have an Action Set inside an Action Set and, if so, how many levels of Action Sets can I have? 

A: No, you can not have an Action Set inside an Action Set: Action Sets within Action Sets are not permitted. In other words Photoshop allows only one level of Action Sets. Search on ACTIONORG
- - - - -

39. Q: On my computer I save my Photoshop files in the following folder and have recorded several actions that specify this path in SAVE commands: 
C:\MyDocuments\My PS Images

I just got a new computer and now all my data files are on D:\. Is there a way I can use, say, Microsoft Word (or any other program) to “find and replace” all occurrences of C:\ with D:\ avoiding the daunting task of rerecording all these actions? 

A: No. There is no way to modify actions outside of the Actions Palette. You’ll need to manually rerecord the SAVE commands one by one. Sorry about that. 

- - - - -

40. Q: I’ve developed quite a few custom Curves settings and saved them as .acv files. Now I want writes actions that include these Curves, but don’t want to have to distribute the individual .acv files with the actions. How can I do that?

A: Search on CURVESETTINGS
- - - - -

41. Q: I’m trying to automate the process of acquiring an image from my scanner, but it doesn't seem to work. After clicking RECORD I choose File > Import > Epson 3200. The scanner starts, but the step does not record in the action. Is this an invalid Action process?

A: No, it’s not an invalid process per se, but sometimes scanning operations cannot be recorded directly.

Try this: Be sure the scanning process is complete and the window to the scanner interface is closed. When you click OK, that may cause the step to record in the action. (RonHirsh)

If it does not this is a situation where the File > Import > Epson 3200 command has to be inserted (not recorded) into the action. (TonyK) Search on INSERTMENU 

- - - - -

42. Q: What question should be a frequently asked question, but isn’t? 

A: I would say, “Is there an easy way to backup all my Action Sets in the Actions Palette without plowing through the Save Actions dialog for each one?”

The good news: Yes there is. You won’t believe how easy it is. Search on ACTIONSPREFERENCEFILE
E. Tidbits For action heads: did you know?
UP
Before I started doing research for this document I’d probably written 200-250 actions of various types and flavors. (Note: Don’t confuse quantity with quality. I’ve still got a LOT to learn about crafting quality actions.) One of the unexpected benefits of this experience has been learning a whole lot I didn’t know previously. 

While hardened action addicts may classify some items from this next list in the categories of “Already knew that one,” “That’s nice, but so what?” or “Trivia,” many were real blockbusters for me. Hopefully you’ll find at least a few golden nuggets among them.

ACTIONHIST 
DID YOU KNOW…

1. The Actions Palette first appeared in Photoshop 4, succeeding Photoshop 3’s Commands Palette? Photoshop 3 Command Sets (as they were called) could not be loaded into Photoshop 4’s Actions Palette? Actions written under PS 5.x could not be played under PS 4, just like PS 5.x cannot play (or even load) actions written with later Photoshop versions. Looks like “Déjà vu all over again,” as Yogi Berra once said.

- - - - -

2. Pressing the TAB key will show/hide all palettes and Tool Bar and SHIFT + TAB toggles the palettes? These comes in handy when you need to see an uncluttered screen while developing actions – or doing anything else for that matter.

- - - - -

3. F5, F7 and F9 will show/hide the Brushes, Layers and Actions Palettes respectively if they are not docked in the palette well and just show them if they are docked? (DougC)

- - - - -

4. You can mass load multiple Action Set Files (as in as many at a time as you like) all at once into the Actions Palette vs. one-at-a-time using the Load Actions… command? Search on LOADFAST
- - - - -

5. You can mass load multiple Action Set Files from a .zip file WITHOUT unzipping it? Search on LOADFAST
- - - - -

6. If Photoshop is open, you can load an Action Set File by opening it using Window’s Open With command or double-clicking on it in Mac? In some cases this works on Windows, too. Search on OPENWITH 

- - - - -

7. There are at least three ways to copy (duplicate) an action? 
Search on BIGTABLE
- - - - -

8. When an action is played you can prevent Photoshop from expanding it in the Actions Palette by choosing Accelerated among the Playback Options. Search on PLAYBACKOPTIONS
- - - - -

9. You can select tools like the Move tool that normally cannot be selected in an action? Search on Selectmovetool
- - - - -

10. If you assign an Action Name in the New Action dialog or change it in the Action Options dialog, the name is restricted to 31 characters, but if you double-click an Action Name in the Actions Palette the name can contain up to 64 characters? 

- - - - -

11. If you assign an Action Set Name in the New Set dialog or change it in the Set Options dialog, the name is restricted to 31 characters, but if you double-click an existing Action Set Name in the Actions Palette the name can be up to 64 characters in length? 

- - - - -

12. Under Windows .atn files with file names as long as 199 characters (203 characters if you count the .atn file name extension) can be converted into Action Sets and loaded into the Actions Palette using the Load Actions… command? It’s unlikely you’ll ever need a 199 character Action Set Name, but it is possible. 

- - - - -

13. Under Windows 2000, XP and XP/PRO you can put over 1,100 5-step actions in a single Action Set? (I stopped trying to add more after 1,100 reasoning that it was doubtful anyone would ever need that many and there’s little value in knowing the exact maximum.)

- - - - -

14. If you’re quick with the mouse it’s possible to check or uncheck the Enable/Disable or Display Dialog checkboxes for a given step while an action is running?

- - - - -

15. If you’re quick with the mouse it’s possible to reposition the active window or an on-screen palette while an action is running?

- - - - -

16. In order to quickly determine actions to which keyboard shortcuts have been assigned, display the Actions Palette in Button Mode? 

- - - - -

17. When the Actions Palette is in Button Mode the button that’s clicked to launch an action will turn red if the corresponding action executes a Stop Command and the user clicks the Stop button in the dialog, and that clicking that same button (turned red) will resume the paused action?

- - - - -

18. The maximum number of characters permitted in a Stop Command message is 255?

- - - - -

19. You can terminate Record Mode or halt a running action by clicking Stop (■) or the Esc key?

- - - - -

20. You can execute Insert Stop and Insert Menu Item commands even when Record Mode is active?

- - - - -

21. To expand/collapse all actions and all Action steps with an Action Set, Alt + click on the Show/Hide Triangle to the left of the Action Set Name?

- - - - -

22. To expand/collapse all steps within an action, Alt + click on the Show/Hide Triangle to the left of the Action Name?

- - - - -

23. You can replace the Adobe provided actions in default action set Default.atn with your own actions? As long as Default.atn resides in C:\Program Files\Adobe\Photoshop 7.0\Required\, Photoshop does not care what actions it contains. 

- - - - -

24. A given keyboard shortcut, such as F5 or Shift + F3, can be assigned to (and will play) multiple actions? Search on DUPSHORTCUTS
- - - - -

25. If you accidentally turn on (or leave on) Record Mode and record numerous commands you don’t want, there is an easy way to delete them? Click (highlight) the first unwanted command, then, while holding down the Ctrl key, click the last unwanted command, selecting the range. Finally drag the selected commands to the Trash ([image: image1.jpg]


).

- - - - -

26. If you have numerous Action Sets in your Actions Palette, they can be backed up all at the same time without a single trip through the Save Actions dialog? This same technique can be used to transfer the contents of your entire Actions Palette to your new computer or to a new version of Photoshop. Search on ACTIONSPREFERENCEFILE
- - - - -

27. For learning or debugging purposes there’s a real easy way to play an action one-command-at-a-time that doesn’t involve Playback Options? Search on 1STEPATATIME 

- - - - -

28. Although you cannot record strokes of the Stamp tool (also known as the Clone tool) in an action, a Patch Tool repair can be recorded which may enable one to automate fixing hot spots in a folder of images? 

F. Basic Concepts

UP

This section is primarily intended for those with little or no experience with actions. The topics addressed are intended to build foundational knowledge and skills by answering questions such as: 
 

· “What is an action?”

· “Why would I want to record one?” 

· “What can actions do (and not do)?”

1. LEARNING ABOUT ACTIONS: PHOTOSHOP HELP, WEBSITES, BOOKS, VIDEOS 

UP
1.1 Q: Before reading further is there anything I should know?

A: I found the help topics in Photoshop 7 to be well organized and very informative. To those interested in actions (or Photoshop automation in general) I would highly recommend reading these. 


Press F1 to display Photoshop’s Help function and then choose Automating Tasks from the topic list on the left. 

- - - - - -

ACTIONTUTS
1.2 Q: Are there Internet tutorials on actions you would recommend?

A: Here are a few sites worthy of mention. The first few are outstanding. Those in the second group are quite good; the rest are worth a look.


NOTE: If you’d like to submit links to action tutorials to be considered for future updates of this document, I welcome your recommendations. Search on SUGGESTIONSCOMMENTS
Best of the bunch:

DigitalIguana.com - http://tinyurl.com/ywkwd or
http://www.digitaliguana.com/Handouts/DPIX2001/DPIX%20-%20Actions%20-%20COLOR.pdf
Seán Duggan, Katrin Eismann (Signature action, batch processing, droplets):

http://www.digitalphotobook.net/tutorials/actions/actions_1.html
Trevor Morris:

http://user.fundy.net/morris/redirect.html?photoshop21.shtml
PDF version: http://user.fundy.net/morris/downloads/Actions.pdf
University of Texas (PDF):

http://technology.communication.utexas.edu/dv/PDF/ps_a_automation.pdf


Rob Dublin’s tutorial (PDF):

http://www.hookbuilt.com/nypc/actions.pdf
Transcontinental (PDF):

http://www.transcontinental-printing.com/cust/training/pdf/PhotoshopActionsBatchProc.pdf
VERY GOOD: 

“Take advantage of PS Actions,” Tim Plumer: http://tinyurl.com/2283j
One of the better ones:
http://www.chainstyle.com/photoshop/webhelp/tutorials/basics/anatomy_of_an_action.htm
Scroll down to the Photoshop section. This is a 3-part series.
http://www.soniacoleman.com/Tutorials/tutorials.htm
More Trevor Morris handiwork:

http://www.webdesignhelper.co.uk/photoshop_tutorials/photoshop_intro_tutorials/photoshop_intro_tutorial26/photoshop_intro_tutorial26.shtml
There are always a lot of goodies at About.com: 

http://graphicssoft.about.com/cs/photoshopactiontip/index.htm
http://graphicssoft.about.com/cs/photoshopactions/
How to create a watermark action.

http://www.riecks.com/forphotogs/copyrightaction.html
Roger Cavanagh’s site:

http://www.rogercavanagh.com/actions/14_creating.htm 
HONORABLE MENTION: 

http://www.actionfx.com/ 

Click on Tutorials button near the top of the window.

http://www.benwillmore.com/tips/012301tip.html
Ben Wilmore: Action tips

http://www.michielsen.info/photoshop/actions/index.htm
Courtesy of Leo Michielsen. Very good screen shots.

http://www.dpandi.com/actions/
Drew MacCallum's. Great for a beginner. Step-by-step.

http://www.ddj.com/documents/s=2932/nam1012433951/index.html
Excerpt from Donnie O’Quinn’s Photoshop in a Nutshell. This is a good summary of action development considerations.

http://www.myjanee.com/tuts/centeract/centeract.htm
A tutorial on how to write a simple action that marks the center of an image.

http://www.retouchpro.com/tutorials/actions/index.html
This tutorial is richly illustrated. 

http://www.lonestardigital.com/action.htm
How to assign a keyboard shortcut to an action. Good screenshots. 

http://www.outbackphoto.com/workflow/wf_19/essay.html
Includes an example of record actions within an action.

http://www.shutterfreaks.com/Tips/GettingStartedPS.html
Good graphics to guide you along the way.

http://www.xkeys.com/resources/action7.php
How to quickly record four actions. Forget the “x-keys” instructions at the end if you like.

http://www.betterphoto.com/photocourses/_samples/PSautomation.asp
By Jim Mioke; a lot of detail and graphics. 

http://www.digital-foundry.com/photoshop/workshop/actions_intro.shtml
Although written for PS 4, the concepts are the same and there’s some good basic info. Describes how to create a sepia toned image from a color photo.

http://www.rice.edu//fondren/erc/howto/photoshop.html#actions
From Rice University.

http://depts.washington.edu/trio/comp/howto/pieces/images/pshopaction/index.shtml From University of Washington.
might be helpful:

http://www.dotproject.org/articles.php?action=read&id=8
Quick and basic.

http://www.photoshopcafe.com/tutorials/actions/actions.htm
A quickie overview. 


http://www.rogercavanagh.com/actions/10_batch_action.htm
Basic overview.

http://www.psmeg.co.uk/pages/tutorials/actions.htm
Basic overview.
- - - - - -

GOODBOOKS 

1.3 Q: What about books?

A: Until February 2004 I had yet to see a book dedicated to actions. Most books give actions give actions minimal coverage, seldom more than a few pages.


These are the exceptions that provide the most in depth coverage I’ve found so far: 

Photoshop in a Nutshell (based on Photoshop 5)


Photoshop 6 Shop Manual (based on PS 6)


Both were authored by Donnie O’Quinn and have comprehensive sections on actions (in general), the Actions Palette, action related commands and batch processing. Though brief, the presentation on droplets is the best I’ve seen anywhere, too. 


Speaking from the perspective of action and batch automation related topics only, the content of each is nearly identical except for slight version differences. The Source/File Browser option in the File > Automate > Batch dialog is the only topic not addressed because this feature was not introduced until PS 7. The rest is fully applicable to PS 7 and later versions.  


Despite being written for older Photoshop versions, I highly recommend either of these not only for the action and batch processing content, but for their overall breadth, depth and exceptionally useful information on Photoshop topics from A to Z. Look into second hand editions at used book sites like http://www.half.com/ and Amazon.com’s zShops (used books).


The second book that stood out action and batch processing-wise was Photoshop 7 Bible Professional Edition by Deke McClelland. Note, this is not the standard edition of PS Bible, which sadly has practically no useful content in these areas. P7BPE has Source/File Browser content as well as practical information and examples missing from the PS Shop Manual above. 

The Hidden Power of Photoshop CS by Richard Lynch (2004) has a very informative section on batch automation and goes into actions for ImageReady as well.

Although not yet published as of this update, keep your eyes open for the first book I’ve seen dedicated to Photoshop actions: Al Ward's Photoshop Productivity Toolkit: Over 500 Time-Saving Actions. Al’s site, www.ActionFX.com, has been around for years and he’s recognized far and wide as one of the pioneering action gurus. He’s written numerous articles about actions and maintains the actions section of the NAPP Website. I’ve preorder his book at Amazon.com. It is expected to be available sometime the second half of 2004.

Search on HELPBIB
- - - - - -

1.4 Q: How about Google USENET discussion groups?

A: Like the Google Web searches, the discussion groups are a GOLD MINE of information. http://groups.google.com/ 

Use search arguments such as:

     Photoshop actions

     Photoshop “action tutorial”

     Photoshop automation

     Photoshop “batch processing”

You’ll be reading for weeks, if not months.

- - - - - -

1.5 Q: How about videos?


A: To date I’ve only seen one video devoted to actions, Unleashing the Power of Actions, produced and distributed a few years back by Scott Kelby. This video is no longer being offered for sale at http://www.photoshopvideos.com/, but it occasionally shows up for sale in eBay auctions. I bought a copy via eBay, watched it twice and sold it. 


Although the breadth of content was sufficient, those looking for meaty content and useful tidbits will find the technical depth shallow. In all fairness adequate coverage of actions in a 1-hour video is impossible. Even so, I would have preferred fewer topics and more depth. This video would be suitable for those seeking a visual highlight film of action capabilities without fear of being buried in technical detail. 
 


Speaking of Photoshop videos, sometimes fairly recent ones are available at public or school libraries or can be rented from video stores. If you are able to view Unleashing the Power of Actions for a nominal rental fee or, better yet, for free, that would be the way to go.

2. WHY RECORD ACTIONS?

UP
2.1 Q: Why would anyone want to record an action?


A: Here are some typical reasons.

To leverage frequently used Photoshop features or functions
Each person uses Photoshop differently. Actions can essentially customize Photoshop to meet individual requirements. 


Knowledge preservation
Since actions consist of recorded steps, once created the steps are available for as long as the action exists. If a key member of the staff wins the lottery and retires to Tahiti, the actions he wrote and used in his work (if they were good ones) will make his departure a little less painful. They can be played by others and will yield the same results.


The ultimate do-over
Since each time an action is played its commands are applied in the same sequence, an image created by playing one or more actions can be recreated in the event the modified image is lost or damaged IF the original image and actions applied to it are still available. 


To accurately capture sessions of exploration or creativity (KentC)
If you’re into photo-art (and who isn’t? LOL) have you ever been in “Trial and Error Mode” where you’ll try this, undo that, apply something here, tweak something there and all of a sudden end up with a GREAT result? Then it hits you: “How the heck did I DO THAT?” The degree of success in recreating a particular effect depends on factors such as memory, ability to interpret and manipulate History Palette states, the number of states recorded before history rolls over and perhaps a little (or a lot) of luck. If you click Record New Action (() just before launching into creative mode, this will ensure all steps leading up to that inspirational result are dutifully recorded thus eliminating memory and luck as factors in the reconstruction process. While you may end up with a lot of throw-away steps using this approach, at least you’ll have all the steps. Eliminating unneeded steps is more efficient and yields more accurate results than starting from scratch, especially on complicated effects.

Note: Photoshop CS introduced a new function called the History log which tracks a great deal more detail than an action can, but the log cannot be converted into an action.

Benchmarking: 

Some actions are written for the purpose of benchmarking (performance comparison). A set of actions is executed on computer A and timed. The same set of actions is played on computer B (or computer A which is configured differently) and timed. The elapsed times are compared for throughput analysis or troubleshooting purposes. (PierreC).

To save time and increase productivity
Using actions has the potential to achieve significant gains in productivity by utilizing the power of today’s computers. For example converting file formats or applying a complex multi-step sharpening process to hundreds of images are daunting tasks that would take hours — possibly days, if done manually, but can be performed automatically by actions in a fraction of the time. (TonyK) 


Increase action development and maintenance productivity (TonyK)
Editorial comment: I’m about to launch into some techno-babble, so don’t worry if your eyes glaze over a bit. Most people won’t have a use for this level of sophistication, while others may be intrigued by the possibilities. 


Suppose you have 50 actions and each must play the same 10 commands at the outset. One way to accomplish this would be to record (or copy) the 10 identical steps into each of the 50 actions.


Another approach would be to write a separate action consisting of the 10 commands. Then, record (or copy) a single command in each of the 50 actions that calls the 10-step action. 


Here’s how the called action model pays off. Suppose when Adobe comes out with Photoshop 11 you decide to replace step three of the 10-step sequence with a new command. Using the called action model, a single change to the called 10-step action is all that’s needed: swap out the old step three with the new step three. No changes are necessary for the 50 individual actions since they call the modified 10-step action. In the model where each of the 50 actions contain the 10 individual steps, step three would have to be swapped out 50 times, once for each action. Ugly. 

Search on NESTEDACTIONS


To aid those less skilled
Actions can be used by entry-level personnel until they have sufficient knowledge/experience to manually complete tasks faster than actions can achieve them. 


Process compliance
Some actions are purposely created to apply commands without user input or variation. Consistent results are produced each and every time. 


Other actions allow users to modify settings or select options as the action plays. Playing actions of this nature ensures the same commands are applied each time, while allowing for setting variations. 


Standards or documentation compliance
If you are an ISO9000/9001 compliant facility or are involved in forensic photo enhancement, it is frequently a requirement to accurately document changes made to an image or group of images. (TonyK)


Simplify making choices among various methods
If you haven’t discovered it yet, you will in time: For a given result there can be multiple methods of achieving it in Photoshop. Sharpening an image is a good example.


Besides Sharpen > Unsharp Mask, other sharpening methods have been developed, each with its own set of pros and cons and optimal target image characteristics – not to mention unique steps. Here are some common sharpening methods: High Pass sharpening, Luminosity sharpening, Overlay sharpening, Edge sharpening and Multi-pass sharpening. Among these are variations as well. 


Being able to play an action for each method relieves one from memorizing individual techniques and variations. It also simplifies the process of applying different techniques and evaluating the results side-by-side.


To share knowledge
Since actions can be e-mailed or posted on Websites for download, they provide a convenient and portable way for sharing techniques with Photoshop users worldwide.


To learn more about Photoshop (self-directed learning)
Studying actions can be a great way to learn different techniques. By looking under the hood and studying actions written by others, those new to Photoshop as well as experienced users can discover not only better ways to create actions, but new ways of applying the limitless combinations of Photoshop commands, filters, options, settings, blend modes, etc. (TonyK)

Personally I’ve found a close correlation between studying (and writing) actions and a more rapid ascent of the steep and seemingly never ending Photoshop learning curve. 


To enable those new Photoshop to explore artistic capabilities
Since taking over administration of the DPReview Retouching Forum Action Collection, which contains numerous actions developed for the purpose of creating photo-art, it has come to my attention how many fairly novice Photoshop users make use of the photo-art actions. These actions inspire some users to engage in a creative activity while they learn basic Photoshop skills. They’re able to apply effects and achieve results without knowing how to write actions. 


As a teaching supplement
Sometimes I craft an action to generate a multi-layer image that serves as the basis for a tutorial. Having an action do this setup relieves me of having to document the construction process and ensures students start with the same image. 


Just for the fun of it – and maybe make a buck or two!

Some people like to build model airplanes; others enjoy woodworking. Why not write actions? A few folks (Fred Miranda and Mike Finn come to mind) earn well-deserved revenue for developing well crafted and useful actions and making them available for purchase. 

- - - - - -

2.2 Q: What characteristics of actions make them appealing?


A: Appealing aspects include:

· Actions are feature rich. Most tasks one performs in Photoshop can be preserved in an action.

· Actions are easy to organize, modify, duplicate, backup and restore.

· The Photoshop implementation of actions is fairly straightforward.

· Learning to use actions is not difficult. There are numerous How to Use Actions tutorials on the Internet. 

· Learning to write actions is not difficult. No formal computer programming background is required. 

· It’s easy to share actions with others.

3. TYPES OF THINGS ACTIONS CAN RECORD

UP
3.1 Q: Can you give some examples of what kinds of things can be recorded in an action?


A: Actions can record most commands that can be chosen from Photoshop’s menus or invoked by the corresponding Photoshop keyboard shortcut, settings made by selecting from a pull-down menu, option choices, keying in text or numeric values into a field, adjusting a slider, etc., for example: 

· Opening, closing, printing files

· Applying filters from Sharpening to Blurring, adding Noise and Film Grain, Emboss, Colored Pencil, Clouds, Plastic Wrap, etc.

· Adding adjustment layers and layer masks

· Changing color space modes, e.g., from cmyk to rgb, rgb to grayscale

· Changing file format, for example, .jpg to .tif

· Easily switching among predefined Window > Workspace definitions 

· Dialog box settings specified by dragging a slider or typing in a value

· Adding, modifying or deleting layers, channels, layer masks or alpha channels

· Changing layer characteristics (blend modes, opacity percentage, etc.), 

· Moving layers up or down in the layers palette

· Applying a gradient or displacement map

· Applying layer styles

· Duplicating images

· Changes to image resolution and canvas size

· Manipulating type layers

· Selections made with any of the selection tools

…and this is just the tip of the iceberg.

4. EXAMPLE RESULTS

UP
4.1 Q: Why all the fuss?


A: Here are just a few examples of how one might use actions:

· If you don’t have Photoshop CS yet, to assign a keyboard shortcut to frequently used commands (or command variations) that were not assigned a native Photoshop shortcut, such as View > Clear Guides, Edit > Stroke, Alt + Merge visible, etc. Note: You can do this in Photoshop CS without actions. 

· To automatically remove (or reduce) noise, sharpen and apply color correction to each image generated by scanning a roll of negatives.

· To generate textures of various types (wood, marble, stone, carpet-like, grass, etc.), frames (oval or rectangular), mattes, buttons, drop-shadows, 3-D and text effects.

· To convert color images to black and white (grayscale) using various techniques, e.g., Desaturate, Channel Mixer (monochrome), individual RGB channels, etc., in order to perform side-by-side comparisons.

· To transform an image into photo-art by applying steps attempting to mimic effects such as pencil sketch, line art, watercolor, oil painting, pen-and-ink, etc. 

· To “age” a picture by adding an old time sepia effect and giving it a scratched, worn and torn look as though it had been stored in the attic for many years.

5. GOOD AND BAD ACTION CANDIDATES

UP
5.1 Q: What qualifies a task to have an action written for it?


A: A candidate task typically has one or more of the following characteristics:

· The task will need to be repeated in the future. 

· Because of the number of steps it’s faster to complete the task by running an action than applying commands manually.

· Regardless of the number of steps, the steps are tedious, complex and/or difficult to remember.

- - - - - -

5.2 Q: What types of tasks are not well suited for actions?


A: Tasks that:

· Will not be repeated in the future. 

· Don’t have a fixed number of steps that needed to be performed in the same sequence each time.

· Require a considerable amount of manual intervention. 

· Can be completed through a simple menu selection or standard keyboard shortcuts, for example, Select All (Ctrl + A) or Undo (Ctrl + Z). 

· Rely on brush strokes, since strokes cannot be recorded. (TrevorM)

CANTDOEVERYTHING

6. ACTION LIMITATIONS AND WORKAROUNDS

UP
6.1 Q: Can actions record everything you can do in Photoshop?


A: No. Here are a few examples: 

· Although somewhat dated this excerpt from Donnie O’Quinn’s Photoshop in a Nutshell (based on Photoshop 5) presents a good summary of action limitations. http://www.ddj.com/documents/s=2932/nam1012433951/index.html
· Strokes generated by tools that use brush strokes, e.g., paint brush, eraser, cloning (stamp), history brush, dodge, burn, blur and smudge tools, etc.

· Although completed paths can be inserted by actions, the individual steps that go into creating a path cannot be recorded.

· Selecting some tools or setting / changing tool options (unless presets have been defined which can be selected)

· Some commands from the File, Edit, View and Window menus

· Accessing what you would think would be common data elements such as file name, EXIF information, current date, etc.

· Actions do not have the capability to do calculations or comparisons that would enable one to, say, determine which of two images was larger, what side of an image was the longest side or change an image’s resolution by a percentage based on its present resolution.


Most of these limitations can be gotten around with Photoshop Scripting. Search on PSSCRIPTING 

- - - - - -

6.2 Q: Besides not being able to record some commands, are there other limitations of which you’re aware?


A: Yes. 

· You cannot create an action that loops (or plays forever) until interrupted that would, say, play a slide show.

· Actions are incapable of executing if-then-else or Boolean logic or perform branching or go to-like operations.

· Actions cannot modify other actions.

· Actions by themselves cannot influence programs outside of Photoshop, for example, an action cannot open an instance of Excel or Illustrator, or carry out a Windows command unless the action invokes a Photoshop Script so programmed. 

· The inability to access common data elements such as file name, EXIF information, current date, etc.


Again, most of these limitations can be gotten around with Photoshop Scripting. Search on PSSCRIPTING 

- - - - - -

6.3 Q: If actions come up short functionally, are there alternatives? 


A: Yes. When Photoshop 7 was released, Adobe introduced Photoshop Scripting. Scripts can be written to perform tasks that are beyond the capabilities of actions. Search on PSSCRIPTING

- - - - - -

6.4 Q: I would like to write an action to place the file name of an image in the top right corner, but I’m having problems trying to figure out how. Can you help? 


A: No and yes. What you’d like to do is not possible with an action. Search on ACTIONALTERNATIVES
7. WHERE ACTIONS COME FROM 

UP
7.1 Q: Where do actions come from?


A: All actions are created by “someone,” either you or someone else.

- - - - - -

7.2 Q: How can I get actions written by others?


A: When Photoshop is installed Adobe includes a number of sample actions for your amusement and education. 


Open your Actions Palette (F9 or Window > Actions) and you’ll see Default Actions. Open the Actions Palette Menu (►) where at the bottom you will see the Action Set File Names of the other Adobe-provided actions. Click on any Action Set File Name to load the actions it contains into the Actions Palette.


The most common sources for actions are self-service, public Internet sites from which Action Set Files can be downloaded. Most actions available for download from the Internet are free. In some cases authors charge for their handiwork. Search on ACTIONSITES

Friends, work associates or folks you’ve gotten to know through forums or e-mail can be sources for actions. Typically they use e-mail to distribute actions from their own collections. Search on SHARINGACTIONS 

While it’s possible to transport Action Set Files on CDs or floppy disks, using e-mail as a distribution method is much more common.

8. MISCELLANEOUS GENERAL QUESTIONS 

UP
8.1 Q: I’m kind of low on disk space. Will Action Set Files chew up disk real estate as fast as Photoshop files?


A: Absolutely not. When compared to Photoshop files in .psd format, Action Set Files are minuscule. They typically fall into the 1KB-10KB range. 

- - - - - -

8.2 Q: How are actions related to Droplets?


A: Droplets are created from actions and are closely related to batch processing that’s initiated by File > Automate > Batch. Search on DROPS
- - - - - -

8.3 Q: I read an opinion in a forum once that people, especially Photoshop rookies, shouldn’t use actions. Do you agree with that opinion?


A: No, I don’t agree. 


Some argue against Photoshop rookies using actions before they understand the underlying concepts and commands that went into building the action. In my opinion that is like taking the position that one has have the credentials of an electrical engineer before operating a television or telephone. 


That said, does it hurt to understand what’s going on under the covers? Of course not. In fact I’ve personally learned a LOT about Photoshop and action writing by dissecting actions. In fact I highly recommend the practice of action analysis to anyone who wants to learn more about Photoshop functionality and capabilities or who aspires to become an action author. 


Although actions should not be the only source of ones Photoshop education, they can certainly play a part. I don’t see anything wrong with using or experimenting with actions regardless of your position on the learning curve. 


For other perspectives, here is an enlightening discussion on the topic. You be the judge.


www.forums.dpreview.com/forums/read.asp?forum=1006&message=4773257
- - - - - -

8.4 Q: When one runs an action, are the steps applied to only one image or can they be applied to more than one image?


A: Yes to both parts of the question.

If an action is played from the Actions Palette, normally its commands are applied to the active image. Exception: When the action consists of commands not requiring an open image, for example Window > Actions. 


If the action is applied via the File > Automate > Batch dialog or has been converted to a Droplet, the action affects as many images as there are in the designated source location.


Search on BATCHPROCESSING
G. Compatibility 

UP
In a perfect world all actions, regardless of which version or language edition of Photoshop was used to write them, would run on all versions of Photoshop, Photoshop Elements and non-Adobe products. Unfortunately, that’s not the case.

The purpose of this section is to identify the speed bumps or roadblocks in this regard. Understanding compatibility (or lack of it) will help some readers “cut to the chase,” that is, determine if further reading is warranted. 

To summarize the following sections:

· Actions can only be created and modified in Photoshop.

· An add-on can be applied to Photoshop Elements, enabling Elements to play actions that meet certain standards, i.e., some actions that play without problems in Photoshop will fail when played by the modified Elements.

· Outside of Photoshop Elements and Photoshop itself, actions cannot be played by any other programs.

· Between versions of Photoshop, action incompatibilities can range from minor (and easily remedied) to impossible to overcome.

1. COMPATIBILITY WITH NEW OR FUTURE VERSIONS OF PHOTOSHOP

UP
1.1 Q: Will the actions I write today under my present version of Photoshop work a few years from now under, say, Photoshop 13 or whatever it will be named?


A: Even though Adobe has a track record of releasing versions of Photoshop that imposed upward and downward action incompatibilities (search on ACTIONHIST), I would bet future versions of Photoshop will play actions written using prior versions.

With so many people and businesses having spent so much time and energy since Photoshop 5 building, testing and modifying actions to meet personal and business needs, I can’t image Adobe coming out with a new version of Photoshop with a sales killing caveat like, “But you know all the actions you’ve written over the years? They won’t work with this new version.” For some this would be a non-issue, but for many it would be a huge showstopper that would result in a considerable amount of lost revenue for Adobe.

That’s not to say there won’t ever again be version that imposes downward compatibility limitations. While I expect PS 13 will be able to play actions written with Photoshop CS, versions 12 and before may not be able to play actions written with PS 13. That’s the situation now where Photoshop 5 cannot play actions written by PS 6 and later.

2. COMPATIBILITY WITH THE NEW VERSION OF PHOTOSHOP

UP
2.1 Q: I’ve got Photoshop version X and version Y just came out. Action-wise, how long should I keep version X around after I upgrade to new version Y?


A: It depends. 
If you are very dependent on actions, it would be wise to test individual actions, actions invoked through batch and especially droplets under the new version.

When Photoshop CS came out some users had problems for months getting droplets to run successfully. Their remedy: Reinstall Photoshop 7. 

Another person had an action fail under CS that worked perfectly under Photoshop 7. (When played under CS the action rendered completely unusable text that came out in a small blob.) Corrective action was for her to send the failing action to me where I could rerecord the failing step under PS 7. I e-mailed it back to her where it worked fine. 

If you’re not hurting for disk space, I see no reason to rush the removal of the old version.

3. COMPATIBILITY WITH PHOTOSHOP ELEMENTS
ELEMENTSCOMPAT
UP
3.1 Q: Can Photoshop Elements run actions?

A: Yes. Elements actually runs actions in several different ways, but you have to know how to get them running. Batch, Effects, the Welcome Menu and Recipes/How-To can all play actions. Add in functionality can make it easier to install and play specific actions, so there is less to know.

- - - - - -

3.2 Q: What sort of “add in functionality”? How is this possible?

A: Elements has functionality that Adobe does not promote, which was revealed in a very well written book by Richard Lynch, The Hidden Power of Photoshop Elements 2, ISBN: 0782141781. See http://www.hiddenelements.com/ for additional information.

As of this writing two methods have been developed and published for this purpose.

1) As a supplement to the book noted above, Richard put together an impressive (and FREE) package that contains a tutorial and all the files necessary to enable versions 1.0 and 2.0 of Photoshop Elements to play actions. It works with simple installers on Mac and PC and can be downloaded here: 


http://www.hiddenelements.com/freetools.html
While it is not difficult to enable this functionality and add prepackaged action sets, one needs to carefully follow the detailed instructions to customize the interface. 

The interface also comes with several add-ons, including Quick Mask, true Layer Masks, Selective Color, Channel Mixer and an Actions Playback speed control. These tools are not available elsewhere, and are not included in the Hidden Power book.


While you’re there, sign up for Richard’s regular newsletters on Photoshop Elements, which almost always has an article or Q/A about playing actions under Elements: http://hiddenelements.com/newsletter.html#
As though Richard isn’t busy enough already, he also moderates the Hidden Power of Photoshop Elements forum at http://www.retouchpro.com/ where he cheerfully answers all kinds of questions about Elements, including ones related to this action enabling functionality. 

2) snapActions was developed by Ling Nero in collaboration with Bud Guinn. This add-on is also free and can be downloaded here:
http://www.geocities.com/rnlnero/PE2stuff2.html
- - - - - -

3.3 Q: Which method is better?

A: I don’t own Elements and, therefore, have no opinion. 

Since there is no functionality conflict, both add-ons can cohabitate in an existing Elements environment. There is no reason why you cannot install each and do your own evaluation. 

- - - - - -

3.4 Q: Can Photoshop Elements record new or modify existing actions?

A: Not as of this writing. If a way is to be found, I’m betting Richard or Ling will be the ones to crack the code, pioneer the path and publish the solution. 

- - - - - -

3.5 Q: I recently implemented the Richard Lynch method to run actions under Elements and it works great. Today I paid for and downloaded an action from Pay-more-4-Actions.com. I installed it, but the first time I played it I got an error message. I went back to the site where I bought the action, looking for assistance. Sure enough there was a warning about incompatibility with Elements that I missed before clicking that fateful Buy It! button. What now?

A: The lesson to be learned from this question is that although Richard’s and Ling’s methods enable Photoshop Elements to run many actions “as is,” actions containing certain commands will fail if played under Elements. 

In this case it may be possible for someone who has Photoshop (and Elements action writing knowledge) to modify the action so it is compatible with Elements. It may be necessary to write a completely different action to achieve comparable (and acceptable) results. It depends on the action and getting permission from the original actions author.

- - - - - -

3.6 Q: I have Photoshop and Elements and I’d like to write actions for Elements. Is that possible?

A: It sure is. Search on WRITINGELEMENTSACTIONS
4. COMPATIBILITY WITH PHOTOSHOP LE

UP
4.1 Q: I have Photoshop LE. Will it run actions? 

A: No. 

5. COMPATIBILITY WITH ACADEMIC (EDUCATIONAL) VERSIONS OF PHOTOSHOP

UP
5.1 Q: I have an Academic version of Photoshop (sometimes referred to as an Educational version). Can I write and play actions with this version? 
A: Yes. Functionally speaking academic and standard versions of Photoshop are identical. Actions can be created and modified across versions (academic or otherwise), subject to version compatibility restrictions noted elsewhere.

6. COMPATIBILITY WITH OTHER PROGRAMS

UP
6.1 Q: Can actions recorded in Photoshop be played by programs like Corel PhotoPaint, Mediachance Photo-Brush, Micrografx Picture Publisher, Ulead Photo Impact, Jasc Paint Shop Pro, Gimp, etc? 

A: No. 

It is possible, however, to print action steps that can be used as a roadmap from which comparable effects can be created by non-Photoshop programs that have the ability to record and playback commands. Search on PRINTSTEPS
7. COMPATIBILITY BETWEEN WINDOWS AND MACINTOSH VERSIONS

UP
7.1 Q: I’m running Photoshop on a Mac. Can actions written under Photoshop for Windows run under the Mac version and vice versa?

A: Yes, for the most part. 

Editorial comment: I don’t have access to a Mac. Based on what I’ve read and heard from others it’s my understanding that about 99.5% of the time actions written on a Mac play under Windows and vice versa, subject to version restrictions noted elsewhere. 

Window > Documents > Tile and Window > Documents > Cascade can be recorded and played by the Mac version of Photoshop, but not the Windows version. If an action developed on a Mac includes one of these commands and the action is played under Photoshop for Windows, it will fail with a “Command not available” error.

These following are not action incompatibilities per se, that is the error message that is displayed is not due to incompatible action functionality. They are due to differences between the computer on which the action was created and the one on which the action was played: 

· When a text layer is created, the font specified in the action written under Windows may not be available on a Mac.

· An action recorded on your computer with an Open or Save command is nearly certain to fail on my computer due to folder structure differences, regardless of platform. 

· Specifying custom brushes, textures, patterns, presets, etc. — anything the action writer has on his computer that you don’t have on your computer — cause actions to fail. This applies to either platform. 

- - - - - -

7.2 Q: What, if anything, needs to be considered regarding file names between Macs and PCs? 

A: A couple of things: 

· Regardless of platform .atn must be the last four characters of an Action Set File Name. This is an exception to the generality that file name extensions are not necessary for files on a Mac. 

· For some Mac OS – Photoshop combinations file names (including the .atn extension) cannot exceed 31 characters. Though OS X apparently has been upgraded to accommodate file names longer than 31 characters, PS 7 under earlier versions of Mac OS won’t load Action Set Files with names exceeding 31 characters. Your mileage will vary.

· To make life easier for our Mac colleagues when creating Action Set Files for public download: Keep the file name less than 27 characters. When the .atn is appended, the file name will not exceed the 31 character threshold on some Macs. 

· Mac users unable to accommodate Action Set File Names of more than 31 characters will to rename the file so the name is 31 or fewer characters and .atn are the last four characters. 

· When a droplet is created on a Mac and loaded on a PC, .exe must be the last four characters of the file name. 

8. COMPATIBILITY BETWEEN PHOTOSHOP 5.x AND LATER VERSIONS

UP
8.1 Q: Will the actions I wrote under PS 5.x play under PS 6 and above?

A: Yes, 99.7% of the time. 

In late 2002 someone reported an error playing an action under PS 7 that I’d written under PS 5.5. The error was caused by a command recorded when I entered a PS 5.5 keyboard shortcut. After modifying the action and testing it under PS 7, I promptly forgot about it.

I wish I could tell you now what that keyboard shortcut was, but I’ve been unable to reproduce the error. The good news: I recall the fix being trivial and haven’t seen a recurrence of it in any other actions. 

The bottom line: If you upgrade from 5.x to a later version, action compatibility will not be a problem. 

9. COMPATIBILITY BETWEEN PHOTOSHOP (current) and Previous Versions

UP
9.1 Q: I’m running Photoshop 5.x. I downloaded some actions, but get an error message that says, “Could not load the actions because the file is not compatible with Photoshop.” What’s going on?

A: The key phrase in the error message is, “not compatible,” which is computer lingo for “Trying to put a square peg in a round hole.” What’s not apparent from the error message is the Action Set File was created in a Photoshop 6 or later. 

Since they cannot be loaded, the steps in the incompatible actions cannot be printed by the PS 5.x user for action recreation purposes.  

These types of downward compatible limitations are not unheard of. A software developer’s typical reason is something like, “The tradeoff was providing more functionality at the cost of file incompatibility versus maintaining file compatibility and less functionality.” 

My theory: It was an Adobe strategy to encourage (force?) 5.x users to upgrade to PS 6 or PS 7. It worked on me as I’m sure it did on many people and business owners.

To my knowledge actions written in PS 6 and above are incompatible with the Mac versions of PS 5.x. 

- - - - - -

9.2 Q: So, if I have Photoshop 5.x isn’t there SOME WAY for me to at least see the steps for actions written under PS 6 and above? That way I might be able to recreate the effect by rerecording the action.

A: Yes there is. You’ll need a friend or colleague with PS 6 or later on whom you can ask a favor. Keep in mind, however, you won’t be able to recreate commands exclusive to versions of Photoshop newer than 5.x. Search on PRINTSTEPS 

- - - - - -

9.3 Q: Will actions recorded with the current version of Photoshop play under Photoshop 6 and above? 

A: For the most part, yes, but it’s not a perfect situation. Here’s were problems can occur. 

New versions of Photoshop include commands and/or options that are not available in previous versions. Suppose an action is recorded that includes some version exclusive commands and options. Further suppose this action is loaded into and played by a previous version of Photoshop. 

When any version of Photoshop encounters a command or option in an action step it does not have, one of two things will happen: (a) The step will be ignored and Photoshop will go onto the next action step or (b) Photoshop will display an error message and interrupt the action at that point. In either case the action will not render the results intended by the action author. 

Options: 

· Forget about the action.

· Modify the action to get similar and/or comparable results.

· Accept the result as is, even if it is not what the action author intended.

· Upgrade to a more current version of Photoshop (which may not necessarily be the most current version) that supports the functionality in question.

H. Actions For The Casual User

UP
Okay. We’re clear on basic terminology, where to learn more about actions, what actions are, what they can and can’t do, upward, downward and sideways compatibility. Let’s move on.

In this section topics are (hopefully) presented in terms and a level of detail appropriate for those new to and/or not yet all that familiar with actions.

In the section that follows this one (IX) many of the topics described in this section are addressed again where additional detail, alternative methods and/or commentary appropriate for more experienced action users are presented. 

1. ACTIONS PALETTE 

UP
1.1 Q: I can’t see an Actions Palette. Where is it?


A: There are a couple ways to show it:

· Window > Actions

· If you have PS 7 or later and you see a tab labeled Actions in the Palette Well, click on that tab

· F9 will show/hide the Actions Palette if it is not docked in the Palette Well and just show it if it is docked. (DougC) 

- - - - - -

1.2 Q: What is the Actions Palette?


A: The Actions Palette is where you’ll find everything needed to create, play and manage actions. This is where: 

· Action Sets are created, renamed, copied, moved, deleted, saved and loaded

· Actions are created (recorded), renamed, played, modified, copied, moved, and deleted

· Action options are assigned, e.g., color code, keyboard shortcut

· Action playback options are set

· The palette display mode option is set

- - - - - -

1.3 Q: Does the Actions Palette have to be visible to play actions? 


A: Sometimes yes, sometimes no, but yes more often than not. 

· No if the action is specified via the File > Automate > Batch dialog

· No if a keyboard shortcut has been assigned to the action you want to play and you know what that keyboard shortcut is

· Yes if you don’t remember the assigned keyboard shortcut 

· Yes if the action has not been assigned a keyboard shortcut

2. DISPLAYING THE ACTIONS PALETTE MENU 

UP
2.1 Q: How do I display the Actions Palette Menu?


A: Click the right-pointing triangle (►) located in the top-right corner of the palette. This menu can only be displayed when the Actions Palette is visible.

3. ACTIONS PALETTE DISPLAY MODE OPTIONS 

UP
3.1 Q: What are the display modes of the Actions Palette?


A: The Actions Palette can be displayed in one of two modes: List Mode (sometimes referred to as Edit Mode) or Button Mode. 


Most people prefer List Mode, which is the mode in effect when Photoshop is installed. 


More information on these modes follows.

4. LIST MODE 

UP
4.1 Q: The Actions Palette is visible. How to I get it into List Mode? 

A: Open the Actions Palette Menu. 

If there is NOT a check mark next to the Button Mode option, the palette is already in List Mode.

If there is a check mark next to Button Mode, choose Button Mode from the menu to switch to List Mode.

Search on MODELIST
- - - - - -

4.2 Q: Holy cow! List Mode looks complicated. What does it all mean? 

A: It looks worse than it really is. Here’s a quick tour.

In List Mode all available Action Sets appear as gray bars with an Action Set control (() to the left of the Action Set Name. 

If the triangle (►) next to an Action Set Name is pointing to the right, click it to reveal the actions inside the Action Set. Individual actions appear as white bars below Action Sets, with Action Names indented slightly.

Each horizontal bar in the Actions Palette is divided into three columns: 

· On the left is an embossed column of squares referred to as Enable/Disable checkboxes.

· To the right of the Enable/Disable checkboxes is another column Adobe refers to as Modal Controls, but for the purpose of clarity I’ve referred to them as Display Dialog checkboxes throughout this document.

· The wide column to the right of the checkbox columns is where Action Set Names, Action Names, action steps and, if applicable, action step settings and options are displayed.

The significance of checking or unchecking the Enable/Disable or Display Dialog checkboxes will be discussed later. Search on ENABLEDISABLE and DISPLAYDIALOG
- - - - - -

4.3 Q: What’s the purpose of the triangle (►) next to Action Set Names, Action Names and action steps?


A: This control is referred to as the Show/Hide Triangle throughout this document. 


Clicking the Show/Hide Triangle so it points down (() expands Action Sets, actions or action steps to reveal actions (inside Action Sets), action steps (within actions) and, if applicable, settings and/or options for a given action step. Clicking the triangle so it points sideways (►) collapses (hides) the contents of the respective object.

- - - - - -

4.4 Q: How about a roadmap to all the controls at the bottom of the palette and all the choices in the Actions Palette menu?


A: No problem. You can’t do much better than this one:


www.actionfx.com/modules.php?name=Content&pa=showpage&pid=2
5. BUTTON MODE 

UP
5.1 Q: The Actions Palette is visible. How to I get it into Button Mode? 

A: Open the Actions Palette menu. If there is NOT a check mark next to the Button Mode option, the palette is in List Mode. Click Button Mode to switch.

Search on MODEBUTTON
- - - - - -

5.2 Q: Hmmm… this is different. Does each button represent an action?


A: Yes. 


The major selling point of Button Mode is simplicity. 


In Button Mode actions are displayed in one or more columns of one-click buttons. A button is displayed in color if a color was assigned to the action it represents. Likewise if a keyboard shortcut was assigned to an action, the shortcut is displayed on the button to the right of the Action Name.


In this mode:

· To play an action one clicks the button to which the action corresponds.

· Actions can only be played. No changes to actions or Action Sets are permitted such as creating, changing or deleting actions or Action Sets. 

· Gray bars representing Action Sets and controls at the bottom of the Actions Palette that are displayed in List Mode are not displayed in Button Mode.

6. ACTIONS PALETTE COMMAND BUTTONS

UP
6.1 Q: What’s the purpose of the buttons across the bottom of the palette?

A: These are called Command Buttons and they perform essentially the same function as their counterparts in the Actions Palette Menu. Here’s a brief overview. 

■ – Stop recording/playing: Terminates a recording session or a running action.

● - Record: Adds additional steps to an existing action. 

► - Play selection: Plays the action or selected action step(s).

( - Create New Action Set: Creates a new Action Set. 

( - Create New Action: Important: Click this control, not Record, to create a new action. 

[image: image2.jpg]


 - Trash: Drag and drop Action Sets, actions or action steps over this control to delete them. 

For those familiar with operating video or audio tape recorders the STOP and PLAY controls perform similar functions. RECORD is an exception in that it is not used to create a new action. It enables one to add steps to an existing action. Choose New Action from the Actions Palette menu or click CREATE NEW ACTION (()to create a new action.

7. ACTIONS PALETTE MENU COMMANDS VS. CONTROL ICONS 

UP
7.1 Q: Why are commands in the Actions Palette Menu duplicated as control icons across the bottom of the Actions Palette? 

A: Convenience. Action Palette Menu commands that correspond to control icons at the bottom of the Actions Palette initiate the same functions. The only difference is support for Drag and Drop.

The Create New Action Set ((),CREATE NEW ACTION (() and Trash ([image: image3.jpg]


) controls support Drag and Drop functionality making it easy to duplicate or delete a selection. 

A trivia note: If you hold your cursor over a control icon, the name in the on-screen tool tip is slightly different than the corresponding menu command, e.g., Create New Action vs. New Action. 

Don’t let this table spook you. Think of it as a reference. Details that follow in subsequent sections will help make sense of all this.

	Action Palette Menu Commands
	CONTROL ICONS 

at the bottom of the

Actions Palette

	Dock to Palette Well: Moves the Actions Palette to the Palette Well.
	

	Button Mode: Toggles between List Mode and Button Mode.
	

	New Action: Initiates the New Action dialog. 

Important: Choose this command, not Record, to create a new action. 
	( - Create New Action: Same as New Action in the Actions Palette Menu. 

Also, Drag and Drop an action or action step over this control to duplicate the action or action step.

	New Set: Initiates the New Action Set dialog. Same as Create New Set (().
	( - Create New Set: Same as New Set in the Actions Palette Menu. 

Also, Drag and Drop an Action Set over this control to duplicate the Action Set or click to duplicate the selected Action Set(s).

	Duplicate: Creates a copy of the selected action step, action or Action Set. Same as Drag and Drop of action step or action over Create New Action (()or Drag and Drop of Action Set over Create New Set (().
	

	Delete: Deletes the selected action step(s), action(s) or Action Set(s). Same as drag and drop of an action step, action or Action Set over the Trash ([image: image4.jpg]


) 

Important: The Actions Palette Delete only deletes action related objects, i.e., Action Sets, actions or action steps. This command will not delete anything else such as image files or .atn files on your hard disk. 

Important: You will have one chance to undo (Ctrl + Z).
	[image: image5.jpg]


 - Delete: Select one or more objects and click this button.

Also, Drag and Drop Action Sets, Actions or commands over this button to delete them or click after object(s) selected (for a confirmation warning) or Alt + click for delete without warning. 

Important: You will have one chance to undo (Ctrl + Z).

	Play: Plays all steps in the action if the Action Name is selected, otherwise starts play with the first action step selected.
	► - Play selection: Same as Play.



	Start Recording: Initiates Record Mode. Same as clicking Record (●). Used to add steps to an existing action. Note: The color changes to red ● when Record Mode is active. See New Action below.
	● - Record: Same as Start Recording.



	Stop Recording: Terminates a recording session only. To stop a running action the Stop button must be clicked or Esc key pressed.

Note: There is no Stop Recording menu command per se. This menu choice is available when a Recording session is in progress.

There is no equivalent to the Stop playing command. To terminate a running action one must click Stop (■) or press the Esc key.
	■ – Stop playing/recording: Terminates a recording session or a running action.



	Insert Stop: Initiates the Stop Command dialog. 
	

	Insert Path: Inserts a command that causes a predefined path to be loaded into the active layer.
	


	Action Options: (Active when an action is selected.)Initiates a dialog where Action Name, keyboard shortcuts, color code can be changed or assigned.
	

	Set Options: (Active when an Action Set is selected.) Initiates a dialog where Action Set Name can be modified. 
	

	Playback Options: Initiates a dialog where options related to action playback speed and audio annotation can be specified. 
	

	Clear All Actions: CAUTION. This command permanently deletes all Actions sets in the Actions Palette. There is one chance to undo via Ctrl + Z. 
	

	Reset Actions: Appends the default Action Set (Default.atn) to the actions already in the Actions Palette. (CAUTION) Optionally REPLACES ALL ACTIONS with Default.atn. There is one chance to undo via Ctrl + Z. 
	

	Load Actions: Reads an Action Set File (.atn) from the location specified and converts it to an Action Set in the Actions Palette.
	

	Replace Actions: CAUTION. Similar to  Reset Actions, except rather than the default Action Set, the Action Set loaded is user specified. There is one chance to undo via Ctrl + Z.
	

	Save Actions: Copies the selected Action Set from the Actions Palette and saves it as an Action Set File (.atn) at the location specified. An Action Set (not an individual action) must be selected before this command is available in the menu.

The entire contents of the Actions Palette can be saved as a text file (.txt). Search on PRINTSTEPS
	

	[At the bottom of the menu: A list of Action Set Names]: These represent Action Set Files that reside in \Presets\Photoshop Actions and/or that are referenced by Windows’ shortcuts or Mac aliases residing in this same folder.
	


8. ACTION SETS 

UP
8.1 Q: What are Action Sets?


A: Action Sets are folders in the Actions Palette used to organize actions. Action Sets are to actions what Windows and Mac OS folders are to files.

An Action Set can contain zero, one or more actions. 

- - - - - -

8.2 Q: How do I create a new Action Set?


A: Two ways: 

· Choose New Set from the Actions Palette Menu –or-

· Click Create New Set (()

Doing either initiates the New Set dialog where you assign the Action Set Name.
- - - - - -

8.3 Q: How long can an Action Set Name be?


A: Up to 199 characters, depending on where and how the name is assigned.

· 1-31 characters if assigned in the New Set dialog or reassigned in the Set Options dialog. 

· 1-64 characters if renamed by double-clicking on the Action Set Name and overtyping the original name. 

· 1-199 characters if the Action Set File Name is assigned in Windows and the Action Set File is loaded into the Actions Palette using a Load Actions… command. 

- - - - - -

8.4 Q: Are there restrictions on Action Set Names?


A: None under Photoshop. Any combination of letters (upper or lower case), special characters, digits or spaces is permitted. 

For actions destined to be played under Photoshop Elements, there are Action Set Name requirement that must be met. Search on WRITINGELEMENTSACTIONS 

- - - - - -

8.5 Q: Are there any considerations Windows-wise for Action Set Names?


A: Yes and no. 

When Action Sets are saved onto your hard disk, by default the Action Set File Name is derived from Action Set Name. If the Action Set Name contains a character that is not permitted in a Windows file name, e.g., “/,” Photoshop detects it and replaces it with a space in the Save Actions… dialog. So the bottom line is, “Don’t worry about it.”

- - - - - -

8.6 Q: Can an Action Set contain other Action Sets, in other words, embedded Action Sets, like Windows folders can contain other folders?


A: No. An Action Set can only contain actions. 

- - - - - -

8.7 Q: Can Action Set Names be changed?


A: Yes. Use any one of the following methods: 

· Double-click on the Actions Set Name and type the new name 

· Double-click to the right of the Actions Set Name, which will display the Set Options dialog

· Click on (select) the Actions Set Name and choose Set Options from the Actions Palette Menu

Beware that there are times when changing an Action Set Name can cause problems. Search on RENAMEPROBLEMS
- - - - - -

8.8 Q: Can I move (change the position of) an Action Set within the Actions Palette?


A: Yes. 

Click on the Action Set Name and Drag and Drop the Action Set in the desired location within the Actions Palette. Important: You cannot drop an Action Set into another Action Set. 

Moving an Action Set within the Actions Palette has no effect on the results generated by actions it contains.

- - - - - -

8.9 Q: Why would I want to change the position of an Action Set within the Actions Palette?


A: Typically moving Action Sets is done for organizational reasons. The actions (or Action Sets) closest to the top of the Actions Palette are the first ones displayed in List or Button Mode.

- - - - - -

8.10 Q: How can I duplicate (copy) the contents of an Action Set?


A: There are several ways. Search on BIGTABLE
- - - - - -

8.11 Q: Why would I want to copy an Action Set?


A: Typically for backup purposes. You would make a copy of an Action Set for the same reason you would make a copy a folder containing, say, Word or Excel files.

- - - - - -

8.12 Q: How can I delete an Action Set?


A: Use any of the following that suit you:

· Select the Actions Set and drag it over the Trash ([image: image6.jpg]


).

· Select the Actions Set and choose Delete Set from the Actions Palette Menu, which will display a confirmation dialog box.

· Select the Actions Set and Alt + click Delete from the Actions Palette Menu. No confirmation dialog box will be displayed.


You get one chance to undo the delete using Ctrl + Z. 

- - - - - -

8.13 Q: What’s the maximum number of actions an Action Set can hold? 


A: If you have to ask, the answer is “You’ve got TOO MANY ACTIONS and need therapy!” Seriously, though, I’ve posted this question on a couple of forums (including http://www.adobeforums.com/) and have never received a definitive answer.


For what it’s worth I created a 5-step action and duplicated it 1,099 times for a total of 1,100 actions in a single Action Set (PS 7.01, Windows 2000 SP3). Figuring that would be enough to satisfy the most addicted action fanatic, I stopped there.

9. ACTIONS INSTALLED WITH PHOTOSHOP 

UP
9.1 Q: Are any Adobe-provided actions installed with Photoshop? If so, where are they?


A: Yes. Several sample actions are installed with Photoshop that range from basic to fairly sophisticated. They perform tasks such as create buttons, apply textures, generate digital frames, render special effects and execute a few common commands. 

They are located in two different folders:


C:\Program Files\Adobe\Photoshop 7.0\Required

C:\Program Files\Adobe\Photoshop 7.0\Presets\Photoshop Actions 

 
When you open the Actions Palette for the first time you will see Action Set Default Actions. This is known as the Default Action Set and is the one Photoshop loads into the Actions Palette when Reset Actions is selected from the Actions Palette Menu. The corresponding Action Set File can be found in the first folder above.


The rest of the Adobe-provide Action Set Files are located in the second folder.

10. LOADING ACTIONS INSTALLED WITH PHOTOSHOP VIA THE ACTIONS PALETTE MENU

UP
10.1 Q: How do I get the Adobe provided actions from \Presets\Photoshop Actions into the Actions Palette?


A: Open the Actions Palette Menu. Note the list of Action Set Names (less the .atn file name extension) listed at the bottom of the menu. To load a set, click on its name.


Note: Actions that reside in \Presets\Photoshop Actions get special treatment: They are listed on and can be loaded from the Actions Palette Menu. Actions that reside other places on your hard disk must be loaded using the Load command. Search on LOADACTIONS
11. HOW CAN I TELL WHAT THE ADOBE-PROVIDED ACTIONS DO?

UP
11.1 Q: How can I tell what these (or any other) actions do?


A: Your first clue is to review the Action Set Names. Action Set Names can be (but are not always) indicative of the purpose or intended result of the actions it contains.


In the big scheme of things, however, you’ll have to play the action to find out the real story!


Click the Show/Hide Triangle next to Action Set Names to reveal the actions inside. Action names, too, should indicate their function and purpose. While this frequently true, it’s definitely not a universal truth.


Important: Before playing any new action the first time, there are some precautions you should take. Search on B4UPLAY
- - - - - -

11.2 Q: Some of the sample Action Names include words like ”(selection),” ”(layer)” or “type.” Why? 


A: Adobe uses these words as a code or indicator:

· (selection): Make a selection before playing the action

· (layer): The action works on the active layer only vs. an entire image

· (type): A type layer must be active in order to apply a text effect 


While this naming convention is intuitive and could prove useful, it is seldom used outside of the Adobe-provided actions. That doesn’t mean you can’t adopt it, however. Search on ACTIONNAMEEXAMPLES
- - - - - -

11.3 Q: Are the sample actions any good?


A: Some are very basic while some are fairly sophisticated. How good they are is a judgment you will need to make after trying them.


For those wishing to learn more about Photoshop functions and capabilities or the craft of writing actions, some of these actions are good models from which to learn.

- - - - - -

11.4 Q: Which of the samples would you recommend trying?


A: Give any of these a go (Action Set Name/Action Name):

· Image Effects/Lizard Skin or Neon Nights

· Frames/Spatter Frame, Brushed Aluminum Frame or Wild Frame

· Text Effects/Sprayed Stencil or Brushed Metal


Important: Before playing any new action the first time, there are some precautions you need to take. Search on B4UPLAY
B4UPLAY

12. SELF-PROTECTION I: BEFORE PLAYING ACTIONS YOU DID NOT WRITE (RobW)

12.1 Q: Before playing for the first time an action I didn’t write are there things I should look for or do?


A: YES! Absolutely.

First of all most actions won’t bite you. You play them, they do their thing and everybody’s happy.


Secondly most authors mean well and don’t write actions that purposely trash images. 


Reality: Whether purposely written to do harm or as a result of inexperience and/or incompetence, some actions can do permanent damage to an image, a folder full of images or clear all history states. The latter is usually not life threatening, but is exceptionally annoying if action development or debugging is in progress where access to intact history states can be very important. 


Although you may not yet be deeply familiar with actions yet, you’ll be able to appreciate the potential risk in this example. Suppose the one and only copy of your great grandfather’s picture open and you played an action consisting of these steps:



Gaussian Blur, radius = 50



Save



Close File


Good-bye classic picture. 


Suppose you worked several hours on an image, during which you’d created many individual layers. Then you ran a new action whose last three steps are:



Flatten Image



Save



Close File


If you don’t have a backup of this file with all layers intact, a lot of work would quickly fly out the window. 


Okay, I’ll grant these are pretty extreme and not likely to occur, but  the possibility does exist for an action to trash an image.

- - - - - -

12.2 Q: Which commands are potentially dangerous?


A: If any of the following are present in an action, be sure to know why before running the action. Before I run an action for the first time, even one provided by Adobe and ESPECIALLY one downloaded from the Internet or received through e-mail, I’ve gotten into the habit of looking for commands such as these. 

· FLATTEN IMAGE: If your image has several layers, having an action flatten it may be bad news. An exception is if the original image is duplicated at the outset of an action and the Flatten Image command is being applied to the copy.

· SAVE followed by a CLOSE command: This command pair could be replacing your one and only original with a modified version. After a modified image is closed you have no chance to recover it, except from a backup file. Generally speaking this save and close sequence is usually not a good thing for an action to do. As a rule of thumb I prefer to do these operations myself.

· Close, Saving: Yes: This command does the same thing (and carries the same risk) as the individual commands above. 

· Purge Histories: This command not only clears the History Palette for the current image, it zaps history states for ALL open images. This isn’t a big deal unless you’re in the middle of working on images or developing actions and depend on history states.

· Purge All: Clears the clipboard in addition to ALL history states.

· Clear history state of current document: Self-explanatory. 

- - - - - -

12.3 Q: Wait. I’m new at actions. You’re suggesting I inspect actions (something I know nothing about) before playing actions (something I know nothing about). This reminds me of high school Spanish class when I was expected to read Spanish before I knew Spanish. What’s wrong with this picture?


A: Yes, this presents a bit of a quandary doesn’t it? At least all the words are in English! ( Seriously, after a little practice, action steps won’t look so cryptic. Take heart. There’s a way to avoid the action inspection thing that takes only a few mouse clicks.

- - - - - -

12.4 Q: So there’s a way to avoid action inspection?


A: Yes, but there’s a small catch.


TonyK recommends (and I agree) that making a duplicate of the original image (Image > Duplicate) AND closing the original image is a good way to go. Once your original image is safely out of the way, apply the action to the duplicate image. This approach eliminates the possibility of the action causing damage to the original file. 


Image > Duplicate


(Click on the window of the original making it the current image)


File > Close


These precautionary steps have saved me countless hours of image recovery due to not so friendly and/or poorly written actions, some poorly written by me. Note: This practice does not get around the potential irritation of an action that includes a Purge command, however. 

 
I hope a thought something like this has crossed your mind: “Hmmm. I’ll bet it would be easy to write an action to do this.” Search on DUPLICATEMYIMAGE
PLAYACTION

13. PLAYING ACTIONS I

UP

Important: If you haven’t yet, please read the previous section.

13.1 Q: What does it mean to play an action? 


A: Playing an action is similar to playing an audio or video tape: Click Play (►) and Photoshop starts applying the action steps one after another to the current image. 

- - - - - -

13.2 Q: How are “running,” “applying” or “executing” different from “playing” an action?


A: There is no difference. These terms are used interchangeably. 

- - - - - -

13.3 Q: How do I play an action? 


A: There are three ways to play an action.

· Click Play (►) at the bottom of the Actions Palette

· Click its corresponding button when the Actions Palette is displayed in Button Mode
· Enter its corresponding keyboard shortcut if one was assigned


This is the most common method, which assumes the Actions Palette is visible and in List Mode: 

· Click on the Action Name (not the Action Set Name) 

· Click Play (►)


If the Actions Palette is displayed in Button Mode:

· Click the button representing the action


If a keyboard shortcut has been assigned to an action, it makes no difference whether the Actions Palette is visible or not and, if visible, which display mode is active:

· Type the keyboard shortcut


There are additional, but less common ways of playing actions (or parts of actions or multiple actions). Search on PLAYINGACTIONS2
- - - - - -

13.4 Q: Does an image have to be open to run an action?


A: Not always, but usually. Most actions apply commands to an image.


A few Photoshop commands, such as some from the Window menu, do not require an open image. Actions consisting exclusively of commands of this type do not require an open image.

- - - - - -

13.5 Q: When I play an action should I go with the values set in filter, adjustment layer and other dialog boxes? 


A: If you’re not familiar with an action and/or the commands it uses, I would say, “Go with them as is” the first few times to get a feel for the results. As you become more familiar with the action and/or the various commands and their settings and options, by all means tinker and deviate from default values. 

- - - - - -

13.6 Q: This one action I play often displays these annoying messages telling me things like the author’s name or that I need to have a file open. This isn’t a problem the first time I run the action, but having to click the Continue button each time for the rest of my life is ridiculous. Can I turn off these well intended, but exceptionally annoying messages? 


A: You sure can. Search on MSGSUPPRESS
- - - - - -

13.7 Q: If an action is collapsed, that is the Show/Hide Triangle is pointing to the right (►), before I play it, when I play an action Photoshop expands the action (triangle points down) and leaves the action expanded after the action finishes. Is there a way to either prevent Photoshop from expanding the action or having it collapse the action when finished? (CassandraG) 


A: In all the testing I did, Photoshop expands the action in all cases and leaves it expanded upon action completion. How untidy!

- - - - - -

13.8 Q: While a long-running action is playing, can I do anything else in Photoshop? 


A: No, so you might as well take a few moments to marvel at the amazing capabilities of Photoshop or count your blessings. Search on GOFASTER
- - - - - -

13.9 Q: I’ve got an action that has a LOT of steps. It takes 5-10 minutes to run on my not-so-fast computer. After I start it, is there a way to tell how much longer it will run, like a progress meter?


A: Good question and a nice thought. No, there is no progress meter that estimates how long it will take a long running action to complete.


If the Actions Palette is visible, you can monitor the progress of an action since Photoshop highlights the active step. Even if an action is collapsed when play is initiated, you’re in luck because Photoshop automatically expands it. If you’re familiar with an action’s typical run time and its steps, watching the action as it executes may give you a sense of how much longer it will take to finish. 


If the action was invoked through the File > Automate > Batch dialog to process a folder full of images, you could check the number of images in the source folder and compare it to the number of images completed in the destination folder. Based on the timestamps of completed images in the destination folder, one could calculate an estimated completion time for the entire batch. 

- - - - - -

13.10 Q: Do I have to do anything before playing an action? 


A: Sometimes yes, sometimes no. It just depends.


Some actions display messages that give an indication of expectations. Many do not. 


These are typical conditions that may need to be met before playing an action:

· An open image. Most actions need an image to which its commands can be applied.

· Setting a specific color mode: Many filters, for example, run only in RGB mode.

· Specifying a specific bit depth, 8 bit vs. 16 bit.

· Making a selection to isolate (or accentuate) a section of an image.

· A flattened image (one that has only a Background) or that the Background in a multi-layer image.

· Creating layer(s) or alpha channel(s) with specific name(s).

· Having a Background vs. an image where the Background was converted to a normal layer.

· Landscape (left-right) or portrait (up-down) orientation.

· Resolution (low vs. high).

· Choosing foreground or background colors for applying effects.

 
Besides meeting requirements before playing an action, you may want (or need) to perform other tasks such as upsizing (or downsizing), cropping, sharpening, color correction, dust/scratch removal, etc. 


In summary preprocessing steps will depend on the action and/or the condition and characteristics of the subject image. 


For actions that do not include hints or recommendations of this nature, you can always modify the action yourself. It is not difficult to include one or more Stop Commands whose function is to display on-screen information, reminders and hints. Search on STOPCOMMANDS 
14. EXITING AN ACTION BEFORE IT HAS FINISHED

UP
14.1 Q: If I decide I really don’t want an action to complete once it has begun playing, is there a way to stop it?

A: Yes. The method you use will depend on what’s going on at the moment. 

· If the action is in flight (commands are executing), click Stop (■). or (my favorite), press the Esc (escape) key, located at the top-left of the keyboard.

· If the action has been paused by a dialog box waiting for a reply, for example a Gaussian Blur dialog box is visible, click the Cancel button in the dialog box or press Esc. Note: I use this method frequently in order to reposition, zoom-in or zoom-out on an on-screen image, or move or hide palettes. Click Play (►) to restart the action with the command you canceled.

RESUMESTOPPEDACTION

15. RESUMING A STOPPED (PAUSED) ACTION

UP
15.1 Q: I ran an action that displayed a dialog box with a button labeled Stop and a message that read, “Choose a foreground color and then continue.” I clicked Stop button in the dialog box and chose a foreground color as directed, but I have no idea “how to continue.” What do I do?


A: Click Play (►) which resume the action with the next step. 

- - - - - -

15.2 Q: I ran an action that displayed two buttons, one labeled “Continue,” the other labeled “Stop” and a message something like, “Click Continue to use the whole image. Click Stop to make a custom selection.” What do I do? 


A: This is a variation of the situation described above. This time you have a choice. If you click the Continue button in the dialog box, the action will proceed with the next step. If you click Stop in the dialog box, you will have to click Play (►) once you have completed the requested task. 

- - - - - -

15.3 Q: How am I supposed to know whether or not to click Play (►) to resume if it’s not specified in the message text?

A: In a perfect world action authors would write message text that is clear, concise and complete. Here’s an example of what messages should look like: “If you want to use WHITE, click CONTINUE. For another color, click STOP, select a Foreground color from the Color Palette. Then click PLAY to continue.” 

It’s not a perfect world. Instructions are often confusing, incorrect or missing completely. 

The important thing to know is when an action is paused by clicking the Stop button in the dialog box, you must click Play (►) to resume.

- - - - - -

15.4 Q: Can I resume an action that was interrupted by canceling out of a dialog box or terminated by pressing Esc?


A: Yes. Click Play (►). The action will resume with the command that was interrupted. 

- - - - - -

15.5 Q: If I’ve interrupted an action via Esc or Cancel button in a dialog box and want to start over, what do I do?


A: To restart an action from the beginning, you MUST click on the Action Name or the first step in the action before clicking Play (►).

PLAYBACKOPTIONS

16. PLAYBACK OPTIONS 

UP
16.1 Q: What’s the low-down on the options associated with the Action Palette Menu’s Playback Options command?

A: Choices: 

· Accelerated: When this option is selected, actions run as fast as possible. Photoshop does not redraw the image each time there is a change made to it, for example when a filter or adjustment layer is applied. This “fast as possible” concept is really only effective when steps are not paused to display dialog boxes. An obscure benefit of this choice is unlike the other options, actions played under this setting are not expanded in the Actions Palette.

· Step by Step: When an action step completes, Photoshop redraws the screen before initiating the next step. Depending on your motherboard, graphics card and/or monitor settings and characteristics, actions may run nearly as fast in this mode as when the Accelerated option is in effect. 

· Pause For: This option causes an action to pause 1-60 seconds between steps, depending on the value specified. Some use this mode for learning purposes to “slow down an action” in order to observe steps as they execute and correlate them to on-screen changes. Others use this mode when trying to debug an action that is not performing as expected. There are other methods for action debugging (and learning) that I like better. Search on 1STEPATATIME 

· Pause For Audio Annotation: See Photoshop Help.

17. SELF-PROTECTION II: VIRUS CONSIDERATIONS

UP
17.1 Q: Can running an action spread a virus? 


A: No, according to some highly knowledgeable action experts who frequent the Photoshop forums at http://www.Adobeforums.com, including Trevor Morris, a true action guru whom I highly respect. He confirms actions can only execute Photoshop commands within the Photoshop environment. Potentially dangerous commands such as Delete Folder, Delete File, and Format Disk cannot be recorded in actions. 


Note: Steps can be recorded in actions that execute Photoshop Scripts, which can be programmed to do all sorts of nasty things. If you’re not using scripts (and most users don’t), this is not a concern. If you are, know what your script does before playing the action that invokes it.

- - - - - -

17.2 Q: So I’m home free virus-wise if I download an Action Set File off the Internet or get one by e-mail, right?


A: Absolutely, positively, NOT! 


If the file downloaded from the Internet is in compressed format, such as a .zip file, be especially wary if any of the files in the package have file name extensions such as .exe, .bat, .com or .scr. (KentC)


Be aware, too, that under certain circumstances the process of opening a CD or merely previewing an infected e-mail message with an .atn attachment in Outlook or Outlook Express could transmit a virus to an inadequately protected computer. Though an .atn file will never be the culprit itself, it could certainly be an innocent bystander. 


Though virus protection and computer security are way, way beyond the scope of this document, if you haven’t yet, please become informed on the subject and take steps to safeguard your computing environment. It can’t be said often enough: Protect yourself. 


Also keep in mind that virus protection is an ongoing effort, not a one time event. Signature files from your anti-virus software need to be updated regularly. Be diligent, too, about applying security fixes to your operating system and browser.

- - - - - -

17.3 Q: Before uploading this document and the DPReview Retouching Forum Action Collection files, were they scanned for viruses?


A: Yes. 

18. INTERNET CONSIDERATIONS

UP
A wealth of information about actions can be found on the Internet. In addition there are countless sites from which actions can be downloaded and forums where they can be discussed. The following sections address some common Internet-related questions. 

ACTIONSITES 

19. INTERNET: FREE ACTION DOWNLOAD SITES

UP
19.1 Q: Do you have any action download sites to recommend?


A: Here are some you may find interesting. They barely represent the tip of the iceberg:


NOTE: If you’d like to submit links to action download sites to be considered for future updates of this document, I welcome your recommendations. Search on SUGGESTIONSCOMMENTS
The DPReview Retouching Forum Action Collection, started by Dr. Randall Smith. An exceptional collection (if I may say so myself) of photo-art, digital frame and general purpose actions.


www.geocities.com/kafuensis/
Jim Lewis’s site… Destined to become one of the best action sites on the planet:

     http://www.AtnCentral.com


Adobe’s site. Everything from soup to nuts (free, but registration required):


http://share.studio.adobe.com/Default.asp
Mathias Vejerslev’s site. General purpose and all very good:
 http://www.96ppi.net/photography/actions/ 
Trevor Morris’s site. Some real good ones here:
http://user.fundy.net/morris/photoshop20.shtml


Mike Finn – some of the best photo-art actions on the planet, mostly free:

http://homepages.slingshot.co.nz/~mikefinn/action.html
Retouch PRO (you must be registered before you can download): Miscellaneous, including some photo-art:
http://www.retouchpro.com/forums/showthread.php?s=&threadid=2767
Retouch PRO (you must be registered before you can download): Mostly Photo-art: 
http://www.retouchpro.com/forums/showthread.php?s=&threadid=2653
Retouch PRO (you must be registered before you can download): Mostly digital frames, edges:  http://www.retouchpro.com/forums/showthread.php?s=&threadid=4298
Fred Miranda. Target audience: Photographers using digital cameras. No longer free, but a lot of actions from which to choose.
http://www.fredmiranda.com/actions/
Adobe Evangelists. Includes an action that will create a separate file for each layer in an image. Unfortunately as of this writing the action doesn’t (errors generated as written), but can serve as a model. SEPARATEFILE

http://www.adobeevangelists.com/photoshop/actions.html
Chainstyle.com. Mostly textures.
http://www.chainstyle.com/photoshop/webhelp/cd_content/downloads/free_downloads.htm 

Bill Richardson’s actions (frames, edges, photo-art):


http://www.outdooreyes.com/photosection20.php3 

Shouchen’s site. Lots of interesting stuff here:

    http://www.photozo.com/forum/viewforum.php?f=2
Peter Sill’s site. Photo-art and some general use actions:

http://www.digitalfocus.net/downloads.htm
Edge effects which are compatible with Photoshop 5.0 and above:

http://www.liknes.no/photoshop
Scott Higdon actions. An interesting assortment: 

http://www.cshigdon.net/
Johny Akerlund actions. Some great black and white and toning effects: 

http://www.jakerlund.net/
Marc Jutras Digital Lith action:

http://www.marcjutras.com/
Bud Guinn frame and matte actions: 

     http://users.adelphia.net/~window/Actions.htm
also available at…

http://www.bytephoto.com/modules.php?s=1957f8e81515876c8975440df5418c2c&name=Downloads&d_op=viewdownload&cid=2
Photoshop Café; mostly text effects:

http://www.photoshopcafe.com/actions.htm
Several action collections:

http://www.elated.com/actionkits/
Al Ward’s site. Click the button labeled Downloads. Mostly text effects:

http://www.actionfx.com/
Text, art, texture assortment:

http://www.actions.8m.com/actions_all.htm
Text effects, some free but mostly for sale:

http://www.actionaddiction.com/
Text, textures, image effects:

http://www.teamphotoshop.com/forum/vbforum/forumdisplay.php?s=&forumid=33
Paul Larson’s site. The Matt Hardy actions are very good. Check the action forum, too, where you may find additional downloads:

http://www.bytephoto.com/modules.php?s=&name=Downloads

Color to Black and White (Russell Brown method) and Infrared (2):

     http://www.nickgallery.com/web_pages/technical%207.htm
Olli Nuutinen’s Canon 10D 6MP actions. Extremely well organized.

     http://koti.mbnet.fi/~ojn/6mpix/action_actionpack.html
Glenn Mitchell’s site. Color to BW, copyright, image resizing using Stair Interpolation actions, plus preset downloads.

http://thelightsright.com/DigitalDarkroom/PhotoshopTools.htm
Links to other action sites or forums:

http://www.websitetips.com/graphics/ - actions
http://www.shutterfreaks.com/Actions/Actions.html
http://www.teamphotoshop.com/photoshop/actions/actions_download.php
http://www.digitalthread.com/photoshopactions/actionsets1.html
After the fun runs out at the above sites, do a search at http://www.google.com/ or www.DogPile.com (or using your favorite Internet search method) and use “Photoshop actions” as a search argument. 

- - - - - -

19.2 Q: Is it possible to download selected actions within an Action Set File? 

A: No. When you download an .atn, you get whatever is inside. If the action author included one action, you get one action. If she included 27 actions, you’ll get all of them. There are no options. 

Once the Action Set is loaded into the Actions Palette, you have discretion over which individual actions to keep.

Some download sites offer single-action Action Sets almost exclusively; others offer Action Sets where it is anyone’s guess how many actions each contains.

- - - - - -

19.3 Q: Out there in Internet-land is there a database, master index or central location I can use to locate an action to solve the particular problem I’m having at the moment? 

A: No, although it would be grand to have such a resource. 

Since Adobe introduced the Actions Palette with Photoshop 4, thousands of actions have been written and made available for download. New actions by the boatload are written and posted everyday by action authors worldwide. Internet sites come and go. 

One side of the double-edged Internet sword is the ability to easily build new (or use existing) sites to share information, files and programs. The other side of the sword is the absence of control and standards in most cases. Without some sort of centralized repository, content controls, universally defined and applied standards, and lots of people to build and maintain such a resource, I’m afraid this great idea will continue to be among the impossible dreams. 

Unfortunately the challenge of locating an action that performs a specific function is made more difficult since the only way to see an Action Name is to load an Action Set File into the Actions Palette. 

Making matters worse, an action author has no obligation to name his action in accordance with what it does. For example I ran across an action once that was named “My first action,” which turned out to be a very useful noise reduction tool. Who could have guessed its function with an Action Name like that?

- - - - - -

19.4 Q: You’re just a load of good news. So, how would you go about finding a function specific action? 

A: Super search engines like http://www.google.com/ provide some help when it comes to locating actions designed for specific tasks. For common Photoshop tasks try search arguments such as

     Photoshop action sharp*  (the * will find sharp, sharpen, sharpening)

     Photoshop action color correct*

Search engines such as Google cannot overcome obstacles noted previously, namely the inability to determine the names of actions inside Action Set Files or action authors who assign meaningless names to useful actions. 

In some cases you can save a lot of search time (and get better results) by logging into an active Photoshop discussion forum and starting a thread titled something like, “Looking for an action that does [whatever].” 

- - - - - -

19.5 Q: Any other downloaded Action Set File thoughts?


A: Some people keep track of Action Set Files they download from the Internet in a table with columns labeled something like URL, Action Set Name and New Action Set Name. When an Action Set File is downloaded, the table is updated at the same time. When an Action Set is renamed, the master action inventory is updated. Having such a document would be useful for cross-reference purposes or keeping track of Action Set Files already downloaded. (DaveC) 

20. INTERNET: PURCHASING ACTIONS

UP
20.1 Q: I am considering purchasing an action through an Internet site. Do you think it will be worth it? 

A: Maybe yes; maybe no. Value would depend on factors such as: 

· How soon you need results, e.g., “Doesn’t really matter” vs. “By 8:00 a.m. tomorrow morning” 

· How often you would use the action (Once/year? 17 times/day? In between?)

· If you have the time, energy and/or skills to build actions yourself of equivalent functionality (and quality)

· If you’re able to find a functionally equivalent (and free) version by whatever means

If in doubt and time permits a good way to gauge value of a commercial action is to post questions on Photoshop related forums seeking advice and opinions. 

- - - - - -

20.2 Q: Why is it that it seems commercial actions are not offered on 30-day trial or for a limited number of runs like some programs are? This prevents me from making an informed decision based a “Try it before I buy it” evaluation.

A: Unlike programs like Photoshop, it is impossible to place limitations common to programs on actions such as “Self destruct in 30 days,” “Limit to 15 plays” or placing SAMPLE in large letters in the resulting image. 

Therefore, most commercial actions I’ve seen advertised are the “You want it? You pay for it!” kind. I suppose if you felt exceptionally ripped off, reputable action authors might entertain a refund request, but I wouldn’t count on that. If a Satisfaction or Your Money Back Guarantee is important to you, that is something I would negotiate (and get in writing) before clicking the button labeled Click Here to Complete Transaction.

- - - - - -

20.3 Q: What do you know about the Fred Miranda actions sold at http://www.fredmiranda.com/? 

A: Though I’ve downloaded and dissected a couple of Fred’s free actions (when he offered free actions), for the most part his actions provide solutions to problems I don’t have yet. (I’m clinging to my 35mm film cameras and lenses for the time being.) I don’t have a strong opinion one way or the other on his offerings.

Based on the number of people who reply to questions of this nature on various forums, it’s my observation that Fred Miranda actions are very popular and have a number of supporters. Like most actions it appears they work great on some images, not so great on others. Your mileage will surely vary. 


I would recommend doing research on various forums at http://www.dpreview.com/, http://www.retouchpro.com/, and http://www.adobeforums.com/.


Search argument recommendations: 

     FM

     Fred Miranda 

Either will yield a boatload of threads where user experiences are described and pros/cons debated ad nauseam. 

Consider checking http://www.fredmiranda.com/ where there are active forums on which FM actions are discussed. Keep in mind opinions expressed on forums at this site might be favorably biased. 

- - - - - -

20.4 Q: If I purchase and download an Action Set File through a Website, can I e-mail it to a friend? 

A: Technically, yes. Ethically and legally, no. As trivial as it might seem, this practice is against the law just like copying and distributing software or music is.

UNZIPFILE

21. INTERNET: HANDLING COMPRESSED (.ZIP) FILES

UP
21.1 Q: I’ve downloaded a file from the Internet that’s supposed to be an action, but the file name doesn’t end with .atn; it ends with .zip. Photoshop doesn’t seem to know what to do with this file. Now what? 

A: The short answer: Unzip it.

Good news if you have Windows/XP: You can unzip files without any third party software. (PierreC) If you have another operating systems you will need a third party program such as Winzip or Stuffit.


Here’s a little background if you are not familiar with compressed files. A .zip file, as it’s known, is one that contains one or more files that have been squished down (made smaller) by a program whose purpose is to compress (that is, “squish down”) files. Compressed files must be decompressed before they are usable. 


Stuffit and WinZip are popular programs among many that perform this compress/decompress function. See http://www.stuffit.com/ and http://www.winzip.com/ for additional information.


After a file has been compressed, it is smaller (sometimes a LOT smaller) than it was originally. It takes less time to download smaller (compressed) files than the larger uncompressed originals. 


Frozen orange juice can be used to illustrate this concept. Before the OJ is packaged, most of the water is removed (compressed); the OJ is then transported to the store where you buy it and take it home (downloaded over the Internet). Then you add water (decompress) to restore the OJ to a usable form. 

To summarize, when actions are compressed into a .zip file and the .zip file is downloaded from the Internet saved on your hard disk, the .zip file must be decompressed (unzipped) before the Action Set Files it contains can be loaded into Photoshop.


To unzip a .zip file that’s been downloaded onto your hard disk:

· Open the .zip file. If you get a cryptic message requesting you identify which of your existing programs you want to open it, interpret this as “You need to acquire and install a program such as Stuffit or WinZip in order to decompress this file.” See links above.

· If you have Winzip, Stuffit or a comparable program installed, a dialog will be displayed asking, in essence, “Where do you want me to put the files?” Search on WHERETOPUTACTIONS
· Once the .zip file has been unzipped, the .atn file(s) it contains are ready to be loaded into the Actions Palette. Search on LOADACTIONS

While it’s important to understand the steps involved in the unzip process and yet to be described Load Actions command, like many tasks in Photoshop there’s a not well known method that achieves the same result in fewer steps. Search on ZIPTOACTIONPALETTE
- - - - - -

21.2 Q: If a .zip file contains multiple compressed Action Set Files, is it possible to pick and choose among them before the file is downloaded? 

A: No. There is no choice in the matter. You get entire contents of the .zip file. Once the download is complete, the decompression program will allow you to choose which files to decompress. 

- - - - - -

21.3 Q: The Action Set File I downloaded is already in .atn format. Do I need to decompress it like a .zip file?

A: No. An .atn file is ready to be loaded into the Actions Palette. Search on LOADACTIONS
- - - - - -

21.4 Q: Are .zip files the only type of compressed files?

A: No. There are other compressed file formats besides .zip, such as .arj, .rar, .sit and .hqx. (PierreC) The process is basically the same: Decompress the file with the appropriate decompression program. (DaveC) 

WHERETOPUTACTIONS

22. Storing Action SET FILES: WHERE DO I PUT THEM?
UP
22.1 Q: When I download an Action Set File (.atn) from the Internet or receive one via e-mail, where should I save it? 

A: An Action Set File is useless to Photoshop until it is loaded into the Actions Palette, so from Photoshop’s perspective it makes no difference where an .atn file resides. It can be on the Desktop, somewhere on your hard disk, a CD or even a floppy disk. As long as the .atn it can be located through the Load Actions dialog, you’re in business. Search on LOADACTIONS
For the convenience of being able to load an Action Set File into the Actions Palette by clicking on the Action Set File Name in the Actions Palette Menu, place the .atn file here:

C:\Program Files\Adobe\Photoshop 7.0\Presets\Photoshop Actions
- - - - - -

22.2 Q: Can you provide an example of how I might organize Action Set Files on my hard disk? 

A: Yes. Here are two examples. 
\My Documents 

\My Actions 

\Adobe.com

\Bill Miller

\Bud Guinn

\Dave Jaseck

\DPReview

\Mike Finn

\RetouchPRO

    etc.

or

\My Documents 


\My Actions



\Art 



\Buttons



\Edges 



\Frames 



\Sharpening



\Text 



\Texture 



\Utility


Another system might be to mirror the Action Sets in your Actions Palette by having a corresponding Action Set File for each in a single folder. 

The possibilities are practically endless. The goal should be to set up a folder hierarchy that enables you to efficiently save your Action Sets and find Action Set Files for loading.

LOADACTIONS
23. LOAD ACTIONS

UP
23.1 Q: What does it mean to load actions? 


A: Technically this is a process where Photoshop reads an Action Set File (.atn) from your hard disk, CD or floppy disk, converts the contents of the file into a format Photoshop can use and places the converted contents into the Actions Palette as an Action Set. 


From a non-technical perspective think of it as copying the .atn into the Actions Palette.

- - - - - -

23.2 Q: Why is it important to load actions into the Actions Palette? 


A: .atn files on your hard disk or inside .zip files are worthless to Photoshop. For an action to be playable by Photoshop it must reside in the Actions Palette inside an Action Set. An action cannot be played directly from your hard disk or a CD. 

- - - - - -

23.3 Q: How do I get the actions inside an .atn into the Actions Palette?


A: This is the most well known method: 

· Choose Load Actions from the Actions Palette Menu 

· Navigate to the location of the desired .atn file

· Single-click on the .atn file name to populate the file name box with the Action Set File Name

· Click OK


Depending on circumstances such as how many Action Set Files you want to load at once, there are other methods that may be faster than this basic approach. Search on LOADFROMAPM 

- - - - - -

23.4 Q: So if I want to use actions downloaded from the Internet and the Action Set File is zipped, it’s a three step process, correct? 


A: Yes: (1) Download the file onto your hard disk. (2) Decompress (unzip) it (3) Use Load Actions to load the Action Set File into the Actions Palette. 

- - - - - -

23.5 Q: If the Action Set File is not zipped, then what? 


A: (1) Download the file onto your hard disk. (2) Use Load Actions to load the Action Set File into the Actions Palette. There’s no need to unzip it.

- - - - - -

23.6 Q: Are the same steps used for Action Set Files received by e-mail?


A: The steps are very similar. Follow the instructions for your e-mail program to save the .atn or .zip file attachment to your hard disk. Then proceed as described previously. 

- - - - - -

23.7 Q: If I double-click on an .atn file, will the actions be loaded into my Actions Palette?


A: Yes if you’re a Mac user and Photoshop is already open. Otherwise, no. 

- - - - - -

23.8 Q: If I double-click on a .zip file, will the actions in it be loaded into my Actions Palette?


A: No. If you have a compress/decompress software installed, opening the .zip file will start that program. Otherwise you’ll get a cryptic and nasty message from Windows which, in effect is telling you to get a decompression program like Winzip or Stuffit. Search on UNZIPFILE
- - - - - -

23.9 Q: If I purchase an action through a Website and download it onto my computer, do I load it the same way as the free ones?


A: Yes.

24. CREATING A CUSTOM ACTION SET

UP
24.1 Q: I downloaded an Action Set File from the Internet, loaded it into the Actions Palette and tested the actions. I like some of the actions and would like to keep them, but others are worthless. How should I proceed?

A: Easy stuff. In a nutshell keep the good ones, trash the rest.

· Option A – Create a new Action Set:

· Click NEW SET (() to create a new Action Set. Give it a meaningful name.

· Drag and drop each keeper action from the source Action Set to the new (or an existing) Action Set

· After the keepers are moved, drag the source Action Set to the TRASH ([image: image7.jpg]


)

· Option B – Delete the actions you don’t want:

· Drag and drop the non-keeper actions over the TRASH ([image: image8.jpg]


) 

25. RECORDING ACTIONS I: CREATING A NEW ACTION

UP
25.1 Q: To start recording steps for a new action I just click Record (●) like my tape recorder, right?

A: NO! That would be much too intuitive. Unlike your VCR and audio tape recorder Photoshop requires you give a name to what you’re about to record, so there’s one more step. 

- - - - - -

25.2 Q: Okay, so what do I have to do to create a new action?

A: This time it is more intuitive: 

· Be sure an image is open if the steps you’re about to record in the action will be applied to an image.

· Click on the Action Set Name of the Action Set where you want the new action to reside.

· Either click Create New Action (() or choose New Action from the Actions Palette menu. 

· In the New Action dialog, assign an:

· Action Set (if different from the one displayed)

· Action Name (any combination of upper or lower case letters, numbers, spaces or special characters)

· Optional color to be displayed in Button Mode. Search on ASSIGNCOLORS
· Optional keyboard shortcut. Search on KEYBOARDSHORTCUTS
· Next click the button labeled Record in the New Action dialog box, which will close the dialog and activate Record Mode. Note: This button should not be confused with the Record at the bottom of the Actions Palette. Note the color of the RECORD icon at the bottom of the Actions Palette changes from black to red (●), indicating Record Mode is active.
· Proceed to choose commands from menus, create layers, run filters, set layer options, manipulate channels, enter Photoshop shortcuts, populate dialog boxes, etc. — whatever steps are needed in the process you’re recording. As each operation completes Photoshop adds another step to the action. There’s no hurry. Photoshop will patiently wait until the next menu command is selected or text box is populated.

Important: As you record your action you’ll most likely engage a command that has a button labeled Cancel. If you click a Cancel button in a dialog, Record Mode is terminated. Record Mode must be reengaged to resume recording. Search on RECORDACTION
- - - - - -

25.3 Q: What should I do when the last step is recorded?


A: Click Stop (■) to terminate Record Mode. You can also press ESC.

- - - - - -

25.4 Q: What if I record a step I didn’t mean to?

A: No problem. 

You can either 

· click Stop (■) and delete the step on the spot, then click Record (●) to resume recording
 or 
· continue on and delete the unwanted step after you finish recording. 

- - - - - -

25.5 Q: What if I record a step out of sequence?

A: Again, no problem. 

Your options are click Stop (■) and correct the problem (Drag and Drop the step into the into the correct sequence) or continue recording and rearrange the step(s) when you finish recording. Search on MOVEACTIONSTEP
- - - - - -

25.6 Q: What if I recorded settings in a filter or an adjustment layer that aren’t the ones I intended?

A: Still no problem. Settings can be easily changed after the initial recording session. Search on RERECORDSTEP
- - - - - -

25.7 Q: There are some commands I can’t seem to record in my action, but I’ve seen them in actions I’ve downloaded from the Internet. How is that possible? 

A: Some commands cannot be recorded, but they can be inserted. Search on INSERTMENU 

- - - - - -

25.8 Q: When most commands are recorded, such as Levels > Flatten Image or Image > Adjustments > Desaturate, the recorded action step is named in accordance with the command, e.g., Desaturate, Flatten Image. Some commands such as File > Save As…, File > Save for the Web, Image > Adjustments > Autocolor and Image > Adjustments > Autolevels are recorded as Save, Export, Levels and Levels respectively. Is that a bug? 

A: No, these are not bugs. Autolevels and Autocolor are, in fact, canned applications of Levels (PierreC). 

On the others if you click the Show/Hide Triangle next to the action steps you will notice specific options assigned to each so they execute properly. 

As you develop more actions you will notice other action steps that appear to be mislabeled. Don’t be concerned. Despite the misleading action step name, the command will execute as expected. 

- - - - - -

25.9 Q: What about testing or quality assurance?


A: It’s a good idea to visually inspect the steps in your action. Did you forget any? Are they in the right order? It’s a good idea, too, to play the action (against a test image) to verify it works as intended.

- - - - - -

25.10 Q: Is there another way I can create a new action?


A: Yes, but this is kind of a slippery use of the term create. A new action can be created by making a copy of an existing action. Search on COPYACTION 
ASSIGNCOLORS

26. ASSIGNING OR CHANGING COLORS

UP
26.1 Q: Why would I want to assign a color to an action? 

A: When the Actions Palette is in Button Mode, color coded actions are easy to distinguish. Assigning colors to actions allows you to group actions by color in the Actions Palette. Search on ACTIONCOLOREXAMPLES
- - - - - -

26.2 Q: How do I change or remove a previously assigned color?

A: Select the action and then chose Action Options. Reassign the color as desired, including the default None.

- - - - - -

26.3 Q: In the New Action and Action Options dialogs, what color is None?

A: The color associated with menu choice None is light gray. The gray that can be selected in the dropdown menu is a darker shade.

- - - - - -

26.4 Q: There are only a few colors from which to choose in the menu, including None (light gray). Can more colors be made available?

A: No. What you see are the only choices available. There’s no problem reusing colors for actions in different Action Sets. 

The only consideration would be not placing two action sets (whose actions have been assigned the same color) side-by-side in the actions palette. Doing so (and assuming the Actions Palette is in button mode) would result in a block of (say) green buttons and no way to visually distinguish which buttons corresponded to what Action Set outside of Action Name recognition.

COPYACTION 

27. DUPLICATING (COPYING) AN ACTION

UP
27.1 Q: Why would I want to duplicate an action?


A: Regardless of your experience level with writing or modifying actions, and especially if you are new at it, it’s not a bad idea to make a duplicate of the action before modifying it. 


When things go horribly wrong, which they sometimes do, there’s nothing like having a copy of an unmodified action on which to fall back. Getting into the habit of making a backup copy before modifying an action or whilst in the process of developing a new one will significantly reduce self-inflicted pain and suffering. Trust me.


Duplicating an existing action can be a way to save some time when creating a new action that’s similar to the original. Once the duplicate is made, delete the unwanted steps and add new ones.

- - - - - -

DUPLICATEACTIONS

27.2 Q: How do I duplicate an action?

A: These are the alternatives: 

· Select the action and choose Duplicate from the Actions Palette Menu.

· Select the action and drag the action over Record New Action (()
· Select the action and click Record New Action (()
· Alt + drag the action to a new position in the current Action Set or to a different Action Set.

28. MODIFYING ACTIONS I

UP
After recording an action or acquiring one from an outside source it is not unusual to make changes to correct errors, make improvements, or pick up where you left off during development. The sections that follow address the following situations.

Corrections are necessary when commands:

· Are left out

· Are recorded in the wrong sequence

· Are recorded in the right sequence, but incorrect (or unfavorable) settings were specified

· Are recorded by accident 


Besides fixing errors, improvements typically involve the following:

· Deleting unneeded steps

· Changing action options

· Moving steps within an action

· Adding new steps

· Record

· Insert Menu Item

· Insert Stop

· Copying steps within the action

· Copying or moving steps from other actions

· Rerecording steps (changing default settings)

· Enabling or disabling dialog boxes

· Enabling or disabling steps

29. RENAMING AN ACTION

UP

Search on RENAMEPROBLEMS for possible negative repercussions of renaming an action.

- - - - - -

29.1 Q: How do I rename an action?


A: Of these three options, the first is probably the best:

· Double-click anywhere on the Action Name, which will select (highlight) the name. Just type to rename it. With this method you can assign an Action Name of up to 64 characters.

· Double-click anywhere to the right of the Action Name, which will display the Action Options dialog. Note: The Action Options dialog restricts Action Names to 31 characters.

· Click on the Action Name to select the action and choose Action Options from the Actions Palette Menu. Note: The Action Options dialog restricts Action Names to 31 characters.

- - - - - -

29.2 Q: Why would I want to rename an action? 


A: Typically renaming is done for organizational reasons. In most cases there are no consequences, but there can be. Search on ACTIONNAMEEXAMPLES
30. DELETING AN ACTION OR ACTION STEP

UP
30.1 Q: Why would I want to delete an action?


A: You delete actions for the same reasons you delete other files:

· You no longer favor the results it generates

· It is seldom, if ever, used

· You replaced it with a different action that gets superior results

· Sometimes the work you do with Photoshop changes, e.g., you used to work exclusively with Web images, but now you do print advertising work, so it’s time to clean house.

· The action is made obsolete by functionality introduced by a new version of Photoshop. For example Photoshop CS introduced the ability to assign keyboard shortcuts to any menu item, a common use of actions in previous versions. (PierreC)

- - - - - -

30.2 Q: Why would I want to delete an action step?


A: There are two common reasons. 

· While recording an action, a command is recorded in error. For example you intended to record an Unsharp Mask command, but your mouse slipped and Sharpen More was recorded instead or perhaps you recorded the same step twice.

· An action downloaded from the Internet can include commands you don’t want executed. Deleting them ensures they never execute. 

· You found an alternative sequence of steps that that produces better or faster results. (PierreC)

- - - - - -

30.3 Q: How is an action step or action deleted?


A: You delete an action step and an action the same way: Select (highlight) it and Drag and Drop it on the TRASH ([image: image9.jpg]


).

Important: You get one chance to undo (CTRL+Z) the delete. 

- - - - - -

30.4 Q: Is it prudent to delete steps I don’t quite understand? I’m a little nervous about doing that because of my lack of actions experience.


A: Good point. An alternative to deleting a step is to disable it. A disabled step is skipped when the action plays. If the result of playing the action with the disabled step is satisfactory, the disabled step can be deleted at any time. Search on ENABLEDISABLE 

31. MOVING AN ACTION

UP
31.1 Q: Why would I want to move an action? 

A: One moves an action typically for organizational purposes. Perhaps you prefer your actions listed alphabetically by Action Name or you want actions ordered by frequency of use. You may have created an action in one set, but decide later it really belongs in a different set. 

The position of an action within an Action Set affects the relative position of the action’s corresponding button if the Actions Palette is displayed in Button Mode. Search on MODEBUTTON
- - - - - -

31.2 Q: How do I move an action within a single action set?

A: Click on the action and Drag and Drop it in its new location. The thick line that appears between Action Names as you drag indicates where the action will be inserted when the mouse button is released 

Moving an action does not affect the result of playing the action. 

- - - - - -

31.3 Q: Can I move an action from one Action Set to another Action Set?

A: Yes. Just Drag and Drop it into the new Action Set. Like moving actions within an Action Set, as you drag a thick line appears indicating where the action will be inserted when the mouse button is released.

If you move an action to a collapsed Action Set, the moved action will be inserted in the last (bottom) position in the set. Click the Show/Hide Triangle of a collapsed destination Action Set beforehand if you want to move the action to a particular location. 

Important: Usually moving an action from one Action Set to another causes no problems. If the action is what’s known as a Nested Action (something rare for most casual users), moving it to another Action Set can cause problems. Search on NESTEDWARNINGS
MOVEACTIONSTEP

32. MOVING AN ACTION STEP

UP
32.1 Q: Why would I want to move an action step?

A: Typically one moves an action step to correct a problem. The step is in the wrong place and, as is, executes out of order causing the action to generate incorrect results.

Important: Moving an action step (with the exception of a Stop Command) almost always changes the result of playing the action.

- - - - - -

32.2 Q: How do I move an action step?

A: Click on the action step and Drag and Drop it in its new location. The thick line that appears between action steps as you drag indicates the location where the step will be inserted when the mouse is released.

- - - - - -

32.3 Q: Can I move an action step from one action to another?

A: Yes as long as both actions are in the same Action Set. While you can move actions from one Action Set to another, you cannot move action steps from one Action Set to another.

33. ADDING STEPS 

UP
Steps can be added to actions in the following ways:

· Record

· Insert Menu Item

· Insert Stop

· Copy

· Move

RECORDACTION

34. WHEN TO USE THE RECORD BUTTON 

UP
34.1 Q: When do I use Record (●)?

A: Click Record (●) when you want to add additional steps to an existing action.

It’s also appropriate to engage RECORD to resume recording a new action if, for whatever reason, the initial recording session was interrupted.

- - - - - -

34.2 Q: How do I add new commands to the end of an existing action?

A: If your action applies commands to an image, be sure an image is open, then do the following.

· Click (highlight) either the Action Set Name or the last command in the action.

· Click Record (●). Note, again, the color of the button changes from black to red (●), indicating Record Mode is active.
· Record commands as desired.

· Click STOP (■) to terminate Record Mode. 
- - - - - -

34.3 Q: How do I add new commands at the beginning of an action?

A: Important: This throws some people.

· Click (highlight) the first step in the action (not the Action Name).

· Click Record (●) and record commands as desired. Note, new commands will start recording right after the first step. Don’t worry.
· Click Stop (■) when finished.

· Move the first action step wherever you want it, effectively moving all other steps up a notch in the action.

- - - - - -

34.4 Q: How do I add new steps other than at the beginning or end of the action?

· Click (highlight) the step after which you want the first new step to be recorded.

· Click Record (●).
· Click Stop (■) when finished.

INSERTMENU 

35. INSERT MENU ITEM COMMAND

UP
35.1 Q: What’s the purpose of Insert Menu Item? 

A: When a File > Open or File > Save command is recorded you are required to specify a file name. Under some circumstances a hard-coded file name is not desirable. Insert Menu Item provides a way to place commands such as the following into an action without having to specify a file name: 

· File > Open (and be able to specify the file name)

· File > Open As… (and be able to specify the file type)

· File > Save (and be able to specify the file name)

· File > Save As… (and be able to specify the file name)


Some commands cannot be recorded when Record Mode is active, so Insert Menu Item provides a way of placing commands such as the following into an action: 

· File > Import… (menu item designating your scanner)

· File > Info… 

· Edit > Step Forward (Next history state)

· Edit > Step Backwards (Previous history state)

· View > Zoom in (or Zoom out)

· View > Actual pixels
· View > Rulers
· View > Set [whatever]

· Window > [palette name]

· Window > Documents > New Window
· From the Channels Palette menu, Merge Channels

A second reason to use Insert Menu Item is to place commands into an action without having to execute them as would occur in Record Mode. For example if you’re recording an action using a multi-layer image and at some point want to include a Flatten Image command, using Insert Menu Item gets the job done without actually flattening the image.

Finally use Insert Menu Item to insert commands that are grayed out in Record Mode due to circumstances of the moment. For example suppose you’re recording an action on a Background-only image and want to record a Flatten Image command. Flatten Image is grayed out in this case and cannot be recorded, but it can be inserted by invoking Insert Menu Item. 


Notes: 

· Some commands, such as Window > Documents > Tile (or Cascade) cannot be inserted under Windows, but can be inserted by the Macintosh version of Photoshop.

· In most cases if a command normally displays a dialog box, such as Levels or Unsharp Mask, and that command is inserted using Insert Menu Item, when the action plays the dialog box for that command will be displayed unconditionally. The option to suppress the dialog box is not available, in fact for non-File menu commands there’s no Display Dialog Checkbox to uncheck. For commands such as Desaturate or Merge Visible that do not have Display Dialog Checkboxes, this is not an issue.

· When Insert Menu Item is used to insert commands from the Filter menu, whatever settings were used the last time the filter was applied are the settings recorded and displayed in the dialog box. The settings can be changed by rerecording the step. Search on RERECORDSTEP
· For 3rd party plug-in steps that display undesirable dialog boxes, making them useless in most Automate > Batch operations, Insert Menu Item can be used as part of a workaround method. Search on IMI3RD
- - - - - -

35.2 Q: How do I use Insert Menu Item? 

A: Here you go…

· From the Actions Palette Menu choose Insert Menu Item. Ignore the dialog that appears on the screen for the time being.

· Click any menu (including palette pop-up menus) and select the desired command. If the on-screen dialog is populated with the command name when it is selected from the menu, the command is eligible for insertion. If the dialog box is not populated with the command name, it means the command cannot be inserted. 

· Click OK in the dialog box to insert the selected command into the action. 

- - - - - -

35.3 Q: Can I use Insert Menu Item even when Record Mode is active? 

A: Yes.

36. DUPLICATING (COPYING) AN ACTION STEP

UP
36.1 Q: Why would I want to duplicate an action step?


A: Duplicating an action step is typically done to save a few mouse clicks. It may be faster to copy an existing step than plow through the menu sequence to record it. Case in point: Select > Modify > Feather, type a value, then click OK to close the dialog. 

- - - - - -

36.2 Q: How do I duplicate an action step?

A: Three options:

· Select (highlight) the step, hold down the Alt key and Drag and Drop the duplicate step into the desired location.

· Select the step, choose Duplicate from the Actions Palette Menu and then drag the step to the new location.

· Select the step and Drag and Drop it on Create New Action (()

- - - - - -

36.3 Q: Can I copy an action step from one action into another action?

A: Yes, as long as the source and destination actions are part of the same Action Set. You cannot copy an action step from an action in Action Set A to an action in Action Set B.

37. MODIFYING SETTINGS

UP
Sometimes settings for filter or adjustment steps aren’t recorded or need to be modified at a later time. Photoshop provides methods to modify one step at a time or multiple steps in an action.

RERECORDSTEP

38. RERECORDING SETTINGS IN A STEP

UP
38.1 Q: For whatever reason the action author set the default radius value for a Gaussian Blur command to 22. I’d like to change it to 2. How can I do that without dragging that command to the Trash ([image: image10.jpg]


) and recording another to replace it?


A: Open a test image. 


Double-click on the Gaussian Blur step in the action. This will open the Gaussian Blur filter dialog box, just as though you’d engaged it from the Filter menu. The Radius setting will be the one originally recorded. Change it as desired and click OK. The step will be updated with the new setting. 


If necessary undo (Ctrl + Z) the change made to the open image. This undo will not undo the change made to the action step. 

39. RERECORDING SETTINGS IN ALL OR MULTIPLE STEPS IN AN ACTION

UP
39.1 Q: I’ve got an action with 54 steps and I’d like to change the settings in just about every command. Can I do this without double-clicking each command to change it?


A: Yes. 

· Open a test image.

· Click on (highlight) the Action Name. 

· For backup purposes choose Duplicate from the Actions Palette menu (PierreC). 

· Choose Record Again from the Actions Palette Menu. This will play the action during which the dialog for each command that has one will be displayed, even if the Display Dialog checkbox is unchecked. (Search on MSGSUPPRESS) If any settings are changed in a dialog, they will replace previous ones when the dialog is closed by clicking OK. To retain settings for a given step, click OK to close the dialog box without making setting changes.

· When finished close the test image.



Notes: 

· Record Again can be used on an individual command, but it’s usually faster to change a single command by double-clicking it.

· To exit the Record Again process at any point, click Cancel in any dialog box.

- - - - - -

39.2 Q: Can I use Record Again to replace settings steps, say, 4-17 of a 20 step action?

A: Not by selecting steps 4-17 in a block. You would choose Record Again and click OK (without making changes) for each step whose settings you did not want to change (in this case 1-3). Then, make changes as necessary to steps 4-17. At step 18 click Cancel in the dialog box to terminate Record Again. 

40. CONTROLLING WHICH STEPS PLAY, WHICH DIALOG BOXES DISPLAY

UP
When it comes to customizing actions key techniques are the ability to control which steps are executed (or skipped) and which steps display their corresponding dialog boxes. 

As noted previously embossed checkboxes correspond to each Action Set, Action and action step, and are designated as follows:

· Enable/Disable: The one to the far left.

· Display Dialog: The one to the right of Enable/Disable. Note: If a command does not have a dialog box, such as Image > Adjustments > Desaturate, there is no corresponding Display Dialog checkbox.

ENABLEDISABLE

41. DISABLING (SKIPPING) AND ENABLING ACTION STEPS

UP
Important: Note this discussion pertains to action steps. Search on ENABLEDISPLAYTABLE for important differences pertaining to Actions and Action Sets. 

41.1 Q: I’ve got an action that applies a Gaussian Blur filter that I don’t want applied. How can I disable that command?


A: If the Enable/Disable checkbox is checked (, the step to which it corresponds is enabled and will be executed when the action plays.


If this checkbox is unchecked (, the command will be skipped.


To disable any command: Uncheck its Enable/Disable checkbox.

MSGSUPPRESS 

42. DISABLING (SUPPRESSING) AND ENABLING ACTION STEP DIALOG BOXES

UP
Important: Note this discussion also pertains to action steps. Search on ENABLEDISPLAYTABLE for important differences pertaining to Actions and Action Sets. 

42.1 Q: An action I frequently use has an Unsharp Mask command that displays a dialog box whose settings I never change. What can I so the Unsharp Mask command is applied with the recorded setting and not have to click OK each time?


A: Click the symbol [image: image11.png]


 next to the command (turning it off). This will suppress the dialog box display. 


- - - - - -

42.2 Q: If I uncheck a step’s Enable/Disable checkbox (, won’t this suppress its dialog box, too?

A: It sure will, but at a cost: it skips the step completely. 

43. ENABLE/DISABLE AND DISPLAY DIALOG CHECKBOX SUMMARY FOR ACTION STEPS

UP
Important: You guessed it. This pertains to action steps. Search on ENABLEDISPLAYTABLE for important differences pertaining to Actions and Action Sets. 

43.1 The following summarizes the results of these checkbox combinations as applied to action steps:


(  [image: image12.png]


  : Execute step. Display dialog box. 


(  (  : Execute step. Suppress dialog box.


(      : Execute step. The step has no corresponding dialog box.


(  [image: image13.png]


  : Skip step. It’s irrelevant that Display Dialog is on.


(  (  : Skip step.  


(      : Skip step. The step has no corresponding dialog box.


Search on ENABLEDISABLE, DISPLAYDIALOG, ENABLEDISPLAYTABLE

SUPPRESSSTOPCMD

44. SUPPRESSING STOP COMMAND DIALOG BOXES

UP
44.1 Q: What’s the difference between a Stop Command dialog box and other kinds of dialog boxes? 


A: Dialog boxes (in general) are displayed when you choose a Photoshop command from a menu or invoke a command using a keyboard shortcut, e.g., Levels, Gaussian Blur, New Guide, New Layer, Select Color, etc. They have sliders to drag, options to select, boxes into which text is typed and buttons labeled OK, Cancel and possibly others.


Stop Command dialog boxes are generated when an action executes a Stop Command. The dialog box displays whatever text was recorded, a button labeled Stop and an optional button labeled Continue. 
- - - - - -

44.2 Q: And your point would be… ? 


A: The method to suppress the dialog box for a Stop Command is different than the method used to suppress dialog boxes for other commands.

- - - - - -

44.3 I find it especially annoying that every time I run an action I have to click through messages displayed about the author’s name or that I need to have an image open. This is fine the first couple times the action is played, but after that it becomes an annoyance. Is unchecking the Display Dialog checkbox the way to do it?


(  (  : Execute command (pauses action). Suppress dialog box.


A: NO! As intuitive as it may seem don’t do it this way. This approach will confuse the daylights out of you! Here’s why.


Observe that this combination of Enable/Disable and Display Dialog executes the command and suppresses the dialog. When you click Play (►) the action will appear to be rolling merrily along. All of a sudden it will mysteriously stop. Here’s why: When Photoshop executes the Stop Command, the action is stopped, but the dialog box will not display since Display Dialog is unchecked. 


The action will appear to be dead in the water and will remain paused until Play (►) is clicked or you go onto something else wondering what went wrong. 

- - - - - -

44.4 Q: Okay, I get your point. So how DO I suppress a Stop Command dialog without stopping the action in its tracks?


A: Uncheck the Enable/Disable checkbox which causes Photoshop to skip the step completely. With Enable/Disable unchecked the status of Display Dialog is irrelevant. Either of the following settings will achieve the desired goal.


(  [image: image14.png]


  : Skip command. Display Dialog setting is irrelevant.  


(  (  : Skip command. This works, too.


Note: Not all Stop Command messages are bad. Some actually contain useful information. As you get more familiar with actions, you develop a feel for which ones to display and which to suppress. 

SAVEACTIONS 

45. SAVING ACTIONS

UP
45.1 Q: Why is the command named Save Actions…? I thought you said you couldn’t save individual actions.


A: That is correct. Individual action cannot be saved using this command. In a perfect world it would be labeled Save Action Sets…, but it isn’t.

- - - - - -

45.2 Q: Why would one want to save Action Sets?


A: Here are some reasons:

· Recovery. For those who write custom actions or modify actions received from external sources, saving Action Sets in which they reside provides backup in case unfavorable changes are made to an action that cannot be undone, accidental deletion or hard disk failure (assuming the saved Action Set Files reside somewhere other than on the failed hard disk). 

· To share actions with other Photoshop users. Once an Action Set has been saved it is available for transport by e-mail, CD, floppy disk or Internet upload as an Action Set File (.atn). Search on SHARINGACTIONS 
· To share action steps with users of Photoshop 5.x or non-Photoshop users by converting Actions Palette contents to a text file. Search on PRINTSTEPS 

- - - - - -

45.3 Q: How do I save an Action Set?


A: First, a picky technical clarification. When one carries out a Save Actions… command, Photoshop converts the selected Action Set into an Action Set File, and places it in the location specified in the dialog box – usually somewhere on your hard disk. The point is you can’t attach Action Sets to an e-mail message or upload Action Sets to an Internet site directly from the Actions Palette. They must be first converted to Action Set Files.


How to do it:

· Click on (highlight) the Action Set you want to save.

· Choose Save Actions… from the Actions Palette Menu.

· Navigate to the desired offload location.

· Click OK. 


Notes: 

· You cannot save more than one Action Set at a time using the Save Actions command. Bummer.

· The resulting Action Set File will contain the same actions as the selected Action Set.

- - - - - -

45.4 Q: What if I don’t want to save all the actions in an Action Set? Can’t I just select the ones of interest and save them? 


A: No. It is not possible to pick and choose which actions in a given action set you want saved. The Save Actions command operates on Action Sets only, regardless of how many or few actions they contain. 


Here’s a workaround: Duplicate the Action Set and delete the actions from it you don’t want saved. Then apply Save Actions to the stripped down set.

- - - - - -

45.5 Q: To expedite the saving of multiple Action Sets can Save Actions… be applied to more than one Action Set at a time or can multiple Action Sets be dragged/dropped outside the Photoshop window? 


A: No, but there is a way to save the entire contents of the Actions Palette. Search on ACTIONSPREFERENCEFILE
PRINTSTEPS
46. PRINTING ACTIONS

UP
46.1 Q: Can I print action steps?

A: Yes, but you cannot print them directly from the Actions Palette. First the Actions Palette must be saved in text file (.txt) format. You can then use any text editor or word processing program to display, edit and/or print the text file.

- - - - - -

MAKETXTFILE
46.2 Q: How do I create the text file?

A: Here are the steps: 

· Select (highlight) any Action Set Name (not Action Name). It makes no difference which Action Set Name is highlighted.

· While simultaneously holding down Alt + Ctrl, choose Save Actions from the Actions Palette menu. Notice the file name box is automatically populated with file name Actions.txt. (You can change Actions.txt to another file name if desired.)

· When OK is clicked Photoshop converts the entire contents of the Actions Palette into a text file (.txt) and places the file in the location specified in the Save Actions dialog. 

- - - - - -

46.3 Q: Can Actions.txt be reloaded into the Actions Palette? 

A: Unfortunately, no, there’s no way to reverse this process. Similarly, you can’t use other programs like Microsoft Word, Wordpad, Notepad, etc. to create actions or modify. Actions can only be created and modified with Photoshop. (TrevorM)

- - - - - -

46.4 Q: Is there a way to limit which actions or Action Sets are saved in Actions.txt? 

A: Not from the perspective of selecting specific actions and/or Action Sets before executing the Save Actions command. The entire contents of the Actions Palette is converted and saved in Actions.txt. It’s all or nothing and just the way it works. 

- - - - - -

46.5 Q: Couldn’t I just delete actions or Actions Sets from the Actions Palette before executing the Save Actions command? That way Actions.txt would only contain actions I want to print.

A: Sure, that’s an option, but not one I would choose. Here’s why.

Let’s assume the actions and/or Action Sets you delete before Actions.txt is created are ones you want to play again. Before deleting them, you will need to apply a Save Actions command to each (about to be deleted) Action Set. After Actions.txt is created the deleted Action Sets will need to be reloaded. 

A better way would be to convert the entire Actions Palette as is, and then use a text editor or word processing program to delete unneeded sections of the text file. 

Since the contents of Actions.txt correspond to the sequence of Action Sets as they appear in the Actions Palette, one tactic is to move (Drag and Drop) or copy (Alt + Drag and Drop) Action Sets of interest to the top of the Actions Palette before Actions.txt is created. When Actions.txt is opened, the Action Sets of interest will be listed first.

47. OTHER USES FOR ACTIONS.TXT

UP
47.1 Q: Besides providing a roadmap for recreating action effects by Photoshop 5.x or non-Photoshop users, why would one want to print action steps? 

A: I have found studying actions to be a great way to learn about Photoshop capabilities and action writing techniques, as well as inspiration for writing new actions. I can’t begin to tell you how much I’ve learned from actions written by Mike Finn. Without a doubt his are the most creative photo-art actions I’ve ever seen, many of which he offers free from his site:

http://homepages.slingshot.co.nz/~mikefinn/action.html
Before a long plane trip I’ll print the steps of several new (to me) actions. Dissecting them makes for fascinating reading (and doodling) while confined to the middle seat on a long flight between Seattle and Atlanta. Really!

- - - - - -

47.2 Q: Anything else? 

A: Photoshop’s spell-check function does not extend to text typed into Stop Command dialogs. If you’re going to publish actions, opening Actions.txt with a program like Microsoft Word will enable you to check Stop Command messages.

SHARINGACTIONS 

48. SHARING ACTIONS WITH OTHERS VIA E-MAIL, INTERNET, FLOPPY OR CD

UP
48.1 Q: I’ve written some cool actions I would like to share with others. What are my options?


A: E-mail, uploading to a public Website so they can be subsequently downloaded and saving to a floppy disk or CD. Although much less common than using e-mail or the Internet, floppies and CDs are attractive to those who don’t have Internet and/or e-mail access.



Upload to Internet (so others can download):

· Use Save Actions… to convert the Action Set to an Action Set File saved on your hard disk.

· Find a site that supports sharing of actions, such as 

  http://www.share.studio.adobe.com/Default.asp
· Read/follow the upload instructions. Note: Some sites allow individual .atn files to be uploaded while others require them to be zipped. 



E-mail:


· Use Save Actions… to convert the Action Set to an Action Set File saved on your hard disk.

· Attach the .atn to the e-mail message. This is done the same way as attaching any other file type, such as .jpg, .txt, .doc, etc. Consult your e-mail Help for specific information regarding file attachments. 

· Send it!


Note: If you have numerous Action Set Files to send, it may be more efficient to zip them and attach a single .zip file to the e-mail message than attaching multiple .atn files.



Floppy disk or CD:

· Use Save Actions… to convert the Action Set to an Action Set File saved on a CD or floppy disk.

· Alternatively, the .atn may be saved onto your hard disk first, then copied (Drag and Drop) onto the floppy or CD. 

49. SHARING ACTIONS WITH PHOTOSHOP 5.x USERS AND NON-PHOTOSHOP USERS

UP
49.1 Q: I have friends who have Photoshop 5.x, who are unable to load actions created under Photoshop 6 and above. How can I share my actions with them?

A: As noted previously Action Sets created in Photoshop 6 and above cannot be loaded in Photoshop 5.x. About the only hope here is for PS 5.x users to get access to a copy of Actions.txt and use it as a roadmap from which to manually record the actions. Search on PRINTSTEPS 

As one formerly isolated from the rest of the world with Photoshop 5.5, I can attest this method works. Having had action writing and dissecting experience, it was not difficult to recreate the actions in PS 5.5, but it was time consuming. The time and effort required to record actions in this manner is a function of action complexity and familiarity with actions in general. 

- - - - - -

49.2 Q: Can people who use programs other than Photoshop recreate the results of Photoshop actions?

A: Sometimes. Most image-editing programs have, to some degree, functions and filters that render results similar to their Photoshop counterparts. Some programs like Photo-Brush, PhotoPaint, Paint Shop Pro and PhotoImpact have the Photoshop-like ability to record commands. Generating the same (or similar) results as a particular Photoshop action just depends on the capabilities of the non-Photoshop program and your ability to interpret and translate Photoshop commands. 

Non-Photoshop users would use the same process as Photoshop 5.x users: Get their hands on a copy of Actions.txt and use it as a roadmap. Search on PRINTSTEPS
Warning: Those with little Photoshop background will find it somewhat-to-very challenging to translate some Photoshop commands and settings into to their non-Photoshop equivalents. 

I. Beyond Basics 
UP
In addition to introducing new topics this section goes into more depth on some topics previously covered. 

50. Review of Potentially Dangerous ACTION SET MENU Commands

UP
Important: These potentially dangerous commands were tested under Photoshop 7. For each, there is one chance to use Undo (Ctrl + Z) if you change your mind.

CLEAR ACTIONS: Clears (purges, deletes) the Actions Palette of all Action Sets. There is a warning dialog box to confirm or cancel this operation. 

RESET ACTIONS: This is the equivalent of Clear Actions (purge all Action Sets from the Actions Palette) followed by loading Action Set Default.atn. Think of it this way: When this command is executed the Actions Palette will be reset to the way it was when Photoshop was installed. There is an option to append Default.atn to the Action Sets already in the Actions Palette. 

REPLACE ACTIONS: Similar to Reset Actions. Clears the Actions Palette and loads an Action Set of your choosing, instead of Default.atn. You will have the option to append the selected Action Set to the Action Sets already in the Actions Palette. 

51. KEYBOARD SHORTCUTS: THE BEST PHOTOSHOP-WIDE SUMMARY ON THE WEB

UP
Before getting into action-specific keyboard shortcuts, we’re going to take a brief, but worthwhile side trip. TonyK suggested including a reference to a site we both believe to be the most comprehensive Photoshop-wide keyboard shortcut summary available on the net: http://www.user.fundy.net/morris/
Click the Photoshop link to display the page from which the Hotkey (shortcut) file can be downloaded. 

As a matter of fact the Trevor Morris site is excellent across the board and just continues to get better. If this URL is not yet saved among your Favorites, it should and probably soon will be.

Thank you, Trevor.

KEYBOARDSHORTCUTS

52. KEYBOARD SHORTCUTS: ASSIGNING AND UNASSIGNING

UP
Photoshop CS introduced a new function which, to me, trumps the comparable action capability in which one can assign keyboard shortcuts to menu commands. If you have CS, use it for this purpose.

Regardless of Photoshop version, you may still find value in the capability of initiating actions using keyboard shortcuts.

- - - - - -

1.1 Why would I want to assign a keyboard shortcut to an action?

A: For those who prefer the keyboard to using a mouse, keyboard shortcuts are a welcome feature.

Some users prefer to have as few palettes as possible displayed at any given time. One way to avoid showing the Actions Palette is to initiate actions by keyboard shortcut. 

- - - - - -

1.2 How does one assign a keyboard shortcut to an action?

A: Open the Actions Options dialog and choose an available Function Key from the menu. If desired specify the Ctrl and/or Shift modifier keys in conjunction with the function key. If a given function or modifier key is not available, it will be grayed-out.

- - - - - -

1.3 Is there anything else I should know?

A: Perhaps these will come in handy:

· Mac keyboards have three more function keys than Windows’ keyboards, thus more combinations available for keyboard shortcut assignment.

· F1 and its modifier key options are not available under Windows; F1 is reserved for Help.

· CTRL + F4 is not available under Windows; it is reserved for the equivalent of File > Close. 

· When the Actions Palette is displayed in Button Mode, the keyboard shortcut is shown on the button corresponding to the action next to the Action Name. 

· In Photoshop CS if a keyboard shortcut has been assigned to another command, it cannot be assigned to an action. (KentC)

· If a particular keyboard shortcut has been assigned, it cannot be assigned again to any other action currently in the Actions Palette, even if the action is in a different Action Set. It is possible to assign the same keyboard shortcut to multiple actions (and have them work) as long as the actions are not in the Actions Palette at the same time. Search on DUPSHORTCUTS
· If a keyboard shortcut has been assigned (and you remember what it is), the Actions Palette does not have to be visible to play the action.

· Some default keyboard shortcuts are assigned when Photoshop is installed. Search on DEFAULTKEYBOARDASSIGNMENTS. If you assign an action a custom keyboard shortcut such as F7 (which normally shows/hides the Layers Palette), pressing F7 will play the action instead of executing the default command. 

- - - - - -

1.4 If I use the new CS function to assign F5 to a menu command and assign F5 to an action in the Action Options dialog, what happens when I press F5? 

A: Not a problem. CS will not allow assignment of a keyboard more than once.

- - - - - -

1.5 Q: When do I assign a keyboard shortcut to an action?

A: The assignment can be made in the New Action dialog when the action is created or after the fact using the Action Options command.

- - - - - -

1.6 Q: How do I deactivate an existing keyboard shortcut?

A: Select the action and open the Action Options dialog. Choose None from the Function Key dropdown menu.

- - - - - -

1.7 Q: If I assign a keyboard shortcut to an action, then execute Save Actions… on the Action Set, then delete the Action Set from the Actions Palette, what happens when I try the keyboard shortcut?

A: It depends.

· If the keyboard shortcut you assigned to the action is one that is among the Photoshop defaults, e.g., F9 shows the Actions Palette, the default function is invoked.

· If the keyboard shortcut you assigned to the action does not correspond to a default Photoshop function, nothing happens when the keyboard shortcut is entered.

- - - - - -

1.8 Q: Suppose I assign a keyboard shortcut to an action, then execute Save Actions… on the Action Set, then e-mail the Action Set File to a friend and he loads the Action Set File into his Actions Palette. What happens when he tries the keyboard shortcut I assigned to the action?

A: It depends.

· If the keyboard shortcut you assigned is one your friend has already assigned to a function in his Photoshop environment, entering that keyboard shortcut will invoke the function to which it is already assigned. Here’s why: During the Load Actions… process Photoshop detects the duplicate keyboard shortcut assignment and automatically sets the action keyboard shortcut to None.

· If the keyboard shortcut you assigned to the action has not been assigned by your friend, entering it will invoke the action you sent to him. (BillR)

2. ACTION KEYBOARD SHORTCUTS: COMMANDS.ATN AND PHOTOSHOP DEFAULTS

UP
DEFAULTKEYBOARDASSIGNMENTS

2.1 Q: What are the built-in (default) keyboard shortcuts?

A: The following table summarizes Photoshop’s default keyboard assignments and compares them to the keyboard assignments assigned to the actions in the Adobe provided action set Commands.atn, which can be loaded from the Actions Palette Menu. 

If you load Action Set Commands, with the exception of F5, all other keyboard assigned to these actions correspond to the default Photoshop keyboard shortcuts activated by the same function keys. Switch the Actions Palette to Button Mode for a great visual illustration of these keyboard shortcuts. 

Note: For completeness keyboard shortcut assignments for all actions in the Commands Action Set are shown in the table below.

	PHOTOSHOP DEFAULT

FUNCTION KEY  

  Command invoked
	Commands.atn

KEYBOARD SHORTCUT ASSIGNMENT 

  Action Name

	F1  

  HELP
	F1 - Not Available

  

	F2 

  Cut (selection)
	F2 

  Cut (selection)

	F3  

  Copy (selection)
	F3  

  Copy (selection)

	F4  

  Paste
	F4  

  Paste

	F5  

  Show Brushes
	F5  

  (unassigned)

	F6 

  Show Color  
	F6 

  Show Color  

	F7  

  Show Layers
	F7  

  Show Layers

	F8  

  Show Info
	F8  

  Show Info

	F9  

  Show Actions
	F9  

  Show Actions

	F10 

  Show Navigator
	F10 

  Show Navigator

	F11 

  Image Size
	F11 

  Image Size

	F12 

  Revert
	F12 

  Revert

	
	Shift + F1  - Not Available

   

	
	Shift + F2

  Flatten image

	
	Shift + F3  

  Purge All

	
	Shift + F4  

  Select Similar (selection)

	
	Shift + F5  

  Grow (Selection)

	
	Shift + F6  

  Flip Horizontal

	
	Shift + F7  

  Flip Vertical

	
	Shift + F8  

  Rotate 90 CW

	
	Shift + F9  

  Rotate 90 CCW

	
	Shift + F10 

  Rotate 180

	
	Shift + F11 

  New Snapshot

	
	Shift + F12 

  New Snapshot/Clear History


- - - - - -

2.2 Q: Why did Adobe provide actions that do the same things as pressing the corresponding function keys?

A: Apparently this was Adobe’s way of documenting the commands that correspond to function keys as well as illustrating how to assign keyboard shortcuts to actions. 

- - - - - -

2.3 Q: If I load Commands.atn into my Actions Palette, what would happen if I deleted one or more actions from the Action Set? 

A: There would be no harm in deleting actions from this set. They can easily be replaced by reloading this set by clicking its name at the bottom of the Actions Palette Menu. Secondly, there would be no apparent loss of functionality. 

- - - - - -

2.4 Q: Why is that (no apparent loss of functionality)? 

A: Pressing F9 launches action Show Actions, which executes the Show Actions command. If you delete action Show Actions from set Commands and press F9, Photoshop executes the default command associated with F9, which happens to be Show Actions. If you assigned F9 to a different action named Super Sharpen and pressed F9, Photoshop will play Super Sharpen. 

The thing to remember is Photoshop gives precedence to an action with a function key-only keyboard shortcut over the default command associated with the same function key. 

- - - - - -

2.5 Q: If I do not load Commands.atn into my Actions Palette or delete it if already loaded, all function keys (except F1) are available for custom assignment, correct?

A: Yes. 

- - - - - -

2.6 Q: Suppose I have an Action Set named Production in my Actions Palette which contains action Color Correct to which I had previously assigned F9 as a keyboard shortcut. Then I load set Commands.atn into the Actions Palette. What happens when I press F9?
A: Pressing F9 will play action Color Correct. Why? During the load process Photoshop detects keyboard shortcuts that are already assigned to actions in the Actions Palette. Duplicate keyboard shortcuts are reset to None. 

Had any of the following occurred before set Commands.atn was loaded (thereby eliminating keyboard shortcut conflict), F9 would have played Show Actions from set Commands.atn:

· F9 had been unassigned from action Color Correct in the Action Options dialog

· Action Color Correct had been deleted 

· Action Set Production had been deleted 

- - - - - -

2.7 Q: Do I have to keep the actions in the Adobe-provided Commands.atn? 

A: Absolutely not. You’re free to delete or modify the actions in this set as you see fit. Before doing so you consider applying a Save Actions… command to Commands.atn. Having a backup of Commands.atn would avoid having to reinstall Photoshop down the road in case you change your mind and want a fresh copy of Commands.atn.

3. KEYBOARD SHORTCUTS: WHY ARE NO F KEYS AVAILABLE FOR ASSIGNMENT??

UP
3.1 Q: I have created a couple actions to which I wanted to assign function key-only keyboard shortcuts, e.g., F4, F7, etc., but when I check the Action Options dialog, none of the F keys are available (they are grayed out). Who stole the F key assignments? 


A: Adobe did, but you can get them back. One of the action sets Adobe provides, Commands, is used to illustrate how to assign keyboard shortcuts to actions. Unfortunately all available F keys (except F5) are assigned to these sample actions. Check your Actions Palette. If Commands is present, deleting this Action Set will free up the F keys for custom assignment except F1, which is reserved for Help. 


You will lose no functionality by deleting this action set and if you ever want to reload it, just choose it from the Actions Palette Menu.


Note: To see which actions have been assigned keyboard shortcuts, switch the Actions Palette into Button Mode. Keyboard shortcuts assigned to actions are displayed on the right side of their corresponding Actions Palette button. Search on MODEBUTTON.

DUPSHORTCUTS
4. ACTION KEYBOARD SHORTCUTS: ASSIGNING DUPLICATE SHORTCUTS ACROSS ACTION SETS

UP
4.1 Q: Is it possible to assign the same keyboard shortcuts to multiple actions?

A: Yes. 

Suppose you have three action sets Phase 1, Phase 2 and Phase 3 and each set has actions to which you want to assign F2 through F11. (Assumption: No actions currently in the Actions Palette have these function keys assigned.) 

Load Action Set Phase 1 and assign function keys F2 through F11 to its actions. When finished perform a Save Actions… command on set Phase 1 and delete it from the Actions Palette. Repeat the process for sets Phase 2 and Phase 3.

With set Phase 3 deleted, load Phase 1 again. Function keys F2 through F12 will play actions from that set. Delete set Phase 1 and load set Phase 2. The same function keys will play actions from set Phase 2, etc.

Note: In this example only function keys were used, but the method works the same way with keyboard shortcuts that include the Shift and Ctrl modifier keys.

- - - - - -

4.2 Q: So I’m okay assigning the same keyboard shortcut to multiple actions as long as both actions aren’t in the Actions Palette at the same time, right?

A: Correct. Using the above example, as long as set Phase 1 is deleted before set Phase 2 is loaded, set Phase 2 is deleted before set Phase 3 is loaded, etc., the keyboard shortcuts assigned to multiple actions will work as assigned.

SELECTMULTIPLEOBJECTS

5. SELECTING MULTIPLE ACTION SETS, ACTIONS AND ACTION STEPS

UP
In the sections that follow are examples that will illustrate the value of being able to select multiple Action Sets, actions or steps within an action. In the points below the word object is used to denote Action Set, action or action step.

Notes:

· Selecting different object types is not permitted, for example you cannot select an Action Set and an action.

· When selecting multiple steps, the steps must reside within the same action. Selected steps cannot span actions.

· When selecting actions, the actions must be within the same Action Set. Selected Actions cannot span Action Sets.

· Photoshop CS works differently in this regard than prior versions. See specifics that follow. (TonyK, SharonLC)

- - - - - -

5.1 How do I select a range of object?

A: Click the first object in the range. 

PS CS: While holding down the Shift key, click the last object in the range. 

PS 7 and prior versions: While holding down the Ctrl key, click the last object in the range.

All objects will be selected between and including the first and last objects. 

- - - - - -

5.2 How do I select non-contigous set of objects?

A: Click the first object in the range. 

PS CS: While holding down the Ctrl key, click the last object in the range. 

PS 7 and prior versions: While holding down the Shift key, click the last object in the range.

Each time you Shift or Ctrl-click, an additional object will be selected. 

6. MODIFYING ACTIONS II

UP
The next few topics go into additional depth on this broad topic. 

7. COPYING VS. MOVING ACTION SETS, ACTIONS AND ACTION STEPS

UP
7.1 Q: What’s the difference between moving and copying?

A: In a move operation Photoshop physically relocates the selected object(s) from the original location to the new location. In a copy operation Photoshop duplicates the object(s), placing the copy in the desired location, leaving the original object(s) undisturbed. 

In move and copy operations the destination may be the same or different actions or Action Sets. In other words you can move or copy steps from Action A within Action A or Action A to Action B. Likewise you can move or copy Action C within Action Set X or to Action Set Y. The same applies when moving and copying multiple steps or actions.

As part of the copy operation on an action or Action Set, Photoshop appends the word copy to the name of the copied object, e.g., Super Sharpening Action copy.

8. COPYING (DUPLICATING) BLOCKS OF COMMANDS, ACTIONS OR ACTION SETS

UP
8.1 Q: Why would I want to copy a block of commands? 

A: Suppose you are building an action that will end up being similar to, but different from an existing action. One way to reduce development time for the new action is to copy a block of commands into it from an existing action. 

One could argue, “Why not duplicate the first action and delete the unneeded commands from it?” You could do that, too. Now you have an option. ( 

- - - - - -

8.2 Q: I have a block of 17 steps I want played within the same action three times. How can I do that without recording the same 17 steps two additional times? 

A: Select the desired steps and choose Duplicate from the Actions Palette Menu, then chose Duplicate again. Presto: You created 34 additional steps in about five seconds. Now that’s productivity! 

9. MERGING TWO ACTIONS USING MOVE OR COPY

UP
9.1 Q: How do I merge the commands of two actions with minimal effort?

A: Before proceeding I recommend duplicating the affected actions. Doing so ensures that if things get messed up, it’s real easy to start over.

· To minimize the distance of the final Drag and Drop step that follows you might want to move either the source or destination actions so they are physically close together in the Actions Palette. 

· If necessary click the Show/Hide Triangles to reveal the steps in both actions. 

· Select the steps from the source action. 

· Alt + Drag and Drop (to copy) or just Drag and Drop (to move) the selected steps from the source action to the destination action.

Note: Alternatively in the first action you could record a step that plays the second action. Search on NESTEDACTIONS (PierreC)
10. DELETING A BLOCK OF COMMANDS

UP
10.1 Q: Why would I ever want to delete a block of commands?

A: Suppose you’re recording an action and then you get interrupted: [the phone rings | your child or significant other needs your immediate attention | “Survivor” comes on | pick your own distraction]. When you come back to Photoshop you start working away, forgetting Record Mode was active when you departed. For the next 10-15 minutes you go about editing images or whatever.

Then it hits you: You were in the middle of recording the world’s next great action when the interruption occurred. You check the Actions Palette and sure enough the Record button is red: Photoshop has faithfully been recording your last 84 steps, placing them after the 34 good ones. You click STOP and have to make a decision:

Option A: Drag and drop 84 individual commands over the Trash ([image: image15.jpg]


).

Option B: Select the 84 commands recorded in error in a block and drag the block over the Trash ([image: image16.jpg]


). 

11. RECORDING ACTIONS II

UP
11.1 Q: I’ve noticed that as steps are recorded that normally display dialog boxes, e.g., Levels or Gaussian Blur, that the Display Dialog checkbox is not checked. Can I turn this setting on without terminating Record Mode?


A: Yes.

- - - - - -

11.2 Q: Can I insert a Stop Command from the Actions Palette Menu without terminating Record Mode?


A: Yes.

- - - - - -

11.3 Q: Can I choose Insert Menu Item from the Actions Palette Menu without terminating Record Mode?


A: Yes.

- - - - - -

11.4 Q: Can the application of 3rd party plug-ins be recorded?

A: Sometimes yes, sometimes no. 

· In some cases Photoshop records the plug-in and settings and applies them as expected when the action is played. 

· In some cases Photoshop records the plug-in and settings but when the action is played, the settings are ignored. Photoshop uses the “last time the plug-in was run” settings instead of the ones recorded.

· In some cases Photoshop displays the plug-in’s dialog box when the action is played regardless of the Display Dialog setting. There is a workaround for this. Search on IMI3RD
· Finally. there are some plug-ins that work fine when selected from the Filter menu using a mouse, but steps to execute them cannot be recorded or inserted.

Bottom line: It just depends.

- - - - - -

11.5 Q: Since each operation I perform on an image is recorded as a state in the History Palette, is there any way to convert history states into an action?

A: No. This capability has been requested since the dawn of the History Palette. Adobe’s position has been (in effect), “If you want to capture your workflow, record an action.” End of story.

- - - - - -

11.6 Q: Is there any way to leverage history states when developing an action?

A: Yes, but it’s a manual method. Here’s a process I’ve used.

I position the Layers and History Palettes side by side so I can easily see layer names, blend mode and opacity settings as I click each history state. 

I click on the first state in the history palette and (physically) write down the command executed. I continue stepping through the states, recording each one I want to eventually record into the action

For commands that have parameters or settings that I remember, I record that information too, for example, Unsharp Mask, 400, 1.5, 0 or Multiply, 70%. 

If I don’t recall filter settings, I open the filter’s dialog (as though I’m going to apply the filter) and note the settings. They are the same ones used during the application of the filter. After noting filter settings, I cancel out of the dialog to preserve the history states.

I record adjustment layer settings last since they are preserved in the adjustment layer itself.

For those who have Photoshop CS, the new History Log is ideal for this purpose. It provides extensive detail not available in history states. (PierreC)

NESTEDACTIONS
12. ACTIONS THAT PLAY OTHER ACTIONS: HOW TO RECORD THE ACTION STEP

UP
12.1 Q: Can I write an action that plays other actions?

A: You sure can. 

A little more terminology is in order before describing how to do this.

If action A plays action B, action A is referred to as the calling action and action B is referred to as the called (or nested) action. 

To further complicate things it’s possible for a called action to call another action, which can call another action which can call another action and so on. While technically doable, leveraging the multiple levels of nesting capability is probably not widely used.

To record a step that, when played, plays another action:

· Record Mode must be active. At the point where you want action A (the action being recorded) to call action B, single-click (select) on the Action Name of the action to be called (action B). 

· Click Play (►) to launch called action B. The called action will play as usual.

· When called action B finishes, Record Mode will still be active. Continue recording additional steps as usual including calling more actions or terminate Record Mode by clicking Stop (■)if you’re finished.
In practice it is common for a called action to reside in the same Action Set as the calling action. Technically, though, the called action can reside in any Action Set.

13. Actions That Play Other Actions: WHY BOTHER?

UP
13.1 Q: Help me out. Why would I want to record an action that plays other actions?

A: Search on BESTOFBOTH
According to Tony Kazarian, an action and droplet heavyweight user,  recording actions within an action is “Part of my ‘Best Practices.’ 

“For me, it's easier to create separate steps to avoid troubleshooting difficulties. For example, just look at the Save for the Web (Export) or Make Text Layer commands. Scrolling your action pallet to troubleshoot a specific issue is ridiculous in my opinion, so I like to break actions up into manageable chunks (other actions) by nesting them.

“I have an action that applies what I call a standard ‘AutoLevels, Gaussian Blur, Unsharp Mask.’ I’ve recorded this action into several others actions that I use for various purposes. Since these are common routines, I find it easier nest them rather than recode the exact steps into several actions. This reduces Actions Palette clutter and makes troubleshooting easier.”

NESTEDWARNINGS

14. Actions That Play Other Actions: Staying Out Of Trouble

UP
14.1 Q: How can I mess up actions that play other actions?

A: Here are the ways. First take note of the called action command format. It specifies the Action Name of the called action and Action Set Name where it resides.

PLAY ACTION [Action Name of the called action] OF SET [Action Set Name where the called action resides]

EXAMPLE: PLAY ACTION Sharpen OF SET My Sharpening Actions


Important: A Play Action step will fail if:

MOVEPROBLEMS

· The Action Set containing the called action has been deleted. 

· The called action itself has been deleted.

· The called action has been moved to a different Action Set.

RENAMEPROBLEMS

· The Action Name of the called action has been changed (renamed). Action Names are case sensitive, that is action named Sharpen is considered to be different than one named sharpen.

· The Action Set Name where the called action resides has been changed (renamed). Action Set Names are case sensitive, that is Action Set named Sharpening Actions is considered to be different than one named sharpening actions.

· The Action Set File Name is renamed before the Action Set File is loaded into the Actions Palette. (PierreC)

DUPLICATEACTIONAMEPROBLEMS

· If for some reason you have two actions with the same name, for example sharpen, in an Action Set and action sharpen is called by another action, the sharpen that’s listed first one listed in the Action Set is the one executed. 

15. SWITCHING AMONG IMAGES

UP
15.1 Q: When using an action am I restricted to only one image?

A: While it’s not uncommon for an action to be written such that it only involves one image, this is not a requirement.

You can open (and close) as many images as needed in order to achieve the desired results, such as copy a layer from one image to another. You select the document by either clicking on its window or choosing it from the list from Window > Documents.

Here are some example commands recorded as you switch among the images:  

· Select next document

· Select previous document

· Select document –3

· Select document +4

Unlike layers where Photoshop is interested in a specific name, Photoshop uses the relative position of an image as listed in the Window > Documents menu when the command is recorded. 

16. INSERT PATH

UP
16.1 Q: What should I know about paths?

A: An action cannot record the creation of a path, but an existing path can be inserted by an action into the active image.

This is done by executing the Insert Path command from the Actions Palette Menu. 

· The result of choosing Insert Path is a Set Work Path command inserted in the action.

· The path will be the same size and be placed at the same location as when it was created.

PLAYINGACTIONS2

17. PLAYING ACTIONS II

UP
The following topics address playing parts of an action or several actions, one after another. 

18. PLAYING AN ACTION, SLOWING IT DOWN FOR LEARNING OR DEBUGGING

UP
18.1 Q: If I’m trying to debug or learn from an action, is there a way to “slow it down”? As is it plays too fast to comprehend what’s going on. 

A: There are three approaches: Playback Options, executing steps one-at-a-time and the History Palette method.

Actions Palette Menu Playback Options:

· Step-by-step: This setting will slow things down a bit (but not much) due to the time it takes to refresh the screen for each step that modifies the image. When this setting is in effect be sure the Actions Palette is visible so you can observe the action’s progress and the Layers Palette is visible to observe changes to layer related settings. 

· Pause for (x seconds): This causes Photoshop to pause between steps for the number of seconds specified. What you see on-screen is reminiscent of a slide show. Values of 1-2 seconds normally give you enough time to absorb what’s happening as the action progresses. After you have finished exploring or debugging don’t forget to reset this option to Accelerated or Step-by-step.

1STEPATATIME


Executing action steps one at a time:

The advantage of this approach is having control over the pace steps are played. In addition you can modify the action on the fly using Insert Menu Item or initiating Record Mode.

Of the methods for playing steps one at a time, I prefer this one because the pace of play is controlled by mouse clicks initiated by me:

· Select (highlight) the step you want to play. It does not have to be the first step in the action. 

· While holding down Ctrl, click Play (►). This plays the selected step. 

· To play subsequent steps repeat Ctrl + Play (►) as many times as desired.


Two other methods for playing steps one at a time: 

· Select the step. While holding down Ctrl, double-click on the step. 

· Select the step. Drag and drop it onto Play (►).


History Palette method: 

· Play the action from beginning to end.

· Window > History (to show the History Palette). 

· Click on the history state that corresponds to the action step of interest. 

An advantage of this approach is the ability to easily skip forward or backward among history states that correspond to action steps.


The Turn On All Dialog Boxes method (Mike Warren):

· Duplicate the action.

· Modify the copy (preserving the original) as follows: Click on the Display Dialog checkbox (even if it’s red) next to the Action Name. This turns on Display Dialog checkboxes for steps that can display a dialog box. When the action is played, every step that has a dialog box will display it, enabling you to review the settings chosen by the action author and see the immediate effect.

19. PLAYING PARTS OF AN ACTION

UP
19.1 Q: Do I have to start an action with the first step?
A: No. 

· Select (highlight) the step you would like played first. 

· Click Play (►).

- - - - - -

19.2 Q: Can I play selected steps in an action?
A: Absolutely. 

· Select a range of steps or individual steps. Search on SELECTMULTIPLEOBJECTS
· Click Play (►).

Selecting a range of action steps and playing them is a way to test a section of your action without playing the entire action. 

20. PLAYING MULTIPLE ACTIONS IN AN ACTION SET: LESS FLEXIBLE METHOD

UP
20.1 Q: Can I play multiple actions in an action set?

A: Yes.

· Select the actions you want to play. Search on SELECTMULTIPLEOBJECTS
· Click Play (►).

The limitations of this method:

· Each action can only be played one time.

· Actions are played in the order they are listed in the Action Set.

21. PLAYING MULTIPLE ACTIONS IN AN ACTION SET: MORE FLEXIBLE METHOD

UP
21.1 Q: Is there a way to get around the limitations noted above (actions will play one time and in the order they appear in the Action Set)?

A: Yes. Record an action that plays other actions. Search on NESTEDACTIONS
This approach allows you to specify the order of playback and the number of times a given action is played. 

22. PLAYING MULTIPLE ACTIONS FROM DIFFERENT SETS

UP
22.1 Q: Since Photoshop won’t let me select actions in different Action Sets, is there a way to play multiple actions contained in different Action Sets?

A: Yes. Recording an action that plays other actions solves this problem, too. There’s no restriction on where called actions reside.

Search on NESTEDACTIONS
STOPCOMMANDS

23. STOP COMMANDS

UP
23.1 Q: What is a Stop Command?

A: When a Stop Command is executed by an action, the action pauses and Photoshop displays an on-screen message. The typical intent is to provide hints, tips and/or instructions for the user. This sort of thing can be especially helpful to new users of an action or serve as reminders for actions played infrequently.

- - - - - -

23.2 Q: Is a Stop Command the same thing as clicking Stop (■)?

A: No. 

Stop (■) terminates Record Mode or a running action. 

When a Stop Command is executed, a running action pauses and a dialog box with a button labeled Stop and a text message is displayed. An optional button labeled Continue may also be present.

- - - - - -

23.3 Q: What happens if I click the Continue button?

A: Photoshop proceeds with the next step in the action. 

- - - - - -

23.4 Q: What happens if I click the Stop button?

A: The action literally terminates at this point. You would typically click Stop in order to perform a manual task of some sort the action is unable to do itself. The message will (hopefully) provide enough information to perform the task. 

- - - - - -

23.5 Q: What do I do to resume the stopped action?

A: Click Play (►). Search on RESUMESTOPPEDACTION
- - - - - -

23.6 Q: When the Actions Palette is in Button Mode, there’s no Play (►) to click. What then?

A: When on clicks Stop in the dialog box under these circumstances the button in the Actions Palette that launched the corresponding action turns red. One needs only to click the red button to resume the action.

- - - - - -

23.7 Q: How is a Stop Command inserted?

A: Here are the steps…

· Click on (highlight) the step in the action after which you want the Stop Command inserted. 

· Choose Insert Stop from the Actions Palette Menu, which will place the Stop Command after the selected step.

· Check the Allow Continue checkbox if necessary.

· Type the message to be displayed.

· Click OK.

- - - - - -

23.8 Q: Can a Stop Command be inserted when Record Mode is active?

A: Yes.

- - - - - -

23.9 Q: What does the Allow Continue option do?

A: This option determines the format of the dialog box: 

· If checked, the message is displayed in a dialog box that has two buttons: Stop and Continue. 

· If unchecked, the message is displayed in a dialog box with one button: Stop. 

- - - - - -

23.10 Q: What happens if Allow Continue is checked and why would I choose this option? 

A: When this box is checked Photoshop displays a dialog box containing two buttons labeled Continue and Stop and the message text. 

This option is chosen: 

· When the user must choose between accepting the situation as is (for example the current foreground color) or exiting the action to perform a manual task the action is unable to perform for itself, for example making a selection, choosing foreground or background colors, erasing, painting, dodging, burning, typing custom text, etc. 

· When it is necessary to display instructions or information. There is no Stop Command option where only a Continue button is displayed.

- - - - - -

23.11 Q: What happens if Allow Continue box is not checked? 

A: The purpose of this option is to cause the action to unconditionally stop. Normally this is done to force the user to perform a manual task that cannot be done automatically by the action, such as choose a foreground color, make a selection, type specific text, etc. 

The Stop Command will display a dialog box with a single button labeled, Stop along with the message text. When the Stop button in the dialog box is clicked, the user is free to take whatever action is needed. 

This option can also be used as the last step in the action to display a message indicating the action completed successfully, to provide additional information or options, or to display the author’s name one more time!


If you’re writing the action, it’s usually a good idea to include instructions in the message text indicating the need to click Play (►) to resume.

- - - - - -

23.12 Q: How many characters can be displayed by a Stop Command?

A: A Stop Command can display a message of up to 255 characters, including spaces. If you double-space between sentences, each double-space counts as a character.

- - - - - -

23.13 Q: How do I know I’ve reached the 255 character Stop Command message limit?

A: You’ll know the limit is reached when characters stop appearing as you continue to type. 

- - - - - -

23.14 Q: What if I absolutely need more than 255 characters to get my message across, need to display a graphic in addition to text or want to use multiple fonts, different font sizes, etc?

A: To display more than 255 characters, insert multiple Stop Commands. 

Another possibility that crafty action master Bud Guinn pioneered is to create one or more separate images that display text and/or graphics to communicate a message. One by one the action  opens an “information image” followed by a Stop Command (with Allow Continue checked) to pause the action. When Continue is clicked, another information or graphic image is opened and another Stop Command executed. This solution, although more complex, permits practically unlimited verbiage beyond 255 characters plus allows the display of graphics.

Note: In addition to providing information about a given action this procedure is used to create Actorials, tutorials (on any topic) that are illustrated through actions. (PierreC)

- - - - - -

23.15 Q: Any other Stop Command tidbits worth sharing?

A: A couple…

· In general it’s desirable to minimize the number of Stop Commands in an action because the more interruptions, the longer it takes to get results. Interruptions chip away at one of the primary advantages of actions: automating a process. To get as much mileage as possible out of the 255 character limit, learn to abbreviate.

· To suppress the Stop Command message, be sure to uncheck the Enable/Disable checkbox. If you uncheck the Display Dialog box, the dialog box will be suppressed, but the command will still execute, stopping the action at that point! Search on SUPPRESSSTOPCMD
· Don’t hesitate to put spaces between lines if it makes the message easier to read. 

· I personally prefer messages that are grammatically correct and free of spelling errors, so I sometimes use Microsoft Word’s Grammar Check, Spell Check and Word Count functions (the latter to keep track of character count). When the content, format and character count are satisfactory, I’ll copy the message from Word into the Stop Command’s text box. Overkill? Maybe. Does it work? Yes.

ENABLEDISABLE

24. ENABLE/DISABLE CHECKBOX: DANGER LURKS AT THE ACTION AND ACTION SET LEVELS

UP
The table below summarizes how an on or off status of the Enable/Disable checkbox affects the execution of individual action steps, all steps within an action and all steps in all actions in an Action Set. For another perspective search on ENABLEDISPLAYTABLE
A qualified caution: If you have purposely disabled some commands in some of your actions (something I do all the time), be very careful about enabling or disabling commands at the action level and especially at the Action Set level. A careless click could result in an afternoon of going through each step of each action to turn steps on (off) that you didn’t mean to disable (enable).

	
	
Enable/Disable Checkbox

	Step
	Click On: Step played

Click Off: Step skipped

	Action
	Click On: Enable/Disable checkbox turned on for all steps in the action

Click Off: Unchecks the Enable/Disable checkbox for every step in the action.

	Action Set
	Click On: Enable/Disable checkboxes turned on for all steps in all actions in the Action Set

Click Off: Unchecks the Enable/Disable checkbox for every step in every action in the Action Set.


DISPLAYDIALOG 

25. DISPLAY DIALOG CHECKBOX: DANGER LURKS AT THE ACTION AND ACTION SET LEVELS

UP
The table below summarizes how an on or off status of the Display Dialog checkbox affects the display of dialog boxes at the action step level, at the action level and for all actions in an Action Set. For another perspective search on ENABLEDISPLAYTABLE
Another qualified caution: This is the same warning as above, except it applies to dialog boxes. If you have purposely disabled some dialogs, something I also do frequently, be very careful about enabling or disabling dialogs at the action and especially at the Action Set level. 

	
	
Display Dialog Checkbox

	Step
	Click On: Dialog box displayed for the step

Click Off: Dialog box suppressed for the step

	Action
	Click On: Display Dialog checkboxes turned on for all steps in the action

Click Off: Unchecks the Display Dialog checkbox for every step in the action. (See next question.)

	Action Set
	Click On: Display Dialog checkboxes turned on for all steps in all actions in the Action Set

Click Off: Unchecks the Display Dialog checkbox for every step of every action in the Action Set.


- - - - - -

25.1 Q: Can you think of a situation where it makes sense to uncheck the Display Dialog checkbox at the action level? 

A: For an action specified in a File > Batch > Automation dialog or destined to become a Droplet it is desirable for the action to run without interruption. Clearing the action’s Display Dialog checkbox would achieve this goal. Search on BATCHPROCESSING 

Keep in mind that if the action contains Stop Commands, their corresponding Enable/Disable checkboxes would also have to be unchecked as well. Search on SUPPRESSSTOPCMD
- - - - - -

25.2 Q: Can you think of a situation where it makes sense to uncheck the Display Dialog checkbox at the Action Set level? 

A: No. 

- - - - - -

ENABLEDISPLAYTABLE

25.3 Q: I’m kind of a visual person. Can you give another perspective of the meaning of the various combination of the (, (, [image: image17.png]
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 symbols at the Action Set, action and action step levels? 

A: See the table below.

	CHECKBOXES
	ACTION SET
	ACTION
	STEP
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	All steps in All Action Sets enabled.

All dialogs boxes in all actions in all Action Sets will be displayed.
	All steps in the action enabled.

All dialog boxes for all steps in the action will be displayed. 
	Step enabled. 

The dialog box for the step will be displayed. 
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	All steps in All Action Sets enabled.

One or more dialogs in one or more Action Sets will be suppressed.
	All steps in action enabled.

One or more dialogs in action will be suppressed.
	

	((
	All steps in All Action Sets enabled.

All dialogs in all Action Sets Suppressed.
	All steps in the action enabled.

One or more dialogs in the action suppressed. 
	Step enabled.

Dialog suppressed.
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	One or more steps in one or more Action Sets disabled.

All dialogs for non-suppressed steps will display.
	One or more steps in the action disabled.

All dialogs for non-disabled steps will display.
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	One or more steps in one or more Action Sets disabled.

One or more dialogs for non-suppressed steps will be suppressed.
	One or more steps in the Action Set disabled.

One or more dialogs for non-suppressed steps in the action will be suppressed.
	

	((
	One or more steps in one or more Action Sets disabled.

All dialogs for all steps suppressed.
	One or more steps in the action disabled.

All dialogs for all steps in the action suppressed.
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 is ghosted, that is, visible but lighter than usual.)

(TrevorM)
	All steps in all actions in Action Set inserted using Insert Menu Item

(very unlikely)
	All steps in action inserted using Insert Menu Item (very unlikely)
	Step inserted using Insert Menu Item
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 is ghosted, that is, visible but lighter than usual.)

(TrevorM)
	All steps in all Action Sets disabled.

All dialogs in all steps in all Action Sets suppressed since all steps disabled.
	All steps in the Action Set disabled.

All dialogs in the Action Set suppressed since all steps disabled.
	Step disabled.

Dialog suppressed since step disabled.



	((

	All steps in all Action Sets disabled.

All dialogs in all steps in all Action Sets suppressed.
	All steps in the Action Set disabled.

All dialogs in the Action Set disabled.
	Step disabled.

Dialog suppressed.

	(
	All steps in All Action Sets enabled.

No steps in any action have dialog boxes.**
	All steps in action enabled.

No steps in action have dialog boxes.**
	Step enabled.

** Step either has no dialog or has a dialog, but Insert Menu Item used to add step to action.



	(
	All steps in All Action Sets disabled.

No steps in any action have dialog boxes.**
	All steps in action disabled.

No steps in action have dialog boxes.**
	Step disabled.

** Step either has no dialog or has a dialog, but Insert Menu Item used to add step to action.


** Some commands, for example Image > Adjustments > Desaturate, do not display a dialog box hence there is no corresponding Display Dialog checkbox. When steps that normally display dialog boxes are added to an Action via Insert Menu Item, the Display Dialog checkbox is not displayed. 

- - - - - -

25.4 Q: Do you know of any other Actions Palette shortcuts? 

A: These two only work at the action step level. I can think of no practical use for them, but am including them for completeness.  

· Alt + click the Enable/Disable Checkbox for an action step: Toggles between turning off/on all other steps in the action.

· Alt + click the Show Dialog Checkbox for an action step: Toggles between turning off/on dialogs for all other steps in the action.

26. WORKFLOW: WHERE DO ACTIONS FIT IN?

UP
26.1 Q: Where do actions fit into my workflow? 

A: I don’t have any experience using Photoshop in a commercial setting, so I’ll leave you with a link to an absolutely fabulous workflow tutorial. You’ll be able to make informed decisions on what works best for you based on ideas you get from it.

http://www.luminous-landscape.com/tutorials/workflow1.shtml
27. MANAGING THE ACTIONS PRESETS FOLDER \Presets\Photoshop Actions
UP
With the exception of Default.atn the rest of the Adobe provided actions are installed in 

C:\Program Files\Adobe\Photoshop 7.0\Presets\Photoshop Actions. 

For the sake of brevity \Presets\Photoshop Actions will be used below to represent the path above. 

- - - - - -

LOADFROMAPM

27.1 Q: Do I have to go through the Load Actions dialog to get Action Sets into the Actions Palette? 

A: No. You can bypass it completely using the following technique. 

To leverage the convenience of loading an Action Set File into the Actions Palette by selecting it from the Actions Palette Menu, do the following:

· Put the Action Set File in \Presets\Photoshop Actions
· Shutdown and restart Photoshop

· Open the Actions Palette Menu 

· From the list at the bottom of the menu click the desired Action Set Name. Photoshop will load it into the Actions Palette.

If you only have a few Action Set Files, placing all of them in \Presets\Photoshop Actions makes sense. If you accumulate a LOT of actions, placing all of them in \Presets\Photoshop Actions may not work for very long. Search on STORINGACTIONS
- - - - - -

ALIASORSHORTCUTTOFINDACTIONS 
27.2 Is there a way to have Action Set Files listed on the Actions Palette Menu without them having to be in \Presets\Photoshop Actions?


A: Yes. You can put Windows shortcuts (or Mac aliases) in \Presets\Photoshop Actions pointing to folders residing outside of \Presets\Photoshop Actions that contain Action Set Files. This provides the option of storing downloaded or personally developed Action Set Files separately from ones provided by Adobe while maintaining the ability to view them in (and load them from) the Actions Palette Menu. 

For example if you create a Windows shortcut or a Mac alias for folder \My Actions and place it in \Presets\Photoshop Actions, all Action Set Files in \Presets\Photoshop Actions AND \My Actions will be listed on the Actions Palette Menu, ready for one-click loading into the Actions Palette.

- - - - - -

27.3 Q: This sounds way too good to be true. Is it?


A: Possibly. Like most things in life if you overdo it, there could be problems. These are some considerations:

· The Action Set File Names will be listed in alphabetical order on the Actions Palette Menu regardless of how your personal actions folders are named or organized on your hard disk. 

· Whatever the maximum number of files is that can be listed on the Actions Palette Menu, it’s WAY more than the number of files you should consider listing. From a practical perspective, how many Action Set File Names can you realistically keep track of?

· The number of files listed on the screen is limited by the size of your monitor’s screen.

· Some versions of Windows such as 95, 98 and ME, place a physical limit on the number of items that can be listed in a menu. If the limit is exceeded, you can no longer display the Actions Palette Menu, that is nothing will happen when you click and hold the black arrow.

· To prevent an Action Set or folder of action sets designated by a shortcut or Mac alias from being listed in this menu, rename the Action Set File Name or the Folder Name by inserting a tilde character (~) into the first position, e.g., Sharpen.atn becomes ~Sharpen.atn or \MyActions becomes \~MyActions. The leading ~ is interpreted by Photoshop as “ignore this file or folder.” (PierreC)

- - - - - -

27.4 Q: Can I affect the sequence of files listed in the Actions Palette Menu?

A: Yes. As noted previously Action Set Files in \Presets\Photoshop Actions or referenced by via shortcuts or aliases are listed alphabetically in the menu regardless of where they reside, so renaming Action Set files definitely can affect the display order.

Preceding file names with digits, e.g., 1, 01, 1.0, or characters such as @, #, $, ! gives you the ability to (in effect) override traditional alphabetical order. Action Sets Files with names such as Able.atn, Baker.atn and Charlie.atn would normally be listed as:

Able
Baker
Charlie 

In these examples renaming the Action Sets results in listing sequences not otherwise possible: 

1-Charlie
2-Baker
3-Able

#Charlie
Able
Baker


!Baker

$Charlie

Able

1.0 Charlie

1.5 Able

2.0 Baker

28. ACTION PALETTE ORGANIZATION
ACTIONORG
UP

A lot of the following discussion is directed to those who have accumulated a LOT of actions (or anticipate doing so), qualifying us for charter memberships in “Photoshop Actions Anonymous.” You know who you are. ( If you’re like most people and haven’t gone completely overboard collecting actions, you can probably skip most of this discussion.


Important: The Actions Palette organization examples that follow assume you are free to rename and/or move actions or Action Sets. That’s true about 98% of the time.


Renaming or moving actions or Action Sets breaks down when it involves actions played (called) by other actions. (EricC) Search on RENAMEPROBLEMS
- - - - - -

28.1 Q: I’m relatively new to Photoshop and have recently discovered the wealth of actions available for download on the Internet. I don’t have many actions yet, but if the trend continues I can envision my collection growing over time. How should I organize my Actions Palette?

A: There’s no specific answer to this question. How you organize actions and Action Sets within your Actions Palette will depend on things like:

· The number of actions in your collection.

· How you use Photoshop, for example, Web work only, prepress only, photo-art, retouching/restoration, other, all of the above, some of the above, etc.

· How often you make changes to your Actions Palette, that is, create, modify or delete actions, load new Action Sets Files downloaded from the Internet, create new Action Sets, etc.

· Whether you develop your own actions, use ones downloaded from the Internet exclusively, or are somewhere in between. 

· Personal organizational preferences which may range from as “Tidy as possible” to “Who cares?”

Several variations of Actions Palette organization are presented in subsequent sections. Be forewarned the scheme you initially adopt will probably evolve into something else. That’s among the beauties of Photoshop: Its flexibility enables you to adapt to changing needs over time. 

29. ACTION NAMES AND ACTION SET NAMES

UP

The following legend will be used to represent the Actions Palette in List Mode.

ACTIONS PALETTE

==> Denotes Actions Palette

· Action Set   1

Solid bullet: Action Set

· Action 1

Hollow bullet, blue text: Action

· Action 2

· Action Set   2

· Action 3

· Action 4

- - - - - -

29.1 Q: Are duplicate Action Names permitted in the Actions Palette? 

A: Absolutely. Photoshop permits duplicate Action Names within the same Action Set or across multiple Action Sets. You could, for example, name all of your actions Fred Flintstone and Photoshop wouldn’t care. 

The downside of duplicate Action Set Names: How are you going know which actions are in which Action Set without examining the contents of each?

- - - - - -

29.2 Q: What about duplicate Action Set Names: are they permitted? 

A: No restrictions here, either. Name all your Action Sets Beverly Hills 90210 and again Photoshop wouldn’t skip a beat. 

- - - - - -

29.3 Q: How do Action Set Names affect organization?

A: Even though you could name all your Action Sets Beverly Hills 90210, you probably wouldn’t want to do that. Just like the names assigned to folders in a filing cabinet, names assigned to Action Sets help you find actions in your Actions Palette. 

These are the sample Action Sets installed with Photoshop 7. The last six were loaded into the Actions Palette by clicking the corresponding entry on the Actions Palette Menu.


ACTIONS PALETTE (List Mode)


· Default





· Commands





· Frames





· Image Effects




· Production




· Text Effects




· Textures





With the exceptions of Action Set Default and Production the other Action Set Names give a decent indication of what the actions therein do.

The point? One of the most effective ways to organize Action Sets is to give them meaningful names. You’ve got plenty of characters with which to work. Assign names that make sense to you and help find actions quickly.

- - - - - -

ACTIONNAMEEXAMPLES

29.4 Q: Can you give some examples of what you mean my meaningful Action Names?

A: If you have several actions that perform similar functions, e.g., create art, build digital frames, sharpen, color correct, etc., it’s helpful to assign Action Names that distinguish actions even further, for example:

Color Correct (CMYK)

Color Correct (RGB)

Fix Blue Channel

Fix Red Channel

Insert Copyright 4x6

Insert Copyright 5x7

Insert Copyright 8x10

Sharpen – Edge Mask

Sharpen – High Pass

Sharpen – Luminosity

Signature – Arial

Signature – Courier

MODEBUTTON

30. PROS AND CONS OF BUTTON MODE

UP
30.1 Q: What are the pros and cons of Button Mode?

PROS

· One-click action launch is convenient. There is no need to select first and then click Play (►). (TonyK)

· When an action is paused by clicking a button labeled Stop in a dialog box displayed by a Stop Command, the corresponding Actions Palette button turns red. To resume the action one needs only to click the red button.

· Organizing actions by color code can be an effective way to visually distinguish among them. This assumes, of course, that actions are assigned colors according to function and organized accordingly within the Actions Palette. A random or rainbow color assignment scheme would be interesting, but not very helpful in finding actions quickly. 

· This mode is great for people with relatively few actions, who don’t have a frequent need to create, rename, modify, rearrange or delete actions and Action Sets, nor load or save Action Sets. 

· Since actions cannot be modified in Button Mode, this mode can be used as a way to protect actions from unauthorized changes. However this would be a weak shield since it’s so easy to switch from Button Mode to List Mode that offers no protection against changes.

· As the Actions Palette is resized wider, multiple columns of buttons are displayed. This can make more efficient use of screen real estate.

· This mode displays keyboard shortcut assignments assigned to actions. Editorial comment: This isn’t so much a reason to use Button Mode over List Mode as it is a way to determine what shortcuts have been assigned. If an action can be initiated by clicking its corresponding button, why would one opt for keyboard acrobatics, such as F9 + Ctrl + Shift, to launch it?

· For those with highly automated workflows, this mode is an attractive choice. 

CONS

· Action operations are limited to Play, Clear All Actions, Reset Actions, Replace Actions and Load Actions. This doesn’t work for people like me who are frequently creating, testing, modifying actions, loading and saving Action Sets. 

· Although names of individual actions are displayed in Button Mode, Action Set Names are not. This is less of a problem when actions are color coded and organized by function.

MODELIST 

31. PROS AND CONS OF LIST MODE

UP
31.1 Q: What are the pros and cons of List Mode?

PROS

· Action Sets, actions and commands can be easily expanded/collapsed to show/hide their contents.

· All action and Action Set operations can be performed.

· As Photoshop plays the action, the active step is highlighted, enabling one to visually track an action’s progress. 

CONS

· Not a big con, but it does require two mouse clicks to start an action.

· No support for color coded Action Sets or actions. Maybe Adobe will add this functionality in a future version of Photoshop. 

· Does not support actions listed in multiple columns when the Actions Palette is resized wider like in Button Mode. For those with numerous actions, this can mean a lot of scrolling to find the desired action or Action Set.

ACTIONCOLOREXAMPLES

32. EXAMPLES OF ACTIONS PALETTE ORGANIZATION: BUTTON MODE

UP
32.1 Button Mode, alphabetical, no colors assigned: Pretty straight forward, but not utilizing the color capabilities would seem to be a wasted opportunity.

ACTIONS PALETTE (Button Mode)




· Art History


 

· Edge Sharpen




· Oils





· Show Actions

 


· Show History


  

· Show Layers


 

· Show Tools

 


· Unsharp Mask


 

· Watercolor




- - - - - -

32.2 Button Mode, color coded: Actions assigned a unique color based on the Action Set in which the reside.

ACTIONS PALETTE (Button Mode)



· Show History




· Show Actions

 


· Show Tools

 


· Show Layers


 

· Sharpen – Unsharp Mask
 

· Sharpen – Edges



· Art – Art History

 

· Art – Oils




· Art – Watercolor



- - - - - -

32.3 Button Mode, color coded: Action colors assigned according to Keyboard Shortcut assignments. These examples were inspired by a similar scheme presented in Photoshop 5.x Artistry. 

Actions listed by keyboard shortcut; color assigned according to modifier key.

ACTIONS PALETTE (Button Mode)


· Show History
F2
  

· Show Actions
Ctrl-F2


· Show Tools
Shift-F2


· Crop 3x5
F3
 

· Crop 4x6
Ctrl-F3
 

· Crop 5x7
Shift-F3
 

· Art – Art History
F4
 

· Art – Oils
Ctrl-F4


· Art – Watercolor
Shift-F4


Actions listed by keyboard shortcut; color assigned according to base function key.

ACTIONS PALETTE (Button Mode)


· Show History
F2
 

· Show Actions
Ctrl-F2


· Show Tools
Shift-F2


· Crop 3x5
F3
 

· Crop 4x6
Ctrl-F3
 

· Crop 5x7
Shift-F3
 

· Art – Art History
F4
 

· Art – Oils
Ctrl-F4


· Art – Watercolor
Shift-F4


Actions listed according to keyboard shortcut; color assigned according to modifier keys.

ACTIONS PALETTE (Button Mode)


· Show History
F2


· Crop 3x5
F3


· Art – Art History
F4


· Show Actions
Ctrl-F2


· Crop 4x6
Ctrl-F3


· Art – Oils
Ctrl-F4


· Show Tools
Shift-F2


· Crop 5x7
Shift-F3


· Art – Watercolor
Shift-F4


- - - - - -

32.4 Button Mode, color coded: Actions Palette resized to display multiple columns. 

ACTIONS PALETTE (Button Mode)


	· Mode RGB
 

	· Crop 8x10
l-F2

	· Art - Oils



	· Mode CMYK
F3

	· Crop 4x6
l-F3

	· Art – Pencil Sketch



	· Mode Grayscale

	· Crop 3x5
l-F4

	· Art – Watercolor




- - - - - -

32.5 Button Mode, color coded: Each Action Set reuses Keyboard Shortcut assignments. Search on DUPSHORTCUTS

While technically possible, this is probably not practical because swapping Action Sets would require switching out of Button Mode into List Mode (in order to delete the current Action Set and load its replacement), then switching to Button Mode again. 

ACTIONS PALETTE (Button Mode)


· Show History
F2
 

· Show Actions
F3


· Show Tools
 F4


ACTIONS PALETTE (Button Mode)


· Crop 3x5
F2
 

· Crop 4x6
F3
 

· Crop 5x7
F4
 

ACTIONS PALETTE (Button Mode)


· Art – Art History
F2
 

· Art – Oils
 F3


· Art – Watercolor
 F4


33. EXAMPLES OF ACTIONS PALETTE ORGANIZATION: LIST MODE

UP
33.1 List Mode: Action Sets named by Alphabetically. 

Pretty straight forward. This is a very common and intuitive method.

ACTIONS PALETTE (List Mode)


· Commands



 

· Default





· Frames 



 

· Image Effects
 



· Production
 



· Text Effects




· Textures

 



- - - - - -

33.2 List Mode: Action Sets Named by Frequency of Use

Ordering Action Sets by frequency of use is another method to consider. If one has a number of Action Sets, keeping frequently used sets near the top of the Actions Palette can reduce scrolling. 

ACTIONS PALETTE (List Mode)





· Production     
Most Frequently Used


· Textures 

   .





· Frames 


   .





· Image Effects 

   .





· Text Effects

   .





· Commands 

   v





· Default

   
Least Frequently Used


- - - - - -

33.3 List Mode: Action Sets ordered by Frequency of Use, plus FUA Action Set

In this variation Action Set FUA was created for and populated with Frequently Used Actions from any Action Set. You might consider assigning keyboard shortcuts to these actions. 

An Action Set named MISC has been added as a place for actions that don’t seem to fit anywhere else.

ACTIONS PALETTE (List Mode)







· FUA

      For Most Frequently Used actions


· Production       
Most Frequently Used Action Set


· Textures 


   .






· Frames 



   .






· Image Effects 


   .






· Text Effects


   .






· Commands 


   v






· Default

      Least Frequently Used Action Set


· MISC


Leftovers





- - - - - -

33.4 List Mode: Precede Action Set Name with a Number or Letter

Since I like the concept of a FUA Action Set as well as keeping the more frequently used Action Sets towards the top of the palette, I’d personally lean towards not preceding the Action Set Names with a letter or number as shown below. Adopting this method would result in a considerable amount of Action Set Name changing each time Action Sets were reordered, added or deleted in the future. If it works for you, however, by all means go for it.

ACTIONS PALETTE (List Mode)




· 1  - FUA (Frequently Used Actions)


· 2  - Production



 

· 3  - Text Effects





· 4  - Frames




 

· 5  - Commands 






· 6  - Default






· 7  - Image Effects



 

· 8  - Textures 






· 9  - Web buttons





· 10 – MISC





ACTIONS PALETTE (List Mode)




· A  - FUA (Frequently Used Actions)


· B  - Production



 

· C  - Text Effects





· D  - Frames




 

· E  - Commands 






· F  - Default






· G  - Image Effects



 

· H  - Textures 






· I  - Web buttons





· J  – MISC





- - - - - -

33.5 List Mode: Action Sets named according to Workflow
Ordering Action Sets by workflow sequence might work for you. Editorial Comment: I’m winging the sequence below. I have no idea what the right sequence should be.

ACTIONS PALETTE (List Mode)


· Noise Removal




· Dust and Scratches



· Color Correction



· Red-eye Fix




· Sharpening-Edges



· Sharpening-General



· Cropping





- - - - - -

33.6 List Mode: Action Sets named by Status of Action
This might work for those who frequently create new actions or modify existing actions.

ACTIONS PALETTE (List Mode)


· Production




· Testing





· Being Modified




· New - Under Development


- - - - - -

33.7 List Mode: Action Sets named according to Action Author or Source
ACTIONS PALETTE (List Mode)


· BillM’s Actions



· Jaseck’s Finest



· RBS actions




· Mike Finn




· RetouchPRO




· share.studio.adobe.com


· www.DPReview.com



- - - - - -

33.8 List Mode: Action Sets assigned a Category Prefix
Prefixing Action Set Names with a descriptive word or two, or a short abbreviation (FRM = Frame in this example) enables one to group Action Sets alphabetically by general category.

ACTIONS PALETTE (List Mode)


· Art – Bill Miller



· Art – JES




· Art – Mike Finn



· Art – RBS




· Art – Sketch Jaseck



· Art – Sketch Shan



· Art – Bud Guinn



· Art – Watercolor



· FRM – Barber




· FRM – Guinn




· FRM – Landscape



· FRM – Oval




· FRM – Portrait




- - - - - -

33.9 List Mode: Action Sets ordered by File Type or Color Space 
ACTIONS PALETTE (List Mode)


· .jpg





· .psd





· .tif





· RGB





· CMYK





· Grayscale




- - - - - -

33.10 List Mode: Dummy Action Sets used for Visual Distinction

A dummy (or null) Action Set is one that contains no actions. Its purpose in this case is to provide visual distinction among Action Sets in the Actions Palette. You create a Null Action Set like any other Action Set. Characters like -, =, > and < with spaces between them seem to work well for this purpose.

ACTIONS PALETTE (List Mode)



· - - - P H O T O   A R T - - -


· Watercolor





· Sketch






· Mike Finn – Slap Dash



· Mike Finn – WhatNots




· Sketch – Shan





· Sketch – Jaseck




· - - - F R A M E S - - - 



· Oval 3D






· Bud Guinn – Frames 1




· Bud Guinn – Frames 2




· Cherry Wood Double




· - - - U T I L I T Y - - - 



· Sharpen Edges





· Color Correction




· Miscellaneous





- - - - - -

33.11 List Mode: One (or a few) Action Sets – Action Names prefixed and ordered Alphabetically

Some people prefer to have one (or a few) fairly large Action Sets vs. many Action Sets containing fewer actions per set. Do what works best for you. 

In this example actions were renamed to assign a category prefix, e.g., “BW,” “Crop,” etc.) and ordered alphabetically. Editorial comment: For organizational purposes I rename just about every action I decide to keep. There’s no harm in renaming an action unless it is called by another action. Search on RENAMEPROBLEMS, MOVEPROBLEMS
ACTIONS PALETTE (List Mode)


· DannyR Actions




· BW Channel Mixer

· BW Lab Black Channel

· Crop 4x6

· Crop 3x5

· Crop Wallet

· Frame Howie Mudge Effect

· Frame Lisa Neal Effect

· Frame Oval Mahogany, Bud

· Frame Oval Walnut, Bud

· Frame Rectangular Bamboo

· Luminosity Mask

· Matte Rectangular Landscape

· Matte Rectangular Portrait

· Sharpen Edges, Jaseck

· Sharpen Edges, Mathias

· Sharpen High Pass

· Sharpen Luminosity

· Sketch Jaseck

· Sketch Lisa Neal

· Sketch Pencil

· Texture Marble

· Texture Granite

· Watercolor Cricket

· Watercolor RBS

· Watercolor Wow 5.x

- - - - - -

33.12 List Mode: Single Action Set – 3-4 character Action Name prefixes.

This example is similar in concept to the previous one. Note the Action Name prefixes that make it easy to distinguish the action category.  

ACTIONS PALETTE (List Mode)


· DannyR Actions




· ART Sketch Jaseck

· ART Sketch Lisa Neal

· ART Sketch Pencil

· ART WC Cricket

· ART WC RBS

· ART WC Wow 5.x

· AUTO Crop 3x5

· AUTO Crop 4x6

· AUTO Crop Wallet

· From DPReview




· FRM Howie Mudge Effect

· FRM Lisa Neal Effect

· FRM Oval Mahogany, Bud

· FRM Oval Walnut, Bud

· FRM Rectangular Bamboo

· MAT Rect L

· MAT Rect P

· TXT Granite

· TXT Marble

· UTL BW Channel Mixer

· UTL BW Lab Black Channel

· UTL Lumask

· UTL Sharpen Edges, Jaseck

· UTL Sharpen Edges, Mathias

· UTL Sharpen High Pass

· UTL Sharpen Luminosity

- - - - - -

33.13 List Mode: Single Action Set – Using Null Actions

A Null Action (an action without any steps) can be used the same way within an Action Set as Null Action Sets can be used within the Actions Palette. 

To create a Null Action, open a New Action dialog, assign a visually distinctive name, click OK (to engage Record Mode), then click Stop (■). The Null Actions in the first example below use “greater than” and “less than” signs for easy identification. You can use whatever characters you like.

ACTIONS PALETTE (List Mode)




· DannyR actions






·      >>> F U A <<<    

· Perfect Skies

· Jaseck Contrast Mask

· Bud’s Walnut frame

·      >>> P H O T O     A R T <<<

· Sketch Insta-Sketch

· Sketch Lisa Neal

· Sketch Pencil

· WC Cricket

· WC RBS

· WC Wow 7.0

·      >>> A U T O M A T I O N <<<

· Crop 3x5

· Crop 4x6

· Crop Wallet

·      >>> F R A M E S  +  M A T T E S <<<

· Howie Mudge Effect

· Lisa Neal Effect

· Oval Mahogany, Bud

· Oval Walnut, Bud

· Rectangular Bamboo

· MAT Rect L

· MAT Rect P

·      >>> T E X T U R E S <<<

· Granite

· Marble

·      >>> U T I L I T Y <<<

· BW Channel Mixer

· BW Lab Black Channel

· Lumask

· Sharpen Edges, Jaseck

· Sharpen Edges, Mathias

· Sharpen High Pass

· Sharpen Luminosity

ACTIONS PALETTE (List Mode)




· ART – Mike Finn





· - - - SLAP DASH EVOLUTION - - -

· Slap-Dash1

· Slap-Dash2

· Slap-Dash3

· Slap-Dash4

· Slap-Dash5

· - - - TEXTURED OILS - - -

· Before You Start

· Simplify

· Edge Effect

· Adding Texture

· - - - WHAT NOTS - - - 

· Scribble

· Scratchy

- - - - - -

33.14 List Mode: Include Keyboard Shortcut assignments as part of Action Name

Although Keyboard Shortcuts are not automatically displayed with the Action Name in List Mode like they are in Button Mode, there’s nothing stopping you from including the shortcut in the Action Name.

ACTIONS PALETTE (List Mode)


· DannyR Actions




· F2 Sketch Jaseck

· F3 WC Cricket

· SHIFT+F2 Sketch Lisa Neal

· SHIFT+F3 Sketch Pencil

· CTRL+F2 ART WC RBS

· CTRL+F3 ART WC Wow 5.x

So, to wrap this up, there are many ways to skin the “How should I organize my Actions Palette?” cat. Now that you have many organizational schemes to consider, experiment and find a method that works for you.

- - - - - -

33.15 Q: Yikes. Talk about a long-winded answer to the last question. Ask a guy “What time is it?” and he tells you how to build a watch. Forgive me, but I’m kind of dazed at the moment. 

Are you recommending ONE HUGE Action Set with the dummy action divider things or individual Action Sets like I now have, just renamed and reordered?

A: Sorry if the answer was muddy. It was intended to be comprehensive and offer many alternatives.

For a few years I got by fine using the single Action Set model. It made backup (Save Actions) and recovery (Load Actions) very easy to do, so easy in fact that I actually carried out the Save Actions command on a weekly basis. (Okay, you got me. Almost weekly.)

My needs have changed since then.

- - - - - -

33.16 Q: How are your actions organized now?

A: The structure of my Actions Palette is never static for more than a few days. Here’s what it looked like as of a couple months ago: 

ACTIONS PALETTE (List Mode)



· FUA






· - - - PHOTO-ART - - -



· Photo-art FUA





· Photo-art DannyR PS 5.5 compat


· Photo-art DannyR PS 7.0 only


· Mike Finn – Misc




· Mike Finn – Slap Dash v1-5



· Sketch – Shan





· Sketch – Jaseck




· - - - F R A M E S - - - 



· Adobe default





· Bud Guinn 1





· Bud Guinn 2





· Bud Guinn 3





· Bud Guinn Elements




· Frames (misc)





· Edges (misc)





· - - - U T I L I T Y - - - 



· Sharpening





· Color Correction




· Red Eye






· Misc






· - - - TEST / EVAL - - -



· www.studio.adobe.com




· Richard Lynch collection



· Mike Finn – Angelo




· Under development




· FAQ for DPReview




- - - - - -

33.17 Q: Have you seen any threads at DPReview on action organization?

A: When you have time here are a couple you might find interesting:

http://forums.dpreview.com/forums/read.asp?forum=1006&message=4626576
http://www.dpreview.com/forums/read.asp?forum=1006&message=3925875
- - - - - -

33.18 Q: Still seems like a lot of work. Are you aware of any 3rd party tools that might be helpful with actions management?

A: Here’s one I recently heard about, Photoshop Side Click Pro (PSSC). Reading the contents of the Website gave me the impression it has a considerable amount of functionality. It might be just what you’re looking for.


www.ksscinc.com/ps_side_click_pro.htm
A 14-day all-features-enabled trial is available. PC version only. (DaveC)

Editorial comment: I have no affiliation with this product. I don’t own it personally, nor have I downloaded it for evaluation. 

- - - - - -

33.19 Q: I’ve begun collecting quite a few photo-art type actions, many from the DPReview Collection. I don’t use them often enough to remember the effect each generates. Any suggestions?

A: One possibility is to select a standard image (or perhaps a couple standard images such as a portrait and one of scenery) representative of the type of photo-art work you like to do. Run your collection of photo-art actions against the standard images and then do whatever is easiest to facilitate comparison, e.g., print examples and put them into a notebook or save them on your hard disk using the action name as the file name and use Photoshop’s File Browser to compare them. (PierreC) 
- - - - - -

33.20 Q: Given all of the above I suspect the answer to the question “How many Action Sets should I have?” is going to be something lame and wishy-washy like, “It depends,” isn’t it?

A: You have anticipated the answer well. 

Asking this question is like asking how many folders should you have in a file cabinet. There is no right answer. The number of Action Sets you need is the number that enables you to find actions you’re looking for in a reasonable amount of time, preferably quickly.

- - - - - -

33.21 Q: Do I have to organize my actions in the Actions Palette?

A: Absolutely not. In fact Roger Rockwell prefers to do action management on his hard disk. Here’s how he does it.

“I have a separate folder on my hard disk named \Photoshop Actions and I put all my .atn files there. When I'm ready to use an action in Photoshop I choose Clear all Actions from the Actions Palette Menu followed by a Load Actions command. This brings up \Photoshop Actions where I select the desired .atn file. 

“I find it much easier to find the .atn I want from the folder on my hard disk than "somewhere” in my Actions Palette. As I am typing this it sounds involved, but its not. Anyway, it works for me.”
- - - - - -

33.22 Q: How about the other end of the spectrum: Is there any reason why I shouldn’t just save all the actions I create, download from the Internet or get through e-mail in the Default Action Set?

A: As long as you periodically execute a Save Actions command on this Action Set and place the resulting Action Set File in a place where you can find it, there’s no technical reason you can’t store all your actions in the Default Action Set.

Because I create and modify so many actions, I wouldn’t do that personally nor would I recommend the practice to someone new to actions. Why? Because of there is risk of losing all non-Adobe provided actions in the event either of the following occur: 

· Inadvertent or improper use of Clear, Reset or Replace Actions commands would clear the Actions Palette and/or replace Default with a clean copy.

· The actions preference file (Actions Palette.psp) becomes corrupt. Search on ACTIONSPREFERENCEFILE 

If you want to save all your actions in a single Action Set, my suggestion would be to save them in an Action Set you create, which you backup regularly and keep separate from the Adobe Default Action Set.

LOADFAST
34. LOADING ACTION SETS – FASTER AND EASIER METHODS

UP
34.1 Q: I’ve just downloaded 27 Action Set Files from the Adobe site. Is there a way to load them into the Actions Palette all at once vs. 27 trips through the Load Actions dialog?

A: Yes. Method 1: 

· Select all the .atn files.

· (In this step don’t release the mouse button until Photoshop’s window appears.) Drag the selected .atn file icons on top of Photoshop’s button in Windows Task Bar (the buttons across the bottom of screen) and when Photoshop’s window appears, release the mouse button. The corresponding Action Sets will be added to the Actions Palette, which does not have to be visible or docked.

A: Method 2: 

· You may have to resize Photoshop’s window a bit so you can (literally) see the Action Set Files about to be mass loaded. 

· Select as many or ALL of the Action Set Files you want to load from your desktop, a folder, Windows’ Search Results window, a CD, wherever…

· Drag and drop them into Photoshop’s window. The corresponding Action Sets will be added to the Actions Palette, which does not have to be visible or docked.

- - - - - -

34.2 Q: Can you mass copy multiple Action Sets out of the Actions Palette onto your hard disk, essentially the reverse of the procedure just described, thereby bypassing many trips through the Save Actions dialog?

A: No, but you can copy Actions Palette.psp, the preference file that contains a snapshot of the contents of the Actions Palette, for backup purposes. Search on $$PSPBACKUP
- - - - - -

ZIPTOACTIONPALETTE 

34.3 Q: Is there a faster way to load .atn files that are zipped?

A: There sure is. 

Although you can unzip a .zip file and Drag and Drop the unzipped .atn files into Photoshop as described above or load individual unzipped .atn using a Load Actions… command, there’s a faster way. 

Double-click the .zip file to engage the decompression program. From the Winzip or StuffIt window that shows the contents of the .zip file, select all .atn files and Drag and Drop them anywhere onto the Photoshop window. (rhsikes) 

- - - - - -

OPENWITH 

34.4 Q: Know of any other easy ways to load an Action Set File without using a Load Actions… command?

A: Photoshop must be open in both cases and will load one .atn at time into the Actions Palette.

· Mac: Double-click on the .atn you want to load into the Actions Palette. (BobMert)

· Windows: Don’t double-click. This will not work. Right-click on the file name, choose Open with and select Photoshop. (Sandra Jackson) Note: This works for some, but not all Windows users.

35. BACKUP AND RECOVERY

UP
If you haven’t yet experienced a hard disk failure, you will. I’ve experienced three in 10 years. The first time I lost everything (on a Mac, no less). Poof. All data lost. It was ugly and a sickening feeling when advised no data recovery was possible. 

The second time (on a fairly new PC) I was lucky: All data was recovered. The third time (again on a PC) I had a backup hard disk onto which all important files, including Actions Palette.psp (see following sections), are copied weekly. The backup HD was a lifesaver. 

So far (knock on wood) I haven’t suffered data loss due to a nasty virus. Despite precautions (anti-virus software, keeping current I figure it’s only a matter of time until one sneaks in and I get bitten. Virus writers, like hackers, are relentless. 

If the prospect of losing all your actions not to mention (but I will) the rest of your data and image files does not concern you, skip this section.

Like virus protection, the subject of system-wide backup and recovery schemes is far beyond the scope of this document. Nonetheless I highly recommend becoming informed on this subject if it’s new to you. 

The following topics address action backup and recovery.

- - - - - -

35.1 Q: Why do I need to backup Action Sets?

A: Depending on your actions download, development and modification profile, it may not be necessary to backup Action Sets. Let’s assume in each scenario that follows your hard disk crashes for whatever reason. 

User profile 1: You don’t develop actions, modify them or download them from the Internet. 

Action backup needed?: No. From a Photoshop perspective the remedy is easy: 

· Repair (or replace) your hard disk

· Reload Photoshop. Action Set Default is installed and the rest of the Adobe provided actions are ready to be loaded from the Actions Palette menu. 

User profile 2: You’ve invested weeks, months, maybe years creating and/or modifying actions as well as sifting through hundreds of actions from the Internet. 

Action backup needed?: Highly recommended. No backup = your actions collection is toast (as in back to square one) in the event of a catastrophic hard disk failure or Actions Palette.psp becomes corrupted. (See next section.)

If you’re somewhere between profiles 1 and 2, I’d still lean toward taking steps to backup important files.

- - - - - -

35.2 Q: But I hate the hassle of doing a Save Action for each of my Action Sets. What do you do?

A: I use a combination of methods. 

· Now when I’m in heavy duty action writing or modification mode, I’ll do Save Actions every hour or so (force of habit) on my Development Action Set. I got into this habit after my cat stepped on the power strip switch and toasted three days of action work.

· Every few days I backup Actions Palette.psp. (See next section.)

- - - - - -

35.3 Q: Can’t I just copy the contents of \Presets\Photoshop Actions to a CD (Vera)?

A: This will work as long as any Action Sets containing actions you create or modify have been saved to \Presets\Photoshop Actions before copying the contents of this folder to CD.

- - - - - -

35.4 Q: Can I just periodically backup my .atn files to CD?

A: Absolutely. Whatever works for you. 

ACTIONSPREFERENCEFILE
36. BACKUP NIRVANA-THE ACTIONS PREFERENCES FILE: Actions Palette.psp
UP
36.1 Q: What is Actions Palette.psp?

A: Actions Palette.psp is one of many Photoshop preference files. It contains a snapshot of the Actions Palette as of the last time Photoshop was shut down normally, that is terminated via File > Exit, Ctrl + Q or by clicking the Close Button (x) in Photoshop’s window.

As part of the shut down process Photoshop copies the entire contents of the Actions Palette into Actions Palette.psp if there have been any adds, changes or deletes, that is changes to, any action or Action Set since Photoshop was opened. When Photoshop starts the Actions Palette is populated with the contents Actions Palette.psp as of the last time it was saved.

- - - - - -

36.2 Q: What happens if Photoshop terminates abnormally?

A: Important: Examples of abnormal termination include events like Windows crashes, Photoshop freezes or suffers a program errors (crashes), the cat steps on the power strip switch or Photoshop is terminated through Task Manager. Actions Palette.psp is not updated under these circumstances because the process that copies the updated Actions Palette to Actions Palette.psp never gets a chance to do its thing. Whenever Photoshop terminates abnormally, all changes to the Actions Palette since the last normal shut down are lost. 

$$PSPBACKUP 

37. BACKING UP THE ENTIRE ACTIONS PALETTE ALL AT ONCE

UP
37.1 Q: Is there a way to backup all actions at once vs. multiple passed through the Save Actions dialog? 

A: Yes there is. 

Simply create a backup Actions Palette.psp. As noted above it’s a snapshot of the Actions Palette. 

I don’t know why I’ve not seen mention of using this file for this purpose in any Photoshop book or Internet actions tutorial I’ve read (so far). I learned about this method a few years ago in the Photoshop forum at www.adobeforums.com -- after Actions Palette.psp under PS 5.5 became corrupted. No backup meant reconstructing my action collection starting from square one.

- - - - - -

FINDINGPSP
37.2 Q: I can’t find this file using the Windows Search function. Where is this file? 

A: When I first looked for Actions Palette.psp on my computer I couldn’t find it either. As it turned out the file was “hidden.”

Important: You may have to select the show hidden files option in order to find this file. Here’s how I did it under Windows 2000:

1. From any folder window choose Tools > Folder Options. (Note: It makes no difference which folder is open. \My Documents is as good as any.)

2. Click the tab labeled View.

3. Under Hidden files and folders, click on the Show hidden files and folders option, then click OK.

I’ve read the location of Actions Palette.psp depends on which flavor of Windows operating system you’re using, e.g., Windows 2003/XP Pro, Windows 2000, Windows/XP, Windows/ME, Windows 98, etc. 

Here’s where it is located on my Windows 2000 system:

C:\Documents and Settings\[user name]\Application Data\Adobe\Photoshop\7.0\Adobe Photoshop 7.0 Settings
If you’re still having problems finding this file after setting the Show hidden files and folders option, use Windows’ Start > Search > For Files or Folders function to locate Actions Palette.psp. Use *.psp as the file name search argument. 

- - - - - -

37.3 Q: What should I use to backup Actions Palette.psp?
A: The software and processes you use to manage file backups and recoveries, including Actions Palette.psp, are beyond the scope of this document. 

I use a fairly basic utility called Backup Magic and am very happy with it. http://www.moonsoftware.com/bmagic.asp.

- - - - - -

37.4 Q: If all my actions are already contained in Actions Palette.psp, what does backing up Actions Palette.psp (or individual Action Sets) buy me?

A: Peace of mind. 

It would be a lifesaver in case of a hard disk failure (assuming the backup file resided on a different hard disk) or some sort of error caused corruption to Actions Palette.psp.

NEWPSVERSION

38. MIGRATING ACTIONS TO A NEW VERSION OF PHOTOSHOP (SAME MACHINE)

UP
Photoshop X and Photoshop Y are used below to represent different versions of Photoshop, X for the “older” version, Y for the new version (or upgrade). As long as X is version 5 or above, the following applies to any combination of versions. 

38.1 Q: I just installed the new Photoshop Y upgrade on my desktop computer. Is there an easy way to migrate the actions from the old version, Photoshop X, to the new version? 


A: First of all it’s important to understand that when the Photoshop Y installation is complete, PS X and PS Y will co-exist on your computer in two separate folders, something like:

C:\Program Files\Adobe\Photoshop X and

C:\Program Files\Adobe\Photoshop Y 

The method you use to migrate actions to Photoshop Y will depend on how many Action Sets there are to migrate. 

· 1-15: 

· I’d apply a Save Actions… command to each Action Set in PS X you want to migrate to PS Y 

· Then load them into the PS Y Actions Palette one at a time using a Load Actions… command or via the “mass load” method. Search on LOADFAST
· 16 or more: 

· Open these folders side by side in different windows:

C:\Documents and Settings\[user name]\Application Data\Adobe\Photoshop\X\Adobe Photoshop X Settings

C:\Documents and Settings\[user name]\Application Data\Adobe\Photoshop\Y\Adobe Photoshop Y Settings

· While holding down Ctrl, Drag and Drop Actions Palette.psp 

from \Photoshop\X\Adobe Photoshop X Settings 
to   \Photoshop\Y\Adobe Photoshop Y Settings 

Holding down Ctrl will make a copy of Actions Palette.psp, leaving the original untouched and enabling you to still access it through PS X. If prompted whether or not you want to replace Actions Palette.psp, click Yes.
· Regardless of how many Action Sets you have to migrate above, don’t forget to copy (Ctrl, Drag and Drop) any non-Adobe provided Action Sets you may have 

from C:\Program Files\Adobe\Photoshop X\Presets\Photoshop Actions
to   C:\Program Files\Adobe\Photoshop Y\Presets\Photoshop Actions


39. MIGRATING ACTIONS TO A NEW MACHINE

UP
NEWMACHINE 

39.1 Q: I just got Photoshop X (or Y) installed on my new PC and then it hit me. How can I move my actions from the old PC to the new one? 


A: In a nutshell you’re going to have to transfer Actions Palette.psp (search on $$FINDINGPSP) and any custom Action Set Files from 

C:\Program Files\Adobe\Photoshop X\Presets\Photoshop Actions

to the new machine. 

Transport options include:

· Attaching the files to e-mail and sending them “to yourself,” assuming e-mail and Internet connective have been established on the new machine. 

· If you’re working in an environment where computers are networked, save the above files from your old PC onto a “shared disk” where they can be accessed by the new PC.

· Copy the files onto a CD.

(EricC)

40. OTHER USES FOR Actions Palette.psp
UP
40.1 Q: What other ways might one use Actions Palette.psp? 


A: In a work setting distributing and sharing a master copy of Actions Palette.psp would ensure everyone uses the same actions.

41. RESTORING THE ENTIRE ACTIONS PALETTE

UP
41.1 Q: My primary hard disk crashed and had to be replaced. How can I recover my actions?

A: Assumptions:

· Data from your “crashed” hard disk could be recovered.

How to do it:

· After reinstalling Photoshop on the replacement hard disk, follow the steps for migrating from Photoshop X to Photoshop Y above. You’ll need to replace the default (and empty) Actions Palette.psp with the Actions Palette.psp recovered from the failed hard disk.

Search on NEWPSVERSION
- - - - - -

41.2 Q: My primary hard disk crashed and had to be replaced. The data could not be recovered. How can I recover my actions?

A: Assumptions:

· You made periodic copies of Actions Palette.psp or saved individual .atn files.

· The backup copies of Actions Palette.psp or the individual .atn files were somewhere other than the hard disk that failed, for example, on a different hard disk or a CD.

How to do it if a backup of Actions Palette.psp is available:

· After reinstalling Photoshop on the replacement hard disk, follow the steps for migrating from Photoshop X to Photoshop Y above. You’ll need to replace the default (and empty) Actions Palette.psp with the Actions Palette.psp from the other hard disk or CD.

Search on NEWPSVERSION
How to do if backups of individual .atn files are available:

· After reinstalling Photoshop on the replacement hard disk, use the “mass load” technique to populate the Actions Palette.

Search on LOADFAST
- - - - - -

41.3 So, if I do not have backups of Actions Palette.psp or individual .atn files separate from the failed hard disk from which files cannot be recovered, it’s back to square one, right?

A. Correct.

42. RESTORING ACTION SETS FROM Actions Palette.psp USING TASK MANAGER
UP
RESTOREACTIONFROMPSP

42.1 Q: I just started Photoshop and two minutes into my session I accidentally deleted an Action Set that’s really important to me. I don’t have a backup Action Set File or a copy of Actions Palette.psp. What can I do?
A: Note. The following will work if the version of Windows you’re running has the ability to invoke Task Manager (or equivalent) in order to terminate a running program.

Important: DO NOT shut down Photoshop via File > Exit, Ctrl + Q or by closing Photoshop’s window (clicking the close window button (x)).

· Save and close any open images if applicable. 

· Open the Windows Task Manager dialog.

· Click the Applications tab and select Photoshop.

· Click End Task. (Don’t worry about the scary looking warning message.)

· Start Photoshop. The deleted Action Set is restored.

Why this works: The End Task command causes Photoshop to terminate abnormally, which in this case is good. Any changes made to the Actions Palette, i.e., the deleted Action Set, will be lost because Actions Palette.psp is not updated when Photoshop crashes. When Photoshop is restarted it uses the same copy of Actions Palette.psp that it did before the prized Actions Set was deleted.

43. RESTORING ACTION SETS FROM Actions Palette.psp BY PULLING THE PLUG
UP
RESTOREACTIONFROMPSP

43.1 Q: What if my version of Windows doesn’t have Task Manager? Is there any hope in recovering my one and only copy of this Action Set? 

A: This isn’t an elegant solution, but it will work.

Important: Use this method as a last resort and at your own risk. Although it has never happened to me, sometimes (literally) pulling the plug can cause unforeseen problems, such as data loss in other areas.

Important: DO NOT shut down Photoshop via File > Exit, Ctrl + Q or by closing Photoshop’s window (clicking the close window button (x)).

· Exit from all other programs, saving files if necessary.

· Perform any other tasks that you normally would perform before a controlled shut down of your computer.

· If you have open files in Photoshop, save and close them.

· When Photoshop is the last program still running (no open files), literally pull the plug on your computer (or hit the power strip switch), simulating a power failure.

· Start Photoshop. The deleted Action Set is restored.

Why this works: Pulling the plug causes Photoshop to terminate abnormally, which, again, is good. Any changes made to the Actions Palette (the deleted Action Set) will be lost because Actions Palette.psp is not updated when Photoshop crashes. When Photoshop is restarted it uses the same copy of Actions Palette.psp that it did before the prized Actions Set was deleted.

44. RESTORING ACTION SETS FROM Actions Palette.psp AFTER MANY CHANGES
UP
44.1 Q: I’ve been working day and night for three days, writing some new actions, that live in Action Set D. 

I don’t know what got into me, but I deleted Action Set A, Action Set B and Action Set C — action sets I’ve had forever that would take weeks to recreate. Silly me I have no backup files. 

If I use the procedure described previously to abnormally terminate Photoshop to restore the old Action Sets, I’ll lose all the actions in Action Set A that I’ve been working on the past three days. Can I have my cake and eat it to? 

A: Yes, you can.

Important: DO NOT shut down Photoshop via File > Exit, Ctrl + Q or by clicking the close window button (x).

· If applicable save and close any open images. 

· Locate Actions Palette.psp and rename it to yesterdays actions.psp. (Note: It’s possible to copy, rename or even delete Actions Palette.psp while Photoshop is open. It’s only used when Photoshop starts up and during shut down. Between times you can have your way with it.) 

· Now you can shut down Photoshop normally (File > Exit). Don’t worry, it’s okay. Since you’re doing a normal shut down, PS saves the contents of the Actions Palette, including all the new actions you wrote over the past three days and nights, in Actions Palette.psp. 

“Wait,” you say. “I just renamed Actions Palette.psp to yesterdays actions.psp. Won’t Photoshop crash when it attempts to save the contents of the Actions Palette to a file that no longer exists?”

That would be a logical assumption, but in fact there is no crash. If Actions Palette.psp does not exist when Photoshop is shut down, Photoshop creates a new Actions Palette.psp and saves the contents of the Actions Palette in it.

A quick recap to this point. We now have two .psp files: yesterdays actions.psp, containing the three zapped Action Sets, and Actions Palette.psp, containing the actions developed over the past three days.

· Rename Actions Palette.psp to today’s actions.psp
· Rename yesterdays actions.psp to Actions Palette.psp 

· Start Photoshop. The Actions Palette is populated from the renamed yesterdays actions.psp. This is the .psp that contains the Action Sets you deleted.

· Use Save Actions to create three Action Set Files from the deleted Action Sets.

· Shut down Photoshop.

· Rename Actions Palette.psp to yesterdays actions.psp 
· Rename today’s actions.psp to Actions Palette.psp 

· Start Photoshop. The Actions Palette is populated with the contents of the renamed today’s actions.psp, which contains all the work done over the past three days (less the three Action Sets you deleted).

· Use Load Actions… to load the three Action Set Files created from yesterdays actions.psp.

· If all is well delete yesterdays actions.psp. It is no longer needed. 

If you’re thinking something like, “Hmmm… That’s a LOT of steps to recover three Action Sets,” consider this. Worst case this is a 15 minute recovery. How long would it take to recreate actions from three sets? I would bet it would be more than 15 minutes.

45. RESTORING ACTION SETS FROM Actions Palette.psp – NOT!
UP
45.1 Q: I’ve been working day and night for three days, writing some new actions. This time I deleted the Action Set that contained the new actions that I was working on and did not do an immediate Undo (Ctrl + Z). Will Actions Palette.psp save me this time?

A: Unfortunately, no. 

Remember that Actions Palette.psp is updated when Photoshop is shut down normally. If you’ve been on a roll and not closed Photoshop in three days, Actions Palette.psp would not yet include the new actions. 

If you’re doing some heavy duty action work, it’s not a bad idea to do a periodic Save Actions… on the Action Set where your new creations live or simply do a Photoshop shut down and startup. You never know when the cat is going to step on the power strip switch. 
ACTIONWRITE 

46. WRITING ACTIONS

UP
46.1 Q: I’d like to give writing my own actions a try. I’ve never done this kind of thing. Do I need to have computer programming expertise? Is it difficult to learn? What kind of background should I have? 


A: While having background in computer programming, script or macro writing experience is helpful, it is definitely not a prerequisite to getting into action development. Many skilled action authors have never spent a minute programming a computer. They began by learning basic skills and with time and experience, built on them. 

Is it difficult? That’s a hard one to answer. Different people have different backgrounds and aptitudes. I believe it takes a certain amount of persistence (sometimes problems are obscure and challenging to overcome) and attention to detail to be consistently successful. The smallest typing error can cause actions to render results that miss the mark completely. There’s a lot of difference in applying a Gaussian Blur with a radius of 20 instead of 2. 

Having a knack for planning helps, too. Since complex actions can consist of dozens of steps and step sequence is very important, the discipline to jot steps down on a piece of paper or type them using a word processing program (this is called creating pseudo code) before engaging in the recording process generally leads to more favorable results. While clicking CREATE NEW ACTION and flailing away without any sense of direction works in some instances, more times than not it’s not a very productive method.

Finally, it is my opinion that having the tendency to be a little bit lazy is a favorable trait. I mean this in a positive way in that one of the fundamental reasons to record an action is to save time by automating a repeated command sequences. If it doesn’t bother you to do the same tasks over and over that you know could be automated, then action writing will probably not be something that retains your interest.

- - - - - -

46.2 Q: What’s the best way to learn to write actions?

A: I’ve never seen a course, book or video dedicated to teaching the craft of action writing nor have I seen an Internet-based tutorial that offered an in-depth presentation on the subject. 

Given the absence of formal training available I would say an approach to consider would be a combination completing action tutorials available on the Internet, writing actions yourself and studying actions written by others. 

Here’s a possible Action Writing 101 course outline.

Go through a tutorial or two that leads you through the action writing process. http://www.myjanee.com/tuts/centeract/centeract.htm
http://www.soniacoleman.com/Tutorials/tutorials.htm (scroll to the bottom)
· After that write a couple simple actions on your own.

· Download, install and start playing actions representative of your interests.

· Start dissecting and studying these actions written by others.

· Complete a couple more tutorials from the Internet.

· Write some more actions.

· Keep dissecting actions written by others.

· Repeat the previous two steps indefinitely.

Don’t get bogged down studying actions or reading through tutorials. The most valuable experience is gained through writing your own actions, ones that solve problems you have or simplify your work. Write your first one, then a second and a third. Remember to crawl before you walk and walk before you run. If it’s still fun after you’ve crafted 10 or 20 actions, you’re probably cut out for this kind of thing.

If you try action writing and get technically flustered, don’t panic. This happens to just about everyone. Set it aside for awhile, learn a little more about other aspects of Photoshop and then come back to action writing in a few days, weeks or months. Sometimes it takes a few swings of the bat to get the hang of it. Remember: No one has ever been born with action writing skills, with the possible exception of Mike Finn!

In addition to writing actions, I’ve found that taking apart and studying actions written by others is very educational – not only from the perspective of action development techniques, but for learning about and how to apply Photoshop functionality of which I had limited or no previous knowledge. There’s much to be gained, too, by studying poorly written actions which can give one insights on how not to do it.

Although I’m not intimately familiar with techniques used to develop actions that generate textures, glitzy text effects or frames, I’ve learned of some potentially useful Photoshop capabilities by studying the types of actions I don’t write myself.

The Adobe-provided actions are good ones to chop up, too. They range from simple (recording a single command) to fairly complex (generating digital frames using an action that calls an action). 

Then I would take a look at many of the actions available in the DPReview Retouching Forum Action Collection (http://www.geocities.com/kafuensis/) and actions occasionally offered for download from the DPR Retouching forum (www.DPReview.com). These actions represent a gold mine of potential learning opportunities: different types of actions written by authors with different action development styles. By analyzing the techniques of talented action writers like Mike Finn, Bill Coughlin, Trimoon, Budd Guinn, Dave Jaseck, Bill Miller, Bill Richardson, VG, and Randall Smith, you will learn from among the best. Studying actions written by these guys is like getting lessons in creativity and Photoshop skills without the expense of traveling to, say, New Zealand or California.

Finally, if you find a supportive mentor, nurture and develop that relationship. Connecting with someone willing to answer questions, critique your work and impart wisdom and thereby helping you avoid, reduce or smooth out some bumps along road to becoming a successful action writer will be more valuable than any book or tutorial you could find. 
- - - - - -

46.3 Q: Is playing an action “one step at a time” helpful in learning how actions work?

A: I would say, “Yes, definitely.” Search on 1STEPATATIME
- - - - - -

46.4 Q: With all the free actions available on the Internet, why on earth would I ever want (or need) to learn how to write one? Wouldn’t it be fair to assume that an action (or two or three or a hundred) has already been written to solve my problem of the moment or generate the effect I need? Someone, somewhere has almost certainly “Been there. Done that.” How many more sharpening, fix red-eye, frame generating, infrared, convert color to grayscale, apply sepia tone, photo-art, contrast mask actions does the world need? 

A: Probably none. Actions that do practically anything you can imagine have no doubt been developed. The challenges are finding an action WHEN you need it that does what you want using the method you prefer. In many cases it’s faster write your own customized action than hunting one down on the Internet.

As long as Adobe keeps adding new functionality to Photoshop, those who like to write actions will have new reasons to develop them. 

Finally, if developing an action helps you learn more about Photoshop and you get a sense of enjoyment and accomplishment out of the exercise, where’s the harm?

47. WRITING ACTIONS OUTSIDE OF PHOTOSHOP

UP
47.1 Q: Is it possible to write actions programmatically? (Syed Zeeshan Haider)

A: No. Actions cannot be created or edited except within the Actions Palette within Photoshop itself.

For what it’s worth ImageReady actions are script-based and may be edited with a standard text editor. (TrevorM)

48. BEFORE YOU HIT THE NEW ACTION BUTTON…

UP
48.1 Q: Before I record an action, is there anything I should do?

A: Before answering let me observe based on my own experiences that:

· Action development can be addictive as well as very time consuming

· A lot of the time spent developing complex actions is spent redoing and redoing and redoing them

· A considerable amount of “redo” time is avoidable

Unless it’s a very simple action with just a few steps or you’re just experimenting, it’s a good idea to think it through before leaping into the recording process. This can be especially important if the action is complex and/or the final result is known ahead of time, for example, a sharpened or color corrected image or a mitered, digital simulated walnut frame. 

Although you don’t need computer programming background to write actions, action writing does have some similarities to computer programming where studies have shown that when planning precedes programming (recording), it takes less time to arrive at a final result because there are fewer errors to correct. 

You might consider making a trial run (or two) during which you manually step through the process you intend to record as an action. Write down commands and settings as you apply them. This becomes a roadmap to which you can refer as you proceed through the actual recording process.

On the other hand if you’re developing a photo-art action where you have no concrete result in mind beforehand I’d say, “Let ‘er rip!” How do you preplan for creativity?

WRITINGELEMENTSACTIONS

49. WRITING ACTIONS THAT ARE COMPATIBLE WITH PHOTOSHOP ELEMENTS

UP
49.1 Q: If I’m writing actions for Elements, what things should I take into consideration?

A: While many actions play under Elements without modification, others require anywhere from a little to a lot of retooling to achieve the same (or acceptably similar) results. 

The craft of Elements’ action writing has steadily evolved since Richard Lynch revealed the possibilities early in 2003. Here are some general things to know: 

· Photoshop Elements has no Actions Palette, so there is no way to resume an action paused by a Stop Command. Likewise actions cannot be modified (or created) in Elements. 

· Action Set Names and Action Names under Elements may contain lower case letters, numbers and _ (the underscore character). No spaces are permitted; use the underscore in lieu of a space to make action names easier to read. 

· Elements does not support the Photoshop Fade command, so don’t record one of those.

· Elements does not support all Photoshop color space modes, e.g., CMYK, as well as some channel related operations. 

My advice would be to check the following sites where you can download and analyze the many actions that have been modified or written specifically for Elements: 

· Richard Lynch’s site: http://www.hiddenelements.com/ 

· Ling Nero’s site: http://www.geocities.com/rnlnero/PE2stuff2.html
- - - - - -

49.2 Q: Looking at existing actions is okay, I guess, but it would be really neat if there was a tutorial with more detail, wouldn’t it?

A: It sure would and guess what? You’re in luck. While you’re at Ling’s site, check the comprehensive “do’s and don’ts” she wrote on how to write actions that are compatible with Elements.

http://www.geocities.com/rnlnero/ElementsActionsGuide.html
- - - - - -

49.3 Q: I don’t have Photoshop, but I’d like to write actions to run under Elements, which I do have installed. Is there any way to write and edit actions without Photoshop?

A: No. You must use Photoshop to record actions.

Look into auction sites such as http://www.ebay.com/ where older (and legitimate) versions of Photoshop are put up for auction on a regular basis. 

If you decide to take this route, get Photoshop 6.0 or later to ensure action compatibility. 

If you are faculty member, student, or have a student living at home, Adobe offers Educational Versions of Photoshop, which work exactly the same as the standard edition but cost substantially less.

50. WRITING ACTIONS FOR COMPATIBILITY WITH NON-ENGLISH VERSIONS OF PHOTOSHOP

UP
50.1 Q: If I want to write actions that will play under non-English versions of Photoshop, what should I take into consideration?

A: Layer names! Be patient. A little background is in order before the problem (and solution) will make sense.

First, actions are very literal. If you’re recording an action and select (click on) layer Levels 1 or Background, Photoshop records steps Select Level 1 and Select Background respectively.

Secondly, consider the English version of Photoshop assigns names to layers such as:

· Background

· Background copy

· Layer 1

· Layer 1 copy

· Levels 1

· Levels 2

· Etc.


Okay, now we can get into the meaty part. Suppose you write an action using the English version of Photoshop that has the following paraphrased steps. Assume the image against which the action is played initially has only has a Background.

1. Create a Layer via Copy (Layer name assigned by Photoshop: Background copy)

2. Create a new layer (Layer 1)

3. Create a Levels Adjustment Layer (Levels 1)

. . . then it goes on to:

4. Select layer Background copy and change the Opacity to 50%

5. Select layer Layer 1 and fill it with 50% gray

6. Select layer Levels 1 so you can adjust contrast

Here’s where things get interesting: Something to be aware of that was news to me, but makes sense if you think about it, is non-English versions of Photoshop assign language specific names to layers they create. In other words the French equivalents of Background, Background copy, Layer 1 and Levels 1 are not Background, Background copy, Layer 1 or Levels 1. They are Fond, Fond copie, Calque 1 and Niveau 1. (Laurant, PierreC) 
As our action plays under (let’s say) the French version of Photoshop, it names the background Fond and assigns Fond copie, Calque 1 and Niveau 1 to the layers created in steps 1-3. These steps will execute without interruption under any language version of Photoshop because the commands are not “layer name dependent.” 

There’s trouble ahead, however, since the next three action steps specifically refer to layers whose names were generated by the English version of Photoshop, which are not present in our French PS generated image. 

Our action will fail at step four and an error message will be displayed that’s the equivalent of 

“The object ‘layer’ “Background copy” is not currently available.” 

If the Continue button is clicked at this point, the next step will fail for the same reason because there is no layer named Layer 1 in the Layers Palette.

So, how can we get around this language differences obstacle? Here’s how.

During the development of the action, each time a layer of any kind is created by Photoshop, rename it immediately. For example after Background copy is created, rename it to something like BG-copy. The action statements would look something like this:

· Create a Layer via Copy (Layer name assigned by Photoshop: Background copy)

· Set (rename) current layer to BG-Copy 

... and later 

· Select layer BG-Copy and change the Opacity to 50%

When the action is played by a non-English version of Photoshop, here’s what happens:

· Create a Layer via Copy (A layer name, whatever it is, is assigned by the non-English version of Photoshop.)

· Set (rename) current layer to BG-Copy (By renaming the current layer immediately, the name of the current layer is irrelevant.)

... and later 

· Select layer BG-Copy and change the Opacity to 50% (This step works because BG-Copy exists.)

To summarize, immediately after Photoshop assigns a default layer name, record a step to rename it to something else. The renamed layer and references to it from within the action will survive any language version of Photoshop. 

- - - - - -

50.2 Q: Isn’t it fair to assume someone using a non-English version of Photoshop might have images with Backgrounds that are not named Background? If I write an action that includes commands such as Select Background or Duplicate Background, the action will fail if played by a non-English version of Photoshop. What then? 

A: I’d say that’s a good assumption about Backgrounds not named Background, but not to worry. There are a couple ways to circumvent this one. 

Option I: Recording these steps preserve all layers in the image while creating a “language proof” layer you can use like you would a background.

· Layer > New Layer 

· Ctrl + Shift + ] moves the layer just created to the top of the layer stack, regardless of how many layers are in the Layers Palette or which layer is active when the action starts. This works even if the image only has a Background.

· Alt + Ctrl + Shift + E merges visible layers into the new one without collapsing the individual layers.

· Finally, rename the newly created top layer. Assign it a name such as “Base.” You can refer to and use this base layer in your action as you would a Background without concern for the language edition of Photoshop that plays the action. 


Option II: Duplicate and flatten the image, then create your background-equivalent base layer. 



· Image > Duplicate
· Layer > Flatten Image
· Immediately drag the highlighted Background over the New Layer icon at the bottom of the Layers Palette. This will cause command Duplicate current layer to be recorded. 

· Just as above rename the newly created top layer. Assign it a name such as “Base.” You can refer to and use this base layer in your action as you would a Background without concern for the language edition of Photoshop that plays the action. 

- - - - - -

50.3 Q: Yikes. Isn’t there a better way? 

A: Better is a relative term. There is a different way. 

Search on MOUSEVSKBS.
51. Writing Actions – Using Keyboard ShortcutS to Move Among Layers

UP
Photoshop has keyboard shortcuts for about everything, including selecting and moving layers in the layers palette without using the mouse. In some cases it makes sense to use them, in others perhaps not. 

Search on LAYERKBSHORTS
- - - - - -

51.1 Q: So, what’s your favorite layer movement keyboard shortcut and why? 

A: Ctrl + Shift + ] 

It comes in particularly handy when one duplicates the Background and wants to move Background copy to the top of the layer stack, regardless of how many layers there are in the Layers Palette.
- - - - - -


MOUSEVSKBS

51.2 Q: If I selected layers by mouse clicks in my action, it can cause problems if my action is played under a language edition of Photoshop different than mine as described in the previous section. Couldn’t I avoid this problem by recording appropriate keyboard shortcut(s) to maneuver among layers? 

A: Yes, you can — if you’re careful. 

Suppose you have an action that’s playing and to this point has generated the following layer stack. 


Easy
      Delta
      Charlie
      Baker
      Able
      Background

Layer Able is the active layer and you want to switch to layer Delta in order to apply the Unsharp Mask filter. Most of the time you would just would click on Delta, which would record a Select Layer “Delta” command in the action. When the action plays, the Select Layer “Delta” command is executed and delta becomes the active layer.


Easy
      Delta
      Charlie
      Baker
      Able
      Background

Further suppose sometime in the future you decide to modify your action so it generates additional layers as follows:


Easy
         Curves 1
      Delta
      Charlie
         Hue/Saturation 1
         Levels 1
      Baker
      Able
      Background

Despite the addition of the new layers, when the Select Layer “Delta” command is executed, Photoshop will find Delta in its new location and apply the USM filter.


Back to our original layer stack.


Easy
      Delta
      Charlie
      Baker
      Able
      Background

An alternative to clicking on layers to select them, is recording keyboard shortcuts to (eventually) achieve the same results. For example to move from Able to Delta using keyboard shortcuts, you would have to record 

Alt + [ 

three times. This shortcut selects the layer immediately above the current layer. 

Another approach would be to record these two shortcuts:  

Alt + Shift + ] followed by Alt + ] 

The first selects the top layer in the Layers Palette and the second selects the layer immediately below the current layer.

All is fine until the action is modified and new layers are present. These must be accounted for when switching among layers using keyboard shortcuts.


Easy
         Curves 1
      Delta
      Charlie
         Hue/Saturation 1
         Levels 1
      Baker
      Able
      Background

Moving up three layers from Able in the modified layer stack lands on Levels 1; taking the other route (jumping to the top layer, then down one) ends up at Curves 1. Not good in either case. Have you ever tried to apply an Unsharp Mask filter to an adjustment layer? To land on Delta as desired, a little more action modification work will be needed.

In this simple example it would not be difficult to add additional keyboard shortcut commands to compensate for the new layers. However, in a complex action that generates more layers and/or has occasion to move among layers more than just a few times, things can get messy in a hurry  trying to keep track of the number of keyboard shortcuts to insert or delete when layers are added or taken out. 

That said, if you’re careful this technique can be done (and very well). If you’re familiar with some of the terrific frame actions written by Bud Guinn, you know what I mean. After he’s got a complex frame action the way he wants it, Bud often goes in and replaces all the Select Layer commands with the appropriate keyboard shortcuts.  

Once completed if your action will most likely never change or change very little, or is relatively simple to begin with, recording the keyboard shortcuts is certainly a viable alternative to selecting layers using the mouse. 

BATCHPROCESSING

52. BATCH AUTOMATION - INTRODUCTION

UP
With the volume of images that can be captured and stored by today’s digital cameras, there can be times when one is faced with processing literally hundreds of images — a daunting task for even the most enthusiastic Photoshop user. 

One solution? Photoshop’s Batch Automation (also referred to as Batch Processing) capabilities that enable one to apply an action in a single pass to a batch (or a bunch) of images vs. applying that same action to one image at a time. With batch automation one can process hundreds of images very efficiently.

The tricks are to do it right the first time (to avoid rework) and to safeguard against destroying your only set of original images.

The biggest obstacle for most is overcoming the intimidating looking File > Automate > Batch dialog.

53. BATCH AUTOMATION – THE BEST BOOK RESOURCES ON BATCH AUTOMATION

UP
53.1 Q: Of all the books you read for this tutorial, which would you recommend for batch processing? 

A: Search on GOODBOOKS
54. BATCH AUTOMATION – PHOTOSHOP ELEMENTS

UP
54.1 Q: Does Photoshop Elements support batch automation? 

A: The answer is a qualified yes. You can do some editing in batch mode by modifying Elements with tools developed by Richard Lynch. (CaseyJ)

Check out: 
http://www.HiddenElements.com
http://www.hiddenelements.com/freetools.html
55. BATCH AUTOMATION – THE BASICS

UP
55.1 Q: I don’t have a digital camera and just process a few images at a time. Do I need to mess with this? 

A: You don’t necessarily have to have a digital camera in order for batch processing to be useful. For example if you display images on the Internet and need to apply a copyright notice to a whole bunch of images at one time, learning more about batch processing couldn’t hurt.

If nothing else, browse the topics to get a feel for how it works and what it can do for you. My bet is you’re closer to getting a digital camera than you think.

- - - - - -

55.2 Q: How is batch automation invoked? 

A: Through the File > Automate > Batch dialog

Note: CS users can invoke batch processing through the File Browser.

- - - - - -

55.3 Q: What’s the difference between playing an action standalone and invoking it through the File > Automate > Batch dialog? 

A: As noted above the major difference is the number of images typically processed at a time: Normally one at a time for a standalone action and potentially hundreds (one after another, without interruption) through batch automation. 

- - - - - -

55.4 Q: For what sorts of tasks is batch automation appropriate?  

A: These are some typical tasks:

· Converting images from one file format to another, e.g., .jpg to .tif or one color space to another, e.g., RGB to CMYK

· Changing image dimensions and/or resolution for, say, a web gallery

· Rotating all or selected images (using the File Browser select feature) 90 degrees from portrait to landscape or vice versa
· Hands off sharpening, color correction, noise reduction, etc.

· Automatic insertion of adjustment layers one image at a time, image after image, enabling custom adjustments and eliminating the need to open, save and close each image as well as not having to keep track of where you are
· Application of digital frames, edges or other effects

· Inserting copyrights, logos, signatures
· If you have a digital camera or a scanner with a feeder for documents, negatives or slides, you may be able to import and process multiple images as long as the scanner or digital camera has an acquire plug-in that supports actions
- - - - - -

55.5 Q: What are the sources of the images?  

A: These are the options:

· A selected folder and optionally its subfolders either selected from a browse dialog or based on the last folder opened in the File Browser

· Images already open

· Directly from a scanner or digital camera (if ancillary software supports this function and has been installed)
- - - - - -

55.6 Q: Is the goal for batch processing to be completely automatic, that is, “hands off”? 

A: Not necessarily. In some cases fully automatic processing is highly desirable and can be achieved, for example if you want to change the format of 200 images from .psd to .jpg.

Even if you want to apply custom adjustments such as sharpening or color correction to each image in a folder it’s usually more efficient to process the images through batch processing. Why? File > Automate > Batch automatically handles all image open, image save and close steps as well as invokes adjustment and correction commands without requiring one to make any menu selections manually. 

- - - - - -

55.7 Q: Conceptually, how does this work?  

A: Think of File > Automate > Batch as a three step process: 
Input -> Process -> Output

· Input

· An image specified in the Source dialog is made available to the action. Automate > Batch takes care of this automatically, which is otherwise a manual trip through File > Open. An added bonus is Automate > Batch keeps track of which images have been processed, always knows which one is the next one in line and never forgets any.

· Process

· The specified action is applied 

· Output

· The processed image is saved and closed in the location specified in Destination dialog. Again Automate > Batch takes care of this automatically, rather than File > Save and File > Close operations.

If you have background in programming, the following pseudo-code will be helpful in understanding how File > Automate > Batch works. 

· Open the next image file from the location specified in the Source dialog

· If the last image has been processed (end of file), exit the File > Automate > Batch dialog

· Call and execute the specified action 

· When the action completes Save the processed image as specified in the Destination dialog and Close the processed image

· Repeat

- - - - - -

55.8 Q: So I don’t have to worry about including Open, Close and Save (or Save As…) commands in the specified action?  

A: Generally speaking, that’s correct. More on that in minute. Search on WHENSAVEASISNEEDED
- - - - - -

55.9 Q: Anything else I should know?

A: Here are a couple things to keep in mind:

· Unlike most standalone actions, the File > Automate > Batch process does not need an open image before it’s launched.

· Consider including a Flatten Image command at the outset of the action. Doing so ensures changes are not just applied to the last selected layer in a multiple-layer image.

· Destination files saved by the Automate > Batch command always have the same format as their corresponding Source files unless the action includes a Save As… command specifying a different format. Search on OVERRIDESAVEAS
· Embedded ICC profiles will be left as is. 

· You do not have to record Save and Close commands in actions that will be applied through Automate > Batch because these operations are handled automatically.

· Although Open and Save As… commands can be recorded in an action to specify explicit Source and Destination folders and file names, most people don’t record these commands because they, too, are not necessary. Instead they opt for the flexibility to specify Source and Destination folders in the dialog.

· To protect original images it’s a good idea for the Source and Destination folders to be different.

56. BATCH AUTOMATION – FILE > AUTOMATE > BATCH DIALOG 

UP
56.1 Q: How about a walk-through of all the fields in the File > Automate > Batch dialog?

A: Sure.

PLAY

Specifies the action that will be applied. By default, the name of the most recently used action and the Action Set in which it resides populate the Set and Action fields. Change them if necessary.

· Set: The Action Set where the desired action resides.

· Action: The action that will be applied.

SOURCE

Identifies the location where images to be modified reside.

· Folder

· If selected, the location must be specified in the Choose (Source) dialog. 

· If applicable check Include All Subfolders.

· Import

· Choose this option if your scanner or digital camera is the image source. A From menu (only displayed if Import is selected) will have the acquire plug-in listed IF it supports batch automation. Select the acquire plug-in if present.

· Opened Files

· Images will be processed in the order listed in the Windows > Documents menu.

· File Browser

· Images will be processed from the current folder in the File Browser. If specific images have been selected in the File Browser window, only they will be processed by Automate > Batch. If no images are selected in the File Browser window, all images will be processed. If desired, Include All Subfolders can be specified with this option.

CHOOSE (Source folder)

Only available if (Source) Folder is selected above. Browse to the folder where the images to be altered reside. The name of the selected Source folder is displayed next to the Choose button.

Override Action “Open” Commands

If any Open commands were recorded as part of the original action, they are ignored during the Automate > Batch process when this option is selected. This ensures that image files will be opened from the specified folder. Under most circumstances this is desired if you’re using the Source/Folder or Source/File Browser or Source/Import options. 

Important: If the action does not include Open commands, do not choose this option. Doing so will cause the action to fail with a “Command not available” error. It’s Photoshop’s way of saying, “I can’t suppress what I can’t find.”

Include All Subfolders

If Folder or File Browser has been selected as the image Source, this option causes the action to be applied to all images in all subfolders of the specified Source folder. If Windows shortcuts or Mac aliases representing other folders reside in the source folder, images in these folders will be processed as well, but only if this option is checked. 
Suppress Color Profile Warnings

Choose this option if you want the Automate > Batch process to ignore color profile mismatches. 
DESTINATION

This is where Photoshop puts the processed images. 

Important: Technically Source and Destination folders (or “open files,” which can be the same, but many people choose to keep them separate. This practice ensures that if things go horribly wrong, the original images won’t be overwritten by bad ones.

· Folder: As specified in the Choose dialog. 

· None: Applies the action and leaves the files open without saving changes (unless the action includes a Save command). This option would allow you to preview modified images to determine if further changes are needed before saving them. 

· Save and close: Saves and closes files in their current location replacing the originals. Important: If you choose this option, be sure you have a backup of the source images before initiating the batch process.

CHOOSE

Only available if (Destination) Folder is specified above. Browse to the folder where the images to be altered reside. On Macs, you can create a new folder in this dialog. No so on Windows. The name of the selected Destination folder is displayed next to the Choose button. 

Override Action “Save As” Commands

Overrides folders and file names specified by Save As… command, ensuring that processed files are saved to the specified destination folder.

Important: 

· If the action does not include Save As… command, do not choose this option. Doing so results in no files being written to the specified destination.

· If the action includes Save As… command for the purpose of changing the file format or file characteristics, e.g., .jpg compression level, turn this option ON. While it will suppress the folder and file name values recorded with the command, it will retain and apply the new file format specifications.

FILE NAMING

This option is only available if Destination/Folder is selected.

These fields enable you to specify that all file names produced by the batch process contain the same information, in the same sequence. Original or custom file name can be specified along with dates in various formats and sequence letters or numbers (various Photoshop provides a number of options for renaming files using these six text boxes, each of which has the same dropdown menu choices. 

The layout of the six boxes is:

1  2

3  4

5  6

If you do not want file names changed during the Automate > Batch process, be sure Document Name and Extension (upper, lower or mixed case selected from the drop down menus) populate any two boxes, such as 1 and 2, 3 and 4, etc.

From the dropdown menus you can assign serial letters or 2-, 3- or 4-digit serial numbers, dates in various formats or type custom text such as such as “DISNEY WORLD” or “Jimmy’s-Birth.” 

It makes no difference if boxes are skipped, for example you could populate boxes 1, 3, 4 and 5. Photoshop concatenates (splices together) whatever is specified in these boxes in the 1-6 order shown above. 

Important:

· EXTENSION or extension must be the last entry. It doesn’t necessarily have to be in box 6, just as long as no entry follows it.

· If Destination Folder = Source Folder, original images will not only be replaced, they will be renamed as well.

Example

As you make changes in File Name boxes, a sample File Name is displayed here.
Compatibility

If the ultimate destination of the Destination images is a Mac or machine running Unix, check the appropriate box. Windows is checked by default.

· Mac OS9 (prevents the number of characters from exceeding Mac OS9 file name limits)

· Unix (prevents the number of characters from exceeding Unix file name limits)

ERRORS

· Stop for errors: Halts the batch processing process if any errors are encountered. Processing may be halted or resumed at user discretion.

· Log errors to file: If an error is detected, it is logged to a text file (your call on its name. I use Errors.txt), but processing continues uninterrupted. After all source images are processed a message is displayed if any errors occurred. 

SAVE AS…

Not available if Stop for errors is selected.

Specify the location of the error text file where details are recorded during processing. This file is helpful in debugging.

57. BATCH AUTOMATION – REVIEW OF STEPS

UP
57.1 Q: Can you capsulize a batch processing development and application?

A: This is a general process. It assumes you want to specify the Source and Destination folders from the Automate > Batch dialog and no file format conversion is needed:

· Develop the action and test it.

· Create Source and Destination folders (if they do not already exist)

· Put 2-3 test images in the Source folder

· Test the action in the File > Automate > Batch dialog

· Specify the Action Set  

· Specify the action

· If the action contains Open command(s) turn on ‘Override Action “Open” Commands’

· Turn on ‘Suppress Color Profile Warnings’ unless you want processing to be interrupted when mismatches are detected

· Specify Destination

· If the action contains a Save As… command, turn on ‘Override Action “Save As” Commands’

· File name: If you want to rename the files, populate fields accordingly 

· Compatibility: Check boxes that apply

· Errors: Choose Log Errors to File
· Save As…: Specifying the Desktop makes it easy to find this file

· Click OK to initiate the process

· Fix problems, if any

· Delete the test images in the Source folder and replace them with the “real” images

· Delete the processed test images in the Destination folder 

· Initiate batch processing

· Open File > Automate > Batch (fields and settings will be unchanged)

· Click OK to initiate the process

· Go get coffee

58. BATCH AUTOMATION – WHEN IS A SAVE AS… COMMAND NEEDED?

UP
WHENSAVEASISNEEDED 

58.1 Q: When does one need to include a Save As… command in an action invoked by File > Automate > Batch?

A: When you want the format of the destination image to be different from the format of the source image, e.g., when you want to convert a batch of .jpg files to (say) .tif or to specify a different .jpg compression level.

When the action is recorded, it makes no difference what file name and folder is specified in the Save As… dialog. 

In File > Automate > Batch be sure ‘Override Action “Save As” Commands’ is checked ON, as unintuitive as it sounds. Doing so retains any Save As… settings (including .jpg compression level values), but ignores the file name and folder specified when the step was recorded. 

59. BATCH AUTOMATION – STOP FOR ERRORS

UP
59.1 Q: What error handling option do you prefer?

A: If Stop For Errors is in effect, processing stops and an error message is displayed when an error occurs. This is a good choice if you’re going to be sitting at your computer while images are being batch processed. 

Log Errors To File is a good option if your intent is to start a batch process just before going to bed (or at the office and are headed for lunch), and you want as many images to be processed as possible by the time you return. With this option in effect processing continues even if an error is detected. Error information is recorded in the text file specified in the Save As… dialog. 

60. BATCH AUTOMATION – TERMINATING AN IN PROGRESS PROCESS

UP
60.1 Q: How do I terminate a batch automation process that’s in progress? 

A: Press Esc. 

61. BATCH AUTOMATION – THE SEQUENCE OF IMAGES PROCESSED

UP
61.1 Q: When File > Automate > Batch is launched, what’s the order of image processing, i.e., what image is processed first, second, etc? 

A: If source images are in a folder, they are processed in alphabetical order by file name.

If source images are open in Photoshop, they are processed in the order listed in Window > Documents, regardless of which image is the active image when File > Automate > Batch is launched. 

62. BATCH AUTOMATION – SINGLE ACTIONS VS. MULTIPLE ACTIONS

UP
62.1 Q: Do I have to write an action to color correct a folder of images and another action for noise reduction and apply each of them separately through two passes of File > Automate > Batch?
A: While you could do it this way, it may make more sense to apply the noise reduction and color correction steps within the same action.

- - - - - -

62.2 Q: What’s the advantage of one action vs. multiple ones?

A: There are two advantages, actually. The technical term that describes the advantage is “less overhead” in the first.

Step back for a moment into standalone action mode. For each image to which you want to apply an action you have to open that image, play the action and, when finished, save and close the image. The open, save and close operations are the overhead. Although batch automation handles these operations, they take time and resources for each image processed. 

If you have 500 images to process and invoke File > Automate > Batch twice (once for each action), that’s 1000 opens, 1000 saves and 1000 closes. If the work can be done by a single action, that reduces the overhead by 50% which could represent a considerable amount of time depending on image sizes and computer speed. 

The second reason applies if you’re processing images that are in .jpg format, what’s known as a lossy format. Without getting into the particulars of what this is and why it happens, let’s just say it is generally accepted that the fewer times you open, modify and save a .jpg image, the better. 

63. BATCH AUTOMATION – MULTIPLE FOLDERS IN, ONE FOLDER OUT

UP
63.1 Q: I’ve got 14 folders of images that I want to process using the same action through File > Automate > Batch. I don’t want to put all images into the same Source folder but it doesn’t matter if the processed images reside in a common folder. How can I do this without engaging the File > Automate > Batch dialog 14 times? 

A: Yes.

Assumptions: 

· The action has been developed and tested standalone and in batch

How to do it:

· Turn on the Include All Subfolders option 

· Create Windows shortcuts or Mac aliases for folders whose images you wish to process

· Move the shortcuts (aliases) into the Source Folder or current folder in the File Browser window

When the OK button is clicked in the File > Automate > Batch dialog, images from the multiple input folders will be processed and the modified images will be placed in the Destination folder.

64. BATCH AUTOMATION – MULTIPLE FOLDERS IN, MULTIPLE FOLDERS OUT

UP
64.1 Q: I’ve got 10 folders of images that I want to process using the same action through File > Automate > Batch. (a) I don’t want to put all images into the same Source folder (different clients) and (b) don’t want all of them to end up in the same destination folder. I’d like to set this up Friday before I leave for home and don’t want to have to come back to shuffle images around after processing has begun. Is this doable? 

A: Yes.

Assumptions: 

· The action has been developed and tested standalone and in batch

· There are 10 clients (Source folders)

· Each client’s folder has 400 images in it

Strategy: Create an action that records the command generated when File > Automate > Batch is applied to each clients’ images folder. When the action is complete it will consist of 10 Batch commands.

· Create 10 Destination folders. Name them D-01 through D-10.

· Create a source folder and name it S-01 and place any three test images in it.

· Duplicate S-01 (and its three images) nine times and name the remaining folders S-02 through S-10.

· Create a new action (record mode is active).

· Engage the File > Automate > Batch dialog, Choose S-01 as the Source folder, D-01 as the Destination folder and make the rest of the settings as appropriate. 

· Specify the Destination folder as the location for Error.txt.

· When File > Automate > Batch finishes with the S-01 images, invoke File > Automate > Batch again and change the Source and Destination folders to S-02 and D-02, and set the Error.txt location to D-02 and click OK. 

· Repeat the previous step for folder pairs S-03, D-03 through S-10, D-10. 

Note: If you specified Desktop for Error.txt, this file would get overwritten with each invocation of the File > Automate > Batch dialog. Specifying its location in the respective D folder ensures each batch of client images  will have a unique (and intact) Error.txt file.

· Stop recording.

· Process the client images.

· Delete all test images from S-01 – S-10, D-01 – D-10.

· Populate folders S-01 – S-10 with the “real” client images that need to be processed.

· Play the action. Each of the 10 steps processes a different pair of Source and Destination folders.

· Hit the road.

65. BATCH AUTOMATION – FOLDER OR FILE BROWSER?

UP
65.1 Q: In the File > Automate > Dialog under the Folder dropdown menu I can chose Folder or File Browser to identify the folder of images for batch processing. Which is the better option? 

A: If you choose File Browser, image thumbnails are displayed enabling you to visually confirm the images about to be processed. In addition by Ctrl + clicking thumbnails you can select individual images to process, an option not available with Folder. 

That said out of habit I almost always use the Folder option. 

66. BATCH AUTOMATION – FILE > SAVE AS… vs. SAVE FOR THE WEB FOR .JPG

UP
SAVEFORWEB
66.1 Q: If I want to convert a folder of images to .jpg format, which command should I use: File > Save As… (and specify .jpg) or File > Save for the Web? 

A: It depends. 

If your intent is just to convert an image from (say) .psd or .tif to .jpg, chose File > Save As…. Save As… converts the image to .jpg format and preserves all EXIF information.

Save for the Web optimizes the image and offers options of interest to Website designers.
LOSTEXIF
IMPORTANT: While Save for the Web also converts the file to .jpg format, EXIF information and the file’s color profile are lost in the process. (PierreC). For those into writing actions in ImageReady, the IR equivalent of Save for the Web does not destroy EXIF data.

Your best bet would to research the differences between these two commands and record the one that best suits your needs.

- - - - - -

66.2 Q: Is there anything else I should know about including a Save for the Web command in an action destined to be executed via File > Automate > Batch? 

A: Yes: 

· First of all the File > Save for the Web command is recorded as an Export command, not as Save for the Web as you might expect.

· After an image is saved by the Save for the Web (Export) command and the SFW dialog is closed, the original (on screen) image is unchanged, that is, its file format is retained. This is different from executing a Save As… command where the image to which the command was applied takes on the format specified in the Save As… dialog. 

IMPORTANT: Suppose an action contains a Save for the Web (Export) command and you invoke it through File > Automate > Batch or File > Automate > Create Droplet. Beware if you specify a Destination folder and/or custom file name settings in File > Automate > Batch or File > Automate > Create Droplet they will be ignored. 

Under all circumstances the destination folder will be the one specified in the Save for the Web (Export) command and the file names of the processed images will be unchanged. Trust me. This is the way it works. 

If, by chance, you DO specify a Destination folder in either the File > Automate > Batch or File > Automate > Create Droplet dialogs and that folder happens to be the same one as recorded in Save for the Web (Export) command, ugly things can happen. Trust me on this one, too. Search on SFWACKINESS for the gory details if you must.

How avoid the most confusion and potential problems:

If you’re invoking an action that includes a Save for the Web (Export) command, choose None from the Destination dropdown menu in the File > Automate > Batch or File > Automate > Create Droplet dialogs.

 - - - - -

66.3 Q: So you’re saying that if (a) my action includes a Save for the Web (Export) command, I cannot override the folder it specifies like I can the Destination folder specified a Save As… command through the File > Automate > Batch dialog and (b) regardless of what I specify in the File > Automate > Batch File Naming section text boxes, the file names assigned by Save for the Web (Export) are the same as the file names of the original images, correct?

A: Correct on both counts. To assign different file names you could use the File Browser’s batch rename function after the action completes. 

- - - - - -

66.4 Q: Under what circumstances would it be appropriate to use Insert Menu Item to place a File > Save for the Web command in an action that will be invoked by File > Automate > Batch? 

A: For each recorded if you wanted: 

· To specify a file name different than the images’ original file name.

· The option of saving different images in different destination folders. 

67. BATCH AUTOMATION – LIMITATION: SELECTIVE IMAGE ROTATION 

UP
67.1 Q: My folder contains some images in landscape and some in portrait format. I want all of them to be landscape. Can I do that through batch automation?

A: Not directly. If just a few are in portrait orientation, you are better off using the File Browser’s Rotate Image option on these. If most are in portrait orientation, use the File Browser’s Rotate Image command on the ones in landscape, then run an action through File > Automate > Batch to rotate all images 90 degrees.
Search on UTILITYPGMS


- - - - - -

67.2 Q: How about selecting images using the File Browser and applying an action to rotate them? 

A: That’s another option. Engage the File Browser and open the source folder. Hold down the Ctrl key and click each image to be rotated.

Apply your action that rotates images 90 degrees CW or CCCW via the File > Automate > Batch dialog and specify File Browser as the source. Only the selected images will be rotated.

Depending on your situation, this might be a case where Save and Close is an appropriate Destination choice.
- - - - - -

67.3 Q: How about selectively rotating images using the File Browser? 

A: That’s possible, too, but it doesn’t take an action. Engage the File Browser and open the source folder. Hold down the Ctrl key and click each image to be rotated. Right-click and select the applicable rotation choice.

68. BATCH AUTOMATION – SIZING ALL IMAGES REGARDLESS OF ORIENTATION

UP
68.1 Q: I’ve got a folder of images that are 4”x6” at 72 ppi. Some are landscape, some portrait. I would like to make all of them 7” on the longest side. Can this be automated? 

A: Yes, with a caveat: All images must be the same size and resolution.

· Determine the number of pixels in 7” at 72 ppi (7” x 72 ppi = 504 pixels)

· Create a new action

· Record File > Automate > Fit Image and specify 504 for both the Width and Height values; OK to close.

· STOP recording

· Play the action through File > Automate > Batch. All images, regardless of orientation, will be resized to 504 pixels (7” at 72 ppi) on the longest side.

- - - - - -

68.2 Q: If I have Photoshop 7 or later, could I also record an Image > Image Size command for this purpose? 

A: Yes, as long as in the Document Size Width and Height values are  specified as Percents. (Choose Percent from the dropdown menu.) 

When using the Image Size option to resize images, images in the Source folder do not have to be the same size, but the size increase/decrease will be a function of the image size. For example 4” x 4” images increased by 25% will end up 5” x 5”, where 8” x 8” images in the same folder will be resized to 10” x 10”.

69. BATCH AUTOMATION – AUTOMATING THE SCAN PROCESS

UP
69.1 Q: Is there a way to automate scanned image processing? 

A: Yes, if the scanner has automatic feed of originals, negatives or slides and comes with an acquire plug-in that supports batch automation.

This functionality is invoked by specifying Import as the Source and selecting the acquire plug-in from the From menu. 

If there is no choice for the acquire plug-in in the menu, it means batch automation is not supported. In this case it is usually more efficient to manually scan all images, negatives or slides, and then apply the action through File > Automate > Batch. This usually beats the scan one, process one processing model.

- - - - - -

69.2 Q: I’m able to automatically scan multiple images in a single pass, but not through the Automate > Batch dialog. When the scan process is complete, the images are open in the Photoshop window. Is there a way to rename, save and close them without manually going through the Save dialog for each? 

A: Yes. 

· Open any test image.

· Create a new action.

· Name it and click the Record button in the dialog box.

· File > Save As…

· Specify any folder or file name

· Specify the file type, e.g., .jpg, .psd, etc.

· Specify .jpg options if necessary

· Click STOP to terminate the recording process

· Engage File > Automate > Batch.

· Specify Source: Opened Files
· Specify Destination

· Click on ‘Override Action “Save As” Commands’

· Populate File Naming boxes as needed

· OK

70. BATCH AUTOMATION – RENAMING FILES

UP
70.1 Q: I noticed stand alone batch renaming files isn’t listed among the common tasks. Why not? 

A: While the task certainly falls within the capabilities of File > Automate > Batch, if all you’re doing is renaming files and not doing anything else, e.g., sharpening, color correcting, cropping, etc., this task might be better suited for the File Browser Batch Rename command. 

Each image processed by File > Automate > Batch undergoes a file open and file close sequence, something you may want to avoid with .jpg files, especially if you’re just renaming files. The File Browser Batch Rename command does not open/close files.

If Photoshop’s renaming options are insufficient, search on UTILITYPGMS

71. BATCH AUTOMATION – Renaming Files and Not Having to Start at 001

UP
71.1 Q: I’m color correcting a folder of images using File > Automate > Batch and want to assign a two-digit serial number as part of each processed image’s file name. How can I start the numbering with, say, 14, instead of 01? 

A: If you have Photoshop CS, there’s a provision for specifying a starting value in the File > Automate > Batch dialog. 

If you don’t have CS, here’s the trick: Instead of selecting 2 Digit Serial Number from one of the File Naming dropdown menus, which would start with 01, type #14# instead. This will assign 14 to the first image processed, 15 to the second, etc.

You can use the same approach if you want to use, say, five or six digit numbers, options not included in the dropdown menu. Here are two examples:  #00001# and #000025#.

72. BATCH AUTOMATION – WORKAROUND: PLUG-INS WHOSE SETTINGS DON’T RECORD

UP
IMI3RD

72.1 Q: I just purchased a 3rd party plug-in to perform a specialized function and recorded an action to apply this functionality to a folder of images. Although the Show/Hide Checkbox is unchecked for the step, when I play the action through File > Automate > Batch, a dialog box for the plug-in appears for each image processed. Why is this and is there anything I can do about it? 

A: As noted elsewhere, some 3rd party plug-ins are not action friendly, that is, even though the Show/Hide Checkbox is off for its step, without a little trickery its dialog is displayed no matter what. 

Here’s a terrific workaround I learned from Scott DuBose:

· Immediately after recording the 3rd party plug-in command in the action, choose Insert Menu Item from the Actions Palette Menu.

· On the Filter menu click the top entry that corresponds to Ctrl + F, the plug-in just applied. This will populate the on-screen Insert Menu Item dialog. Click OK to insert the command into the action.

· Important: Note the inserted command: Play last filter menu item
· Either delete or disable the step just prior to the inserted Play last filter menu item command. It is no longer needed.

Important: Before applying the action via File > Automate > Batch, you’ll have to remember to:

· Open any test image

· Apply the 3rd party plug-in to it using the desired settings

· Close the test image

· Open the File > Automate > Batch dialog and apply the action to the folder of images. The action will run without interruption.

Here’s why this works:

· Each time you make a selection from the Filter menu and apply it, Photoshop stores the relevant information, e.g., the filter (or plug-in) name, settings (if any), etc. Being able to retrieve this information is the basis for keyboard shortcuts Ctrl + F and Alt + Ctrl + F.

· When the action executes the Play last filter menu item command, it uses the information stored when the plug-in was applied prior to starting the action via File > Automate > Batch. 
- - - - - -

72.2 Q: Why not just record a Ctrl + F keyboard shortcut following the step that invokes the plug-in? 

A: The command recorded in response to Ctrl + F is exactly like the one recorded when the plug-in is selected from the Filter menu, which does you no good. The desired Play last filter menu item command can only be inserted as described previously. 

- - - - - -

72.3 Q: Are there any limitations to this workaround? 

A: Yes. It only works if you want to record one troublesome plug-in step in the action. No other filters or plug-ins steps can be present in the action. Recall that the workaround requires application of the plug-in before the action is applied through File > Automate > Batch. The Play last filter menu item in the action only has access to information about the last filter.

- - - - - -

72.4 Q: What if the action has already been recorded and I want to modify it?

A: Before modifying the action:

· Open any test image

· Apply the 3rd party plug-in to it. It makes no difference what settings are used here. Settings are important only when the plug-in is applied just before the action is invoked through File > Automate > Batch.

· Close the test image

To modify the action:

· Click on the step that invokes the plug-in

· Choose Insert Menu Item from the Actions Palette Menu.

· On the Filter menu click the top entry that corresponds to Ctrl + F, the plug-in just applied. This will populate the on-screen Insert Menu Item dialog. Click OK to insert the command into the action.

· Disable (or delete) the original step that invoked the plug-in.

STOPINBATCHNONO

73. Batch Automation – Why Stop Commands are a No-No
UP
If an action invoked through File > Automate > Batch includes a Stop command and one clicks the Stop button in the dialog box, the action cannot be resumed by clicking PLAY. It’s an architectural thing and is what it is. So, don’t bother with Stop commands with batch processing.

- - - - - -


73.1 Q: I have written an action that includes a Stop Command that allows me to type in a custom proof number into a text layer for each image. After entering the proof number I click PLAY to resume. This works fine one image at a time, but it doesn’t work when I try to use it with File > Automate > Batch. What am I doing wrong? 

A: You’re doing nothing wrong. If File > Automate > Batch is interrupted by a Stop Command, as noted above it loses track of where it was among the images in the source folder and, therefore, cannot be resumed. (Joe Filer) 

To accomplish this seemingly simple task one option would be to write a script. Search on PSSCRIPTING

74. BATCH AUTOMATION – WORKAROUND: WHEN A STOP COMMAND IS NEEDED
UP
74.1 Q: But what if I NEED to exit from an action to perform some sort of manual task. Isn’t there some way I can batch process my images? 

A: Yes. Here are two not entirely elegant but functional workarounds. They aren’t pure batch automation, in that neither involve File > Automate > Batch, but through actions and images opened beforehand can improve throughput over standalone actions.

The first assumes the Stop Command was to have been the last step in the action:

· Assign a keyboard shortcut to the action. Search on KEYBOARDSHORTCUTS
· Modify the action so a Close (with Save) command is recorded as the last step in the action. (Open any test image, modify it in some way, click on the Action Name, Record (●), File > Close and accept changes, Stop (■). Drag the command to the first position in the action.) 

· Modify the action to disable or just delete the Stop Command
· Duplicate the folder of images you want to modify (as a precaution).

· Close any open images.

· File > Open the source folder and select multiple images, as many images as can, subject to RAM limitations. These will appear in your Photoshop window.

· Open any test image.

· Enter the keyboard shortcut to play the action. The first step will save close the test image just opened, then apply its commands to the first available open image. When the ends, perform the manual task as needed.

· Play the action again. The first step will save and close the first “real” image and then apply its commands to the second available open image. Continue playing the action until all images are processed, then repeat the steps described in the previous two bullets as many times as needed.

Here’s a workaround if the Stop Command was to have been followed by other steps:

· Assign a keyboard shortcut to the action. Search on KEYBOARDSHORTCUTS
· Modify the action so a Close (with Save) command is recorded as the last step in the action. (Open any test image, modify it in some way, click on the Action Name, Record (●), File > Close and accept changes, Stop (■).) 

· Duplicate the folder of images you want to modify (as a precaution).

· Close any open images in Photoshop’s window.

· File > Open the source folder and select multiple images, as many images as can, subject to RAM limitations. These will appear in your Photoshop window.

· Enter the keyboard shortcut to play the action, which will apply the steps until the Stop Command is executed. When the Stop Command dialog box is displayed, click the Stop button and perform the manual task as needed. When the manual task is complete, click Play (►) to resume the action which will execute the remaining tasks, finishing up with the Close (with Save) step.

· Continue playing the action until all images in the Photoshop window are processed. Repeat the steps described in the previous two bullets as many times as needed.

75. BATCH AUTOMATION – LIMITATION: INSERTING FILE NAME 

UP
75.1 Q: I have about 150 images and I’d like to include the file name of each on a separate layer, but I’m stuck. How can I do that? 

A: Unfortunately not with actions and, therefore, not through File > Automate > Batch. There are low-cost and sometimes free programs that have this capability or you can investigate Photoshop Scripting. 

Search on UTILITYPGMS


Search on ADDFILENAMEWITHSCRIPT

76. BATCH AUTOMATION – RAW CONSIDERATIONS 

UP
76.1 Q: What do you know about batch processing files in RAW format? 

A: This is a very good resource: http://www.rogercavanagh.com/pstips/13.htm
77. BATCH AUTOMATION – RAW FILES AND DR. BROWN’S IMAGE PROCESSOR

UP
77.1 Q: What do you know about Dr. Brown’s Image Processor? 

A: Dr. Brown’s Image Processor is a free, easy to use PS CS-only utility written in JavaScript that through batch processing allows you to apply settings of your choice and convert RAW files into .tif, .jpg and/or .psd format. You have the option of selecting multiple output formats  and specifying format-specific destination subfolders in a single pass as well as resize images or add copyright information. All this and more. 

Although there is a scripting plug-in for PS 7, this utility is not compatible with PS 7. It does work on PCs and Macs running CS. 

The script file, documentation and QuickTime tutorial can be downloaded here:

http://russellbrown.com/body.html
(Dave Lewis, Mike Flaherty)

78. BATCH AUTOMATION – MOST COMMON ERRORS USING FILE > AUTOMATE > BATCH

UP
78.1 Q: What’s the most frequent mistakes people make when first using File > Automate > Batch?  

A: These are the most common:

· Recording unnecessary Open, Close or Save commands.

· Turning on ‘Override Action “Open” Commands’ when there is no Open command in the action. Search on NOFILES1
· Not turning on ‘Override Action “Open” Commands’ when there is an Open command in the action.

· Turning on the ‘Override Action “Save As” Commands’ when there is no Save As… command in the action. Search on NOFILES2
· Not turning on the ‘Override Action “Save As” Commands’ when there is a Save As… command in the action.
· Including STOP commands. Search on STOPINBATCHNONO
79. BATCH AUTOMATION – TUTORIAL LINKS

UP
79.1 Q: How about some Batch Automation tutorial links? 

A: I thought you’d never ask:

This set of three tutorials is very good. Definitely check these out.
http://designdsk.com/Tips/action/Tipsx.htm
Others:
http://graphicssoft.about.com/library/extra/blps_batch.htm
http://www.creativemac.com/2002/04_apr/tutorials/psbatch.htm
http://www.cbtcafe.com/photoshop/batch/batch.html

http://www.rogercavanagh.com/actions/04_fileauto.htm
http://www.webclass.ru/tut.php?tut=127
http://www.corporatemedianews.com/2002/04_apr/tutorials/psbatch.htm
Step-by-step to develop an action for batch cropping:
http://www.digimorph.org/resources/dmc/handouts/pdf/PS 6.pdf
Important: The author of the following well written tutorial is the Webmaster of an XXX porn site. If you restrict your reading to parts 1 and 2, you won’t be offended.
http://www.niched-hubs.com/articles/photoshop-actions-workshop/index.htm
Creating Web thumbnails.
http://www.casabasa.com/2ndlevel/batch.htm
Applying Auto Levels, Auto Contrast and sizing the image.

http://www.fcs.iastate.edu/computer/tips/batchphotoshop/default.htm
Brief and to the point. Good description of the File > Automate > Batch dialog. http://www.ucd.ie/avc/html/homepage/hintstiPS 6.htm
Roger Cavanagh’s site: http://www.rogercavanagh.com/actions.htm
DROPS

80. BATCH AUTOMATION - DROPLETS

UP
Once you get familiar with the File > Automate > Batch dialog and find yourself using it on a regular basis, it might occur to you that specifying the source and destination folders each time plus choosing among the options is a bit of a hassle — not to mention redundant.

To avoid repeated entry of File > Automate > Batch settings, one can use droplets, introduced in Photoshop 6.

In the same way actions automate the application of a sequence of Photoshop commands, droplets (in a sense, but not exactly) automate the application of an action by recording the settings one would make in the File > Automate > Batch dialog. 

- - - - - -

80.1 Q: What is a droplet and where does a droplet come from?  

A: A droplet s technically an executable file (.exe) and is created by the File > Automate > Create Droplet dialog, a dialog is very similar to the File > Automate > Batch dialog. 

- - - - - -

80.2 Q: What are the differences between the Automate > Droplet and Automate > Batch dialogs?  

A: The differences are minor. Create Droplet has no controls for specifying source images and includes Save Droplet In controls enabling you to specify placement of the Droplet file.

- - - - - -

80.3 Q: What’s the differences between an action and a droplet?  

A: When you play an action Photoshop must be open, that is you must do so within Photoshop. 

You initiate a droplet outside of Photoshop. There’s no provision inside Photoshop to launch a droplet. 

A droplet causes Photoshop to play an action. An action, by itself, has no effect on an existing droplet.

- - - - - -

80.4 Q: Can I create Droplets using the same action, but specifying different options?

A: You sure can. Just be sure when you assign a file name to the droplet file you make it descriptive enough to distinguish the functions of droplet A from droplet B.

- - - - - -

80.5 Q: Since the Automate > Create Droplet dialog has no controls for source images, how does a droplet know where to get them?

A: The image source for a droplet is, “You.” See next question.

- - - - - -

80.6 Q: How do I play a droplet?

A: Here are the steps:

· Open the folder containing the droplet

· Open the folder(s) containing the folder(s) or individual images to be processed by the droplet

· Drag and drop the icon(s) of the image(s) and/or folder(s) containing images onto the droplet icon. This launches the droplet which invokes Photoshop to process the image files. 

The Droplet places processed images in the location specified in the Destination dialog. 

- - - - - -

80.7 Q: In other words dragging and dropping any of the icons listed below  initiate the droplet, correct?

· An individual image

· Two or more individual images

· A folder containing any combination of individual images, folders of images, shortcuts (or aliases) pointing to other images or folders of images

A: Correct. 

- - - - - -

80.8 Q: Can I drop the image or folder icons onto a shortcut (alias) of the droplet executable?

A: Yes.

- - - - - -

80.9 Q: Does Photoshop need to be open to execute a droplet?

A: No. Photoshop will automatically open (if not already open) when a Droplet launches.  

- - - - - -

80.10 Q: Since a droplet is just a file, can it be distributed to others like an .atn file?

A: Yes it can. Don’t forget to take into consideration Destination folder specifications that must be met on each machine the Droplet runs and that Photoshop must be present on ones system.

- - - - - -

80.11 Q: Can droplets be modified?

A: Yes under ImageReady, no under Photoshop. Go figure. 

Changes to any droplet setting or Destination specification requires that it be recreated from scratch in the Automate > Create Droplet dialog. When the Droplet file is saved, replace the previous edition.

- - - - - -

80.12 Q: What can I do to make droplets execute faster? 

A: Search on GOFASTER
- - - - - -

80.13 Q: If I create a droplet under Photoshop for Windows, will it run on a Mac? 

A: Yes, with a little help. Besides cross-platform length of file name issues there are minor technical details worthy of note. Consult Photoshop Help topic “Creating droplets for use on different operating systems.”  

If a Mac droplet is introduced in a Windows environment, be sure to rename the file and add the .exe file name suffix.

- - - - - -

80.14 Q: Did you run across any useful droplet tutorials?

A: Not many. 

The first one proceeds from action development through Droplet creation. The text is a bit hard to read (white on lavender) and the graphics not of the highest quality, but it’s better than none:

http://www.squashduck.com/ltd/photogallerymanipulated/tutorial/actionstut.htm
There’s a brief mention of Droplets in this one: http://www.pcquest.com/content/multimedia/103101101.asp
81. Batch Automation – Droplets vs. File > Automate > Batch

UP
81.1 Q: What’s the difference between playing an action through the File > Automate > Batch dialog and using a Droplet? 

A: Each time you engage File > Automate > Batch and specify a different action, you must manually select options. 

To play a droplet, no settings need be entered. Settings made in the File > Automate > Create Droplet dialog are saved when the droplet file is created.

- - - - - -

81.2 Q: What’s the benefit of batch processing images using a Droplet?

A: With Automate > Batch it’s easy to make setting changes, normally to Source or Destination. 

Some people prefer use the Source menu and Choose dialog to specify the location of source images rather than dragging and dropping icons on top of the droplet icon. 

- - - - - -

81.3 Q: What’s the benefit of droplet over batch processing?

A: The convenience of drag and drop and the ability to easily select multiple images or folders of images to process.

Not having to specify setting each time a droplet is executed. The settings are saved with the droplet. 

82. Batch Automation – THE CONVENIENCE OF A DROPLET AND FLEXIBILITY OF BATCH

UP
BESTOFBOTH

82.1 Q: Can I have the convenience of saved settings like a droplet has and the flexibility of changing Source and Destination of Automate > Batch? 

A: Yes you can: 

· Write and test your action in stand alone mode.

· Further test it through the File > Automate > Batch dialog

· Start recording a new action.

· Engage the File > Automate > Batch dialog. When it finishes a Batch command will be recorded in the action.

· Click STOP to terminate recording.

Comments 

· If you play the action and the Display Dialog checkbox for the Batch command is unchecked, images will be processed according to recorded settings, just like a droplet. You will not have to completely repopulate File > Automate > Batch settings each time.

· If any settings need to be changed, turn on the Display Dialog checkbox, make changes as needed and click OK.

83. BATCH AUTOMATION – Making Actions and Droplets Play Faster

UP
GOFASTER

83.1 Q: What can I do to make File > Automate > Batch go faster?
A: Check this out for Adobe’s advice on this topic in general:
http://www.adobe.com/support/techdocs/12dde.htm
These may help by reducing RAM requirements and eliminating screen redraw steps:

· Probably the most significant improvement will come from choosing Accelerated in the Actions Palette Menu’s Playback Option command

· History options: Turn off Automatically Create First Snapshot 

· Edit > Preferences > General – History states: Set to 1.

· Edit > Preferences > Memory and Image Cache – Cache Levels: Set to 1.

(If you’re feeling ambitious you could write two actions, one to make these settings and another to reset them to their normal settings.)

· Some actions are designed (with good intentions) to generate a lot of layers and not merge any during flight, but the downside is generating enormous images which eat Photoshop’s lunch. In some cases these types of actions can be modified safely to merge layers on the fly.

· Some actions work well on low resolution images, e.g., 72 ppi, while the same action really bogs down with higher resolution images, e.g., 300 ppi. If you can get away with it (like with a photo-art action), in some cases downsizing an image beforehand can help a lot. 

PSSCRIPTING

84. SCRIPTING

UP
84.1 Q: What should I know about Photoshop Scripting? 

A: If you have programming skills in Microsoft Visual Basic for Applications (VBA), AppleScript or JavaScript, you can use these powerful languages to write scripts capable of achieving results far beyond what’s possible with actions. 

Photoshop Scripting is built into Photoshop CS, but needs to be added to Photoshop 7 via a plug-in downloaded from http://www.Adobe.com.

Scripting is built into PS CS; it’s a standalone download (plug-in) for PS 7. 

From the Photoshop Scripting Guide: 

“Any Windows system that runs Photoshop CS will support scripting. You will also need either the Windows Scripting Host, Microsoft Visual Basic, or one of the applications that contains a Visual Basic editor. Most Windows systems include the Windows Scripting Host. 

“If you do not have Windows Scripting Host or would like more information about Windows Scripting Host, visit the Microsoft Windows Script Technologies Web site at: http://msdn.microsoft.com/scripting/.“ (Jim Lewis) 

Additional information can be found here:

· Go to the Photoshop Scripting forum at www.adobeforums.com
:
http://www.adobeforums.com/cgi-bin/webx?13@171.HEX0aaMJaxN.3@.ef7f2cb
· Adobe Scripting: Your Visual Blueprint to Scripting in Photoshop and Illustrator, ISBN: 0764524550. This book addresses JavaScript only. (Excerpt link courtesy of PierreC): http://media.wiley.com/product_data/excerpt/50/07645245/0764524550.pdf
· AppleScript: http://www.apple.com/applescript/
· PhotoShop Script Builder: http://www.ksscinc.com/ps_script_builder.htm
· Roger Cavanagh’s site: http://www.rogercavanagh.com/actions.htm
· Yahoo discussion group: http://groups.yahoo.com/group/PS_scripting/
- - - - - -

84.2 Q: How is a script different than an action? 

A: JavaScript, AppleScript and Visual Basic for Applications (VBA) are programming languages used to write (program) scripts. Actions are written using the controls and commands available from the Actions Palette.

Scripts can be programmed to perform to execute functions and exercise capabilities not possible in actions such as if-then-else type constructs, Boolean operators, the ability to make comparisons and perform complex calculation, looping, branching, etc. In addition scripts can access data objects that are not available to actions such file names, image dimensions, EXIF information, etc.

The outcome of a given script can vary. Scripts can be programmed to carry out some or all commands within the script, or carry out commands in varying sequences depending on the results of calculations or comparisons. 

Although the outcome of an action can vary based on command settings made by the user as it plays, all commands are executed in exactly the same sequence each time.

Since Java and VBA are programming languages, having programming experience is almost a must in order to write your own scripts. (While it is possible to download scripts written by others, much like actions can be downloaded, modifying prewritten scripts in order to customize their results also requires programming background.)

Although actions have considerably less functionality, they are very powerful and can be recorded by those who have never dreamt of programming a computer.
- - - - - -

84.3 Q: Can I install Scripting on Photoshop 6? 

A: No. The Scripting plug-in is an optional and separate download/install for PS 7. The Scripting facility is installed by default with Photoshop CS.

- - - - - -

84.4 Q: Is it possible to write actions with the Photoshop Scripting facility? 

A: No. You can write scripts with the Scripting facility, but not actions. (Trevor M)

- - - - - -

84.5 Q: Can scripts play actions? 

A: Yes.

- - - - - -

84.6 Q: Can actions play scripts? 

A: Yes, the command to invoke a script can be recorded. (KentC)

- - - - - -

CONDITIONALEXECUTION

84.7 Q: If an action can invoke a script, then in theory one could invoke an action through File > Automate > Batch that plays a script that conditionally executes two or more actions or other scripts, true? 

A: True. Check out following site wing link for an example an example script that illustrates the coding necessary to conditionally execute actions. The author has confirmed that this model is supported by batch processing initiated by File > Automate > Batch.
http://www.hanfordlemoore.com/photoshop/
- - - - - -

84.8 Q: Can you give some examples of what a script could do that an action could not? 

A: Since scripts can do calculations, a script could be programmed to examine pairs of images in folder, determine which of the pair was larger and apply further changes accordingly. 

Scripts can determine whether an image is in RGB, CMYK or another mode and apply subsequent steps or filters appropriate for the color space. 

A script can access data like file name, today’s date or EXIF information and format text layers with it. In addition font types and sizes could be selected based on image dimensions, e.g., 18 point Ariel for an 8” x 10” image and 10 point Courier for a 6” x 4” image.

These examples don’t even begin to scratch the surface of scripting possibilities.

If you had a folder of images of various sizes, some in landscape and some in portrait orientation, a script could be written to examine each image and, if necessary, rotate it so all images would have the same orientation regardless of image dimensions.

- - - - - -

84.9 Q: Do scripts and actions have any similarities? 

A: In neither can you record strokes from tools like the Brush, Clone, Eraser, History, Art History, Dodge, Burn, etc.

Scripts can be programmed to invoke actions. Steps can be recorded in Actions to invoke scripts.

- - - - - -

ADDFILENAMEWITHSCRIPT

84.10 Q: Do you know where I can get a script to place an image’s file name onto a separate layer?

A: Sure do (see following). Note: You will need to register at this site before the script can be downloaded:  

http://www.retouchpro.com/forums/showthread.php?s=&threadid=7468


- - - - - -

84.11 Q: Are there alternatives to Photoshop Scripting?

A: None that I’m aware of on the Windows side of the world. 

For Macs look into Event Software’s PhotoScript, CE Software’s QuicKeys as a supplement to or replacement for functionality provided by actions.

- - - - - -

84.12 Q: Do I have to worry about getting a virus from a script? 

A: Like an .atn, a script file itself cannot transmit a virus per se, but a maliciously programmed script could do considerable damage to one’s system, for example, delete all files in \My Documents.

Sometime in the future it wouldn’t surprise me if sites start popping up where scripts can be downloaded as easily as actions are today. When that time comes it would be wise check the script before running it the first time, just like you do now for new actions. 

- - - - - -

84.13 Q: Will Photoshop Scripting eventually replace actions? 

A: In my opinion, no. Action development does not require sophisticated computer programming skills, whereas scripting does to varying degrees. I can’t imagine Adobe pulling the plug on actions which are used by so many customers in favor of a method whose skill requirements would preclude most users from using it. Not only that, abandoning actions would deter, not encourage, users from upgrading to new version of Photoshop.

- - - - - -

84.14 Q: Does Photoshop Elements support scripting? 

A: No.

85. ALTERNATIVES TO ACTIONS, SCRIPTING AND BATCH PROCESSING 

UP
UTILITYPGMS

85.1 Q: Do you know of any products that don’t require scripting expertise that can be used to get around the awkwardness and/or limitations of actions and File > Automate > Batch? 

A: Yes. See the list below.

In a perfect world Photoshop would provide all the functionality necessary to meet digital image processing needs, but alas it’s not to be. To Adobe’s credit each version of Photoshop seems to add a few features that are badly needed. It just seems like their inclusion is 2-3 years late. 

There’s good news: Over the years some creative and enterprising folks recognized these functional gaps and to their credit developed a number of programs to meet these needs. 

Some of the following programs are free; most appear to be modestly priced. Come to think of it, just about anything is modestly priced compared to the retail cost of a standard edition of Photoshop.

Functionally speaking I’m told they run circles around Photoshop when it comes to tasks like image organization, renaming, resizing, making contact sheets, conditional rotation, watermarking, applying copyrights and signatures and providing easy access to fields like file name, date, time and EXIF information. 

I have not used any of these personally and I leave to you to engage in research and evaluation to find the one(s) that meet your personal needs.  Your mileage will vary.

· Irfanview (free): http://www.irfanview.com/
· ACDSee:  http://www.acdsystems.com/
· Breezebrowser: http://www.breezesys.com/BreezeBrowser/
· DCE: http://www.mediachance.com/dce/index.html
· Qimage: http://www.ddisoftware.com/qimage/
· ThumbsPlus: http://www.cerious.com/
· EasyThumbnails (image resizing): http://www.fookes.com/ezthumbs/
· The Rename (free - batch rename):
http://www.herve-thouzard.com/therenamea.phtml
· CopyrightLeft:
http://www.webattack.com/get/copyrightleft.html
· DropWaterMark from LAJ Design: http://www.lajdesignsw.com/DWM.html
· PhotoWatermark: http://www.photowatermark.com/
· Dr. (Russell) Brown’s Image Processor: http://www.russellbrown.com/tips/pdf/Dr_Brown.pdf 

· Watermark software from a lookup at tucows.com: http://www.tucows.com/watermarking_default.html:

J. HELP — ACTIONS

UP
1. HELP! INTRODUCTION

UP
The following topics attempt to address some of the more common problems that occur when playing or dealing with actions. 

Frequent sources of errors include:

· Actions can only apply commands if conditions permit, for example, if the Background is the active layer and the action attempts to add a layer mask, it will fail. Backgrounds can’t have layer masks.

· Some commands work on images of certain types: If your image is a .gif and the action tries to apply an Unsharp Mask filter, it will fail. You cannot apply some effects to .gif images.

· Some commands will not work on images in certain color spaces: An action will fail trying to apply the Texturizer filter to an image in CMYK mode.

· Trying to select brushes, presets, textures or other files that for one reason or another don’t exist on your computer.

· Some actions require you to use one of the selection tools, e.g., Lasso, Elliptical Marquee, etc. to make a selection before playing the action. Without an active selection, the action will bomb.

· Actions written in a language edition of Photoshop different than yours can fail because of language specific file name or layer name differences. (PierreC).

While some action authors anticipate these types of situations and write their actions accordingly or include guidelines in ReadMe file or display them in STOP message, many do not. 

As the person who will most likely diagnose and correct your action problems, over time you will develop expertise in recognizing the symptoms when an action fails trying to do something it is not permitted to do or able to do under the circumstances.

2. HELP! Deleting Photoshop Preferences: A common cure

UP
2.1 Q: Photoshop is starting to act weird. I’m getting error messages I’ve never gotten before. Ever heard of this?

A: Sure have. Sometimes the symptoms appear to be related to actions,  sometimes not.

“Deleting the Preferences File,” Adobe Photoshop x.x Prefs.psp, is a common catch-all problem solving tactic, as in “If all else fails, try deleting this file.” 

Here’s a good article on the subject:
http://www.creativepro.com/story/feature/17478.html?origin=story
There are two ways to delete this file: 

· Automatically by simultaneously holding down Alt + Ctrl + Shift immediately after starting Photoshop

· Manually as described below. When there is no Preferences file at Photoshop startup, a new one is created with the default settings.

Note: If you are unable to locate this preferences file under Windows, it may be because the file is “hidden.” Here’s how to fix that:

· Open My Computer

· Tools > Folder Options 

· Click the tab labeled View 

· Click on option Show hidden files and folders 

Editorial comment: While I generally agree with the concept of creating a new preferences file, rather than deleting Adobe Photoshop 7.0 Prefs.psp, I would rename it to something like Adobe Photoshop 7.0 Prefs – old.psp instead. Then I would bring up Photoshop to see if the problem is corrected. (If no Adobe Photoshop 7.0 Prefs.psp is present, Photoshop creates a new one.)
Why rename rather than delete? Trashing the preferences file does not solve all problems. For such occasions it’s a lot easier to delete the “new” (just created) Adobe Photoshop 7.0 Prefs.psp and rename the previous one (change the Prefs – old.psp back to Prefs.psp) than plowing through all the preferences dialogs again to customize your Photoshop environment.

3. HELP! PLAY (►) IS GRAYED-OUT

UP
3.1 Q: I’ve selected (highlighted) an action, but Play on the Actions Palette Menu and Play (►) are grayed-out. What’s going on?

A: You probably meant to highlight an action, but clicked on an Action Set Name instead. Click the Show/Hide Triangle to the left of the Action Set Name (() so it points down ((), revealing the actions inside. When you click an Action Name, Play and Play (►) will be available. 

4. HELP! PLAY (►) IS GRAYED-OUT (2)

UP
4.1 Q: This is crazy. Not only is Play (►) grayed-out, I can’t scroll. None of the buttons work. Can you help?

A: It’s a bit embarrassing to tell on myself here, but here goes: I’d taken a screenshot of the Actions Palette and had pasted it into a new Photoshop window. I was trying to click buttons on the screen shot image, not the real buttons on the Actions Palette.

5. HELP! WHEN I CLICK PLAY (►) NOTHING HAPPENS
UP
5.1 Q: An action I play all the time all of a sudden just won’t play. I verified that I’m definitely highlighting the Action Name, not the Action Set Name, but when I click PLAY, nothing happens. Not a whimper. I don’t get it. How can I get this action going again? 

A: Here’s probably what happened. The Enable/Disable checkbox to the far left of the Action Name probably got turned off by mistake. When this happens it turns the Enable/Disable checkbox off for every step in the action. When the action is played all steps are skipped.

To undo this click the Enable/Disable checkbox to the left of the Action Name which will turn on all steps in the action. (PierreC) 

6. HELP! WHEN I CLICK PLAY (►) NOTHING HAPPENS (2)
UP
6.1 Q: Just checked: The Enable/Disable checkboxes for all commands are all on. What else could it be? 

A: Check the action steps. Is the first step a Stop Command? If so, is the Display Dialog checkbox off? If so, that’s the problem.

Photoshop executes the Stop Command, which pauses the action. Since the Display/Dialog checkbox is off, no message is displayed indicating what’s up.

Either turn on the Display/Dialog checkbox for the Stop Command (it will probably display a dialog with a button labeled Continue) or turn off the Enable Command checkbox, which will cause the Stop Command to be skipped. 

7. HELP! WHEN I CLICK PLAY (►) ONLY PART OF THE ACTION RUNS
UP
7.1 Q: I click PLAY (►) and the action plays about halfway through, then just stops.
A: Check the action steps. Is the last step the action plays a Stop Command? If so, is the Display Dialog checkbox off? If so, that’s the problem.

Photoshop executes the Stop Command, which pauses the action. Since the Display/Dialog checkbox is off, no message is displayed indicating what’s up.

Either turn on the Display/Dialog checkbox for the Stop Command (it will probably display a dialog with a button labeled Continue) or turn off the Enable Command checkbox, which will cause the Stop Command to be skipped. 

8. HELP! WHERE DID ALL THESE DIALOG BOXES COME FROM?

UP
8.1 Q: All of a sudden an action I’ve had for quite some time and use regularly is displaying a dialog box for every step. It used to only ask for Unsharp Mask settings. What happened and how can I get it back the way it was? 

A: This is probably what happened. The Display Dialog checkbox next to the Action Name probably got clicked on by accident. When this happens it turns the Display Dialog checkbox on for every step in the action, so that when the action is played, a dialog box is displayed for each step that has one.

To undo this, click the Show/Hide Triangle next to the Action Name, revealing the steps in the action. For steps that you don’t want a dialog box displayed, uncheck the corresponding Display Dialog checkbox. 

9. HELP! "No files are selected in the File Browser"
UP
9.1 Q: I’m trying to play an action through the File > Automate > Batch dialog. I’ve played this action many times before, but now I’m getting this message. What can I do?

A: Check the source folder. It’s probably empty. (Steve Zez) 

NOACTIONS

10. HELP! ACTIONS PALETTE: I CAN’T OPEN THE ACTIONS PALETTE MENU
UP
10.1 Q: I click and hold on the black triangle (►) located at the top-right of the Actions Palette to display its menu, but it doesn’t open. What am I doing wrong?
A: You are probably running Windows 95, 98 or ME and have exceeded a menu limitation. Remove some .atn files from:

C:\Program Files\Adobe\Photoshop 7.0\Presets\Photoshop Actions
Windows NT, 2000 and XP do not have this menu limitation. (Chris Cox, Dave Milbut) 

11. HELP! ACTIONS PALETTE: IT WOn’T STAY IN BUTTON MODE
UP
11.1 Q: I selected Button Mode from the Actions Palette Menu. Then I shut down Photoshop. When I opened Photoshop later, the Actions Palette came up in List Mode. That’s never happened before. Is something broken? (Yesiam1996)
A: It could be a corrupt preferences file (bottles). Search on DELETEPREFS
Meanwhile, back at the ranch, did this help?

After Yesiam1996 deleted his preferences file, the next time Photoshop came up a new Adobe Photoshop 7.0 Prefs.psp was automatically created and the Actions Palette was displayed in List Mode (the default). He switched the Actions Palette to Button Mode, shut down and then started Photoshop again. This time the Actions Palette came up in Button Mode as expected. Problem solved.

12. Help! PLAY BUTTON: I CAN’T FIND IT
UP
12.1 I’m playing an action and get a message that says, “Pick a foreground color, then hit Play.” So I click the button labeled Stop in the dialog box, select a foreground color and darned if I can find PLAY anywhere, so I’m stuck. Where is this so-called “Play Button”? 

A: If the Actions Palette is in List Mode, you will find PLAY among the controls at the bottom of the Actions Palette. It’s the one shaped like a triangle ►. 

If by chance the Actions Palette is in Button Mode (in this mode to start an action you click its corresponding button on the Actions Palette), you must first change from Button Mode to List Mode by clicking Button Mode (I know, this looks wrong, but it isn’t) from the Actions Palette menu. In this mode, as noted above, Play (►) is visible at the bottom of the palette. 

13. Help! PLAY BUTTON: IT’S GRAYED OUT
UP
13.1 I want to play an action, but Play (►)  is grayed out and not available. What do I do? 

A: You must select (highlight) an Action Name before Play (►) is available. If you have selected an Action Set Name, Play (►) is grayed out.  

14. HELP! “Can't load action because there is not enough memory.”
UP
14.1 I’ve got a Mac and when I try to load and action that was just unzipped I get this error message: “Can't load action because there is not enough memory.” I’ve got a G4 with acres of RAM so I quadrupled PS's memory allocation to over 800 MB and it doesn’t help. It’s only a 7KB .atn. How is this possible? 

A: A: Thanks to Ivan Good, I’ve got a great suggestion. Ivan had this same problem and did some fine troubleshooting to diagnose it. Here’s what he discovered.

Zipit, the program he used to unzip the original .zip file, was the culprit. Although Zipit appeared to unzip the .zip file successfully, as it turned out the .atn file was somehow corrupted in the process. When Photoshop attempted to load the damaged file, it triggered an error causing Photoshop to display the misleading (at best) error message above. 

Anyway, here’s the solution: You may need to upgrade Zipit (or whatever program you’re using) to a new version or unzip the file using a different program such as StuffIt or StuffIt Expander. 

15. HELP! GENERAL SELF-HELP APPROACHES

UP
15.1 Q: When I played an action for the first time it stopped in the middle and Photoshop displayed an error message I didn’t understand. What do I do now?

A: Welcome to “Realities Of Actions, Part I: Actions Written by Other People Are Sometimes Posted For Download Before They’re Ready For Prime Time!” 

An action can fail for a number of reasons including:

· It was written poorly to begin with and just doesn’t work.

· Insufficient testing. The action may have worked for the author on the image(s) he tested, but due to testing or development inexperience or oversight it wasn’t checked out under the circumstances that caused it to fail on your computer.

· It was written using a language version of Photoshop different than yours and your version encountered an incompatibility. 

· Action author assumptions, such as: 

· The image is flat (has a Background only) when it actually consists of multiple layers. 

· The image has a Background when in fact you converted the Background to a regular layer.

· The active layer is the one at the top of the Layers Palette, but when you play the action a layer other than the one at the top of the stack is active.

· You will have made a selection before playing the action.

· The image is in 8-bit, RGB.

· You will play the action on images of certain characteristics such as one with neutral lighting, but your image has high key lighting. (PierreC)

· The subject image is low resolution, whose intended destination is the Web, but the action was designed to be applied to high resolution images that will ultimately be printed. (PierreC)

· The subject image is high resolution, but the action was intended for low resolution images. (PierreC)

Regarding your specific problem and how to solve it, it’s hard to say without seeing the error message and the action. 

What to do?

Try this first: A common cure is to duplicate your image (for safety reasons), flatten the duplicate and make sure it’s in RGB mode (Image > Mode > RGB color). Run the action against the flattened, duplicate image.

If you understand what caused the error AND have the skills to implement corrective changes, duplicate the action for backup purposes, make changes and try it again. 

Not ready to modify actions yet? Here are a few considerations:

· Search the Internet using some or all of the Photoshop error message text. Sometimes solutions are a Google.com search away.

· Some authors include their Website or e-mail address in the text of a Stop Command. If so, you might try to contact the author for assistance.

· Post a question on a Photoshop forum with the full text of the error message and preferably with an attachment or a link to a site where you’ve uploaded screen shots of the error message and/or your Actions Palette showing the steps of the failed action, with the failing step highlighted.

· Some forums, e.g., http://www.retouchpro.com/, support attachments to posts. Zip the failing action and attach it to a post requesting assistance. 

· E-mail the .atn to a friend or colleague who has more experience with debugging actions than you do. 

16. HELP! WHAT SETTINGS SHOULD I USE?

UP
16.1 Q: When I run this new action, numerous dialog boxes are displayed offering opportunities to make setting choices and adjustments. Since I’m new to Photoshop I have no frame of reference for correct settings. What should I do? 

A: Until you get a little experience you can always try the “bracket approach” in which you run the action three times, changing settings in one dialog box only:

· 1st run: No changes; accept the default settings

· 2nd run: Adjust settings “high”

· 3rd run: Adjust settings “low” 

As you gain more experienced with the action and Photoshop in general, your ability to anticipate the result of setting changes will improve. Judgment skills of this nature develop with time and practice.

17. Help! This Action Runs REALLY Slow

UP
17.1 Q: When I run this action it usually runs fairly quickly. Today I ran it and it was slow as frozen molasses. Why?

A: This is probably a case where the images against which you normally play this action are relatively small or only had a few layers. Overall image sizes grow very quickly if an action creates layers on the fly. If you start out with a larger than normal image and the action starts creating layers, progress can slow to a crawl. 

What can you do?

· Live with it if it’s not a huge inconvenience.

· Some actions can be modified to delete unneeded layers or merge some layer on the fly rather than retaining each individual layer.

· If you can get away with it, downsize the target image (Image > Image Size)

· There are some Photoshop settings that can be tweaked, but you’ll have to experiment to see if changes to them affect throughput enough to warrant the effort. Search on GOFASTER
18. HELP! THE ACTION IS FINISHED, BUT WHAT DO I DO NOW?

UP
18.1 Q: The result of playing most photo-art actions I’ve used is an arty version of the original image. The result of this new action, however, is several layers that I don’t understand and a message that instructs me to “Be creative and have fun!” What am I supposed to do?

A: Actions (photo-art or otherwise) can be crafted to generate a final result (applying all changes to the image) or built to generate numerous layers (also known as “building the environment”) assuming you will take over when the action completes to apply finishing touches.

Some action authors presume you’ll know what to do and provide no further guidance. In those cases it’s “Fend for yourself time.” 

If the action arrived in a .zip file, check for a ReadMe.txt file which may include helpful hints.

Check the Action Set for an action named something like, “ReadME” or “Play me first.” You might get lucky there.

If the action displays the author’s e-mail or website addresses you might be able to make direct contact to ask questions.

You might also check the action for disabled Stop Commands whose text might include contact or additional information. 

If all else fails consider seeking assistance by calling on friends or posting questions on your favorite forums.

19. HELP! HOW DO I UNDO THIS MESS?

UP
19.1 Q: HELP! I ran an action and it completely ruined my original image. I don’t know how to undo the damage. What can I do? 

A: It depends. Since actions typically consist of more than one command, a single Undo (Ctrl + Z) command is seldom helpful. Fortunately there are options beyond that.

· The History Palette I: 

· From the Window menu, choose History to show the History Palette. At the very top of the palette should be a thumbnail image that represents the original image. Click on the thumbnail. This should restore the image to its “before action steps were applied” state. 


For future reference if it’s not on, consider turning on the History Palette option “Automatically Create First Snapshot.” This causes a “before any changes were made” snapshot to be taken when the file is opened. 

If you do a lot of batch processing and/or time is an issue, this isn’t such a good idea as it will reduce throughput. (PierreC)

· The History Palette II: 

· Depending on how many steps the action has and how many history states (a Preferences setting) are retained before (what’s known as) wrap around occurs, clicking on the first history state may restore the original.


· Snapshot. Some actions create a snapshot of the original image before applying the commands. Check the History Palette (see above).

· Duplicated image. Some actions create a duplicate of the original image before applying commands. Check to see if this was done.

· Background. Some actions don’t modify the original Background. Turn off all layers except the Background. You may find it untouched. 

· File > Revert. If the action was applied to the original and did not execute a Save command, File > Revert will “revert to” an unmodified version of the file. 

· File > Close. To the option Save Changes? click No. This only works if the action did not execute a Save command. 

· Restore the image from a backup. If none of the above work, restore the original image from a backup copy. You’ve got a backup, right? 

· Rescan the image. If the source of the image was a hard copy print, rescan it.

20. HELP! DO I HAVE TO START OVER? 

UP
20.1 Q: I just finished playing a multiple step, multiple dialog box action. After it finished I realized that about three-quarters of the way into the action I really messed up. The setting I chose in a Gaussian Blur step completely hosed the outcome. Is there a way I can go back to that point, choose a different Gaussian Blur setting and continue from there instead of having to replay the entire action?
A: Maybe. It will depend on the number of steps in the action and the value specified in the Edit > Preferences > General History States setting. (See Photoshop Help topics on the History Palette.)

The following assumes the history state for the Gaussian Blur step has not been overwritten. If it has, the only solution is to play the action from the beginning. 

· Show the History Palette (Window > History).

· Click on the history state just before the one recorded for the Gaussian Blur command. This will undo all changes made from the Gaussian Blur step until the end of the action, restoring the image to its status just before applying Gaussian Blur. 

· Look through the action until you find the Gaussian Blur command you want to reapply and select (highlight) it.

· Click Play (►). This will restart the action with the blur step. 

21. HELP! I DOUBLE-CLICK AN .ATN, PHOTOSHOP OPENS, BUT I CAN’T FIND THE ACTIONS

UP
21.1 Q: I read in Photoshop User Magazine that if I double-click on an .atn file, Photoshop will load the Action Set File into the Actions Palette. I tried just that, but it didn’t work. Why? 

A: Assuming Photoshop is already open this method works on Macs, but not under Windows, a fact the Mac-centric folks at PUM most likely overlooked. 

Under Windows double-clicking an .atn does nothing if Photoshop is already open, otherwise Photoshop opens without loading the Action Set File.

Search on OPENWITH
22. HELP! RESTORING ACTIONS – ADOBE PROVIDED (Default.atn)

UP
22.1 I just deleted one of the actions in the Default set. Do I have to reinstall Photoshop to get it back?

A: No.

· From the Actions Palette Menu choose Reset Actions. (Note: Most commands that have a dialog box associated with them have ... following the menu choice, e.g., Save As ... . Although Reset Actions is not followed by ... , it definitely has a dialog box.)

· In the dialog box click the Append button. A new copy of the Default set will be loaded and will appear at the bottom of the Actions Palette.

· Either Drag and Drop the broken Action Set over the Trash ([image: image27.jpg]


) or Drag and Drop the replacement action to the original set from the set just appended. 

Here’s another way to restore this Action Set that takes a few more mouse clicks, but the result is the same.

· From the Actions Palette Menu choose Load Actions, then navigate to
C:\Program Files\Adobe\Photoshop 7.0\Required\ and load Default Actions.atn. 

Trivia tidbit: When Default Actions.atn is loaded into the Actions Palette via the Replace Actions command (the first method above), the Action Set Name in the Actions Palette is Default Actions.atn. When it’s loaded into the Actions Palette via the Load Actions command, the Action Set Name in the Actions Palette is Default Actions.

Very curious. Looks like an itty bitty bug to me.

23. HELP! RESTORING ACTIONS – ADOBE PROVIDED (FROM \Presets\Photoshop Actions)

UP
23.1 I just deleted an action from an Adobe-provided Action Set, which I’d loaded via the Actions Palette Menu. Do I have to reinstall Photoshop to restore the action?

A: As long as the Action Set File in \Presets\Photoshop Actions has not been changed, no reinstallation is needed. Delete the broken Action Set from the Actions Palette. Replace it with a fresh copy from \Presets\Photoshop Actions by choosing it from the Actions Palette Menu. 

24. HELP! RESTORING ACTIONS – ONES I WROTE OR MODIFIED

UP
24.1 I accidentally trashed my absolute, favorite Action Set. How can I get it back?

A: If a copy of the Action Set was created using a Save Actions command, the action set can be restored using a Load Actions command.

If by chance you duplicated the Action Set (see DUPLICATEACTIONS), use that copy.

If there is no backup Action Set or Action Set File, there’s still hope as long as you DO NOT SHUT DOWN PHOTOSHOP. Search on RESTOREACTIONFROMPSP 

25. HELP! RESTORING ACTIONS – RECEIVED VIA E-MAIL OR THE INTERNET

UP
25.1 I deleted an Action Set I downloaded from the Internet (or received through e-mail). Is there a way to get it back? 

A: Options:

· Locate the original .atn on your hard disk and (re)load it into the Actions Palette.

· Next to last resort. DO NOT SHUT DOWN PHOTHSHOP. There is a method to restore Action Sets even if you have no backup as long as you have not yet shut down Photoshop. Search on RESTOREACTIONFROMPSP 

· Last resorts: Hunt down the person who e-mailed the .atn to you, track it down on the Internet (again) or post a request for assistance on a public forum.

26. HELP! FINDING ACTION SET FILES (.ATN) ON MY HARD DISK

UP
STARTSEARCH

26.1 Q: If I want to find Action Set Files on my hard disk, how can I do that?

A: Mac folks: Use Sherlock for the following.

Use Windows’ search function (Start > Search > For Files Or Folders) or while holding down the ‘Windows Key’ (the one between the Ctrl and Alt to the left of the space bar), press F. 

In the Search for Files or Folders Named box type (literally) 

*.atn 

This search argument tells the search function to display all files regardless of the file name that have .atn (upper or lower case) as a file name extension.

In some cases Action Set Files may be stored within .zip files, so you may have to use *.zip as a search argument in a subsequent search.

27. HELP! FINDING ACTIONS ON MY HARD DISK

UP
27.1 I’m looking for a specific action that’s in one of the numerous Action Set Files spinning around on my hard disk. I know the Action Name as well as some unique words used in Stop Command messages that could be used for search arguments. Is there an easy way to find this action?

A: Easy? No. The Windows search function has no way to see inside an .atn file, so Action Name and/or unique text in a Stop Command message are of no value.

Plan B. Search on FINDLOSTACTIONS 
28. HELP! FINDING ACTIONS MISFILED IN THE ACTIONS PALETTE
UP
28.1 Q: I’ve got quite a collection of Action Sets in my Actions Palette. About six months ago I downloaded an Action Set from the Internet, found an action in it I liked and dragged the action into an existing Action Set. Now I can’t find this action and it’s no longer available for Internet download. Does Photoshop have a search function to locate actions like Windows does for files?

A: Unfortunately there’s no search function within Photoshop. If you misfile an action, it’s up to you to find it by clever means. 

One tactic would be to collapse all actions within an Action Set and search by eyeball. Collapsing them removes the visual distraction of action steps and their settings. 

Here’s an easy way to collapse all actions in an Action set. If the Show/Hide Triangle next to the Action Set Name is pointing down ((), while holding down the Alt key, click the triangle so it closes the Action Set. Then (without holding down the Alt key), click the Show/Hide Triangle again. All actions within the Action Set will be closed, revealing only the Action Names.

If the Show/Hide Triangle points sideways (►), click it to reveal the actions inside. If the Action Sets are not already collapsed, perform the steps above to collapse and then reveal them.

If you have no luck finding the desired action using the eyeball method, Plan B is an option here, too. Search on FINDLOSTACTIONS
29. HELP! FINDING LOST ACTIONS - A CLUNKY BUT FUNCTIONAL METHOD

UP
FINDLOSTACTIONS

29.1 Okay. What’s the clunky way to find a misfiled action, whether in the Actions Palette or not?

A: Here you go:

· If you positively know the missing action is among those in your Actions Palette, skip this step. If the lost action is hidden among an Action Set File spinning around on your hard disk, use Windows’ Search function to locate all .atn files on your hard disk. Search on STARTSEARCH
· Mass load all of these .atn files into the Actions Palette. Search on LOADFAST
· Save the contents of the Actions Palette as a text file (.txt). Search on MAKETXTFILE
· Open the text file with a text editor or word processing program and search on Action Name or unique text in a Stop Command until you locate the action. When you find it, scroll up until you see the Action Set Name.

· If you mass loaded Action Set files from your hard disk, select all of the ones you want to delete from the Actions Palette. Search on SELECTMULTIPLEOBJECTS
· Drag and drop the selected Action Sets onto the Trash ([image: image28.jpg]


).

30. HELP! E-MAIL ATTACHMENTS (RECEIVING)
UP
30.1 I received an e-mail with an .atn attached, but I can’t save it to my hard disk. What’s going on?

A: It’s hard to tell without knowing exactly what security or antivirus software you have installed on your computer or what settings are in force with your e-mail client. 

Some e-mail, anti-virus and Internet firewall programs provide options to prevent opening and/or saving attached files, in fact some attachments are deleted completely. This is one way to limit exposure to viruses spread by file attachments. It could be one program or a combination of them that is holding up the show. Check the respective Help topics for information on e-mail file attachment options and settings. 

31. HELP! E-MAIL ATTACHMENTS (SENDING)

UP
31.1 I sent a friend an Action Set by e-mail, but he’s unable to save it to his hard disk. Suggestions?

A: Could be the same problem as above. 

Something else to try is to .zip the Action Set File first. Sometimes .zip files are permitted as attachments when .atn files are not. 

32. HELP! COMMAND NOT AVAILABLE

UP
32.1 Q: What does this mean when error message “Command [Command Name] Not Available” and what do I do about it?

A: Note: If you’re getting this message while applying an action through a droplet or File > Automate > Batch, search on COMMANDNOTBATCH

First of all do not interpret this error message to mean that some part of Photoshop is broken or missing. There’s no need to call Adobe or reinstall Photoshop.

If you’re using any program, not just Photoshop, and you open a menu and a command is "grayed-out," it means that at the moment the circumstances are such that it is not appropriate or technically possible to execute the command. The grayed-out status is the program’s way of indicating that command is not available and you’re not permitted to use it. Of course all of us at one time or another have clicked on a grayed-out command and got the same results: Nothing happened. No big deal.

When an action tries to execute a grayed-out command, it’s like running into a dead end and Photoshop’s way of waving the white flag is displaying this somewhat misleading message. 

1. First thing to check: Before you play the action the only image open should be the one to which you’re going to apply the action. Close all other open images. This cures problems that can come up when complex actions create new images on the fly and get confused jumping back an forth among the open images. 

2. Start with a flattened image: 
· Original image: Image > Duplicate Image…  

· Original image: File > Close  

· On the duplicate: Layer > Flatten

3. More things to check on the flattened duplicate: 

· Image > Adjustments > Mode: Verify mode is RGB. (Many frequently used commands only work on RGB images.)

· Image > Adjustments > Mode: Verify mode is 8-bit. (Many frequently used commands only work on 8-bit images.)

· Some actions assume a selection has been made before the action is played. This is not an uncommon requirement for frame, border and edge actions. If a selection is needed, make one before starting the action. Some actions include “(Selection)” as part of the Action Name to signal this requirement. Most do not.

Try the action again. If it still displays this message it’s most likely due to an improperly designed or inadequately tested action that will need to be repaired.

For the benefit of action authors here’s an obscure situation that causes this error: The layer to which a command is to be applied is selected (highlighted), but it’s not visible (the “eyeball icon” next to the layer name is not “on”).

In almost all cases a layer must be not only be selected, but also visible in order to apply a command to it. Trying to apply a command to a selected but “not visible” layer is probably the most common cause for this error.

Again, applying the action to a flattened copy of the original image solves this problem.

33. HELP! FILE, BRUSH, TEXTURE, PRESET OR OTHER FILE NOT FOUND

UP
33.1 Q: When I ran a recently downloaded action for the first time it stopped and displayed a message saying a file could not be found. What do I do?

A: (In the following points the word “file” represents any of the following: .jpg, brush, preset, gradient, texture, etc.) This “xxx not found” problem can be caused by any of the following: 

· The required file does not reside on your computer because it’s part of Photoshop version X and wasn’t among those installed with Photoshop version Y.

· Many support files, e.g., shapes, gradients, etc., and presets installed with Photoshop have language edition specific names. If you have (say) the English version of Photoshop and the action was written in (say) the French language version, the action will fail looking for a preset or texture whose name is in French, which would not be present on your computer. (PierreC)

· The required file does not reside on your computer (yet) because it was among the optional files on one of the distribution CDs and was never copied onto your hard disk.

· The required file does not reside on your computer because it’s a custom file the action author forgot or chose not to include it in the download package. 

· The required file resides on your computer (somewhere) but you forgot to unzip it, you installed in the wrong folder, you installed in the right folder, but the action is looking for it in a different folder, etc. Too many files, not enough time.

· You installed Photoshop using the default path, e.g., 
C:\Program Files\Adobe… but the author chose a custom path, e.g., F:\MyCoolAdobe\Custom\Path. As a result the path that leads to the file on his computer will be completely different than the path that leads to the same file on your computer. 

Options to consider if the missing file is available:

· Unzip it or download it and/or copy it to the required location

· Rerecord the action step specifying the location of the file on your computer

Options to consider if the missing file is not available:

· Disable the action step (maybe you can live without it)

· Create your own version of the missing file

· Rerecord the action step and specify a file you do have

34. HELP! THESE AREN’T THE RESULTS I EXPECTED

UP
34.1 Q: I’ve got an image that needed to be sharpened. I ran a recently downloaded sharpening action on it (several times, as a matter of fact, with different settings), but each time the result was worse than the original. What gives? 

A: Welcome to the “Realities of Actions, Part II: Some Actions Don’t Deliver The Result You’re Hoping For.” 

How an image turns out as a result of playing an action depends on image characteristics (resolution, focus, exposure, color, noise, cracks, dust spots, fading, other damage, etc.) and the knowledge and experience of the action author when it comes to Photoshop (in general) and action crafting. 

Bad picture + great action = bad picture.

Great picture + bad action = bad picture. 

- - - - - -

34.2 How do you explain running the same action on two images from the same sitting and one turns out great and the other is okay, but not as good as the other?

A: Again, without seeing the actual target images it’s hard to be specific. Here’s another perspective that may (or may not) explain it.

Under the covers just about everything Photoshop does is based on calculations and comparisons applied to numerical values that characterize each pixel in an image. Sometimes these calculations and comparisons are applied to adjacent (neighboring) pixels like with blur, dust and scratches, median-type effects. Sometimes the calculations and comparisons are applied to corresponding pixels on a layer to layer basis. For example if you’re using adjustment layers or layer blend modes the first pixel in the top row of Layer 1 is compared to the corresponding pixel in the layer below it, the second pixel in the top row of Layer 1 is compared to the corresponding pixel in the layer below it, etc. What Photoshop displays is based on the results of those pixel-by-pixel comparisons. 

While two images may appear to be visually similar, from Photoshop’s purely numerical perspective they may be different enough that when the same action is applied to each (and especially if the action has a number of steps) the results will be noticeably different.

This also accounts for wildly different results when substantially different images are processed by the same action.

- - - - - -

34.3 I ran an action that was supposed to sharpen my image, but instead it produced ugly halos. It seems my friend, who wrote this action, gets consistently good results by using it. What am I doing wrong?

A: The above observations apply here as well. It might be image characteristics related, that is, the images against which your friend plays the action are better suited for this particular action than your images. 

Sometimes getting desired results comes down making informed decisions when specifying values and choosing options as an action plays. On the other hand if an action is poorly or improperly written, no combination of options or setting values will yield pleasing results.

Here’s another alternative worth considering: For many common tasks, sharpening among them, the are several tried and true (yet different) methods for completing them, each with pros and cons. If a high pass sharpening action doesn’t work, you might try actions based on edge sharpening or luminosity sharpening methods.

With so many variables, including knowledge and experience, image characteristics, method used, etc., the bottom line is sometimes actions will deliver results you like, sometimes they won’t. There will be times when you’ll probably be better off finding tutorials on the Internet and applying their steps manually rather than depending on actions. 

Just so there’s no misunderstanding let me go on record at this point by stating something I truly believe: “Actions are not a cure all. Playing an action does not always render results as favorable as manually performing a given task.”

35. Help! Text Action Worked Under PS7, But Not Under CS

UP
35.1 Q: To automate my watermarking process I wrote an action under Photoshop CS that creates a text layer with my name and copyright notice. Nothing fancy. I recorded on an image whose resolution was 240 ppi.

When I apply it to a 240 ppi image, it works okay. If I apply it to, say, a 240 ppi or 300 ppi image, the text is squashed, that is, all the characters appear to be on top of one another.  

I’ve covered the bases: Kerning is set to 0, vertical scaling = 100%, horizontal scaling to 125%. I’ve tried different fonts, different font sizes, different images, images of various resolutions without success. I called NAPP and they suggested rasterizing the layer, but that didn’t help. Any ideas? (Judy Woodruff)

A: There is apparently a bug in CS when it comes to some fonts and/or combination of Text tool settings. Besides Judy, I know of two other users who reported the exact same symptoms.

Corrective action: Record the action under a previous release of Photoshop, save the Action Set and load the Action Set File into CS. In each case this circumvented the problem.

Lesson to be learned: After installing a new version of Photoshop, keep your old version of Photoshop around for a while so you have way to test (and get around) these types of anomalies.

36. Help! I Can’t Move An Action From One Action Set To Another

UP
36.1 Q: I’m trying to organize my Actions Palette and am unable to move an action from one Action Set to another. Any ideas why?

A: Make sure Record Mode is not active. If it is, you cannot move actions, Action Steps or Action Sets within the Actions Palette. 

37. Help! I Recorded A Stop Command AND IT HAS NO DISPLAY DIALOG CHECKBOX

UP
37.1 Q: This is really weird. I recorded a Stop Command, but when I play the action the message doesn’t display. When I checked the Display Dialog checkbox, I discovered, “There is no Display Dialog checkbox!” What’s up with that?

A: You clicked OK to close the Stop Command dialog without typing any message text.

Corrective action: Double-click the Stop Command to open the dialog and then enter message text.

38. Help! Nested Action Fails. I Changed An Action Or Set Name

UP
Q: A friend sent me an Action Set File named Darren’s Sharpening.atn by e-mail. After loading the actions into my Actions Palette I changed the name of Action Set Darren’s Sharpening to My Sharpening.

Now the actions won’t play anymore.

A: Bad dog. You violated the cardinal rule of nested actions. Search on NESTEDWARNINGS
Corrective action option 1: Rename the Action Set to its original name.

Corrective action option 2: Rerecord the calling action. Search on NESTEDACTIONS
Note: The same advice applies if one or more actions called by the calling action were renamed.

39. Help! Nested Action Fails, but I Did Not Change the Action or Set Name

UP
39.1 Q: A friend sent me an Action Set File named Darren’s Sharpening.atn by e-mail. It includes an action (Master Sharpen) that plays two nested actions (Sharpen 1, Sharpen 2). (Search on NESTEDACTIONS, NESTEDWARNINGS). After the Action Set File was loaded into my Actions Palette using Load Actions…, I did not change the Action Set Name or any Action Names. The first time I played the action Master Sharpen I got this message.

“The object action “Sharpen 1” of set “Darren’s Sharpening” is not currently available.”

My friend swears the action set he sent me plays flawlessly on his machine. Why won’t it work for me?

A: According to PierreC, here’s what caused the problem: Before executing the Load Actions… command, our user (Mike) had changed file name Darren’s Sharpening.atn to darren’s sharpening.atn (all lower case) because that was how he named files on his PC. 

Although he did not change the Action Set Name after it was loaded it into the Actions Palette, the change he made had a similar effect since the Action Set Name corresponds to the Action Set File Name. Change the Action Set File Name and you’re effectively changing the Action Set Name.

While Windows considers these file names to be the same, Photoshop considers them different when it comes to actions.

This corrected the problem: Renaming the Action Set Name in the Actions Palette from

darren’s sharpening 
(this name resulted from changing the file name to all lower case)

back to

Darren’s Sharpening
(this was the name of the Action Set when the action was recorded).  

40. Help! SAVE FOR THE WEB IS PUTTING DASHES IN MY FILE NAMES

UP
40.1 Q: I’ve written an action that executes a File > Save for the Web command. When I play the action no matter what I type into the file name field in the Save dialog, Photoshop replaces any spaces with dashes. What do I need to do to prevent the dashes?

A: You will need to rerecord the Export (Save for the Web) command in the action.

· Open a test image.

· Double-click on the Export command to invoke the Save for Web dialog.

· Click Save to invoke the Save Optimized As dialog.

· In the Settings menu, choose Other, which invokes the Output Settings dialog.

· In the Output Settings dialog, turn off the Unix option and click OK.

· Click Save in the Save for Web dialog.

· For more information, see: http://jazzdiver.com/photoshop/no_hyphen.htm
41. Help! SAVE FOR THE WEB IS CUTTING OFF MY FILE NAMES

UP
41.1 Q: I’ve written an action that executes a File > Save for the Web command. Whenever I type in a file name greater than 31 characters, it’s cutoff. After the command completes I have to go into Windows’ Explorer and add the last characters of the file name. What do I need to do to prevent this from happening?

A: You will need to rerecord the Export (Save for the Web) command in the action.

· Open a test image.

· Double-click on the Export command to invoke the Save for Web dialog.

· Click Save to invoke the Save Optimized As dialog.

· In the Settings menu, choose Other, which invokes the Output Settings dialog.

· In the Output Settings dialog, turn off the Mac option and click OK.

· Click Save in the Save for Web dialog.

· For more information, see: http://jazzdiver.com/photoshop/no_hyphen.htm
42. Help! Missing Actions: They’re Unzipped, but Not in the Actions Palette

UP
42.1 Q: I unzipped two .atn files into 

C:\Program Files\Adobe\Photoshop 7.0\Presets\Photoshop Actions

When I open Photoshop, they aren’t in the Actions Palette. What’s up?

A: You are almost there. 

Open the Actions Palette menu and you’ll see the actions listed at the bottom of the menu. Click on one and it will be loaded into the Actions Palette. Repeat for the other and you’ll be in business.

43. Help! (Mac OSX) KEYBOARD SHORTCUT ASSIGNMENTS AREN’T WORKING

UP
43.1 Q: I’ve got Panther (OSX) 10.3.2 and Photoshop CS. I’ve assigned F9, F10 and PF11 to three actions. I get no error messages when I do so. When I press F9, F10 and F11, nothing is happening. By If I press Cmd + F9, Cmd + F10, or Cmd + F11, the actions play. This is really weird. What’s going on?

A: As one Macaholic put it, “Expose is hijacking your keys.” 

Upon inspection it was confirmed Expose was set to F9, F10 and F11. After reassigning keys assigned to Expose, F9, F10 and F11 played the actions as expected.

K. HELP – BATCH PROCESSING AND DROPLETS

UP
There will be times that an action by itself works fine, but will fail when invoked through File > Automate > Batch or a droplet. A classic case is when a STOP command is executed in batch and the user pauses the action and attempts to restart it. Search on STOPINBATCHNONO
Generally speaking errors that occur through File > Automate > Batch will also occur when one uses a droplet, so there is no attempt to duplicate topics for both situations.

1. BATCH AUTOMATION HELP – “A COMMAND WAS CANCELED OR STOPPED WHILE BATCHING”

UP
1.1 Q: When I tried to play this action I’ve used a hundred times without problems through File > Automate > Batch I’m getting message, “No messages are selected in the File Browser.” I’m not using the File Browser. What’s up? 

A: STOP commands in actions invoked through File > Automate > Batch are not permitted. This error will also occur if you click Cancel in a dialog during a batch run.

Search on STOPINBATCHNONO
2. BATCH AUTOMATION – CONVERTING TO .JPG WITHOUT THE ANNOYING DIALOGS

UP
OVERRIDESAVEAS

2.1 Q: I’m trying to use File > Automate > Batch to convert a folder of images from .psd to .jpg format. No matter what I try a dialog box is displayed for each image asking me to specify .jpg characteristics. How can I suppress the dialog to make the process automatic? 

A: According to Adobe support, “By default, Photoshop 7.0 doesn't maintain the compression settings recorded in an action if the action is run with the Batch command on unsaved JPEG files. Instead, Photoshop prompts you to enter the compression/quality settings so that you can specify different compression levels for each new file.”

As unintuitive as it sounds, here’s the workaround:

· When you record the action be sure it includes a File > Save As… command in which the .jpg settings are specified. Don’t worry about having to provide a folder and file name before clicking OK. These will be overridden in the File > Automate > Batch dialog.

In the File > Automate > Batch dialog be sure the Override Actions “Save As” Commands checkbox is checked (on) for the Destination folder. This causes the folder and file name specified in Save As… command to be ignored, but retains and applies the .jpg specifications.

3. BATCH AUTOMATION HELP – “NO MESSAGES ARE SELECTED IN THE FILE BROWSER”

UP
3.1 Q: When I tried to play this action I’ve used a hundred times without problems through File > Automate > Batch I’m getting message, “No messages are selected in the File Browser.” I’m not using the File Browser. What’s up? 

A: The folder specified in the File > Automate > Batch Choose (Source) dialog has no images in it.

4. Batch Automation Help – “Photoshop cannot recognize the file extension”

UP
4.1 Q: I’m getting the following error message when I try to run my action in batch. What does it mean? 

File: "D:\tff\Thumbs.db"
Error: Could not complete your request because Photoshop cannot recognize the file extension. (-25600)
A: Translation: Photoshop doesn’t know what to do with a file in this format, that is when .db is the file name extension.

Corrective action options:

· Delete files Photoshop can’t open from the source folder –or-

· Go to the File Browser, enter a Select All command (Ctrl + A), then Ctrl + Click on the files to be excluded from batch processing. When you invoke File > Automate > Batch, be sure to specify Source: File Browser.

5. Batch Automation Help – command not available

UP
COMMANDNOTBATCH

5.1 Q: I’m trying to apply a new action to a folder of images through File > Automate > Batch, but each time I try to run it the message ‘The command [command name]” is not available” is displayed for all images. There are no images in the destination folder. Why am I getting this error?

A: You checked on the “Override Action ‘Open’ Commands” option, but there’s no Open command in the action. Since you specified the Stop on Errors option, this message is displayed for each image processed. 
Corrective action: Uncheck “Override Action ‘Open’ Commands.”
NOFILES1

6. BATCH AUTOMATION HELP – NO FILES IN DESTINATION FOLDER (1)

UP
6.1 Q: When I played my action through File > Automate > Batch I checked the “Override Action ‘Open’ Commands” box. When all images were processed, none were in the destination folder. What went wrong?

A: Check your errors text file. There will be a message for each image indicating a command (the first in the action) not being available.

Checking the “Override Action ‘Open’ Commands” box only works if you have an Open command in your action. If you check this box and there is no Open command, no images are placed in the destination folder.

Corrective action: Uncheck “Override Action ‘Open’ Commands.”
NOFILES2
7. BATCH AUTOMATION HELP – NO FILES IN DESTINATION FOLDER (2)

UP
7.1 Q: When I played my action through File > Automate > Batch I checked the “Override Action ‘Save As’ Commands” box. When all images were processed, none were in the destination folder. What went wrong?

A: Checking the “Override Action ‘Save As’ Commands” box only works if you have Save and or Save As… commands in your action. If you check this box and one or the other of these commands is not present, no images are placed in the destination folder.

Corrective action: Uncheck “Override Action ‘Save As’ Commands.”
8. BATCH AUTOMATION HELP – ONLY ONE FILE IN DESTINATION FOLDER

UP
8.1 Q: When I played my action through File > Automate > Batch, all images were processed (I watched them go by on the screen), but there was only one in the destination folder, the one that corresponded to the last image in the source folder. What went wrong?

A: Check your action. It probably contains a Save command that specified a folder and file name. Each image saved to the destination folder has the name specified in the Save command. As each image is processed, it overwrites the previous image. This explains why the last image in the source folder was the only image in the destination folder. 

Depending on your intent:

If you recorded File > Save, or File > Save for the Web, specify a Destination folder and turn on the “Override Action ‘Save As’ Commands” option. Images will be saved in the folder specified in the Save command.

If you want the option to choose the destination folder and/or assign a file name to each image, be sure the “Override Action ‘Save As’ Commands” option is off and the Show Dialog checkbox for the Save command is on.

9. Batch Automation Help – Automate > Batch is Grayed Out
UP
9.1 Q: When I go to choose batch from the file > automate menu, batch is grayed out. I’ve tried deleting my Photoshop preferences file, checked for missing files (I compared my files with those of a friend who has the same version of Photoshop I have). I even reinstalled Photoshop, but it’s still grayed out. What am I supposed to do?
A: To make a long story short somehow all the actions in this poor chap’s actions palette got deleted. 
He didn’t notice this anomaly because he normally operated with the actions palette hidden which makes sense: it takes up a lot of screen real estate and if necessary you can select the action to be played from the automate > batch dialog.
Another unreported symptom: create droplet was grayed out, too.
Corrective action: restore the actions palette from a backup file or start writing some new actions. When there are one or more actions in the actions palette, batch is available as usual.
10. Batch Automation Help – EXIF data: It’s GONE!
UP
10.1 Q: I’ve written an action that converts .psd files to .jpg format using the save for the web command. When I open the .jpg, my EXIF data is gone. What have I done wrong?
A: You’ve done nothing wrong. That’s the way it works. 
Search on LOSTEXIF
11. Batch Automation Help – I Can’t Restart a STOPPED Action to Crop!

UP
11.1 Q: I have created an action I want to use it during the batch process. The problem is I need to stop the action with each image to make a selection. That works fine when I play that action for only one file. When I try to use it with a batch process, Photoshop cancels the batch process when it gets to the stop in my action. If I click play after the selection is done Photoshop only finishes that one image. Do you know the solution for that?
A: Actions with embedded stop commands just don’t work in batch processing. Search on stopinbatchnono
It sounds like you're trying to crop your images using the rectangular marquee tool. As you discovered this works fine on a single image, but cannot be done in batch.
A method that will work is to record a crop command in your action instead. Be sure the display dialog checkbox is on. When the crop command is executed, Photoshop will pause the action enabling you to resize or reposition the crop rectangle as desired. Once you accept the crop by pressing enter or double-clicking inside the crop rectangle, processing will continue uninterrupted with the next image.
12. Batch Droplet Help – Photoshop CS: Droplets Stopped Working

UP
12.1 Q: I recently upgraded from Photoshop 7 to Photoshop CS. After I uninstalled Photoshop 7, droplets stopped working, as in I drop a file or folder over a droplet icon and nothing happens. Zilch. Any ideas what’s going on?
A: As of this writing this problem has been reported several times on various forums, but to date no definitive cause or solution has been posted by adobe. The following sequence of events describes how one person “lost” then restored droplet functionality under CS. Your mileage will vary.

Operating System: Windows XP PRO
1. PS 7 installed on in 2002.
2. Installed PS CS upgrade January, 2004. Tested it. Everything worked okay, including droplets.
3. Uninstalled PS 7 (via Windows control panel)
4. Noticed droplets stopped working under CS.
5. Uninstalled CS (via control panel)
6. Tried to reinstall CS upgrade, but no luck. Upgrade requires full version of Photoshop to be installed.
7. Reinstalled PS 7. When the option to select file associations was displayed, “NC” (for no change) was selected. No attempt was made to start PS 7.
8. Reinstalled PS CS upgrade. Again “NC” selected for file associations.
9. Used Explorer to delete the PS 7 file tree.

The above steps restored droplet functionality to Photoshop CS.


The next step is cosmetic and should not be attempted unless you know what you’re doing.
10. Manually deleted PS 7 install key from the registry.
- - - - - -

12.2 Q: What are the other situations?
A: Here’s another: 

Operating System: Windows XP PRO
1. PS 7 installed
2. Installed PS CS upgrade.
3. Uninstalled PS 7 (via windows control panel)
4. Noticed droplets stopped working under CS.

Corrective action (Ron Ross)

1. Rebuilt the machine, i.e., reinstalled Windows XP Pro
2. Installed CS and used the serial number from the PS 7 CD for verification.

- - - - - -

12.3 Q: Any problems with Windows 2000?
A: Yes.

Operating System: Windows 2000, SP4

The symptoms were a little different than the incidents reported above:

· The user wrote a droplet to convert .psd files to .pdf format. 

· When a .psd file icon was dropped onto the droplet icon, the droplet failed with this message from Windows: “[name of droplet].exe has generated errors and will be closed by Windows. You will need to restart the program,” crashing Photoshop CS.

All attempts to correct the problem by uninstalling and reinstalling  Photoshop 7 and CS were unsuccessful. Engaging Adobe Technical Support was fruitless.

Finally the user’s administrator signed onto the administrators account on his PC. The admin tried the droplet and it worked fine. After logging off, the user logged back on to Windows using his personal account. The previously failing droplet worked fine for the user, too.

Conclusion: When the admin signed on and executed the droplet, it triggered some sort of registry setting that corrected the problem. This has not been verified as a correct explanation. 

L. HOW TO


UP
This is a grab bag of miscellaneous action and batch processing techniques.

1. HOW TO: ADJUSTMENT LAYERS, BYPASSING NEW LAYER DIALOG

UP
1.1 Q: I’ve written an action that creates a Levels adjustment layer. Before playing the action I clicked the Display Dialog checkbox so I could adjust the settings. When the action plays, two dialogs are displayed: New Layer (to assign a custom layer name) and the Levels dialog. Is there a way to suppress the New Layer dialog (accept the default layer name) and just display the Levels dialog?

A: Here’s one way.

· When you record the Levels step, change the value in the first Input Levels box from 0 to 1 and click OK to close the dialog. Do not turn on the Display Dialog checkbox for this step.
· While still in record mode, add the next step by double-clicking the newly created Levels adjustment layer in the Layers Palette. Change the value in the first Input Levels box from 1 to back to zero and click OK to close the dialog.
· Click on the on the Display Dialog checkbox for this second step.
What’s happening here:

· The original add Levels adjustment layer is recorded with a very slight modification and the dialog is not displayed by choice, thus bypassing the New Layer dialog and accepting the default layer name.
· The second step “undoes” the first by displaying the Levels dialog box with all default value settings.
This method of recording a “slightly modified” adjustment layer and undoing the adjustment in a following step works with any adjustment layer whose New Layer dialog you want to bypass.

2. HOW TO: ADJUSTMENT LAYERS, ADD AS A GROUPED LAYER

UP
2.1 Q: Is there a way to insert an adjustment layer into an action so it is grouped with the previous layer (Layer > Group with Previous) without adding the Group with Previous command separately?

A: There sure is. 

At the point in the action where you want to insert the grouped adjustment (or fill) layer, while holding down the Alt key, click the New Fill or Adjustment Layer icon at the bottom of the Layers Palette and make your choice from the menu. The inserted layer will be automatically grouped with the layer below it.

CURVESETTINGS

3. HOW TO: DISTRIBUTE AN ACTION WITH A CUSTOM .ACV SETTING

UP
3.1 Q: I have created a number of actions that include Curves steps that specify custom Curves setting files (file extension: .acv) I have defined. I’d like to share these actions, but they won’t work for others since no one except me would have a path like this: 

c:\My Documents\Custom Photoshop\very cool curves settings

To be useable I would have to package the .acv files and most likely instructions on how to customize the actions. Any ideas on how I can get around this?

A: Absolutely. 

· Open any test image.
· Locate the Curves step in question in the action.
· Double-click on the Curves step, opening the Curves dialog.
· Click (literally) anywhere on the RGB curve in the dialog box. It makes no difference where you click or if there are points on the individual R, G and B curves.
· Okay to close the dialog. What you’ve done is captured all the .acv settings (as well as the one just created) and saved them within the action step.
· Double-click on the Curves step again. This time just drag the point you created above “off the screen,” deleting it.
· OK to close the dialog. 
Success: The .acv file settings are now embedded in the action command. There is no longer a need to be concerned about .acv file distribution nor including convoluted instructions for action modification.

- - - - - -

3.2 Q: If I located .acv settings on the Internet and downloaded them, could I use this approach to embed the settings into my actions?

A: You sure can.

- - - - - -

3.3 Q: Can this same process be used with other adjustment layer setting files, e.g., Levels, Hue/Saturation, etc.

A: Yes, but instead of clicking a point on a curve, you will need to adjust one of the settings by a small amount, e.g., change Hue from –5 to –6, then click OK. Double-click on the adjustment layer command again and set Hue back to –5 and click OK to save the command.

4. HOW TO: USE BATCH PROCESSING FOR IMAGE FOLDER TO FOLDER COPY

UP
4.1 Q: Are you saying you could (and would) use File > Automate > Batch to copy images from one folder to another? Why not just drag and drop them?

A: I can’t argue with the obvious simplicity of drag and drop, but I’ll share this method because it was useful to someone.  

Situation:

· The user had an action (Action Name: Place Tiles) that opened 16 uniquely and consistently named .bmp format images from a specific folder and placed them like tiles into a 2 x 8 matrix. To meet this requirement there were 16 Open commands in the action, each specifying the same source folder, but with different file names, and 16 Move statements, each specifying an exact location for a particular image tile. He was looking for a way to make the action more generic so he wasn’t locked into the same source folder (file name: Tile Holding Folder) each time. File > Automate > Batch was no help because it would not support unique processing on each image opened. 
· Why drag and drop was a hassle: In his case the source and destination folders were many, many folders deep, so each time he had to do a lot of mouse clicking and window maneuvering before the he could do the drag and drop from the folder containing the images to be processed into the generic folder specified in the action.
Solution:

· Create an action that “does nothing” (literally), called a Null (or Dummy) Action. It has a name, but no steps. Name it Copy Files.
· Create a new action (name it Copy and Process Tiles).
· First step: Open the File > Automate > Batch dialog and specify newly created action Copy Files, Tile Holding Folder as the destination folder and as the source folder any folder containing 16 images that needed to be processed.
· OK to initiate batch processing. Each image is opened, saved (into the destination folder) and closed. No changes are applied to it by the action with no steps.
· Second step: Record the playing of the Place Tiles action.
· Click on action name Place Tiles.
· Click PLAY and wait until the action completes and the Play Action command is recorded. 
· STOP recording.

· Click on the Display Dialog checkbox for the Batch command. 

Summary and comments:

· New action Copy and Process Tiles has two steps:
· Batch, which plays null action Copy Files via the Automate > Batch dialog. Since Display Dialog is on, the user is able to browse to the source folder using the Choose (source) dialog.
· Play Action, which plays previously recorded action Place Tiles
· Since the files in this case were .bmp format (lossless) there was no loss of image quality in this process. 
5. HOW TO: MERGE MULTIPLE LAYERS INTO ONE LAYER WITHOUT COLLAPSING THEM

UP
5.1 Q: When I record the Layer > Merge Visible command the individual layers are lost when the action plays. How can I merge layers and preserve the individual ones?

A: Here’s how: 

· Record a step that either creates a new layer or selects the layer into which all layers are to be merged.
· In the next step, while holding down the Alt key, chose Merge Visible either from the Layers Palette menu or the Layer menu. If you’re into keyboard acrobatics, Alt + Ctrl + Shift + E achieves the same results.
6. HOW TO: How To Select Tools You Can’t Normally Select

UP
SELECTMOVETOOL

6.1 Q: When creating actions I’ve discovered that I can record commands that select certain tools, e.g., Brush, Eraser, Clone, History, etc., but commands to select other tools (such as the Move tool) cannot be recorded — even if I try Insert Menu Item. Is there a way around this limitation?

A: Thanks to this tip from Carl Stawicki, there is.

· In the Tool Presets Menu, be sure the Show All Tool Presets option is selected
· Click the Move tool in the Tools Palette
· In the Tool Presets Menu define a new preset
· While record mode is active choose the newly created preset from the Tool Presets Menu to add the selected Select Tool Preset command to the action
Note: The resulting action will only work on machines where the appropriately named tool preset has been defined.

7. HOW TO: CONDITIONALLY EXECUTE AN ACTION (IF-THEN-ELSE)

UP
7.1 Q: Is there a way that, depending on a given condition, e.g., image size, orientation or color space, that I can automatically execute one action or another in a batch process?
A: Yes, with a little help from scripting. Search on CONDITIONALEXECUTION
8. HOW TO: RECORD FILE > OPEN WITHOUT HAVING TO SPECIFY A FILE NAME

UP
BLANKFILENAME

8.1 Q: When I recorded an Open command in an action I was forced to specify a file name. Each time the action plays the file name specified when the action was recorded is the one that populates the File Name text box. I’d like the file name field to be blank. How can I do that?

A: Instead of recording File > Open, use Insert Menu Item. While in record mode engage the Insert Menu Item dialog and choose File > Open. Since this command was inserted and not recorded, when it is executed the dialog box will always be displayed (the Display Dialog checkbox is disabled) and the file name field will be blank.

9. HOW TO: RECORD FILE > SAVE AS WITHOUT HAVING TO SPECIFY A FILE NAME

UP
9.1 Q: I recorded a Save As… command in an action, so each time the action plays the file name specified when the action was recorded is the one that’s in the file name field. I’d like the file name field to be blank. How can I do that?

A: Works the same as Open. See BLANKFILENAME
10. HOW TO: HOW TO INDICATE WHEN BATCH AUTOMATION IS FINISHED

UP
10.1 Q: Since I cannot do anything else in Photoshop while it is batch processing images, I usually start surfing the web. Sort of switching back to Photoshop to see if it has completed processing, is there a way to be alerted when batch processing is complete? 

A: Here’s one way that works with PS 7 on Windows 2000. Your mileage may vary.

· Suppose the long running action invoked through File > Automate > Batch is named Sharpen and Color Correct.
· Create a new action (name it All Done Alert). Insert a Stop command. The message text can be something like, “Processing complete.” Be sure Allow continue is checked on.
· Create another new action (name it Process Images).
· Step one: Engage File > Automate > Batch and specify Sharpen and Color Correct and the options you normally set. Whether or not you check the Display Dialog option will depend if you need to set source and/or destination folders each time.
· Second step: Click on action All Done Alert and click PLAY. When you click the Continue button in the dialog, the Play Action command will be recorded.
· STOP recording.
Process Images starts by playing action Sharpen and Color Correct, at which time you can start Web surfing or another game of Solitaire. When Sharpen and Color Correct finishes, All Done Alert plays. When the dialog box is displayed, the Adobe Photoshop button in Windows system tray blinks three times and remains highlighted, indicating a pending message. 

11. HOW TO: WRITE AN ACTION TO CONVERT .TIF TO .JPG AND SHARPEN

UP
11.1 Q: I just want to sharpen (Amount = 100, Radius = 1.0) a folder of images and save them as .jpg, compression level 10. What are the action steps? 

A: Here’s what you need to do:

· Open any test image, .tif or not

· Create a new action

· Record these steps:

· Filter > Sharpen > Unsharp Mask (Amount = 100, Radius = 1.0)
· Save As… (specify any file name and any folder and compression level value of 10 in the next dialog; click OK to close the image)
· Click STOP to terminate recording

· If you want to tweak sharpening settings for each image, turn on the Enable/Disable checkbox for the Unsharp Mask command, otherwise leave it unchecked 

· Engage File > Automate > Batch 

· Choose Source, Destination folders

· Turn on ‘Override Action “Save As” Commands’ 

· Click OK to process your images

12. How To: Fix Hot Pixels USING THE PATCH TOOL

UP
12.1 Q: I have a digital camera with a single hot pixel and I would like to write an action so I can fix the problem in batch. I tried using the Healing Brush however, when I try to record an action the commands do not record. Can anyone help? Thanks in advance. (edde)

A: While its true Photoshop does not record Healing Brush commands, Patch Tool commands can be recorded.

The steps to a one pixel fix follow:

Setup:

· Open a test image that includes the hot pixel.

· Zoom in as far as needed in order to see the individual pixels. (I was zoomed to 1600% [max] for a 72 ppi image.) 

· If necessary sharpen it using the Unsharp Mask filter to make the pixel edges show up a little better. 

· Right-click in the ruler and select Pixels
· Note the location of the hot pixel in terms of horizontal and vertical position, e.g. 225, 386.

· Use View > New Guides to have PS precisely position guides along each side of the hot pixel and any one of the eight pixels adjacent to it

· Choose the Rectangular Marquee tool. (Style=Normal, Feather=0) 

· View > Snap (on)

· View > Snap to > Grid 


Start recording. 

· Select the hot pixel.

· Choose the Patch Tool from the tools palette.

· Drag the selection to an adjacent pixel. PS will record the Patch command in the action.

· STOP recording

· Close the sample image without saving
13. How To: Fix Hot Pixels USING COPY/PASTE

UP
13.1 Q: I have three hot pixels on my digital camera sensor. Of course they are always at the same place in images as long as I use the same resolution for shooting each. I'd like to make an action that would open the clone tool, choose 1-pixel as brush size, for a source sample Alt + click the pixel immediately to the right of the hot pixel, then click on the hot pixel to copy the source. This would be repeated two more times, once for each of the other hot pixels. Since I have PS 6, I don’t have the Patch Tool. Is there a way around this? (Linda Baldwin)

A: This can be done in an action, but not using the Clone (Stamp) tool. It and other brush-type tools, e.g., Brush, Eraser, Burn, Dodge, etc. are not supported in actions.

This method is essentially the same as the Patch Tool method described previously with these changes.

· Select a pixel adjacent to the hot pixel.

· Edit > Copy

· Select the hot pixel

· Edit > Paste, creating a new layer

· Layer > Merge Down

· Repeat for hot pixels 2, 3.

14. How To: Fix Hot Pixels USING COPY/PASTE AND MEDIAN

UP
14.1 Q: I’ve read of a hot pixel fix using the Noise > Median command, but can’t find it. Have you heard of it?

A: Yes.

· Select a 3 x 3 or 5 x 5 area with the hot pixel in the center.

· Apply Noise > Median with radius of 1-2

· Edit > Fade Median. Back off the effect as needed.

· STOP recording.
15. How To: PLACE HORIZONTAL & VERTICAL GUIDES AT 33%, 66% (RULE OF THIRDS)

UP
15.1 Q: For image assessment (do a Google lookup on ‘Rule of Thirds’) I’ve written an action that creates horizontal and vertical guides at 3.334” and 6.667” points vertically and 2.672” and 5.334” points horizontally for 8” x 10” images. I wrote another action for landscape 8” x 10”s. Is there a way to record a universal action for this purpose so I don’t have to have to create two actions for every print size I process, e.g., 5” x 7”, A2, etc.? 
A: There sure is. The trick is to have your ruler set to Percent when the action is recorded. Settings are recorded in percent values rather than physical dimensions, meaning the action can be applied to images of any size and orientation.

Setup:

· Open any test image

· If the Rulers are not visible, CTRL + R or View > Rulers

· Right-click in the Horizontal Ruler at the top and choose Percent 


Record the action:

· View > New Guide > Vertical (33%), OK

· View > New Guide > Vertical (67%), OK

· View > New Guide > Horizontal (33%), OK

· View > New Guide > Horizontal (67%), OK

· Optional: Insert Menu Item: Insert Stop 

· Type any character in the text area, OK ##

· Click OFF the Display Dialog checkbox **

· Optional: View > Clear Guides **

· STOP recording


## There must be at least one character typed into the message before the dialog box can be closed.

** The effect of inserting a Stop command and turning off Display Dialog is the action stops after creating the guides without displaying a dialog, which in this case is the desired outcome. After image assessment is complete it’s not unusual to deletes the guides. If that’s desired, clicking Play (►) executes the Clear Guides command.

16. How To: AUTOMATICALLY PLACE GUIDES AT the Center of an Image
UP
16.1 Q: How can I write an action that marks the center of an image? 
A: Again the trick is to have your ruler set to Percent when the action is recorded. Settings are recorded in percent values rather than physical dimensions, meaning the action can be applied to images of any size and orientation.

Setup:

· Open any test image

· If the Rulers are not visible, CTRL + R or View > Rulers

· Right-click in the Horizontal Ruler at the top and choose Percent 


Record the action:

· View > New Guide > Vertical (50%), OK

· View > New Guide > Horizontal (50%), OK

· Optional: Insert Menu Item: Insert Stop 

· Type any character in the text area, OK ##

· Click OFF the Display Dialog checkbox **

· Optional: View > Clear Guides **

· STOP recording


## There must be at least one character typed into the message before the dialog box can be closed.

** The effect of inserting a Stop command and turning off Display Dialog is the action stops after creating the guides without displaying a dialog, which in this case is the desired outcome. After image assessment is complete it’s not unusual to deletes the guides. If that’s desired, clicking Play (►) executes the Clear Guides command.

17. How To: AUTOMATICALLY CREATE CONTACT SHEETS AND PRINT THEM IN ONE ACTION
UP
17.1 Q: I’m using File > Automate > Contact Sheet to manually generate about 15 contact sheets. First, I have to wait for Contact Sheet to do its thing. Then after using File > Print on each, I have to close the contact sheet images. Can this process be automated?

A: Yes it can. It will take three actions.

Action 1: Create Contact Sheet - Preparation

· Decide on an existing folder or create a new folder that will contain the source images to be used to populate the contact sheet.

· Put two test images in this folder.


Action 1: Create Contact Sheet – Record the action

· ## Optional: File > Printer Setup (## You may or may not need this step depending on your workflow.)

· Make printer setup changes as needed.

· Click the Display Dialog checkbox for this command.

· File > Automate > Contact Sheet.

· Specify a Source folder via the Browse dialog. 

· Decide on and select the contact sheets options.

· Click OK to invoke the function and record the command.

· If you are going to choose a different folder for each run, e.g., perhaps you organize your images by client name, then click the Display Dialog checkbox for this command. This will allow you to engage the Browse dialog each time.

· STOP

Action 2: Print Contact Sheet – Record the action

· File > Print

· The contact sheet just created will print. Wait until printing finishes before recording the next command. 

· File > Close

· Reply “no” to the “Save Changes?” dialog.

· STOP



Action 3: Create and Print Contact Sheet – Record the action

· Click on Action Name Create Contact Sheet, then click PLAY.
· This invokes Create Contact Sheet and your two-image contact sheet is created in Photoshop’s window.

· Click on Action Name Print Contact Sheet.
· File > Automate > Batch

· Be sure Print Contact Sheet is the name in the Action box.
· Source: Open Files.

· This option uses the open images created by the Contact Sheet function.
· Destination: Folder: None. 
· The destination is irrelevant since the action closes the file without saving it.
· STOP


Testing

· Populate the source folder with

· Play action Create and Print Contact Sheet
· If the Display Dialog checkbox is off in the Contact Sheet step of action Create Contact Sheet, the two test images will be used. Otherwise, you’ll be able to specify the source folder through the Browse dialog.

18. HOW TO: Create 3 Image Sizes and Put Each Size Into a Separate Folder

UP
18.1 Q: From each source image I want to create three images of different sizes. If the source image file name is 3345.jpg, is there a way to automate the process and name the resulting images 3345-SML.jpg, 3345-STD.jpg and 3345-LGE.jpg?
A: Yes. It will take three actions, one for each size.

In this case it would probably be easiest to have a staging folder that is used each time for the source images. Let’s call it \Source

· Create the destination folders, e.g., \SML, \STD, \LGE

· Record each action, e.g., SML, STD, LGE
· Create a fourth action, Generate-3-image-sizes. Record a File > Automate > Batch step for each action:

· File > Automate > Batch, action: SML, Source: \Source, Dest: \SML

· File > Automate > Batch, action: STD, Source: \Source, Dest: \STD

· File > Automate > Batch, action: LGE, Source: \Source, Dest: \LGE

For each batch step utilize the file naming option to assign the custom formatted names. In this case four boxes will be used:

· Choose from menu: 4 digit serial number
· Type: – (literally type a dash)

· Type: SML, STD or LGE (depending on action)

· Choose from menu: extension
Before playing action Generate-3-image-sizes remember to clear out folders \Source, \SML, \STD and \LGE and populate \Source with the new batch of images to be processed.

When action Generate-3-image-sizes plays, each action invoked through the called actions will take images from the common source folder, size them accordingly, assign custom file names and place them in the correct destination folder.

19. HOW TO: POPULATE A LAYER MASK (OR ADJUSTMENT LAYER) WITH IMAGE LUMINOSITY

UP
19.1 Q: I want to put populate a layer mask with an image’s luminosity. I can do this manually by duplicating the background, desaturating it, Edit > Copy, create a new layer and create a new layer mask (or a new adjustment layer), Alt + click the layer mask (or adjustment layer thumbnail) and Edit > Paste. The steps record okay, but when I play the action, the Edit > Paste command creates a new layer. I can’t figure this out. Can you help?
A: Yes. The trick is to use a not well known keyboard shortcut.

· Start recording your action. 

· On the layer whose luminosity you want to load, apply this shortcut:

   Alt + Ctrl + ~

   Notice the selection (marching ants) on the screen.

· With the selection still active, create a new layer and then create a new layer mask for it. The layer mask will be populated with the image’s luminosity. If you want to apply the luminosity to an adjustment layer, just create the desired adjustment layer type while the selection is active.

20. HOW TO: Populate File > File Info Keywords Field

UP
20.1 Q: I'm beginning to use Adobe Portfolio in conjunction with Photoshop 7 to organize my many thousands of files. Most of my photos have keywords, however, there's a couple hundred that do not yet have keywords associated with them. Is there a way that I can use batch to add keywords to these fields. For example, could automate the addition of keyword "flower" into an entire folder of 250 images? 

A: Yes. Actions support addition of keywords to the File > File Info… dialog. 

You'll need to create an action to populate the keyword field, then invoke it via Photoshop's batch processing dialog.


record the action:

· Open any test image. 

· F9 to show the Actions Palette. 

· From the Actions Palette menu (black arrow, top right), choose New Set
- Assign a name, e.g., Add Keywords. 
- Click OK to close the dialog 

· From the Actions Palette Menu again, choose New Action. - Assign a name, e.g., Add Keyword=flower 
  - Click the button labeled Record to engage record mode
· From the File menu choose File Info... 
  - Navigate to the Keywords dialog. 
  - Type "Flower" 
  - Click Add. This records the step in the action. 
  - Add other keywords if you like. 
  - Click OK to exit the Keywords dialog. 

Click STOP to terminate recording


Preparation to batch process 

· Close any open images

· Create a folder, call it and copy the images to which you want to assign the keyword(s) into it \Source (see Note below before doing this)

· Create another folder, call it \Destination


ENGAGE BATCH PROCESSING

· Choose File > Automate > Batch.

· The keyword adding action and its action set should already be specified. 

· Source: Folder. Click Choose (browse to \Source). 

Note: Folder \Source is used for illustration. You don't HAVE to create a folder with this name. Any folder will do. 

Alternatively you can pre-select images to be processed in the File Browser and choose File Browser from the Source dropdown menu. (TonyK) 

· Destination: Folder. Click Choose (browse to \Destination). 

· Click OK. PS will start fetching images from \Source, adding keyword(s) you recorded in the action and putting the processed images in \Destination.

21. BATCH AUTOMATION – ADDING COPYRIGHT AND URL TO FILE > FILE INFO  

UP
21.1 Q: Can I automate updating the File > File Info… dialog? 

A: Yes. When you record the action, engage File > File Info… and change Unmarked to Copyrighted Work in the Copyright Status dropdown menu. In the Owner URL box, type the desired URL.

When you click OK, this information will be recorded in an action step. Also, notice the © to the left of the file name in the image title bar, a result of the Copyrighted Work setting.

- - - - - -

21.2 Q: If I have standardized information saved in an .xmp file with which I want to populate fields in the File Info dialog. Can an action be used to do that? 

A: Yes.

A very good tutorial describing such a method can be found at Shan Canfield’s fine site http://www.shanzcan.com/.

Click on Shanzcan Tutorials and scroll down to #13 Action that Copyright.

Important: If you load a previously saved .xmp file for this purpose, all existing File Info fields in the current image (with the exception of EXIF) will be replaced by the corresponding information in the .xmp file, even if the .xmp field is blank. 

22. How To: Create a File From Each Layer in an Image

UP
22.1 Q: Is it possible to write an action that will create a file (and save it) for each layer in my file.
A: There sure is. An action to do this can be downloaded from www.AtnCentral.com.

Notes:

· This action cannot be invoked vie File > Automate > Batch because it requires manual intervention with each image. 

· It also requires you to type in the file name for each files corresponding to layers. Actions cannot determine a layer’s name.

· If an automated solution is required for this task, it can be performed with a script. Photoshop CS comes with such a script installed. Search on PSSCRIPTING
23. How To: Convert .jpg To .psd and Save .psd Files In Same Folder As .jpgs

UP
23.1 Q: I have a folder of .jpg images that I want to convert to .psd format. When finished I’d like the .psd images placed in the same folder as the source .jpg images. How can I do that?

A: Here’s what you need to do.

Before you record the action: 

· Open a test .jpg image

Record the action: 

· File > Save As... [.psd]. 

· Don't worry about file name and folder specified. 

· Click OK to save the file. 

· Click STOP to terminate recording.

· Close the test file.


File > Automate > Batch 

· Source: Folder. Choose (Specify source folder) 

· Destination: Folder. Choose (Specify destination folder, same as source folder). 

· "Override Action "Save as" commands" - turn this ON. This, in effect, will ignore the file name and folder recorded in the Save As command, while preserving your intent to save in .psd format.

· Click OK.

24. How To: Create a Selection 1/4" From Each Edge of an Image

UP
24.1 Q: I am creating an action but can't figure out how to precisely set a rectangle selection. I want to set it 1/4" inches from all edges. The action needs to work on images of different sizes.

A: The following solution will work, but will require a little math along the way.

Before you record the action: 

· Open a test .jpg image

Record the action: 

· File > Save As... [.psd]. 

· Click STOP to terminate recording.

· Close the test file.


File > Automate > Batch 

· Source: Folder. Choose (Specify source folder) 

· Destination: Folder. Choose (Specify destination folder, same as source folder). 

· "Override Action "Save as" commands" - turn this ON. This, in effect, will ignore the file name and folder recorded in the Save As command, while preserving your intent to save in .psd format.

· Click OK.

Action steps 

· Use command Insert Menu Item to insert command Image > Image Size into the action. ## 

· Layer > New Layer 

· Select > All 

· Edit > Stroke 

· Choose Inside 

· Enter stroke Width in pixels. A value of 16 is a good default choice for this particular situation. Many images are 72 ppi, so a value of 16 pixels represents 1/4". 

· Ctrl + Click on the stroke layer name to record a Set selection to transparency channel command 

· This selects the stroked section 

· Select > Invert Selection 

· This selects the area inside the stroke, a rectangle whose edges are the width specified in the Stroke dialog from each side. 

· Delete current layer  

· This layer is no longer needed. The active selection rectangle remains on the screen.

## The purpose of the inserted Image Size command is to display image resolution (in case you don't know what it is), a value necessary to calculate the number of pixels equivalent to 1/4".
The width value will be a function of image resolution. If the image is 72 ppi, 16 px = 1/4"; if the resolution is 300 ppi, 75 px = 1/4".
Be advised: On a 4" x 6" 72 ppi image, using this method resulted in a 3.556" x 5.556" rectangle (as determined in the Info palette), the sides of which were .222” from each edge, not .25” as specified. Using an 18 px width, resulted in the required 3.5" x 5.5" selection rectangle. 

On a 4" x 6" 300 ppi image using a 75 px width, the selection rectangle was 3.5” x 5.5”, exactly what was required.

25. How To: Batch Process Images From Multiple SOURCE Folders

UP
25.1 Q: I have images in several folders that I want to batch process, applying the same action to each image. Can I do that? 

A: Yes.

SETUP

· In the Source folder specified in the File > Automate > Batch dialog (see ** below), there must be:

· Images

· Subfolders

· Windows’ shortcuts (or Mac aliases)

· Any combination of the above 


INVOKE THE ACTION THROUGH FILE > AUTOMATE > BATCH

· In the File > Automate > Batch dialog 

· Choose Folder** from the Source dropdown menu. 

· Click on the Include All Subfolders option. 

Important: Regardless of the number, organization and mix of source images, subfolders and/or shortcuts, all processed images are placed in the location specified by the choice in the Destination dropdown menu.

- - - - - -

25.2 Q: What if I have several source folders, say, one for each customer and a destination folder corresponding to each customer. Is there a way to apply an action through File > Automate > Batch that processes images from Customer A’s source folder and puts the processed images in Customer A’s destination folder, then goes onto Customer B’s source folder and puts the processed images in Customer B’s destination folder, etc.?

A: No. 

Separate invocations of the File > Automate > Batch dialog would be  required for each customer source and destination folder pair. 

Something more sophisticated than single or multiple source folders, but only a single destination would have to involve scripting.

MAKENULLACTION

26. HOW To: CREATE A NULL ACTION

UP
26.1 Q: I’ve seen reference to Null Action a few places. What is it again and how do you create one?
A: A Null Action is one that has a name, but no steps. They come in handy for such things as:

· If assigned ‘names’ such as “- - - - — - - - “ or “>>>>> <<<<<”, they can serve as visual organizational aids (section dividers) in your Actions Palette.

· If invoked through the File > Automate > Batch dialog, they can be used to

· Copy files from one folder to another. Caution: Opening/closing .jpgs can degrade quality.

· Rename files (good for PS6 folks who don’t have File Browser yet)

· Open files for manual processing

· Save and close open files


Creating a Null Action
· Create new action, assign name and click Record.

STOP recording. You now have an action without any steps, a Null Action.

27. How To: Adding Text, LogoS, SignatureS, COPYRIGHT to Images - Introduction

UP
Applying a signature, copyright notice, logo and/or watermark to batches of images is not an uncommon requirement. There are several ways to achieve these results depending on your needs and workflow.

As a general rule it’s to your advantage to have the Ruler units set to Percent before recording the action. When Percent is in effect text, logos and/or signatures are positioned at relative locations in the image, e.g., 85% vertical and 90% horizontal vs. specific measurement units, e.g., 5” from the top and 2” from the right edge. 

The percentage values translate to images of different sizes, orientations and even resolution. Positions specified in a fixed values limits the action to the specific size, orientation and resolution of the image used to record the action.

In addition regardless of which method you use it’s usually a good idea to make a practice run or two before recording the action in order to map out details like logo or font size, font style, layer styles, positioning, etc. 

INSERTCOPYRIGHT

28. How To: TYPE A COPYRIGHT SYMBOL ©  
UP
28.1 Q: First of all what combination of keys insert the copyright symbol ©? 

A: Here’s one way to do it (Lucy):

· When the text layer is active, while holding down the Alt key enter 0169 on the numeric keypad. When you release the Alt key, the © symbol will appear in the text.

Since I can never remember the 0169, here’s another method if you have Microsoft Word:

· Alt + Ctrl + C generates ©
· Copy and paste the © into the Photoshop text layer

- - - - - -

28.2 Q: Do I have to use an action to insert a copyright notice? 

A: No. Check out this link courtesy of EJN to a freeware program:

http://www.webattack.com/get/copyrightleft.html
29. HOW TO: BATCH ADD CUSTOM TEXT TO EACH IMAGE

UP
29.1 Q: I’ve created 100 copies of our Christmas card image. On each I’d like to include a custom message to each recipient, e.g., “Merry Christmas, Mom and Dad,” “Happy Holidaze, Uncle Steve,” etc. Can I batch process this?

A: You sure can.

In this case it’s most likely the images will be the same size, but if you want to apply custom text to a batch of images and they are a mix of different sizes, e.g., 8”x10”, 5”x7” and 3”x5”, consider the following:

· If you want the first character of the text to be, say, 1” to the left of and 1” inch above the bottom right corner regardless of image size, be sure the Ruler is in any mode except Percent. (Right-click in the ruler to choose a setting.)
· If you want the first character of the text to be, say, 75% of the way across the image and 80% down — regardless of image size — be sure the units setting in the Ruler is Percent. 

Preparation

· Open a test image.

· Set ruler units as needed (see above).

· If necessary drag horizontal and vertical guides to set a starting point for the Text tool.
· Select the Text tool and make all the applicable settings, e.g., font style, size, color, etc. Click the justification button that coincides with text placement. For example if the text will be entered at the left side of the image, choose left justification, etc.

· Click at the intersection of the Guides and type in a generic phrase, for example, “Type greeting here”

· If necessary, reposition the text, adjust the guides and settings, etc.

· When satisfied, click the Commit Current Edits checkmark icon at the top of the screen. This layer will serve as a model.


Record the action

· Create a new action.
· Click at the intersection of the Guides and type in a generic phrase, for example, “Type greeting here”

· If necessary, further reposition the text. 

· When satisfied, click the Commit Current Edits checkmark icon at the top of the screen. This layer will serve as a model.

STOP recording.

· Turn on the Display Dialog checkbox for the Make Text Layer command. Doing so will cause the action to pause with each image, allowing you to type the custom text.


Invoke the action through File > Automate > Batch

· The action will pause with each execution of the Make Text Layer command. “Type greeting here” will appear highlighted. Just start typing to replace it with the custom text.

· When the custom text is complete click the Commit Current Edits checkmark icon and the action will continue with the next step.

30. HOW TO: BATCH ADD THE SAME TEXT TO EACH IMAGE

UP
30.1 Q: I just want my name and copyright symbol added to each image… nothing fancy.

A: No problem.

Preparation 

· If you want to apply custom text to a batch of images and they are a mix of different sizes, e.g., 8”x10”, 5”x7” and 3”x5”, consider the following:

· If you want the first character of the text to be, say, 1” to the left of and 1” inch above the bottom right corner regardless of image size, be sure the Ruler is in any mode except Percent. (Right-click in the ruler to choose a setting.)
· If you want the first character of the text to be, say, 75% of the way across the image and 80% down — regardless of image size — be sure Ruler units is set to Percent. 
· Open a test image.

· Set ruler units as needed (see above).

· If necessary drag horizontal and vertical guides to set a starting point for the Text tool.
· Select the Text tool and make all the applicable settings, e.g., font style, size, color, etc. Click the justification button that coincides with text placement. For example if the text will be entered at the bottom right, choose right justification, etc.

· Click at the intersection of the Guides and type in your name, the copyright symbol and date, i.e., “© 2004 - John Doe”

· If necessary, reposition the text, adjust the guides and settings, etc.

· When satisfied, click the Commit Current Edits checkmark icon at the top of the screen. This layer will serve as a model.


Record the action

· Create a new action.
· Click at the intersection of the Guides and type in your name, the copyright symbol and date, i.e., “© 2004 - John Doe”

· If necessary, further reposition the text. 

· When satisfied, click the Commit Current Edits checkmark icon at the top of the screen. This layer will serve as a model.

STOP recording.

· Be sure the Display Dialog checkbox for the Make Text Layer command is not checked. If it is, the action will pause for each image.


Invoke the action through File > Automate > Batch

· The text you specified will be applied uninterrupted to each image.

31. How To: Create a WATERMARK

UP
31.1 Q: I can create the action to apply a watermark, but can you give me some ideas on creating the watermark per se?
A: Here is a very good tutorial from DigitalWeb: http://www.dwphotoshop.com/photoshop/watermarking.php
32. HOW To: CREATE A SIGNATURE BRUSH


UP
32.1 Q: I’ve seen reference to “creating a signature brush” that can be used to sign (or apply a copyright) to an image. How does one create a signature brush?
A: See this tutorial: http://www.myjanee.com/tuts/brush/cbrush7.htm
The brush can be of a signature, logo, copyright notice or any combination thereof.
- - - - -

32.2 Q: Can a signature brush be applied in an action?
A: Not directly. The specific brush can be selected by the action from in the Brushes Palette, but the actual application of the brush must be done manually just like any other brush stroke.

33. HOW To: USE A SIGNATURE BRUSH TO SIGN IMAGES IN BATCH – METHOD 1 AUTOMATIC

UP
33.1 Q: I’ve created a signature brush for my signature. Since brush strokes cannot be recorded, is there a way to apply my signature to a folder of images?
A: Yes.

The big picture and assumptions:

· All images in the source folder have the same orientation and are of the same width, height and resolution.

· You have created a separate image that’s the same orientation, width, height and resolution of the target images. (These are not absolute requirements, but if true it makes things a lot easier.) 

The signature has been applied to a white Background using a color of choice.

The position of the signature on the Background is exactly where you want it on the target images, for example, the bottom right corner.

· You will record four actions to fully automate the process.


Action 1:

· Preparation: Be sure the signature file is closed.

· Action name: Open signature file
· Create new action, assign name and click Record.

· File > Open (choose the appropriate signature file)

STOP recording


Action 1 option:

· In the File > Open step, click the Display Dialog checkbox if you want the option of choosing among different signature files with each run. That way this process becomes more generic. 


Record action 2:

· Preparation: The signature file used for the first action should still be open. If it’s not, open it again.

· Action name: Close signature file
· Create new action, assign name and click Record.

· File > Close 

STOP recording


Record action 3:

· Preparation: 

· Manually open the signature file again. You must open this file before opening the test file below.

· Open a test image which is the same orientation, size, resolution as the signature file.

· Action name: Apply Signature
· Create new action, assign name and click Record.

· Click signature image to select it.

· Select > All to select the Background signature layer

· Edit > Copy
· Click on the test image.

· Edit > Paste to add the signature layer

· Change the blend mode of the layer from Normal to Multiply. This causes the white to be dropped out revealing the layers below the signature.

STOP recording


Record action 4:

· Preparation: 

· Close all open files.

· If you haven’t yet, create a destination folder for the signed images. For this example name it \Destination.

· If you haven’t yet, create a source folder for the unsigned images. For this example name it \Source.

· Place an unsigned test image in \Source.

· Action name: Apply Custom Sig in Batch
· Create new action, assign name and click Record.

· Click on Action Name Open signature file 

· Click PLAY. The signature file will be opened.

· Click on Action Name Apply Signature but DO NOT click PLAY.
· File > Automate > Batch

· Action Apply Signature should be selected

· Source: Folder. Choose (navigate to \Source)

· Destination: Folder. Choose (navigate to \Destination)

· Click OK. This will open the test image in \Source, copy/paste the signature layer and save the signed image in \Destination, as well as record the Batch step in the action.

· Click on Action Name Close signature file 

· Click PLAY. The signature file will be closed

STOP recording


Comments

· After you delete the test image from \Source and signed test image from \Destination, you’re ready to copy images into \Source. Then play action Apply Custom Sig in Batch.

· After pasting the signature layer into the image in action 3 above, you’re free to apply Layer Styles or opacity changes or filters or whatever effects you like to the signature layer. If you decide to take this approach, it would be a good idea to get the steps ironed out before recording the action.

· If you want to apply a copyright notice in the same action, you can either modify the signature layer to include a copyright notice or create a separate copyright layer in the signature file. Extra steps would need to be recorded to select, copy and paste the copyright layer.

· This set of actions can be used for images of varying orientations and sizes. Just create signature files for each variation and in the first action, turn on the Display Dialog checkbox for the Open command. When the first action plays would you open the appropriate signature file whose characteristics correspond to the target images, e.g.
  5x7 @ 300.psd
  7x5 @ 300.psd

  5x7 @  72.psd
  7x5 @  72.psd
     etc.

34. HOW To: USE A SIGNATURE BRUSH TO SIGN IMAGES IN BATCH – METHOD 2 MANUAL

UP
34.1 Q: I’d like to decide where to place the signature stamp for each image. Is there any way to at least semi-automate this?
A: Yes.

The big picture:

· You will need to open the target images either through File > Open or a Null Action invoked through File > Automate > Batch. The number of images you open at a time will be a function of your systems’ resources.

· After applying the signature to each open image, minimize the image window. 

· Run another Null Action via File > Automate > Batch to save and close  all open images.


Step 1: Open the images using an action.

· Action name: Open images
· Create new action, assign name and click Record.

STOP recording

· This creates a Null Action, one with a name but no steps.

Invoke action Open images through File > Automate > Batch 

· Source: Folder or File Browser, wherever the images reside.

· Destination: None. This causes the files to be opened in Photoshop’s window.



Step 2: Apply the signature brush.

· After putting the signature where you want it on each image, minimize the window as a way of keeping track which images have been processed.



Step 3: Save and close images.

· Create a destination folder if you have not yet created one.

· Action name: Close images
· Create new action, assign name and click Record.

STOP recording

· This creates another Null Action, one with a name but no steps. You could use the same action created in step 1 if you like, but one named Close images is more intuitive.

Invoke action Close images through File > Automate > Batch 

· Source: Opened Files.

· Destination: Folder. Choose (browse to destination folder)


Action 1 option:

· In the File > Open step, click the Display Dialog checkbox if you want the option of choosing among different signature files with each run. That way this process becomes more generic. 


Record action 2:

· Preparation: The signature file used for the first action should still be open. If it’s not, open it again.

· Action name: Close signature file
· Create new action, assign name and click Record.

· File > Close 

STOP recording


Record action 3:

· Preparation: 

· Manually open the signature file again. You must open this file before opening the test file below.

· Open a test image which is the same orientation, size, and resolution as the signature file.

· Action name: Apply Signature
· Create new action, assign name and click Record.

· Click signature image to select it.

· Select > All to select the Background signature layer

· Edit > Copy
· Click on the test image.

· Edit > Paste to add the signature layer

· Change the blend mode of the layer from Normal to Multiply. This causes the white to be dropped out revealing the layers below the signature.

STOP recording


Record action 4:

· Preparation: 

· Close all open files.

· If you haven’t yet, create a destination folder for the signed images. For this example name it \Destination.

· If you haven’t yet, create a source folder for the unsigned images. For this example name it \Source.

· Place an unsigned test image in \Source.

· Action name: Apply Custom Sig in Batch
· Create new action, assign name and click Record.

· Click on Action Name Open signature file 

· Click PLAY. The signature file will be opened.

· Click on Action Name Apply Signature but DO NOT click PLAY.
· File > Automate > Batch

· Action Apply Signature should be selected

· Source: Folder. Choose (navigate to \Source)

· Destination: Folder. Choose (navigate to \Destination)

· Click OK. This will open the test image in \Source, copy/paste the signature layer and save the signed image in \Destination, as well as record the Batch step in the action.

· Click on Action Name Close signature file 

· Click PLAY. The signature file will be closed

STOP recording


Comments

· After you delete the test image from \Source and signed test image from \Destination, you’re ready to copy images into \Source. Then play action Apply Custom Sig in Batch.

· After pasting the signature layer into the image in action 3 above, you’re free to apply Layer Styles or opacity changes or filters or whatever effects you like to the signature layer. If you decide to take this approach, it would be a good idea to get the steps ironed out before recording the action.

· If you want to apply a copyright notice in the same action, you can either modify the signature layer to include a copyright notice or create a separate copyright layer in the signature file. Extra steps would need to be recorded to select, copy and paste the copyright layer.

· This set of actions can be used for images of varying orientations and sizes. Just create signature files for each variation and in the first action, turn on the Display Dialog checkbox for the Open command. When the first action plays would you open the appropriate signature file whose characteristics correspond to the target images, e.g.
  5x7 @ 300.psd
  7x5 @ 300.psd

  5x7 @  72.psd
  7x5 @  72.psd
     etc.

35. How To: Batch Process A Signature With A Layer Style  

UP
35.1 Q: My signature is on a regular layer (not a background) and has a Layer Style associated with it. How to I copy/paste it into the target image? The text transfers okay, but the Layer Style is missing and the signature ends up right in the middle of the target image.

A: When a signature (with or without a Layer Style) is by itself on an otherwise transparent Type layer, you cannot use Select All, Copy and Paste to transfer the layer to the target image. Doing so will place the signature directly in the center of the target image regardless of the placement of the signature in the layer. If the signature has a Layer Style associated with it, it will be lost in the transfer.

When recording the action do this instead:

· Instead of Select All, Alt + Click on the signature layer, loading the signature’s selection.

· Instead of Edit > Copy, use Edit > Copy Merged (TonyK). This gets the Layer Style, too.

· Before executing Edit > Paste in the target image, choose the Rectangular Marquee and create a small selection at the center of where you want the signature to be positioned.

· Then finish up with Edit > Paste, centering the signature on the active selection.

36. How To: Create a Custom Shape for a Signature and apply it through Batch
UP
36.1 Q: Can I create a custom shape from my scanned (or typed) signature and use an action to apply it?
A: Not only that but you can apply it to batches of images via File > Automate > Batch.
Check out this tutorial from Trimoon’s (Stephen LeQuier) site: 

http://www.trimoon.com/Signature.jpg

Preparation

· Create the signature shape as described in the tutorial above.

· Open a test image.

· If the ruler units are not Percent, right-click the in the Ruler and choose Percent from the menu.

· Drag horizontal and vertical guides so they intersect at what you want to be the bottom right corner of your custom signature. (Alternative: Have them intersect at the center of where you want to place the custom shape).

· Chose the Custom Shape tool and select your signature shape from the customs shape menu.

· For a practice run click the point where the guides intersect, then drag left and up to position/size the shape. (Alternative: While holding down Alt + Shift, drag from the center point.)

· Select the Move tool (V) and fine tune the custom shape location and, if necessary, adjust the guides. 


Record the action

· Click the point where the guides intersect. Then using guides and the previously created shape as a reference drag (or Alt + Shift + drag) to create the custom shape. When you release the mouse button, Photoshop will record a Make Fill Layer command in the action.

· STOP 


Note: Because the ruler units were set to Percent, the command positions the shape in the image at a relative position (by horizontal and vertical percent relative), not by specific measure (say, inches). So what? The action will work without modification on images of any size, orientation or resolution. That's about as flexible as it gets for an action.

M. Excercises 
UP
The purpose of following exercises is to provide an opportunity to create and modify a few simple actions. 

1. EXERCISE 1: CREATE NEW ACTION “STOP ACTION 1”

UP
1.1 Let’s record an action consisting of four Stop Commands. No image is required.

· Be sure the Actions Palette is visible (Window > Actions) and is in List Mode (Actions Palette Menu: No check mark next to Button Mode.)

· At the bottom of the Actions Palette click Create New Set (() to bring up the New Set dialog.

· Action set name: My Actions
· OK

· Click Create New Action (() to bring up the New Action dialog.

· Assign an Action Name: Stop Action 1
· Click the button labeled Record in the dialog box to close the dialog box and engage Record Mode. Notice Record (●) at the bottom of the Actions Palette changes from black to red (●), indicating Record Mode is active.
· Insert the 1st Stop Command: From the Actions Palette Menu choose Insert Stop…
· Enter message text: “Step 1: This action was written by [your name].”

· Click the Allow Continue checkbox.

· Click OK to exit the dialog box.

· Insert the 2nd Stop Command: From the Actions Palette Menu again choose Insert Stop…

· Enter message text: “Step 2: Choose a foreground color.” 

· This time do not click the Allow Continue checkbox.

· Click OK to exit the dialog box.

· Insert the 3rd Stop Command: From the Actions Palette Menu, choose Insert Stop…
· Enter message text: “Step 3: Click STOP to choose a different foreground color or CONTINUE to stick with the one already selected.”

· Click the Allow Continue checkbox.

· Click OK to exit the dialog box.

· Insert the 4th Stop Command: From the Actions Palette Menu, choose Insert Stop…
· Enter message text: Type “Step 4: The End” and the rest of the text is up to you. “Congratulations! MY FIRST ACTION!” would work or whatever you decide to type.

· Click the Allow Continue checkbox.

· Click OK to exit the dialog box.

· Click Stop (■) to terminate Record Mode. 

2. TESTING ACTION “Stop Action 1”

UP
2.1 Whenever you write an action, even a simple one, you should test it just to be sure it does what you expect.

· Click the Action Name Stop Action 1
· At the bottom of the Actions Palette click Play (►).
· The “Step 1” message displays. You see this type of thing all the time with actions downloaded from the Internet. These are informative the first time you play the action and annoying forever more. What do you think will happen if you click the Stop button in the dialog box? How can you disable the display of this message without completely pausing the action? If you do click the button in the dialog box labeled Stop, how do you resume a paused action? 

· The “Step 2” message displays requesting you take manual action to complete a task the action cannot perform for you. You have no choice. Click the button labeled Stop in the dialog box. Notice, too, the absence of information in the message on how to resume the action. This is not a good example of how not to compose messages if you expect rookies to play your actions! Something like, “Click PLAY when colors selected” would be helpful.

· For this exercise it’s not imperative you actually choose a different foreground color, so do so if you choose. The point is to illustrate what to do when an action is paused when Stop is clicked: click Play (►). (If you’re not familiar with selecting colors and you want to find out more, consult Photoshop Help and search on “Choosing foreground and background colors.”) 

· The “Step 3” message is displayed. This is another typical situation where you’re being asked to make a decision. Your call on which button to push. If you click Stop, what has to be done to resume the action? (Is this starting to make sense?)

· The “Step 4” message displays your message of triumph. Click either button since this is the last step in the action.

· A quick modification.

· Although there’s no real harm, it makes no sense to display the Continue button in the last step of an action. Just for fun double-click on this last Stop Command (to open the dialog box), uncheck the Allow Continue checkbox and click OK.

· To test your change without having to play all the preceding steps, select (highlight) the last Stop Command (if it is not still highlighted) and then click Play (►), which starts the action from the selected step. 

3. DUPLICATEMYIMAGE

4. EXERCISE 2: RECORD NEW ACTION “Duplicate My Image”

UP
4.1 Let’s create an action that creates a duplicate image and closes the original image. This action will come in handy for testing actions acquired from outside sources. Applying an action to a copy of an image is safer than applying it to the original if you’re not familiar with the action.

· Be sure the Actions Palette is visible (Window > Actions) and is in List Mode (Actions Palette Menu: No check mark next to Button Mode.)

· Open any image. It makes no difference which one.

· Click Create New Action (().

· In the New Action dialog, assign:

· An Action Name: Duplicate My Image
· Click the Record button in the dialog box.
· From the Image Menu: 

· Choose Duplicate. In the dialog box leave the file name as is and click OK.

· Click on the original image making it the current image. Notice a Select command was added to the action reflecting the just-made mouse click. 

· File > Close.

· Click Stop (■). 
5. TESTING ACTION “Duplicate My Image”

UP
5.1 Let’s test our second action.

· Close the image generated during the development of the action. There is no need to save it.

· Open any image.

· Select (highlight) the Action Name (Duplicate My Image)

· Click Play (►) and observe your handiwork:

· Duplicate First Document

· Select Previous Document

· Close

You can (and probably should) play this new action before you run actions downloaded from the Internet. 

Close the duplicate and open any document. Let’s try playing an action “one step at a time.”

· Select (highlight) the first step in the action.

· While holding down Ctrl, Click Play (►). The first step executes, then the action pauses.

· While holding down Ctrl, Click Play (►) again. The second step executes, then the action pauses.

· You’re on a roll. Do it again for the last step.

This technique comes in handy when you’re learning about actions (you control the playback rate) or when there’s a problem with an action and you’re trying to figure out what’s wrong.

6. EXERCISE 3: ASSIGNING A KEYBOARD SHORTCUT TO “Duplicate My Image”

UP
6.1 In this exercise we’ll assign a keyboard shortcut to the Duplicate My Image action created in the previous exercise. 

· Modifying the action.

· Click on (highlight) action Duplicate My Image.

· From the Actions Palette Menu choose Action Options.

· If F5 is available from the Function key menu choose it. If F5 is not available, choose any non-grayed out function key. It may be necessary to choose one of the modifier keys (Ctrl, Shift) as well. In any event REMEMBER THE KEYBOARD SHORTCUT you just assigned! 

· Select a color (something other than gray) from the Color drop down menu. 

· Click OK to exit the dialog.

· Test the action. 

· Open any image.

· Close the Actions Palette. 

· Press F5 (or whatever keyboard shortcut you assigned) to launch Duplicate My Image and watch in amazement as the image is duplicated and the original closed.

· Pat yourself on the back. Well done!

· Close your duplicate image without saving.

· Going a little farther. 

· Show the Actions Palette (F9 or Window > Actions)

· Open any image.

· From the Actions Palette menu choose Button Mode.

· Scroll and/or size the Actions Palette so you can see the color coded button labeled Duplicate My Image that also displays the keyboard shortcut. 

· Click the button. You have just played an action in Button Mode!

· Close your duplicate image without saving.

· From the Actions Palette menu choose Button Mode, which will put the Actions Palette into List Mode. Go figure.

7. EXERCISE 4: INSERTING A DUPLICATE IMAGE COMMAND IN AN ACTION

UP
7.1 After downloading an action from the Internet and playing it for the first time something I always do is visually inspect it. Search on B4UPLAY
After that I frequently modify the action so a Duplicate Image command is the very first step. What makes this a little tricky is the fact you cannot Record or use Insert Menu Item to place a command in the first position of an existing action. Here’s how to do it.

· Open any image. It makes no difference which one. 

· Choose any action on which you want to try this technique.

· Create a backup copy of the action to be modified (a good habit to start): Drag and Drop the action onto Create New Action (().

· Select (highlight) any step in the action, first, last, in between. It makes no difference. (I usually choose the first step.) 

· Click Record (●).

· Image > Duplicate. In the dialog box change the file name if desired. Click OK. (I typically choose a file name that’s the same as the Action Name so I know what action created the image.)

· Click Stop (■). We have a minor problem, however: The Duplicate Image command has been recorded, but obviously is not the first command that the action will execute. What to do? 

· No problem. Drag and drop the Duplicate Image command from wherever it is into the desired position, that is, the first step in the action. 

· Optional (but recommended): Click the Display Dialog ([image: image29.png]


) setting for the Duplicate Image command to clear it. This will suppress the Duplicate Image dialog when the action plays.

· Close the original image.

· Test your action.

· Take a bow.

N. APPENDICES

UP
1. TESTING ENVIRONMENT

UP
· Dell 330 Precision workstation, 1.4mhz P4, 1gb RAM, 320gb HD space (three drives)

· Windows 2000, Service Pack 3

· Sony 21” FD Trinitron monitor

· Photoshop 7.01

· Lots of orange juice

2. SUMMARY OF ACTION AND ACTION PALETTE OPERATIONS

UP
BIGTABLE

This table summarizes various methods used to add, change or delete commands, actions or Action Sets within the Actions Palette.

	OPERATION
	ACTION SET
	ACTION
	STEP

	Changes outcome of action: Duplicating an object
	No
	No
	Yes, if copied step(s) remains in original action

	Changes outcome of action: Moving an object
	No
	No
	Yes

	Color code: assign, change, unassign
	
	For a new action assign in New Action dialog. For an existing action add, change or delete through the Actions Options dialog.
	

	Delete (no confirmation)
	Select, Alt + click Trash ([image: image30.jpg]


)
	Same
	Same

	Delete (no confirmation)
	Select, Drag and Drop onto Trash [image: image31.jpg]


)
	Same
	Same

	Delete (with confirmation)
	Select, choose Delete from Actions Palette Menu
	Same
	Same

	Delete (with confirmation)
	Select, click Trash ([image: image32.jpg]


)
	Same
	Same

	Duplicate (copy)
	Select, Click Create New Set (()
	Select, Click Create New Action (()
	

	Duplicate (copy)
	Select, Drag and Drop onto Create New Set (()
	Select, Drag and Drop onto Create New Action (()
	Select, Drag and Drop onto Create New Action (()

	Duplicate (copy)
	## Select, Alt + Drag and Drop into new location. 
	Same
	Same

	Duplicate (copy)
	Select, choose Duplicate from Actions Palette Menu
	Same
	Same

	Load
	Choose Load Actions from the Actions Palette Menu
	You cannot Load an individual action
	

	Load
	Drag and drop selected Action Set File(s) into Photoshop Window
	You cannot Load an individual action
	

	Modify all steps in action
	
	Select Action Name and choose Record Again from Actions Palette Menu
	Select first step in action and choose Record Again from Actions Palette Menu

	Modify multiple steps in action, not starting with the first step
	
	
	Select steps and choose Record Again from Actions Palette Menu

	Modify single step
	
	
	Double-Click step

	Modify single step
	
	
	Select step and choose Record Again from Actions Palette Menu

	Move
	## Select, Drag and Drop into new location 
	## Same 
	## Same

	New Action 
	
	$$ Select any action or Action Set and click 
	

	New Action
	
	Select any action or Action Set and click New Action from Actions Palette Menu
	

	New Action Set 
	$$ Select any action or Action Set and click Create New Set (().
	
	

	New Action Set
	Select any action or Action Set and click New Set from Actions Palette Menu
	
	

	New step
	
	
	Click Record (●)

	New step
	
	
	Choose Start Recording from Actions Palette Menu

	New step
	
	
	Copy step from another action

	New step
	
	
	Move step from another action

	New step
	
	
	Select Insert Menu Item from Actions Palette Menu

	New step at end of action
	
	Select Action Name and click Record (●)
	Select last step in action and click Record (●)

	New step (Stop Command)
	
	
	Select Insert Stop from Actions Palette Menu

	Play Action
	
	Select and click Play (►)
	Select 1st step in action and click Play (►)

	Play Action
	
	Select, Ctrl + Double-click
	

	Play Action
	
	Select, Drag and Drop onto Play (►)
	

	Play Action
	
	Select and choose Play from Actions Palette Menu.
	Select 1st step in action and choose Play from Actions Palette Menu.

	Play part of an action
	
	
	Select steps and click Play (►), or

Select steps actions and drag over Play (►) or 

Select steps actions and choose Play from Actions Palette Menu

	Play all actions in the same Action Set in sequence listed
	
	Hold down Shift key to select individual actions, then click Play (►), or

drag over Play (►) or 

choose Play from Actions Palette Menu


	

	Play some actions in the same Action Set in sequence listed in Action Set
	
	Hold down Shift key to select individual actions, then click Play (►), or

drag over Play (►) 

or 

choose Play from Actions Palette Menu
	

	Play some actions in the same Action Set but not in sequence listed in Action Set
	
	Write an action that plays desired actions in desired sequence.
	

	Play actions across multiple action sets
	
	Write an action that plays desired actions in desired sequence.
	

	Play one step at a time
	
	
	Select step, Ctrl + click Play (►)

	Play one step at a time
	
	
	Select step, Ctrl + Double-click

	Play one step at a time
	
	
	Select step, Drag and Drop onto Play (►)

	Rename
	Double-click on Action Set Name and type new name
	Double-click on Action Name and type new name
	

	Rename
	Select and choose Set Options from Actions Palette Menu 
	Select and choose Action Options from Actions Palette Menu
	

	Save
	Select and choose Save Actions from Actions Palette Menu
	You cannot save an individual action by clicking on it. 

You must click on the Action Set Name it resides in and save the Action Set as described at left.

Alternative: Create a new Action Set and then copy (Alt + drag) the action of interest into it. Save the new Action Set using the Save Actions command.
	

	Select one 
	Click Action Set Name
	Click Action Name
	Click step

	Select many, contiguous range (CS)

SharonLC
	Click first Action Set Name, then Shift + click last Action Set Name
	Click first Action Name, then Shift + click last Action Name
	Click first step, then Shift + click last step

	Select many, contiguous range (Prior to CS)
	Click first Action Set Name, then Ctrl + click last Action Set Name
	Click first Action Name, then Ctrl + click last Action Name
	Click first step, then Ctrl + click last step

	Select many, non-contiguous (CS)

SharonLC 
	Click first Action Set Name, then Ctrl + click last Action Set Name
	Click first Action Name, then Ctrl + click last Action Name

Actions must be in same Action Set.
	Click first step. 

Ctrl + click last step.

Steps must be in same action.

	Select many, non-contiguous (Prior to CS) 
	Click first Action Set Name, then Shift + click last Action Set Name
	Click first Action Name, then Shift + click last Action Name

Actions must be in same Action Set.
	Click first step. 

Shift + click last step.

Steps must be in same action.

	Shortcut keys:

assign, change or unassign
	
	For a new action assign in New Action dialog. For an existing action add, change or delete through the Actions Options dialog.
	

	OPERATION
	ACTION SET
	ACTION
	STEP

	Changes outcome of action: Duplicating an object
	No
	No
	Yes, if copied step(s) remain in original action

	Changes outcome of action: Moving an object
	No
	No
	Yes

	ACTION PALETTE OPERATION
	HOW TO
	
	

	Delete all actions
	Choose Clear Actions from Actions Palette Menu
	
	

	Delete all actions and load Default.atn
	Choose Reset Actions from Actions Palette Menu
	If you choose the append option, no action sets will be deleted. Default.atn will be appended. 
	

	Delete all actions and load the Action Set specified 
	Choose Replace Actions from Actions Palette Menu
	If you choose the append option, no action sets will be deleted. The specified Action Set will be appended.
	

	Alt + Click Show/Hide Triangle
	Shows/Hides all actions steps in all actions in the Action Set
	Shows/Hides all steps in the action
	

	Show/hide Actions Palette
	F9 (unless reassigned) or Window > Actions
	
	

	Stop action that’s running
	Esc or click Stop (■)
	
	

	Stop action when a dialog box is displayed
	Esc or click Cancel button in dialog box
	
	


## When moving or copying an Action Set, action or step, the thick line that appears between Action Sets, Actions or steps as you drag indicates where the selected object(s) will be placed when the mouse button released. If the destination Action Set or action is collapsed, the selected object(s) will be placed at the bottom position of the destination Action Set or action.

$$ If you hold down the Alt key as you click Create New Set (() or Create New Action ((), the New Set or New Action dialogs will be suppressed and Photoshop will assign default names.

LAYERKBSHORTS

3. KEYBOARD SHORTCUTS: LAYERS PALETTE RELATED (HANDY FOR ACTION WRITING)

UP
Repositioning layers

· Move the current layer to the bottom layer of the Layers Palette, above the Background if a Background is present.
Ctrl + Shift + [


· Move the current layer to the top of the Layers Palette.
Ctrl + Shift + ]

· Move the current layer up one position in the Layers Palette.
Ctrl + [

· Move the current layer down one position in the Layers Palette. 
Ctrl + ]

Making a different layer active

· To activate the bottom layer in the Layers Palette. It does not have to be named Background.
Alt + Shift + [


· To activate the top layer in the Layers Palette. 
Alt + Shift + ]



· To activate the layer immediately below the current layer. 
Alt + [


· To activate the layer immediately above the current layer.
Alt + ]

Miscellaneous

· Merge visible layers without collapsing individual layers.
Alt + Ctrl + Shift + E


· Copy a layer from Image A into Image B and center the layer in the destination image.
Shift + Drag

ACTIONFILTERPLUGIN

4. ACTIONS ARE NOT FILTERS OR PLUG-INS (and vice versa)

UP
4.1 Q: What’s the difference between an action, a filter and a plug-in (also spelled, plugin, and sometimes referred to as a third (3rd) party plug-in)?

A: Plug-ins and filters have a number of similarities but few characteristics in common with actions.


FILTERS 

The term filter comes from traditional photography and denotes a device, attached to or placed in front of a camera’s lens, absorbs, that minimizes or alters light waves passing through it. From the Photoshop perspective filters selected from the Filter menu also modify an image by applying mathematical algorithms to image pixels to generate various effects, few of which have any correlation to traditional photography. The set of filters installed with the base Photoshop product are sometimes referred to as native filters.

Filters cannot carry out Photoshop commands nor run actions, plug-ins or other filters. Beyond dialog box controls (if any), one cannot alter the outcome of a filter, for example, by reprogramming it.

Something that’s confusing is that Photoshop’s native filters must reside in a folder named \plug-ins.



PLUG-INS

Plug-ins are the equivalent to optional equipment on cars. Much like a luggage rack, winch or power ashtrays add functionality or convenience to an SUV, plug-ins do the same in Photoshop. The term plug-in comes from the metaphor of adding functionality by “just plugging it in.” 

It’s not uncommon to hear a plug-in referred to as a plug-in filter because many plug-ins perform filter-like pixel altering functions. Some plug-ins, however, do not transform an image; hence the term plug-in filter does not apply to all plug-ins.

Plug-ins can be free (or shareware) and downloaded from the Internet; others are available commercially (sometimes referred to as “3rd party plug-ins”) and can cost from $15 to hundreds of dollars. Photoshop has a few plug-ins included in the base product.

While plug-ins can reside in the folder named \plug-ins, most can reside in folders other than \plug-ins. Go figure.

Like filters, plug-ins have limited functionality which can usually be modified or adjusted through dialog box controls and settings. They cannot carry out Photoshop commands nor run actions, filters or other plug-ins.

Occasionally the source code (programming language commands) for free plug-ins is available, enabling those with applicable skills to modify the plug-in. I’ve never seen source code made available for a commercial plug-in.

Plug-ins are usually, but not always, initiated from the Filters menu, though some can be found under the File, Select and even their own custom menus. 

Here are a few well known 3rd party plug-ins: BuzzPro, Nik Sharpener, Knockout 2, Neat Image, AutoFX Dream Suite, Extensis PhotoFrame.


Actions 

· Easy to modify; very flexible.

· Not initiated by menu commands like plug-ins; initiated by keyboard shortcuts, Actions Palette control, droplets or the File > Automate > Batch dialog.

· Computer programming skills are not required to develop or modify them.


SIDE-BY-SIDE COMPARISON

The table below may help lift a little more of the fog. On the other hand, it may make matters worse. You decide.

	CHARACTERISTIC
	ACTIONS
	FILTERS
	PLUG-INS

	Installed with Photoshop?
	Yes. About 50 sample actions are installed.
	Yes. Filters are part of the base product.
	A few as part of the base product. Most others are acquired by shareware download or purchase. 

	Examples
	See Adobe provided actions in Default.atn as well as actions available to load via the Actions Palette Menu 
	Gaussian Blur, Unsharp Mask, Watercolor, plus over 90 more
	BuzzPro, PhotoFrame, Genuine Fractals,

Nik Sharpener, etc.

	Can you add more to Photoshop?
	Yes. Free or commercial actions are readily available.
	Yes. 

Filter > Other > Custom allows you to create your own filters.
	Yes. Free or commercial plug-ins are readily available. 

Optional plug-ins are available on the Photoshop CD.

	Activated from?
	Actions Palette, Keyboard Shortcut, File > Batch > Automate dialog or other actions
	Filter menu
	Filter or File menu (normally); sometimes from other menus.

	What is displayed on-screen?
	Dialog boxes associated with commands it carries out, which can be optionally suppressed.

In addition a very simple, action-specific dialog boxes are generated Stop commands. Button choices are limited to “OK,” “Continue” and “Stop.”


	Adobe programmed dialog box. With the exception of the Lighting Controls filter, generally speaking options are relatively few and controls are intuitive.
	A custom interface. Options and controls range from few and simple to many and complex. May or may not have separate menu(s).

	File name extension?
	.atn
	.8bf (usually)
	.8bf (usually)

	In order to run, must be located where? 
	In the Actions Palette.
	\Plug-Ins\Effects or

\Plug-Ins\Filters
	\Plug-ins or a custom folder



	Affect on an image
	Depends. May perform a completely non-transformational task.
	Usually transforms it in some way.
	Most, but not all, transforms it in some way.

	How developed?
	Recording or inserting commands
	Compiled Programming Languages
	Compiled Programming Languages

	Can be created easily by a typical Photoshop users?
	Yes
	No **

** I’m talking about Adobe provided filters, available in the Filter menu, not ones created through the Filter > Other > Custom Filter dialog, whose settings can be modified.
	No**

** Tools like Filtermeister and Filter Factory can be used to craft custom plug-ins (PierreC).

A typical user, however, would not find building plug-ins an easy task. Some degree of programming skill is required.

	User can modify?
	Yes
	No. Photoshop source code not available.
	Yes, if source code is available (shareware plug-ins).

	Can invoke
	Filters, plug-ins, other actions, most commands.
	Cannot invoke actions, plug-ins or other filters. 
	With the exception of scripts generated by PS Scripting, cannot invoke actions, plug-ins or other filters.

	Functional scope
	Extremely broad compared to filters and plug-ins.
	Limited to programmed function.
	Limited to programmed function.

	Programming skills required to create or modify?
	No. Can be written by “regular people.”
	Yes, definitely. Must be an Adobe engineer.
	Yes, definitely.

	Easy to create or modify?
	Yes
	Does not apply.
	If source code is available, it depends on plug-in complexity and programming skills.

	Support, bug fixes
	If a commercial action, the degree and quality of support depends on the vendor. If you got the action via Internet download, support will be a function of being able to reach the original author.
	Yes, if necessary, but highly unlikely. Photoshop filters are very stable.
	If a commercial plug-in, degree and quality of support depends on the vendor. If you got the plug-in via Internet download, support will be a function of being able to reach the original author.

Visit http://www.adobe.com for downloads and fixes.

	Compatible with Photoshop Elements?
	Yes, subject to limitations.
	N/A. Elements has its own filter set.
	Usually.

	Compatible with other image editing programs, e.g., Paint Shop Pro, PhotoImpact, Photo-Paint, etc.
	No.
	No.
	Usually.

	Cost if purchased
	Generally less than $10 U.S. Most actions are free, however.
	No additional cost. Included with Photoshop.
	From $20 U.S. to literally hundreds of dollars U.S.

	Estimated availability of additional, non-Adobe provided
	Thousands (commercial and shareware)
	N/A
	Best guess: Less than 2500 sets of plug-ins (commercial and shareware)


SFWACKINESS

5. NUANCES OF APPLYING SAVE FOR THE WEB VIA BATCH OR DROPLET

UP
5.1 If an action invoked through either the File > Automate > Batch (FAB) or File > Automate > Create Droplet (FACD) dialogs contains a Save for the Web (SFW) command, which is recorded as an Export command in the action, strange and unexpected things can happen depending on settings made in the FAB or FACD dialogs. 

Search on SAVEFORWEB
The things to remember are:

· Under all circumstances, regardless of what settings are specified in the FAB or FACD dialogs, files are written to the folder recorded in the Export command.

· Under all circumstances, regardless of what settings are specified in the FAB or FACD dialogs, file names are unchanged by the Export command.

· Most setting combinations result in two new copies of each image from the Source folder.

Normally if an action does not include a Save As… command specifying ‘Override Action “Open” Commands’ results in no images written to the Destination folder. However if an Export command is present in the action, you do indeed want to check ON ‘Override Action “Save as…” Commands.’ 

Why? If you don’t, two copies of each image from the Source folder are saved:

· One to the folder recorded in the Export command.

· The other in either Photoshop’s window when Destination = None or in the specified Destination folder.

To suppress the second copy generated the underlying functionality of File > Automate > Batch, specify any Destination folder (it will be ignored) and remember to check ON ‘Override Action “Save as…” Commands.’ 

The table below summaries the results of various setting combinations. 

	Save for the Web (Export) command present in action
	Destination dropdown menu choice specified in File > Automate > Batch (FAB) or File > Automate > Create Droplet (FACD) dialogs
	Folder specified in FAB or FACD same as the one specified in SFW.
	Custom File Name specified in File > Automate > Batch or File > Automate > Create Droplet
	Result: SFW folder
	Result: FAB or FACD folder
	Comment

	No
	N/A
	N/A
	No.
	N/A
	Processed images written to folder specified in FAB or FACD command.

File names unchanged.
	SFW command not present in the action.

This entry included for completeness.

	No
	N/A
	N/A
	Yes
	N/A
	Processed images written to folder specified in FAB or FACD command.

File names assigned according to specifications in FAB or FACD command.
	SFW command not present in the action.

This entry included for completeness.

	Yes
	None
	N/A
	N/A
	Processed images written to folder specified in SFW command. 

File names unchanged.
	N/A
	In addition processed images are left open in Photoshop’s window.

	Yes
	Folder
	No
	No.
	Processed images written to folder specified in SFW command. 

File names unchanged.
	Processed images also written to folder specified in FAB or FACD command.
	“Ignore Action ‘Save As’ command”

option OFF

	Yes

See ## below.
	Folder
	No.


	No.
	Processed images only written to folder specified in SFW command. 

File names unchanged.
	
	Specify any folder as a Destination. It makes no difference which one.

“Ignore Action ‘Save As’ command”

option must be ON.

	Yes
	Folder
	No
	Yes.
	Processed images written to folder specified in SFW command. 

File names of images saved via SFW unchanged.

Net result: Two copies of each image: One optimized via SFW, the other not.
	Processed images also written to folder specified in FAB or FACD command.

File names assigned according to specifications in FAB or FACD command

Net result: Two copies of each image: One optimized via SFW, the other not.
	You get two copies of the processed images. 

One copy in the SFW folder; another copy in the FAB or FACD folder.

SFW file names: Unchanged.

FAB or FACD file names: Assigned according to custom settings.

	Yes
	Folder
	Yes
	No. Default settings used.
	Processed images written to folder specified in SFW command. File names unchanged.

Unfortunately each image is overwritten with a processed, but unoptimized copy as a result of the FAB or FACD settings. 

Since the default settings were used for the custom file name, it appears that SFW was ignored. It wasn’t ignored. Each image processed by SFW was  overwritten.
	Processed (but unoptimized) images written to folder specified in SFW command. 

File names unchanged.


	Big problems. 

The images saved by the SFW command are lost; they are overwritten as a natural byproduct of the FAB or FACD settings because the default file name settings are, in effect, don’t change the file name.

This is just how it works.

	Yes
	Folder
	Yes
	Yes.
	Processed images written to folder specified in SFW command. File names unchanged.


	Processed images also written to folder specified in FAB or FACD command.

Files named according to settings specified in FAB or FACD command.


	You get two copies of each image in the folder specified in SFW, which happens to be the same folder specified in FAB or FACD.

The file name of the copy from SFW will be unchanged. The other copy will be named according to the file name specifications in FAB or FACD.




6. BIBLIOGRAPHY

UP
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With all due respect to every English teacher I ever had who taught me that bibliographies are supposed to be listed by author last name, I submit this format is more useful. We’re living in the age of the Internet, where all you need is a title or ISBN.

Secondly, you’ll note most of the references below were written for past editions of Photoshop. Fortunately actions and their capabilities haven’t changed all that much over the years. 

ACE Photoshop 5 Exam Cram: Exam: 9A0-006. Mike Cuenca. The Coriolis Group, 1998. ISBN: 1-57610-374-9.

Photoshop 4 Complete. Kate Binder. Ted Alspach. et al. Hayden Books, 1997. ISBN: 1-56830-323-8.

Photoshop 5 & 5.x Artistry. Barry Haynes. Wendy Crumpler. New Riders, 2000. ISBN: 0-7357-0994-7.

Photoshop 5 4th Edition. Adele Droblas Greenberg and Seth Greenberg. Osborne/McGraw-Hill, 1998. ISBN: 0-0788-2579-2.

Photoshop 5 In Depth. David Xenakis. Sherry London. The Coriolis Group, 1998. ISBN: 1-57610-293-9.

Photoshop 5.0 Certification Guide. Michael Lennox. Elizabeth Bulger. Adobe Press, 1999. ISBN: 1-56830-473-0.

Photoshop 5.x: Get Professional Results. Ken Milburn. Osborne/McGraw-Hill, 2000. ISBN: 0-0721-2299-4.

Photoshop 6 Shop Manual. Donnie O’Quinn. New Riders Publishing. 2002. ISBN: 0-7357-1130-5.

Photoshop 7 Bible. Deke McClelland. Wiley Publishing Inc., 2002. ISBN: 0-7645-3694-X.

Photoshop 7 Bible Professional Edition. Deke McClelland. Wiley Publishing Inc., 2003. ISBN: 0-7645-1993-X.

Photoshop 7 Help. Adobe Systems, Inc., 2002.

Real World Photoshop 5 Industrial Strength Production Techniques. David Blatner. Bruce Fraser. Peachpit Press, 1999. ISBN: 0-201-35375-X.

The Complete Reference Photoshop 6. Adele Droblas Greenberg and Seth Greenberg. Osborne/McGraw-Hill, 2001. ISBN: 0-07-213167-5.

The Hidden Power of Photoshop CS. Richard Lynch. Sybex, 2004. ISBN: 0-7821-4255-9.

The Waite Group’s Adobe Photoshop 5 How-To. Richard Lynch. SAMS Publishing. 1999. ISBN 1-57169-156-1.

7. Submitting Suggestions And Corrections

UP
==================================

FEEDBACK IS WELCOME AND ENCOURAGED

==================================

If you have suggestions, corrections, opinions, questions, comments, or version 2.0 content ideas you’d like to submit for consideration, I’d like to hear from you. 

Send e-mail to:

PhotoshopActions@Yahoo.com 

· In the e-mail text please specify The version number of this document (1.1B)

· For each correction, suggestion, comment, etc. specify the section reference number from the document to which you are referring, e.g., 

24.6 – This is incorrect. You CAN teach an old dog new tricks. 
37.3 – There’s another way to do that, and here it is…
77.5 – This isn’t clear to me: What do you mean “xxx…” 
125 – Photshop is misspelled.
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Alan Smallbone, who back in 2001 crafted http://www.geocities.com/kafuensis/ to host the DPReview Retouching Forum Action collection and continues to support and improve it. More times than I can count Alan has reeled me back to reality and calmed me down when overstressed — usually over things that don’t amount to a hill of Viagra.

Tony Kazarian (known as YrbkMgr to those who frequent the http://www.adobeforums.com/ Photoshop for Windows forum) for his incredible enthusiasm and willingness to help others. You are one in a million, Tony. The world needs more people like you. 

Mike Finn, a certified photo-art action genius, who’s graciously shares so many of his techniques and has inspired me beyond description.

Gerry Reid (http://www.gerryreid.com/), the A.S.K. Master, who was a mentor in the late eighties and early nineties. One day after his book A.S.K for Success was published he planted a seed when he said, “You really should get you’re A.S.K in gear and get published yourself.” Though you’ll never see this tutorial for sale at Amazon.com, Gerry, know your inspiring presentations and seeing how you always have distinguished yourself with integrity and class regardless of the circumstances in your life has made a real difference in mine.

Richard Arnold IV, who counseled me to complete my college degree back in the late 1970s, which I eventually did. Completing my B.S. opened doors that would never been open otherwise allowing me to pursue career opportunities that had a dramatic impact (for the better) on my future.

My mother, Joyce Margaret Raphael, who taught me that “If you want a helping hand, you’ll find one at the end of each arm.” Thanks, Mom, for a lifetime of encouragement and believing in me during the times I wasn’t believing in myself.

My father, Joe C. Raphael, who nurtured my budding interest in photography. I’ll never forget the times he sequestered himself in our one and only bathroom-converted-to-a-darkroom so he could make his own prints. The lessons I learned from him about the importance of delivering high quality work and paying attention to planning and detail have served me very, very well. Thanks, Dad.

My children, Alexandra (Ali) and Nathaniel, who remind me each day of the definitions of joy and miracles.

My caring, supportive lifetime partner and wife, Lisa, who is often bewildered why I take perfectly good photographs and try to turn them into “art” — but continues to love me anyway.

And finally, to Pastor Rick Flanagan from Ridge Crest Community Church in Snoqualmie, Washington, whose 2002 Easter sermon inspired me to form a relationship with and accept Jesus Christ as my Lord and Savior. What greater gift is there than that? 

9. ABOUT THE AUTHOR

UP
I feel a little awkward doing this, but several folks who previewed this document recommended I share a bit about myself, so here goes. 

My story describes the convergence of my interests in photography and computers. It only took about forty years for them to finally come together.

My earliest lesson in photography came when I was about six years old. I’d just gotten out of the bathtub and as I was drying off my father returned from the toy store with a brand new, simulated-chrome, plastic Mattel six-shooter with belt and holster (complete with fringe). This was back when it was still politically correct to buy toy guns for your kids. 

I was so excited that I insisted on strapping on my new pistol and holster without first bothering to get dressed. Dad, having a keen sense for Kodak Moments long before that became a marketing slogan, reached for his Rolleiflex camera and prepared to shoot. Having a bit of modesty then and realizing what was about to happen I decided to foil the photographer by turning around, leaning against the bathroom door and covering my eyes with my hands. My six year-old brain reasoned, “If I can’t see you, then you can’t see me.”

Click. Flash. A moment in time preserved in black and white (color film and processing was too expensive for most folks back then).

Sure glad there was no Internet when this happened or that image surely would have shown up in your e-mail inbox with a description something like, “Plastic six-shooter, complete with simulated bullets: $2.95. Imitation leather holster and belt (with fringe): $1.49. Naked kid hiding eyes with back to camera while wearing both: Priceless.”

That incident piqued my interest in photography and since then I’ve taken hundreds of pictures, which fill boxes and albums in my garage. Much to the chagrin of friends, relatives and my children, many of those pictures are ones I’m sure they wish I hadn’t taken. 

My equipment has been representative of my enthusiastic amateur skills: Kodak Brownie and 110 Instamatic, Argus C-3, Canon AE-1 (wore one out and bought another) and as of 1996 a Nikon N70 35mm SLR. The plan is to make the transition to big time digital when Nikon comes out with a 10MP+ body for less than a grand. 2005 maybe? We just purchased a 3MP Minolta pocket digital, so the transition has begun, albeit slowly. 

Now for the computer part of the tale…

In late 1999 I started tinkering with Adobe PhotoDeluxe 2.0 that came with a freebee scanner thrown in with a laptop computer purchase. Before I knew it I was hooked. 

It didn’t take long to outgrow PhotoDeluxe and after a frustrating experience with a trial version of Photoshop, opted for Corel PhotoPaint 10, the newest release at the time. It only took a few months to give up on PhotoPaint (it had a nasty habit of crashing at exceptionally inconvenient times), so I gave Photoshop another try and decided to purchase PS 5.5. It’s been a love—hate relationship ever since.

About that same time I discovered a pen and ink photo-art tutorial at http://www.reallyusefulpage.com/techniques/pen-ink.htm by Gregory Georges and other photo-art tutorials at http://www.myjanee.com/. Those tutorials got me interested in photo-art primarily because I’m artistically challenged when it comes to traditional skills, but always wanted to “create.” 

Sometime later I stumbled on a photo-art tutorial that not only described a lengthy, multi-step technique, it included an action. After downloading it I had no clue what to do next, so I started poking around with actions and have since become a certifiable action addict.

In May, 2002 I accepted an offer from Doug Nelson from RetouchPRO.com to become the moderator of the Photo-based Art forum he created at http://www.RetouchPRO.com. A few months later I had an opportunity to take over stewardship of the http://www.dpreview.com/ Retouching Forum Action Collection. Since then I feel like I have been a kid in a candy store. Besides having a big hand in what I truly enjoy doing (messing with actions and engaging in photo-art), I have been most privileged to have connected with many talented, creative and genuinely nice folks primarily through the forums at these sites. To say I’ve been blessed in this regard would be a huge understatement. 

So, that’s how I got interested in photo-art and became an action hound along the way. I’m happy to say it’s been a great trip so far and I continue to enjoy writing actions. I see them as ways to capsulize and easily share what I learn with others. I truly look forward to every single day. There’s just so much more to learn and fun to have. 

Someday, if and when I ever grow up, “I want to be just like Mike.” Mike Finn, that is. 

10. ** HOW YOU CAN MAKE A DIFFERENCE **

UP
Was this document valuable to you? If so make a donation in any amount to a church or charity of your choice.

Thanks, and God bless.
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